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About this guide
This guide provides information about:

• Installing and configuring the HP LeftHand P4000 VSA for 
ESX 

• Installing and configuring the HP LeftHand P4000 VSA 
demo version that runs on VMware Player, Workstation, or 
Server

HP technical support
For worldwide technical support information, see the HP support 
website: 

http://www.hp.com/support

Before contacting HP, collect the following information:

• Product model names and numbers
• Technical support registration number (if applicable)
• Product serial numbers
• Error messages
• Operating system type and revision level
• Detailed questions

Subscription service
HP recommends that you register your product at the Subscriber's 
Choice for Business website: 

http://www.hp.com/go/e-updates
 ix
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HP websites
After registering, you will receive e-mail notification of product 
enhancements, new driver versions, firmware updates, and other 
product resources.

HP websites
For additional information, see the following HP websites:

• http://www.hp.com
• http://www.hp.com/go/storage
• http://www.hp.com/service_locator
• http://www.hp.com/support/manuals
• http://www.hp.com/support/downloads

Documentation feedback
HP welcomes your feedback.

To make comments and suggestions about product documenta-
tion, please send a message to storagedocsFeedback@hp.com

All submissions become the property of HP.
x                                                                               
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Getting Started with th
1SA 
Getting Started with the V
for ESX Server
Introduction
The free 30-day, fully functional evaluation HP LeftHand P4000 
VSA (VSA) is pre-formatted for the VMware ESX Server. To 
continue using the VSA after the 30-day trial period has ended, 
you must purchase a license key. After you apply the license key, 
your configuration can be used as is in a production environment, 
or reconfigured if necessary.

Prerequisites
• Have available drive space of up to 10 TB for ESX Server. 

HP LeftHand Networks recommends installing ESX Server 
on top of a redundant RAID configuration. Do not use RAID 
0.

• At least 1 GB of memory reserved.
• A single virtual CPU with at least 2000 MHz reserved.
• Have a Gigabit Ethernet or internal network environment 

• Designate a host name for the VSA,
• Plan the network configuration, including an IP address, 

subnet mask, and gateway for the VSA, or use DHCP.
• VMware ESX Server version 3.x

Planning for the VSA
Careful planning of the virtual network configuration, the VSA 
configuration and the configuration of the clusters and volumes 
for data storage ensures that you can take full advantage of the 
features and benefits of the HP LeftHand Storage Solution.
e VSA for ESX Server 1



Planning for the VSA
Planning the Virtual Network Configuration
Before you install the VSA on the network, plan the virtual 
network configuration, including the following areas:

• Design and configuration of the virtual switches and network 
adapters. 

• VSA directories, host names and IP addresses.
• Virtual network configuration, including the subnet and the 

virtual IP addresses (VIPs) for iSCSI access.

For more detailed information, see the HP LeftHand P4000 VSA 
User Manual, which is installed as a PDF in the directory into 
which you unzipped the VSA files. Or you can download it from 
the HP LeftHand Networks web site.

Planning the SAN/iQ Software Storage Configuration
When you install the HP LeftHand Centralized Management 
Console (CMC), you should plan and configure the storage node 
features, such as email alert notification, before you configure the 
data storage.
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Installing the VSA
Installing the VSA
There are two ways you can obtain the VSA.

• As a zip package downloaded from the HP LeftHand 
Networks web site.
When you install the packaged VSA for the first time, you 
must perform the following steps. 
• Unzip to the prepared directory and start the VMware 

Infrastructure Client (VI Client).
• Transfer the virtual machine to the ESX Server.
• Add the VSA to inventory.
• Select the network.
• Configure the data disk(s).
• Reserve the CPU and memory.
• Power on the VSA.
• Set the IP address and host name of the VSA.

• As a OVF package imported through the VI Client Import 
Virtual Appliance wizard.
When you import the VSA as an virtual appliance through 
the VI Client you must perform the following steps.
• Configure the data disk(s).
• Reserve the CPU and memory.
• Power on the VSA.
• Set the IP address and host name of the VSA.

Configuring the Capacity of the Data Disk
When you configure the data disk, use Table 1.1 to determine the 
proper size for the disk. The maximum disk size on the ESX 
Server is limited by the block size used to format the datastore.
Getting Started with the VSA for ESX Server  3



Installing the VSA
Installing with VMware VI Client
Use one of the following methods, depending on the VSA you are 
using.

Upload the VSA (zip version)
If you downloaded the VSA zip package, use these steps.

1. Connect to the ESX host via VC or VI Client. 
2. Click on the ESX host and select the Configuration tab. 
3. Select Storage.
4. Find the local VMFS datastore where VSA will be hosted. 
5. Right-click and select Browse DataStore. 
6. Create a new directory and click the upload files icon. 
7. Upload the unzipped folder with the VSA files. 

Import the VSA (ovf version)
If you imported the VSA as a virtual appliance through the 
Virtual Infrastructure Client, skip to “Configure a Data Disk” on 
page 5.

Add VSA to Inventory
Using the VI Client:

1. In the Inventory Panel, select the VMware ESX Server. 
2. In the Information Panel, select the Configuration Tab. 

Table 1.1. Relationship of disk size to datastore block size

Block Size Max VMDK

1 MB 256 GB

2 MB 512 GB

4 MB 1024 GB

8 MB 2048 GB
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Installing the VSA
3. In the Hardware section, select Storage (SCSI, SAN, and 
NFS). 

4. In the Storage section, right-click the datastore icon and 
select Browse Datastore. 

5. In the Datastore Browser, right-click the VSA.vmx file and 
select Add to Inventory.

6. In the Add to Inventory Wizard, enter a name for the new 
VSA and click Next. 

7. Select the Resource Pool to run the VSA and click Next.
8. Verify the information and click Finish. 
9. Close the DataStore Browser. 

Select A Network Connection
1. In the Inventory Panel select the VSA. 
2. In the Information Panel select Edit Settings in the 

Commands section.
3. On Virtual Machine Properties window, select the Hardware 

tab and select Network Adapter 1.
4. Select the appropriate network connection from the Network 

label list on the right side.

Configure a Data Disk
1. Next, click Add at the bottom of the Hardware tab. 
2. Select Hard Disk as the type of device you want to add and 

click Next. 
3. Select Create a new virtual disk and click Next. 
4. In the Disk Capacity section, designate a capacity that is 

suitable for the amount of storage available on your ESX 
Server. 
See “Configuring the Capacity of the Data Disk” on page 3 
for information about maximum disk size.

5. In the Location section, select Store with Virtual Machine, 
and click Next.
Getting Started with the VSA for ESX Server  5



Installing the VSA
6. For the first disk, select the Virtual Device Node to be 
SCSI 1:0 from the drop-down menu. For additional disks, 
assign SCSI 1:1 through 1:4, in sequential order.

7. Select Mode > Independent > Persistent and click Next.
8. Review the device configuration and click Finish to complete 

the Add Hardware wizard.
9. Click the Resources tab on the Virtual Machine Properties 

window.
10. Select CPU and reserve at least 2000 MHz.
11. Select Memory and reserve the appropriate amount of 

physical memory for the disk capacity, as shown in the table.

12. Click OK to close the Virtual Machine Properties window.
13. Select the ESX Server in the inventory panel.
14. Click the Resource Allocation tab.
15. Verify the CPU and Memory reservations you just set.

Configuring the VSA for Use with the HP LeftHand Storage Solution
1. In the inventory panel, select the new VSA and power it on. 
2. Select the Console Tab and wait for the VSA to boot. 

Caution:  Selecting anything other than SCSI 1:0 for the 
first disk causes RAID to be unconfigurable later.

Table 1.2. Reserve physical memory for VSA disks

Total Capacity of All Installed 
Disks

Requires At Least This Much 
Memory

< 500 GB 384 MB

500 GB to 4.5 TB 1 GB

4.5 TB to 9 TB 2 GB

9 TB to 10 TB 3 GB
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Installing the VSA
3. After the VSA boots up, log in and use the SAN/iQ Configu-
ration Interface to configure an IP address and host name for 
the VSA.

Figure 1.1. Logging in to the SAN/iQ Configuration Interface

Using the Configuration Interface
Use the Configuration Interface to set the IP address and host 
name on a VSA. 

1. Type Start and press Enter to log in to the Configuration 
Interface. 

2. On the Configuration Interface main menu, tab to Network 
TCP/IP Settings and press Enter.

3. On the Available Network Devices window, tab to the 
network interface and press Enter. 

4. On the Network Settings window, tab to the Hostname field 
and type a host name for the VSA. Use backspace to erase an 
entry if necessary.
This host name displays in the CMC only. It does not change 
the name of the original .VMX file, nor does it change the 
name of the virtual machine in the VMware interface.

5. Tab to the method for setting the IP address. 
If typing in a static IP address, note that Gateway is a 
required field. If you do not have a gateway, enter 0.0.0.0.
Getting Started with the VSA for ESX Server  7



Installing the HP LeftHand Centralized Management Console
6. Tab to OK and press Enter.
7. Press Enter again to confirm the action.
8. After the settings are configured, press Enter to confirm the 

IP address change.
9. On the Available Network Devices window, tab to Back and 

press Enter.
10. On the Configuration Interface, tab to Log Out and press 

Enter.

Finishing Up with VI Client
1. In the VI Client Information Panel, click the Summary tab.
2. In the General section on the Summary tab, verify that the IP 

address and host name are correct, and that VMware Tools 
are running.
Note: If VMware Tools show “out of date” then they are 
running correctly. The “out of date” status is not a problem. 
VMware tools are updated with each SAN/iQ software 
upgrade.

3. In the inventory panel, right-click the VSA and select 
Rename. 

4. Change the name of the VSA to match the host name, if 
desired. 
Next, install the CMC. Then follow the steps in “Getting 
Started with the HP LeftHand Centralized Management 
Console” on page 10.

Installing the HP LeftHand Centralized 
Management Console

Install the CMC on the computer or virtual machine that you use 
to administer the VSA. You administer the entire network of 
VSAs from this CMC. 
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Installing the HP LeftHand Centralized Management Console
To obtain the latest CMC for the VSA, go to 
http://resources.lefthandnetworks.com/forms/Email-VSA-
Download. 

Installing the CMC in Windows
1. Start the CMC installer.
2. At the Choose Install Set window, select the configuration 

most appropriate for your setup.
3. When the installation completes, HP LeftHand Networks is 

added as a separate Program Group and a shortcut icon is 
added to the Microsoft Windows desktop.

To start the CMC: 

• Double-click the icon on your desktop, or 
• From the Start menu, select All Programs > LeftHand 

Networks > Centralized Management Console.

Installing the CMC in Linux
You must be running X Windows in order to run the application. 

1. Click the CMC installer.
2. At the Choose Install Set window, select the configuration 

most appropriate for your setup.
3. When the installation completes, HP LeftHand Networks is 

added as a separate Program Group.

To start the CMC: 

From the directory into which you installed the files, run the 
script ./Console.
Getting Started with the VSA for ESX Server  9



Getting Started with the HP LeftHand Centralized Management Console
Getting Started with the HP LeftHand 
Centralized Management Console

1. Open the CMC.
If you are opening the CMC for the first time, and have not 
already discovered storage nodes on the SAN, the Find 
Wizard opens automatically. 

Figure 1.2. Opening the CMC for the first time

2. Click Next and proceed through the Find Nodes Wizard.
The wizard guides you through the steps for finding the VSA 
on your network. After finishing the wizard, the VSA appears 
in the navigation window in the Available pool.
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Getting Started with the HP LeftHand Centralized Management Console
Figure 1.3. Newly found VSA in CMC 

Configuring the Hardware
Configure hardware settings before you add the VSA to a man-
agement group. Select the VSA in the navigation window to 
expand the hardware configuration categories. Use these catego-
ries to configure RAID (if necessary), monitoring, and the 
network.

Figure 1.4. Configuring the hardware

Configure monitoring, 
RAID, and network 
from these categories
Getting Started with the VSA for ESX Server  11



Getting Started with the HP LeftHand Centralized Management Console
Configuring RAID
RAID is configured automatically the first time you power on the 
VSA for use with the HP LeftHand Storage Solution. However, if 
you power off the VSA and add disks, you must configure RAID 
when you power on the VSA.

1. Select the VSA in the navigation window and select the 
Storage category.

2. Click RAID Setup Tasks on the RAID Setup tab.

Figure 1.5. Configuring virtual RAID

3. Choose Configure RAID.
4. Select RAID (virtual) from the list and click OK.
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Getting Started with the HP LeftHand Centralized Management Console
 

Figure 1.6. Navigation window and the VSA RAID Setup tab

Caution:  If you have trouble configuring RAID now, you 
may have made a mistake when configuring a virtual disk 
earlier. 

On the ESX Server, verify that the VSA has at least one 
virtual disk. The first virtual disk must be configured on 
SCSI 1:0. Additional disks must be configured 
sequentially on SCSI 1:1 through 1:4.

VSAs use SCSI 0:0 and 0:1 for operating system disks, 
and use the disk configured for SCSI 1:0 for SAN data 
storage. If no SCSI disk is configured for SCSI 1:0, RAID 
cannot be configured on the appliance. 

RAID is Normal
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Creating the iSCSI SAN
Configuring Monitoring and Network
Use the rest of the configuration categories to change settings for 
the following features:

• Alerts and monitoring
• SNMP traps
• Network settings such as NIC bonding.

Click the Help button available on any window for further infor-
mation.

Creating the iSCSI SAN
The VSAs are on the network and operating properly. Next, use 
the HP LeftHand Centralized Management Console to create the 
clustered iSCSI SAN with the VSAs.

Use the Management Groups, Clusters, and Volumes wizard to 
create your storage pool. For information about using the 
wizards, see Chapter 1, “Getting Started,” the section “Creating 
Storage by Using the Getting Started Launch Pad” in the HP 
LeftHand Storage Solution User Manual or in the Online Help.

Caution:  You cannot clone a VSA after it is in a 
management group. You must clone a VSA while it is in 
the Available Nodes pool.
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Troubleshooting
Troubleshooting 

Table 1.3. Troubleshooting Installation

Trouble Solution

You want to reinstall the 
VSA

1. Close your CMC session.
2. In the VI Client, power off the VSA.
3. Right-click and select Delete from Disk.
4. Copy fresh files into the virtual machine folder from the 

downloaded zip file or distribution media. 
5. Open VMware and begin again. 

You cannot find the VSA 
with the HP LeftHand 
Centralized Management 
Console, and cannot 
recall its IP address.

CMC windows display the IP address of a machine if the 
machine can be found. 

Open a VI Client session and select the Summary tab for 
the machine you want. The IP address and DNS name 
are displayed in the General information section.

You can’t configure 
RAID.

Verify that the VSA has a virtual disk configured on SCSI 
1:0. VSAs use SCSI 0:0 and 0:1 for operating system 
disks. They use the disk configured for SCSI 1:0 for SAN 
data storage. If no SCSI disk is configured for SCSI 1:0 
then RAID cannot be configured on the appliance. 

In Windows

If the Installation wizard 
freezes, reset the 
Hardware Acceleration in 
Windows.

1. Open the Windows Display Properties > Settings tab > 
Advanced button > Troubleshoot tab.

2. Move the Hardware Acceleration slider to one notch 
above None.

3. Click OK, and then OK again to leave the Properties 
dialog.

4. Restart the Installation wizard.

In Linux 

If the installer does not 
start automatically

Run CMC_Installer.bin again. 

In VI Client 
Getting Started with the VSA for ESX Server  15



Documentation Available
Documentation Available 
For detailed instructions about using the HP LeftHand Central-
ized Management Console and the VSA, see the following 
resources. The User Manuals are available in PDF format and are 
installed in the Documentation subdirectory with the HP 
LeftHand Centralized Management Console program files.

Online Help
All User Manual content is contained in the Online 
Help, available from the menu bar under Help > Help 
Topics. Context sensitive help is available by clicking 

the question mark on any window.

HP LeftHand P4000 VSA User Manual

“Designing a Virtual SAN” in the HP LeftHand P4000 VSA User 
Manual provides important information about configuring the 
VSA virtual network environment, hardware configuration, and 
using the VSA with physical platforms and the SAN/iQ software.

You don’t have the 
cursor available, or you 
don’t have the keyboard 
available.

If your cursor is missing, you are in console mode. Press 
Ctrl-Alt to regain the cursor.

If your keyboard is missing, move the mouse to the 
console window and click once.

You want to see your 
VSA, but the window is 
black.

• You are in the console view of the guest window. 
Change to the Summary view.

• Your console window has timed out. Click in the 
window with the mouse and then press the Backspace 
key.

Table 1.3. Troubleshooting Installation (Continued)

Trouble Solution
16  Getting Started with the VSA for ESX Server                                                                             



Documentation Available
HP LeftHand Storage Solution User Manual
The HP LeftHand Storage Solution User Manual provides 
detailed instructions for using the SAN/iQ software to create, 
access and manage the SAN data storage. 

Remote Copy User Manual
The Remote Copy User Manual provides instructions for using 
the Remote Copy capabilities of the SAN/iQ software.

HP LeftHand P4000 Multi-Site HA/DR Solution Pack User Manual
The HP LeftHand P4000 Multi-Site HA/DR Solution Pack User 
Manual provides instructions for configuring and using the HP 
LeftHand P4000 Multi-Site HA/DR Solution Pack, which must 
be licensed separately.

VSA Frequently Asked Questions
Check out www.lefthandnetworks.com for the HP LeftHand 
Networks VSA Forum. 
Getting Started with the VSA for ESX Server  17
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Using the VSA L
2
Using the VSA Laptop Demo
Introduction
The VSA laptop demo is HP LeftHand Networks smallest and 
most portable version of the SAN/iQ software virtual appliance. 
Use this demo to create an HP LeftHand Storage Solution, 
complete with storage clusters.

The VSA runs a full-featured version of the SAN/iQ software, 
and provides the following benefits:

• Experience the SAN/iQ software without investing in 
physical storage devices

• A 30-day evaluation period for advanced SAN/iQ software 
features such as Clustering and Virtualization, Managed 
Snapshots, Remote Copy and Multi-Site SAN.

• Can be used indefinitely as a stand-alone iSCSI target.
• Is a VMware certified virtual appliance

The demo is available at www.lefthandnetworks.com.

Requirements for the Demo
• Minimum of 384 MB of RAM
• 5 GB to 950 GB SCSI of disk space
• VMware Player, Workstation, or Server
• IP address, subnet mask, and gateway for the virtual machine
aptop Demo 19
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Overview
Overview
When using the demo version, the full suite of features in the 
SAN/iQ software is enabled for 30 days. After 30 days, volumes 
become unavailable if any licensed features are in use. Licensed 
features include:

• Multi-Node Virtualization and Clustering
• Managed Snapshots
• Remote Copy
• Multi-Site SAN

The VSA can be used for free indefinitely as a single node iSCSI 
target with snapshots. If a configuration is deleted and recreated, 
the 30-day trial period of licensed features starts again.

If you want to use the VSA fully featured on an ESX Server, 
simply purchase a license and follow the instructions in Chapter 
1, “Getting Started with the VSA for ESX Server” to set up a 
virtual HP LeftHand Storage Solution.

Using the VSA demo comprises the following steps:

• Install a VMware application on a host system. 
• Download the VSA to the host system.
• Unzip the downloaded package to a directory on the host 

system. 
• Using VMware, browse to directory containing the virtual 

machine and start it. 
• Configure the IP address and hostname of the VSA using the 

VMware console.
• Install the HP LeftHand Centralized Management Console 

(CMC) on a machine from which to administer the SAN. 
• Use the CMC to create clusters and storage volumes and use 

the features of the HP LeftHand Storage Solution. 
20  Using the VSA Laptop Demo                                                                             



Planning the Demo Installation
Download the VSA

The VSA for Laptop Demos is available from the HP LeftHand 
Networks web site:

• www.lefthandnetworks.com

Planning the Demo Installation
Before you install the VSA, plan the virtual network configura-
tion. Then, when you install the HP LeftHand Centralized Man-
agement Console, plan and configure the hardware features 
before configuring the virtual storage node for data storage.

Configuration planning includes the following elements:

• Virtual appliance directories, host names, IP addresses
• Network configuration, including subnet and virtual IP 

address
• Storage configuration

Plan the Network Configuration
Plan the subnet and IP address for the virtual machines as well as 
for the VIPs required for SAN/iQ clusters. 

Plan for Installing the VSA on Hardware
Create a directory for your virtual machines on the hard drive you 
will use as the storage node. Create a separate directory for each 
virtual machine.

Plan for Installing the CMC
Install the CMC on a Linux or Microsoft Windows OS. Then use 
the CMC to find storage nodes, create storage, and connect to 
application servers. 
Using the VSA Laptop Demo  21
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Installing the CMC
Installing the CMC
Install the CMC on the computer that you will use to administer 
the HP LeftHand Storage Solution. You administer the entire 
network of VSAs from the CMC.

Installing the CMC in Windows
1. Click the CMC installer.
2. At the Choose Install Set window, select the configuration 

most appropriate for your setup.
3. When the installation completes, HP LeftHand Networks is 

added as a separate Program Group and a shortcut icon is 
added to the Microsoft Windows desktop.

Installing the CMC in Linux
You must be running X Windows in order to run the application. 

1. Click the CMC installer.
2. At the Choose Install Set window, select the configuration 

most appropriate for your setup.
3. When the installation completes, HP LeftHand Networks is 

added as a separate Program Group.

To start the CMC:

1. From the directory into which you installed the files, run the 
script ./Console.
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Installing the VSA
Installing the VSA
When you start the VSA for the first time with a VMware 
console, you will: 

• Unzip to the prepared directory and start the virtual machine. 
• Direct the Ethernet port to NAT (default), Host-only, or 

bridged.
• Set the IP address and host name of the VSA.

You only need to configure each virtual machine once.

1. Copy or download the VSA zip file. 
Leave this zip file intact. 

2. Copy or unzip the VSA files to the virtual machine directory.
3. Start the VMware application. 

Installing with VMware Player, VMware Server, or VMware 
Workstation

1. Open the VMware console.
2. Click File > Open or other choice to open the VSA.vmx file.
3. Navigate to the location of the unzipped VSA files.
4. Select the VSA.vmx file and click Open.
5. Edit the VSA settings as required by the VMware console 

you are using. Select the appropriate network mode:
• Bridged
• NAT
• Host-only

Note:  All VSAs on the same platform should use the same 
networking mode. 

When running multiple VSAs on a single host, use NAT or 
Host-only networking mode, and use DHCP to assign IP 
addresses to the VSAs. 
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Installing the VSA
6. Power on the VSA.

Figure 2.1. Logging in to the Configuration Interface

Using the Configuration Interface
Use the Configuration Interface to set IP addresses and host 
names on VSAs configured in your environment. 

1. Type Start, and press Enter to log in to the Configuration 
Interface. 

2. On the Configuration Interface main menu, tab to Network 
TCP/IP Settings and press Enter.

3. On the Available Network Devices window, tab to the 
network interface and press Enter. 

4. On the Network Settings window, tab to the Hostname field 
and type a host name for the VSA.
This host name displays in the CMC. It does not change the 
name of the original .VMX file, nor does it change the name 
of the virtual machine in the VMware interface.

5. Tab to the method for setting the IP address. 
If typing in a static IP address, note that Gateway is a 
required field. If you do not have a gateway, enter 0.0.0.0.

6. Tab to OK and press Enter.
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Getting Started with the HP LeftHand Centralized Management Console
7. Press Enter to confirm the action and press Enter.
8. Press Enter to confirm the change to the network settings.
9. Press Enter again after the settings are configured to confirm 

the IP address.
10. On the Available Network Devices window, tab to Back and 

press Enter.
11. On the Configuration Interface, tab to Log Out and press 

Enter.
12. [Optional] In the inventory list or sidebar, right-click the 

VSA and rename to match the host name. (Not available in 
VMware Player.)

13. Minimize the VMware console. 

Next, configure storage using the HP LeftHand Centralized Man-
agement Console. “Getting Started with the HP LeftHand Cen-
tralized Management Console” on page 25.

Getting Started with the HP LeftHand 
Centralized Management Console

1. Open the CMC.
If you are opening the CMC for the first time, and have not 
already discovered storage nodes on the SAN, the Find 
Wizard opens automatically. 
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Figure 2.2. Opening the CMC for the first time

2. Click Next and proceed through the Find Nodes Wizard.
The wizard guides you through the steps for finding the VSA 
on your network. After finishing the wizard, the VSA appears 
in the navigation window in the Available Nodes pool.
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Figure 2.3. Newly found VSA in CMC 

Configuring the Hardware

Configure hardware settings before you add the VSA to a man-
agement group. Select the VSA in the navigation window to 
expand the hardware configuration categories. Use these catego-
ries to configure RAID (if necessary), monitoring, and the 
network.

Figure 2.4. Configuring the hardware

Configure monitoring, 
RAID, and network 
from these categories
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Configuring RAID
RAID is configured automatically the first time you power on the 
VSA for use with the HP LeftHand Storage Solution. However, if 
you power off the VSA and add disks, you must configure RAID 
when you power on the VSA.

1. Select the VSA in the navigation window and select the 
Storage category.

2. Click the RAID Setup tasks list and choose Configure RAID. 

Figure 2.5. Choosing to configure virtual RAID

3. Select RAID (virtual) and click OK.

Configuring Clustered Storage
Use the Getting Started wizard to configure storage volumes.
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Installing Another VSA
You may install more than one VSA to fully evaluate the SAN/iQ 
software and the HP LeftHand Storage Solution. To install addi-
tional VSAs, create separate directories at the same level as the 
first VSA. Follow the same steps to configure additional VSAs. 

Troubleshooting

Trouble Solution

You want to reinstall 
the VSA.

1. Close your CMC session.
2. In VMware, power off the VSA.
3. Click File > Remove from inventory.
4. In a file manager, go to the folder that holds the VSA.vmx file 

and delete all the files.
5. Copy fresh files into the VSA folder from the downloaded zip 

file. 
6. Open VMware and begin again. 

You cannot find the 
VSA with the CMC, 
and cannot recall its IP 
address.

1. Open a VMware console session and display the console 
window for the VSA. 

2. At the SAN/iQ Welcome window, type START and press 
Enter.

3. In the Configuration Interface, navigate to the Network 
TCP/IP settings. Select eth0 to open the Network Settings 
window. 

4. The IP address is displayed in the Network Settings window.

Tip: Enter the IP address in the NOTES area on the VMware 
summary window.
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Documentation Available 
For detailed instructions about using the HP LeftHand Central-
ized Management Console and the VSA, see the following 
resources. The User Manuals are available in PDF format and are 
installed in the Documentation subdirectory with the HP 
LeftHand Centralized Management Console program files.

In Windows

If the installation 
wizard freezes, reset 
the Hardware Acceler-
ation in Windows.

1. Navigate to Windows Properties > Settings > Advanced > 
Troubleshooting.

2. Move the Hardware Acceleration slider to one notch above 
None.

3. Click OK, and then OK again to leave the Properties dialog.
4. Restart the installation wizard.

In Linux 

If the installer does not 
start automatically

Run CMC_Installer.bin again.

In VMware 

You don’t have your 
cursor available, or 
you don’t have your 
keyboard available.

• If your cursor is missing, you are in console mode. Press 
Ctrl-Alt.

• If your keyboard is missing, move the mouse to the console 
window and click once.

You want to see your 
VSA, but the window is 
black.

• You are in the console view of the guest window. Change to 
the Summary view.

• Your console window has timed out. Click in the window with 
the mouse and then press the Backspace key.

Trouble Solution
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Online Help
The CMC Online Help is available from the menu bar 
under Help > Help Topics. Context sensitive help is 
available by clicking the question mark on any 

window.

HP LeftHand P4000 VSA User Manual
“Designing a Virtual SAN” in the HP LeftHand P4000 VSA User 
Manual provides important information about configuring the 
VSA virtual network environment, hardware configuration, and 
using the VSA with physical platforms and the SAN/iQ software.

HP LeftHand Storage Solution User Manual
The HP LeftHand Storage Solution User Manual provides 
detailed instructions for using the SAN/iQ software to create, 
access and manage the SAN data storage. 

Remote Copy User Manual
The Remote Copy User Manual provides instructions for using 
the Remote Copy capabilities of the SAN/iQ software.

HP LeftHand P4000 Multi-Site HA/DR Solution Pack User Manual
The HP LeftHand P4000 Multi-Site HA/DR Solution Pack User 
Manual provides instructions for configuring and using the HP 
LeftHand P4000 Multi-Site HA/DR Solution Pack, which must 
be licensed separately.

VSA Frequently Asked Questions
Check out www.lefthandnetworks.com for the HP LeftHand 
Networks VSA Forum link on the home page.
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