Providing a key element of the new i2 Intelligence-Led Operations Platform, Analyst’s Notebook 8 delivers powerful new analytical and visualization capabilities designed to reduce the time required to identify high value intelligence within quickly growing data sets.

New features such as dynamic filtering, social network analysis, mapping support and conditional formatting allow analysts to keep pace with the ever increasing tempo of operations and help to identify hidden intelligence that may otherwise have been missed.

When combining all of this with the new task-based user interface, Analyst’s Notebook 8 offers new and unrivalled levels of support for analysts in their mission critical work. The latest release, Analyst’s Notebook 8.5, continues to build on the powerful capabilities delivered by Analyst’s Notebook 8 with the new HeatMatrix, additional Social Network Analysis centrality measures, a brand new set of high quality icons and more.

Contents

What’s New in this Release? 2
Analyst’s Notebook 8.5.1 Release Highlights 2
System Requirements 5
Hardware Specification 7
Authorization Information 8
Installation 9
Enhancements and Bug Fixes 10
Known Limitations 11
Contacting i2 15
Acknowledgements 17
What's New in this Release?

Analyst's Notebook 8.5.1 Release Highlights

The main highlights for Analyst's Notebook 8.5.1:

- Entity icons have been redrawn as high quality images
- Icon frames for highlighting and easy visualization of key entities
- The ability to add pictures to entity representation including theme lines, event frames and icons
- A new HeatMatrix to reveal and highlight hot-spot activity when working with Dynamic Filtering
- Support for importing Cellebrite Universal Forensic Extraction Device (UFED) data to automatically create charts
- Enhanced Social Network Analysis with support for a new eigenvector centrality measure

Analyst's Notebook 8.0.5 (SP1)

The following new and updated features are included in Analyst's Notebook 8.0.5 (SP1):

- Enhanced Social Network Analysis
  - Normalize results options
  - Run Social Network Analysis as a background task
- Performance & Usability Improvements and Bug Fixes

Analyst's Notebook 8.0.1

The following new and updated features are included in Analyst's Notebook 8.0.1:

- New task-based user interface grouping together common commands used for a particular task
- Improved chart navigation including Pan, Zoom and the Chart Overview Window
- Filtering chart items using a list or histogram view
- Mapping chart items containing geographical information to Google Earth
- Social Network Analysis allows you to explore group dynamics within a chart by focusing on the relationships that exist between entities
- Automatically formatting chart items for analysis or presentation using Conditional Formatting
• Enhancements to the Importer including exporting column actions
• Reveal Hidden functionality displays hidden chart items as grayed
• New Compact Peacock chart layout providing a more compact and legible final chart
• Tabs for switching and moving data between multiple open charts
• Theme line icons can now be displayed as you pan across theme lines
• Exporting charts to PDF documents
• Saving charts or sections of charts as pictures
• Custom icons are now embedded within charts
• Over 100 new icons have been added

Note: An overview of these features is provided by the Analyst’s Notebook online help. To view this information: start Analyst’s Notebook and select Contents from the Help menu. Alternatively, see the What’s New in Analyst’s Notebook 8 White Paper.

Release Contents

The following table summarizes the Analyst’s Notebook 8 releases:

<table>
<thead>
<tr>
<th>Version</th>
<th>Release Date</th>
</tr>
</thead>
<tbody>
<tr>
<td>Analyst’s Notebook 8.0.1</td>
<td>June 2009</td>
</tr>
<tr>
<td>Analyst’s Notebook 8.0.5 (SP1)</td>
<td>October 2009</td>
</tr>
<tr>
<td>Analyst’s Notebook 8.5.1</td>
<td>May 2010</td>
</tr>
</tbody>
</table>

Notes for existing Analyst’s Notebook users

Upgrading Analyst’s Notebook 7 to version 8

Please note that Analyst’s Notebook 8 replaces an installation of Analyst’s Notebook 7. It is not possible to run version 7 and version 8 simultaneously on the same computer.

Compatibility with Analyst’s Notebook 7 format

Analyst’s Notebook 7 charts can be opened in Version 8, modified, saved and reopened in Analyst’s Notebook 7. When the chart is saved, the chart is checked to see if there are any significant compatibility issues with earlier versions and a relevant warning is displayed. For details of Analyst’s Notebook 8 features not supported in version 7, see the Analyst’s Notebook online help.

Saving Charts in Analyst’s Notebook 6 format

Analyst’s Notebook 6 charts can be opened in Version 8, modified, and subsequently saved in Version 6 format. When the chart is saved, the chart is checked to see if there are any significant compatibility issues with earlier versions and a relevant warning is
displayed. For details of Analyst’s Notebook 8 features not supported in version 6, see the Analyst’s Notebook online help.

Notes for existing Link Notebook 5 users

Link Notebook 5 charts can be opened in Analyst’s Notebook 8.

Updating customized templates and specifications

This version of Analyst’s Notebook provides you with the latest templates, import specifications and report specifications. Product enhancements are made available through these files and, where appropriate, you should make sure you are using the latest versions.

If you have customized Link Notebook 5 or Analyst’s Notebook 6 or 7 templates and wish to utilize them within Analyst’s Notebook 8 the templates must be merged. For more information, see the online help topic Merging Templates.

Import specifications created in Analyst’s Notebook 7 will open in Analyst’s Notebook 8. You can use Link Notebook 5 and Analyst’s Notebook 6 import specifications in Analyst’s Notebook 8 once you have converted them into the format required by the Import Editor. For more information, see the online help topic Managing Import Specifications.

Compatible companion products

You may have licensed one or more Analyst’s Notebook companion products.

The following versions of companion products that run with Analyst’s Notebook 7 also work with Analyst’s Notebook 8:

- iBase 8
- iBridge 8
- TextChart 8
- ChartExplorer 2
- PatternTracer 2
- iXa Search AN 2

Upgrading new icons across i2 products

Installing Analyst’s Notebook 8.5.1 will automatically upgrade the legacy icon set used by other i2 products installed on your machine to the new, redrawn icon set. Once this upgrade has been performed, other i2 products such as iBase and TextChart will display new icons only. Legacy icons will no longer be supported.
System Requirements

For latest details on system requirements, supported operating systems and any other additional requirements check the i2 Web site:

www.i2group.com/products/system-requirements/

At release these are the supported operating systems for Analyst's Notebook 8:

Operating System

Desktop Operating Systems

Windows 7 Professional/Enterprise/Ultimate x86 (32-bit) and x64 (64-bit)

Windows Vista Business/Enterprise/Ultimate x86 (32-bit) and x64 (64-bit) SP1 or later

Windows XP Professional x86 (32-bit) SP3 or later and x64 (64-bit) SP2 or later

Server Operating Systems offering thin client environments

Windows Server 2008 R2 x64 (64-bit) with Terminal Services enabled

Windows Server 2008 x86 (32-bit) and x64 (64-bit) with Terminal Services enabled

Windows Server 2003 Standard/Enterprise x86 (32-bit) and x64 (64-bit) SP2 or later with Terminal Services enabled

Windows Server 2003 R2 Standard/Enterprise x86 (32-bit) and x64 (64-bit) SP2 or later with Terminal Services enabled

All server operating systems are also supported with Citrix MetaFrame Presentation/Xen App Server 4.0 or later

Analyst's Notebook is supported on Western Europe & USA, Central Europe, Baltic, Cyrillic, Turkic, Arabic, Japanese, Traditional Chinese and Simplified Chinese, regional versions of the supported operating systems.

Analyst's Notebook requires that Microsoft .NET Framework 2.0 SP1 or .NET Framework 3.5 is present on the installation system. The version of .NET you require will depend on the operating system you are running. Microsoft .NET Framework 2.0 SP1 is included on the CD. Microsoft .NET Framework 3.5 can be downloaded from the Microsoft Download Center http://www.microsoft.com/downloads/details.aspx?FamilyId=333325fd-ae52-4e35-b531-508d977d32a6&displaylang=en.

Analyst's Notebook requires that Microsoft Windows Installer 4.5 is present if the installation system is running Windows Vista or Windows Server 2008.

The printed documentation provided with Analyst’s Notebook is also available electronically in Adobe PDF format. In order to display this documentation, a PDF viewer must be present on the installation system.
*Analyst’s Notebook* installs a PDF printer driver (*Analyst’s Notebook Chart PDF Writer*) on the installation computer. This printer driver is required for export to PDF functionality to work.

*Analyst’s Notebook* can map items to Google Earth. Google Earth 5.0, or later is required. Google Earth is not currently supported on Terminal Service enabled Server environments. Please note that in this environment only one user at a time can use Google Earth.

*Analyst’s Notebook* interoperates with applications in the following versions of Microsoft Office:

- Office 2003 (all editions)
- Office 2007 (all editions)

*Analyst’s Notebook* can work with documents created by the following Office versions:

- Office 2000 (all editions)
- Office XP (all editions)
- Office 2003 (all editions)
- Office 2007 (all editions)

**Virtual Machine Environments**

*Analyst’s Notebook* 8 is supported in Virtual Machine environments running on any of the operating systems listed above.

If any issues are found and are reproducible by i2 in the following virtual machine environments:

- Citrix XenServer
- VMWare Workstation 6 or later
- VMWare ESX Server 3 or later
- Microsoft Hyper-V

i2 will treat as an issue and attempt to fix or offer a workaround as long as the cause is not within the VM vendor’s software layers.
Hardware Specification

These are the minimum desktop hardware requirements for Analyst’s Notebook 8:

Minimum Requirements

1.4 GHz processor computer
512 MBytes RAM
500 MBytes free disk space for installation, plus space to store chart data (This does not include disk space required for pre-requisites)
XGA capable graphics card (1024 x 768 high color (16 bit)) and color monitor
Mouse or Trackball
USB Port or Parallel Printer Port (for local dongle)
CD-ROM drive or network access (for installation)

For better performance and for running a combination of i2 products a higher specification is recommended:

Recommended Requirements

At least 2 GHz processor computer
At least 2 GB RAM
At least 1 GB free disk space for installation plus space to store chart data (This does not include disk space required for pre-requisites). Total disk space requirements depend on number of i2 products to be installed.
SXGA capable graphics card (1280 x1024 high color (16 bit)) and color monitor
Mouse or Trackball
USB Port or Parallel Printer Port (for local dongle)
CD-ROM drive or network access (for installation)
**Authorization Information**

*Analyst’s Notebook* is a licensed product and requires a dongle containing a valid permit in order to run. *Analyst’s Notebook 8* uses the same dongle permits as previous versions of *Analyst’s Notebook*. Therefore existing users do not require a replacement dongle.

**NetHASP License Manager**

If you use a NetHASP authorization solution (network dongle), you are required to use License Manager 8.20, or higher.

Version 8.31 can be found on the product CD in the following location:

CD Drive:\Dongle\HASP Server\Windows

Further details regarding the installation of the License Manager are available in the NetHASP License Manager Guide.

**NetHASP timeout**

A timeout value is set for each client workstation so that the NetHASP server releases permits after 60 minutes of application inactivity. This prevents permits from being held indefinitely if they are not released at the end of a session.

**NetHASP authorization**

If you use a NetHASP authorization solution and you have specific configuration information in *NetHASP.ini* then if it exists you should copy the *NetHASP.ini* configuration file in your existing installation folder to the *Analyst’s Notebook 8* folder.

**Product Authorization in a Virtual Machine environment**

If you are using i2 software in a virtual machine (VM) environment you will need to consider the following for reliable product authorization.

**Hardlock (USB/Parallel Port)**

If you are using Hardlock (standalone) dongle you need to ensure that your virtual machine environment has support for the port type of the dongle you are using (USB or Parallel)

**NetHASP (USB/Parallel Port)**

i2 strongly recommends that NetHASP (network) dongles and the License Manager software is installed in a non virtual machine environment on the same network as the i2 products that require authorization.
Utilities

The following utilities are available within Analyst’s Notebook and are installed in the Utils folder beneath the installation folder for Analyst’s Notebook:

- Reset Toolbars.exe

  This application resets toolbar settings to the Analyst’s Notebook defaults.

- SeriesImport.exe

  This command line application allows you to automate running one or many import specifications into your charts.

Documentation describing how to use these utilities is available in the online help.

Installation

Before installing Analyst’s Notebook please check that your system meets all the system requirements.

Installation steps

Using Setup.exe

Note: Administrator privileges are required in order to install Analyst’s Notebook.

To install Analyst’s Notebook:

1. Close all applications that you might have open.

2. If present, remove any USB Authorization Device (Dongle).

3. Insert the product CD into your computer’s CD drive.

   The installation will start automatically. If it does not start automatically, you need to browse to the CD to run Setup.exe in the folder Analyst’s Notebook 8.

4. Follow the prompts to complete the installation.

   The following shortcut will be installed:

   ![i2 Analyst’s Notebook 8](Start Analyst’s Notebook)

Installing Google Earth

The Google Earth Plug-in for Analyst’s Notebook requires that Google Earth 5.0 is present on the user machine. Google Earth is a third party application subject to separate license terms and can be downloaded from [http://earth.google.com](http://earth.google.com).
Advanced installation options

Advanced options for installing this product are described in the *i2 Products Packaging and Deployment Guide*. This explains how to perform automated and silent installs and use the advanced features provided by the Windows Installer (MSI), and includes details on customizing installed files, details of third party software installed and language specific files.

Enhancements and Bug Fixes

Mousing over theme lines when the theme line icon bar is displayed selects the correct theme line (#35350)

Reported 8.0.5

Previously when working with multiple and diverted theme lines, it was not always possible to select or link from the required theme line if the theme line icon bar was displayed. Now correct tooltips are displayed when you move your mouse pointer over theme lines and theme line icon bar and theme lines can be selected and links can be created as required.

Imported data records can be exported in their entirety (#35710)

Reported 8.0.1

Clicking **Export** on the Column Actions page of the Importer now exports all data records, not just the first 2000 records.

The Importer uses the time zone set in the template (#35815)

Reported 8.0.1

Imported data containing date and time references use the time zone set in the template. Previously, an error occurred where hours were automatically added to or subtracted from imported temporal data depending on daylight saving hours.

Imported non-controlling items are displayed on the chart as free (#35183)

Reported 8.0.1

Setting the Controlling property to **No** on the Assign Columns page of the Importer now ensures that the Order and Control of Date & Time is set to **Free** for items imported onto a chart.

Import specifications created in Analyst’s Notebook 8 versions are mutually compatible (#35415)

Reported 8.0.5
Previously, import specifications created in Analyst's Notebook 8.0.5 could not be opened in Analyst's Notebook 8.0.1. Now, import specifications created in any of the version 8 releases are compatible with all other version 8 releases.

**Analyst's Notebook no longer freezes when selecting from the Add Chart Items Task Pane (#35765)**

Reported 8.0.5

Previously, displaying the Add Chart Items Task Pane and selecting several options from the Entity Type panel shortcut menu in quick succession could cause Analyst's Notebook to freeze. This has been fixed in Analyst's Notebook 8.5.1.

**Find Matching Entities cannot create links that will affect Social Network Analysis results (#35763)**

Reported 8.0.5

Previously, if running Find Matching Entities found non-matching entities on a chart, a link labeled 'does not match' would be created automatically on these entities. Social Network Analysis calculations would take these extra links into consideration and produce unexpected results. Now, additional links are no longer added to non-matching entities by default.

**Daylight savings are now being taken into account when filtering (Dewis #64)**

Reported 8.0.1

When filtering using dates and times, daylight savings were not being taken into account causing data to be placed in inappropriate bins in some situations. In conjunction with this fix, some additional enhancements have been provided. The time zone is now displayed in the histogram header and a tooltip is also provided in both the histogram header and filters list. For certain date and time filters menu options will be available to switch between viewing the data using the chart time zone (default) or the time zone of the chart items.

**Default setting has changed for double-click behavior on items charted from iBase (#35495)**

Reported 8.0.1

Previously, double-clicking an item charted from iBase would display the Edit Item Properties dialog. Now, the default setting on the Data Sources Task Pane ► Options page has been changed so that iBase Show Dialogs are displayed.

**Known Limitations**

**16-bit JPEG images are not handled properly when passed in from the clipboard (#36827)**

For users with the "minimum" graphics capability (16-bit color depth), copying and pasting images from Internet Explorer directly onto a chart item will cause that item to disappear from view, and the item will not be displayed in the Chart Overview Window.
Workarounds to this problem are:

- Undo the last action, by selecting **Undo** from the **Edit** menu.
- First save the picture using **Save As Picture** option in Internet Explorer.
- Delete the item from the List Items dialog. (Press the F11 key to display this dialog.)

**Export to PDF - output is not as good quality as printing to a printer (#36262)**

Reported 8.5.1

Export to PDF produces output that is not as good quality as that displayed on the chart surface. Icons can appear squashed and display a white border around them and lines and event frames can look untidy.

**When deleting a picture from an Event Frame it does not revert to showing the type icon (#36295)**

Reported 8.5.1

Deleting a picture from an event frame does not switch back to displaying the type icon. The type icon can be easily switched back on again either by using the right-click shortcut menu or the display options in the Item Properties dialog.

**The Select Entity Type dialog might take some time to display (#36298)**

Reported 8.5.1

When selecting **All Entity Types** from the drop-down list in the Add Chart Items Task Pane for the first time, the Select Entity Type dialog takes some time to load and display the icons.

**Chart background color is always printed (#36227)**

Reported 8.5.1

The chart background color is included on printed charts even if you turn off the **Chart** check box in the Borders page of the Page Setup dialog. A workaround for this is to set the chart background to white in the **Chart Properties ▶ Options ▶ Display** page before printing.

**Some plug-ins fail to load when launching Analyst’s Notebook by opening two charts from the Desktop (#36133)**

Reported 8.5.1

If you select two charts from your Desktop and press the Enter key, **Analyst’s Notebook** is launched but some Task Pane tabs are missing because several plug-ins fail to load. A workaround for this is to launch **Analyst’s Notebook** and then open the charts.
Icons in the legend may be incorrect if the chart is saved in Analyst’s Notebook 7 (#36130)

Reported 8.5.1

Icons in the legend of Analyst’s Notebook 8 charts may not be displayed correctly if they have been saved previously in Analyst’s Notebook 7. This problem occurs if the icons used in the legend did not exist in Analyst’s Notebook 7. Icons used in the chart itself are displayed correctly.

Printing

The Analyst’s Notebook icon sets incorporate transparency so that icons may be used on areas of the chart where the background is not white, for example in filled event frames or on top of background items. The printing of legacy icons is complex and on some older computer and printer combinations there may be problems. In particular, the legacy icons may print incorrectly or printing may be very slow. To overcome these difficulties, two printing options are provided, as described below. These options can be found in the Advanced Printer Setup dialog, which is accessed using the Advanced button on either the Printer Setup or Print dialogs.

• Always Simulate Transparent Icons

This option uses an alternative, simpler means of printing transparent legacy icons. Try this option if the icons do not appear correctly. Printing will be slower using this option.

• Use Basic Icon Drawing

This option uses a very basic means of printing legacy icons. Try this option if the icons do not appear correctly or if printing is too slow. Printing will not include any transparency using this option and therefore icons will always have a white square surround.

Displaying OLE objects

Analyst’s Notebook is now capable of displaying .bmp, .jpeg and .gif OLE objects without the requirement for any third party OLE server. However, the following limitations still apply:

• If your operating system has an application that has taken ownership of .bmp, .jpeg or .gif files, and it is not a valid OLE server, the drag and drop from Windows Explorer may return the error message “Unexpected file format.” If you encounter this issue, try inserting the image from the Insert OLE Object ► Picture menu, or use the Edit Item Properties dialog to add a picture to an entity representation.

• If an unrecognized file type is dragged onto the chart surface and the “Unexpected file format.” warning is received, subsequent drag and drop operations to the chart surface from Windows Explorer may fail. If you encounter this issue try inserting the object from the Insert OLE Object ► Picture menu, or use the Edit Item Properties dialog to add a picture to an entity representation.

Save As Version 6 not available if attribute class names are written in non-western characters

Attribute classes whose names are not written using western characters can cause an issue when using the Save As Version 6 feature. Some Analyst’s Notebook 8 charts that
contain attribute classes whose names contain unavailable characters, will not be able to be saved as Version 6 charts, if the **Save As** is performed on a computer with a different language operating system. For example a Chinese chart, that contained attribute class names written in Chinese characters, may not be able to be saved as a Version 6 compatible chart on an English operating system.

**Performance problems when disconnecting from the network (#34489)**

Reported 8.0.1

It takes between 4 and 5 seconds to move between tabs.

This issue occurs when a user disconnects from a network and a network printer remains set as the default printer.

A workaround for these issues is, when disconnecting from a network change the default printer to a local printer and in **Analyst’s Notebook** select a local printer. You should also delete the registry settings in:

```
HKEY_CURRENT_USER\Software\i2\Default\Printer
```

**Memory problems when using Save as Picture (#34807)**

Reported 8.0.1

Using **Save as Picture** ➤ **Complete Chart** may fail to create a picture if the chart is very large, due to insufficient memory.

A workaround for this issue is to save the chart in sections using **Save as Picture** ➤ **Current Window**, or save the chart in PDF format using **File** ➤ **Export to PDF**.

**ChartReader does not start on Windows XP x64 (64-bit) (#34938)**

Reported 8.0.1

**ChartReader** installs, but does not start, on Windows XP x64 (64-bit).

**Filtering Known Limitations**

**Copy results to New Chart - include linked items - ignores background chart items.**  
(Dewis #61)

Reported 8.0.1

The **Copy Results to New Chart** function with the **Include Linked Items** check box turned on does not include background items in the chart items copied over to the new chart.

**Limitations Specific to Microsoft Windows Vista, Windows 7 and Windows Server 2008**

**Analyst’s Notebook** is fully compliant with Windows Vista and Windows 7. Known issues with **Analyst’s Notebook** operating on Windows Vista and Windows 7 are as follows:
Some third party components are not fully supported on Windows Vista, Windows 7 or Windows Server 2008 (#31000)

Reported: 7.0.0

Not all of the third party components that are installed and used by Analyst’s Notebook are claimed to be supported by their suppliers on the Windows versions listed above. As they become available i2 will include supported versions of third party applications in future releases. Unless stated in the known issues below the third party components have not been shown to cause issues.

What’s This? Help is not natively supported in Windows Vista, Windows 7 or Windows Server 2008 (#30396)

Reported: 7.0.0

Analyst’s Notebook uses Windows Help (WinHlp32.exe) to deliver What’s This? Help functionality. Microsoft is not shipping Windows Help with the Windows versions listed above. You can download compatible versions and find out more information from the Microsoft Knowledge Base http://support.microsoft.com/kb/917607.

i2 files cannot be indexed and searched by Windows Vista, Windows 7 or Windows Server 2008 search mechanisms (#30999)

Reported: 7.0.7

The content of files created by i2 Products cannot currently be indexed and searched by the search mechanism in the Windows versions described above.

Document Properties do not work on Windows Vista, Windows 7 or Windows Server 2008 (#30361)

Reported: 7.0.0

Some entries in the summary information are not visible on the Windows versions described above. The 'Description' and 'Origin' sections are not visible through Explorer.

Contacting i2

Technical support is available to anyone whose organization has opted for our annual support program. If you have a question and cannot find a solution in the online help, you can send an e-mail to the i2 Technical Support team.

- For customers in North and South America, e-mail support.mclean@i2group.com.
- For customers in the UK or the Rest of the World, e-mail support.cambridge@i2group.com.

Note: If your i2 software was purchased from one of our distributors, please contact your supplier for technical support.
i2 International and i2 Americas Consulting services work with customers to understand specific requirements and then determine the best methods to get these requirements met through custom development, on-site training, or alignment with the right system integrator or product vendor.

For further information, contact your i2 supplier, or visit the i2 Web site at: www.i2group.com.
Acknowledgements

GEOTRANS The Map Chart Items feature was developed using GEOTRANS, a product of the National Geospatial Intelligence Agency and U.S. Army Engineering Research and Development Center. Use of GEOTRANS in connection with the Analyst’s Notebook software does not indicate endorsement or approval of the product by the Secretary of Defense or the National Geospatial Intelligence agency.

Qt Copyright © 2009 Nokia Corporation and/or its subsidiary(-ies). All rights reserved.

SafeNet Sentinel RMS 8.3 Sentinel® RMS © 1989-2006 SafeNet, Inc. All rights reserved.

SourceGrid Copyright © 2009 Davide Icardi.

ARPACK Copyright © 1996-2008 Rice University.

Developed by D.C. Sorensen, R.B. Lehoucq, C. Yang, and K. Maschhoff. All rights reserved.

Amyuni PDF Converter Copyright © 1999-2007 AMYUNI Technologies). All rights reserved.

BCMenu Copyright © 2002-2005 Brent Corkum). All rights reserved.

Rijndael Simple Encryption Copyright © 2002 Obviex(TM). All rights reserved.

FileDialogExtender Copyright © 2006, Gustavo Franco. All rights reserved.

Copyright © 2007 Decebal Mihaiescu. All rights reserved.

CMemDC Copyright © 1996-2002 Keith Rule. All rights reserved.