vCloud Director 5.5.1.2 | 12 juin 2014 | Build 1881717

Dernière mise à jour : 18 juin 2014

Contenu de ces notes de publication

Ces notes de publication contiennent les rubriques suivantes :

Nouveautés

Cette version de vCloud Director 5.5.1.2 résout les failles de sécurité d'OpenSSL dans le plug-in d'intégration du client, qui ont été documentées dans la section Problèmes résolus.

Les clients qui utilisent vCloud Director 5.5.0, 5.5.1 ou 5.5.1.1 doivent immédiatement effectuer la mise à niveau vers la version 5.5.1.2.

Configuration requise et installation

Pour plus d'informations sur la configuration requise et les instructions d'installation, consultez le Guide d'installation et de mise à niveau de VMware vCloud Director .

Documentation

Pour accéder à l'ensemble de la documentation de vCloud Director 5.5.1, allez à la page Documentation de vCloud Director.

Problèmes résolus

Cette version résout le problème suivant.

  • Problèmes de sécurité d'OpenSSL CVE-2014-0224, CVE-2014-0198, CVE-2010-5298 et CVE-2014-3470 dans le plug-in d'intégration du client
    La bibliothèque OpenSSL du plug-in d'intégration du client VMware a été mise à jour vers la version openssl-1.0.1h pour résoudre les problèmes de sécurité d'OpenSSL CVE-2014-0224, CVE-2014-0198, CVE-2010-5298 et CVE-2014-3470.

    Après avoir effectué la mise à niveau vers vCloud Director 5.5.1.2, tous les utilisateurs doivent mettre à jour le plug-in d'intégration du client.

    La console Web vCloud Director affiche l'une des invites suivantes pour mettre à jour le plug-in d'intégration du client lorsque vous chargez ou téléchargez un OVF ou un fichier multimédia ou que vous accédez à une console de machine virtuelle.

    Une mise à jour du plug-in d'intégration du client est disponible. Cliquez sur le lien ci-dessous pour télécharger le programme d'installation.

    Une mise à niveau du plug-in d'intégration du client est disponible. Cliquez sur OK pour télécharger le plug-in.

    Lorsque l'une de ces invites apparaît, suivez la procédure ci-après pour mettre à jour le plug-in d'intégration du client.

    1. Téléchargez le plug-in d'intégration du client VMware en suivant les instructions qui s'affichent.
    2. Exécutez l'application afin de mettre à niveau le plug-in d'intégration du client.

      Le redémarrage de votre navigateur Web est nécessaire.

Problèmes connus

Les problèmes connus suivants surviennent dans cette version de vCloud Director.

Les problèmes connus sont regroupés de la façon suivante :

 

Problèmes généraux

  • Redirection incorrecte vers la page d'attribution de licence indiquant que les fonctionnalités de vCloud Director sont indisponibles
    Lorsque vCloud Director détecte une violation dans l'attribution de licence, vous êtes redirigé vers la page d'attribution de licence qui indique la valeur Non pour toutes les fonctionnalités de vCloud Director.

    Solution : Ignorez le message et continuez d'utiliser vCloud Director comme d'habitude. Toutes les fonctionnalités sont disponibles malgré le message sur la page d'attribution de licence.

Problèmes d'installation et de mise à niveau

  • Message d'erreur incorrect de mise à niveau du schéma de base de données lors de la mise à niveau de vCloud Director de la version 5.5.1 ou 5.5.1.1. vers la version 5.5.1.2
    Lorsque vous mettez à niveau vCloud Director de la version 5.5.1 ou 5.5.1.1 vers la version 5.5.1.2, le message d'erreur suivant vous invite à tort à mettre à niveau le schéma de base de données.

    Vous devez mettre à niveau le schéma de base de données avant de démarrer le service vmware-vcd. L'outil de mise à niveau du produit ne doit être exécuté qu'une seule fois par groupe vCloud Director. L'outil doit être exécuté avec la commande suivante : /opt/vmware/vcloud-director/bin/upgrade.

    Solution : Vous pouvez ignorer ce message d'erreur en toute sécurité.

  • Les tentatives de mise à niveau de vCloud Director de la version  5.1.x vers la version  5.5.1 échouent après un échec de la passerelle
    La mise à niveau de vCloud Director  5.1.x vers vCloud Director  5.5.1 peut potentiellement provoquer l'échec de la procédure de mise à niveau d'une ou plusieurs passerelles Edge du système et l'affichage d'un message similaire au suivant  :

    Impossible de mettre à jour vCloud Director vers la version 5.5 : Détection d'une passerelle Edge dont la version n'est pas prise en charge. Redéployez les passerelles ou réinitialisez les réseaux vApp disposant d'une passerelle Edge, puis réexécutez la mise à niveau.

    Solution : Consultez Vérification préalable à la mise à niveau concernant les problèmes potentiels avec la passerelle Edge.

Problèmes de localisation

  • Échec de la mise à niveau de l'agent hôte si le nom du système vCloud Director contient des caractères non-ASCII
    Lorsque vous mettez à niveau un système vCloud Director dont le nom contient des caractères non-ASCII d'une version précédente vers la version  5.5.1, la mise à niveau de l'agent hôte échoue.

    Solution : Annulez la préparation de l'hôte à supprimer l'agent hôte, puis préparez de nouveau l'agent hôte.

  • Un nom de lecteur de CD/DVD contenant des caractères non-ASCII provoque l'échec de l'ajout du lecteur de CD/DVD à une machine virtuelle
    Les tentatives d'ajout à une machine virtuelle d'un lecteur de CD/DVD dont le nom comporte des caractères non-ASCII échouent.

    Solution : Modifiez le nom du lecteur de CD/DVD afin qu'il ne contienne que des caractères ASCII avant d'ajouter le lecteur à une machine virtuelle.

  • Les caractères non-ASCII dans les noms de tunnel VPN apparaissent sous la forme de caractères altérés dans les organisations distantes
    Lorsque vous affectez un nom comprenant des caractères non-ASCII à un tunnel VPN, ces derniers apparaissent de manière altérée lorsque vous visualisez le tunnel VPN depuis une autre organisation. Le tunnel VPN continue de fonctionner normalement.

    Solution : N'utilisez aucun caractère non-ASCII dans un nom de tunnel VPN.

  • Impossible de créer et de mettre à jour des passerelles Edge avec un serveur de pool ou un serveur virtuel dont le nom contient des caractères non-ASCII
    Lorsque vous essayez de créer une passerelle Edge avec un serveur de pool ou un serveur virtuel dont le nom contient des caractères non-ASCII, l'opération échoue. Lorsque vous modifiez le nom d'un serveur de pool ou d'un serveur virtuel en ajoutant des caractères non-ASCII, toutes les passerelles Edge qui y sont associées ne peuvent plus être mises à jour.

    Solution : N'utilisez aucun caractère non-ASCII dans les noms de serveurs de pool ou de serveurs virtuels utilisés par des passerelles Edge.

  • Les noms de modèles vApp ne peuvent pas inclure de caractères non-ASCII uniquement
    vCloud Director affiche le message d'erreur Nom d'ordinateur non valide  : Le nom de l'ordinateur ne peut contenir que des caractères alphanumériques et des tirets et ne doit pas contenir uniquement des chiffres. si vous utilisez uniquement des caractères non-ASCII dans un modèle de nom vApp.

  • Dans les langues autres que l'anglais, les listes d'objets peuvent être filtrées uniquement par colonnes ayant du contenu généré par l'utilisateur
    Lorsque vous utilisez vCloud Director dans des langues autres que l'anglais, la fonction de filtre dans les listes d'objets ne fonctionne que lorsque vous filtrez des colonnes ayant du contenu généré par l'utilisateur, comme Nom ou Nom vApp.

  • Certains messages localisés s'affichent en anglais sur Red Hat Enterprise Linux et CentOS  6.x
    Sur Red Hat Enterprise Linux et CentOS  6.x, certaines cellules de vCloud Director ne détectent pas le paramètre de lieu correct au premier démarrage ou lorsque le système d'exploitation est réinitialisé, ce qui entraîne l'affichage de certains messages en anglais.

    Solution : Redémarrez manuellement la cellule en exécutant la commande /opt/vmware/vcloud-director/bin/vmware-vcd restart.

  • Invites réitérées demandant l'installation du plug-in d'intégration du client VMware lors de l'importation d'un fichier dans un catalogue ou de l'ouverture d'une console de machine virtuelle à partir d'un compte Windows qui contient des caractères non-ASCII
    Lorsque vous tentez d'importer un fichier dans un catalogue vCloud Director ou d'ouvrir une console de machine virtuelle à partir d'un compte Windows dont le nom comporte des caractères non-ASCII, vCloud Director vous invite à installer le plug-in d'intégration du client VMware. Cela se produit même si le plug-in est déjà installé.

    Solution : Connectez-vous au compte administrateur Windows ou à un comte utilisateur dont le nom ne contient que des caractères ASCII, puis chargez le fichier ou ouvrez la machine virtuelle.