与通常在浏览器中提供的下载功能相比,Akamai Download Manager (DLM) 可提供更加有效、迅速的文件下载,对于大文件尤其如此。 它可以暂停,然后重新开始下载,即便在关闭并重新启动计算机以后也可恢复下载。
此下载管理器可为终端用户提供更强大的下载能力,对于那些 Internet 连接速度较慢以及下载较大文件时会遇到困难的用户尤其如此。
下载管理器尤其有利于:
此下载管理器是两个类似的应用程序:
当终端用户单击某个设置为使用下载管理器的链接时,将发生以下事件:
此下载管理器可在多种平台上运行:
当然,未使用下载管理器的平台上的用户仍可使用浏览器的下载功能来下载文件,只是无法使用此下载管理器的功能。
第一次使用此下载管理器时,系统可能会要求您接受一份安全证书,是否会出现此要求取决于您所使用的浏览器和平台。 如果选择不接受证书,并且网站提供了用于下载文件的替代链接,您仍然可以下载文件,只是不使用下载管理器而已。
列表窗口: 使用此下载管理器时,下载开始后您将看到两个窗口的其中一个。 您可能看到列表窗口:
下载多个文件:此窗口列出当前的所有下载文件。 您可以同时下载多个文件,并且可以选择列表中的文件以对其采取进一步操作。
暂停、恢复:您可以在下载列表中选择以暂停、暂停后恢复或取消下载。 如果单击“Pause”(暂停),该按钮将更改为“Resume”(恢复)。
暂停、退出、恢复:如果退出,下载管理器会在桌面上放置一个图标,让您能够在以后恢复下载。 您可以在以后任何时候恢复下载,即便在关闭并重新启动计算机以后也可恢复。 如果该下载文件已在下载站点上更改,则会在您恢复下载时发送一条消息通知您。 恢复下载时,将使用您的默认浏览器,即与 HTML 文件关联的应用程序。 如果需要,可以使用“打开方式”这个操作系统功能来改变所使用的默认浏览器(例如在 Windows 中,可以右键单击文件并选择“打开方式”)。 如果最初使用浏览器 B 开始下载,您需要使用浏览器 B 来继续并完成下载。
移除、删除: 如果选择列表中某个已完成的下载,您将看到“Remove”(移除)按钮。 此按钮用于从列表中移除文件。 如果单击该按钮,则还会询问您是否希望从目标磁盘删除该文件。
摘要信息窗口: 如果单击“Detail”(详细信息)按钮,您将看到摘要信息窗口。
运行或关闭窗口:下载完毕后,您可以使用摘要信息窗口暂停或恢复下载。 如果选中“Launch When Done”(完成后运行)复选框,下载管理器会在下载完成后尝试使用关联的应用程序来启动或打开该文件。 选中“Close”(关闭)复选框将会在下载完成后关闭此窗口。
下载时间因所下载的文件大小、Internet 连接速度和网络状况而异。
问题:
将任何版本的 Akamai Download Manager 与 Internet Explorer 配合使用时,当前在以下平台上具有 4 GB 的文件大小限制。
原因:
使用 SSL 时,Akamai Download Manager 的 ActiveX 版本所使用的 Microsoft WinINet API 中当前存在 4 GB 的文件大小限制 (http://support.microsoft.com/kb/298618)。 这只会在使用 SSL 时影响 Internet Explorer 浏览器的使用。 所有其他浏览器和平台当前具有 10 GB 的文件大小限制。
解决方法:
原因:
Web 浏览器上的弹出窗口拦截器或较高的安全设置可能阻止了 Akamai DLM 窗口打开。
解决方法:
如果 Web 浏览器或 Internet 工具栏(例如 Yahoo! 工具栏或 Google 工具栏)中启用了弹出窗口拦截器, 您需要禁用弹出窗口拦截器才能开始下载。
注意:下载管理器有时最长可能要花一分钟时间才会开始下载。 请等待其完成初始加载,不要匆忙地认定存在问题
原因:
如果 Akamai 检测到您的计算机不满足运行 Akamai DLM 的最低系统要求,则会显示一个空白窗口或“File not found”(文件未找到)消息。 在大多数情况下是由于未启用 JRE 或 ActiveX 控件造成的。
解决方法:
要让您的 Web 浏览器能够运行 Akamai DLM,请参阅 “概述”选项卡上列出的系统要求。 您可能希望切换到另一个满足系统要求的浏览器以访问您的下载。
原因:
Akamai DLM 在 Mozilla Firefox、Apple Safari、Netscape Navigator 和 Mozilla 中以一个 Java Applet 的形式来实现。 当 Java Applet 第一次在 Web 浏览器会话中运行时,必须启动 Java Run Time Environment (JRE)。 在大多数计算机上,JRE 在不到 10 秒内即可启动。 在较慢的计算机上,JRE 可能要花几分钟时间才能启动。 第一次安装 Akamai DLM 时,该 Java Applet 会请求您接受来自 Akamai Technologies 的安全证书。 此对话框可以隐藏在其他窗口后面。
解决方法:
如果咖啡杯图标几分钟后还未消失,则最小化打开的窗口,然后接受该安全证书。
原因:
如果遇到“Cannot connect to server”(无法连接到服务器)、“Network error. Cannot download”(网络错误,无法下载)、“server not found”(服务器未找到)或“DNS error”(DNS 错误)等服务器错误,这可能是由于网络中断,或者您的代理服务器从 URL 请求中去掉了必需的信息。 在大多数情况下,是由于网络中断或网络问题导致您无法下载文件。
解决方法:
在这种情况下,我们建议您稍后重新尝试下载,或者通过另一家网络 ISP 连接到 Internet 来尝试下载。
原因:
如果您在禁用 Akamai DLM 以后或在从未启用 Active-X 控件的情况下尝试开始下载,Internet Explorer (IE) 中将会显示此错误。
解决方法:
要在 IE 6 或 IE 7 中启用 Akamai DLM,请执行以下步骤:
要在 Firefox 3.0 for Windows 中启用 Akamai DLM,请执行以下步骤:
在“工具”->“选项”->“内容”屏幕上:如果选中了“阻止弹出窗口”
原因:
如果您收到“Malicious software reported. If you trust the site continue to download”(报告了恶意软件。如果您信任该站点,请继续下载)、“Files from the internet can harm your computer”(来自 Internet 的文件可能损害您的计算机)或者只是“unable to download”(无法下载)等警告,这可能是由防病毒软件导致的。 这是 Norton 360 和 Online Security 2006 以及 Windows Live OneCare 的一个已知问题
解决方法:
在大多数情况下,可以在警告窗口中单击以允许下载,但在某些情况下,您可能需要禁用安全措施才能下载。
常见问题:
故障排除:
您是否在运行弹出窗口拦截器?
某些弹出窗口拦截软件会阻止下载管理器打开其窗口。
对于 Internet Explorer:
安全设置情况如何?
要使下载管理器能够工作,浏览器必须能够下载并运行经过签名的 ActiveX 控件、下载文件并运行 JavaScript。 可通过访问“工具”->“Internet 选项”->“安全”->“自定义级别”来检查这些设置。 “中”安全级别启用所有必要的功能。 “高”安全级别禁用了这些必要设置中的大部分功能。
对于非 Internet Explorer 浏览器:
您是否在计算机上安装了 JRE? 如果是,安装的是什么版本?
您可能没有为非 Internet Explorer 浏览器安装最新的 Java RunTime 插件。 请参见 “概述”选项卡上列出的要求。
要修正上面弹出窗口中的证书问题,请在您的 JVM 中进行以下两处更改。
完成这两处更改后,重新启动浏览器,您应该能看到以下 3 个弹出窗口:
单击“Run”(运行)按钮接受数字签名后,您应该能够看到并使用此下载管理器。
消息:Cannot connect to server: Check connections, and try again. Would you like to retry now?(无法连接到服务器。请检查连接,然后重试。是否立即重试?)
含义:Internet 连接存在,但是文件服务器未应答。
操作建议:确保您的 Internet 连接已建立并处于活跃状态。 如果连接正常,而您无法找出问题,可以通过常规 HTTP 来尝试下载文件。 在该对话框中选择“Yes”(是)将会重试下载。
消息:Network error, cannot download. Check connections, and try again. Would you like to retry now?(网络错误,无法下载。请检查连接,然后重试。是否立即重试?)
含义:下载管理器无法建立网络连接。
操作建议:确保您的 Internet 连接已建立并处于活跃状态。 如果连接正常,而您无法找出问题,可以通过常规 HTTP 来尝试下载文件。 在该对话框中选择“Yes”(是)将会重试下载。
这适用于将此下载管理器与 Internet Explorer 一起运行的情况。 其他浏览器依赖 Java 来显示下载管理器。 虽然文件本身可能出于性能考虑而进行了缓存,但不会在计算机上安装任何内容。 在许多情况下,关闭并重新打开浏览器即可使用新版本。
Internet Explorer 7:
如果希望移除用于 Internet Explorer 应用程序的下载管理器,可按如下方式删除 ActiveX 控件:
删除该对象后,在下次启用下载之前,此下载管理器不会再次下载。
Internet Explorer 5 和 6:
如果希望移除用于 Internet Explorer 应用程序的下载管理器,可按如下方式删除 ActiveX 控件:
删除该对象后,在下次启用下载之前,此下载管理器不会再次下载。
以下是此下载管理器可能生成的提示和错误的列表。 如果任何错误持续存在,请尝试通过常规 HTTP 下载。 如果仍然收到错误,请与客户支持部门联系。