vCloud Director 5.5.1.2 | 2014 年 6 月 12 日 | 内部版本号 1881717

上次更新日期:2014 年 11 月 10 日

本发行说明涉及的内容

本发行说明涵盖下列主题:

新增内容

此次发布 vCloud Director 5.5.1.2 解决了客户端集成插件中的 OpenSSL 安全漏洞,该漏洞已记录在 已解决的问题部分中。

使用 vCloud Director 5.5.0、5.5.1 或 5.5.1.1 的客户应立即升级到 5.5.1.2。

系统要求和安装

有关系统要求和安装说明的信息,请参见  《VMware vCloud Director 安装和升级指南》

可以采用以下升级途径。

  • 从 vCloud Director 5.5.1 升级到 vCloud Director 5.5.2。 如果您是服务提供商,请参见以下说明,然后升级到 vCloud Director 5.5.2。
  • 从 vCloud Director 5.5.1 升级到适用于服务提供商的 vCloud Director 5.6.3。 只有参与 vCloud Air Network(原名 VSPP)方案的服务提供商才能使用此升级选项。

针对服务提供商的重要说明: 如果升级到 vCloud Director 5.5.2,则无法升级到适用于服务提供商的 vCloud Director 5.6.3,除非 VMware 在未来提供修补程序。 如果近期计划升级到适用于服务提供商的 vCloud Director 5.6.3,请勿升级到 vCloud Director 5.5.2。 如果您不是服务提供商,则无权访问适用于服务提供商的 vCloud Director 5.6.3。 请再次查看此升级限制的相关更新说明。

文档

要访问全套 vCloud Director 5.5.1 文档,请转到 vCloud Director 文档页面。

已解决的问题

此版本解决了以下问题。

  • 客户端集成插件中的 OpenSSL 安全问题 CVE-2014-0224、CVE-2014-0198、CVE-2010-5298 和 CVE-2014-3470
    VMware 客户端集成插件的 OpenSSL 库已更新至版本 openssl-1.0.1h,解决了 OpenSSL 安全问题 CVE-2014-0224、CVE-2014-0198、CVE-2010-5298 和 CVE-2014-3470。

    升级到 vCloud Director 5.5.1.2 以后,所有用户必须更新客户端集成插件。

    当您上载或下载 OVF 或媒体文件或者访问虚拟机控制台时,vCloud Director Web 控制台会显示以下更新客户端集成插件的提示之一。

    客户端集成插件的更新可用。单击以下链接可下载安装程序 (An update to the Client Integration Plugin is available. Click the link below to download the installer)

    客户端集成插件的升级可用。单击 [确定] 可下载插件 (An upgrade is available for the Client Integration Plug-in. Click OK to download the plugin)。

    当显示这些提示之一时,请执行以下步骤来更新客户端集成插件。

    1. 根据提示说明,下载 VMware 客户端集成插件。
    2. 运行应用程序以升级客户端集成插件。

      这将需要重新启动您的 Web 浏览器。

已知问题

此版本的 vCloud Director 存在以下问题。

这些已知问题可分为以下几组:

 

一般问题

  • 用户被错误地定向到许可页面,并且页面显示各项 vCloud Director 功能不可用
    当 vCloud Director 检测到许可违例时,用户将被重定向到许可页面,其中列出的所有 vCloud Director 功能的值均为 [否]

    应对措施:忽略该消息,继续照常使用 vCloud Director。尽管许可页面上显示该消息,但所有功能实际上均可用。

安装和升级问题

  • 当将 vCloud Director 从版本 5.5.1 或 5.5.1.1 升级到版本 5.5.1.2 时会出现错误的数据库架构升级错误消息
    当您将 vCloud Director 从版本 5.5.1 或 5.5.1.1 升级到版本 5.5.1.2 时,会错误地提示您升级数据库架构,并显示以下错误消息。

    在启动 vmware-vcd 服务之前,您将需要升级数据库架构。产品升级工具针对每个 vCloud Director 组只能运行一次。此工具可以使用以下命令运行: /opt/vmware/vcloud-director/bin/upgrade (You will need to upgrade the database schema before starting the vmware-vcd service. The product upgrade tool should be run only once per vCloud Director group. The tool may be run with the following command: /opt/vmware/vcloud-director/bin/upgrade)

    应对措施:您可以安全地忽略此错误消息。

  • 尝试将 vCloud Director 从版本 5.1.x 升级到版本 5.5.1 的操作在网关失败后失败
    任何将 vCloud Director 5.1.x 版本升级到 vCloud Director 5.5.1 的操作都有可能导致系统的一个或多个 Edge 网关在升级过程中失败,并记录类似于以下内容的消息。

    无法将 vCloud Director 升级到 5.5:找到一个由不受支持的 Edge 版本支持的网关。请重新部署网关或重置 Edge 支持的 vApp 网络,然后重新运行升级 (Cannot upgrade vCloud Director to 5.5: Found 1 gateways backed by unsupported edge version. Please redeploy gateways or reset vApp networks backed by edge and then run upgrade again)。

    应对措施:请参见“ 升级前的 Edge 网关潜在问题检查”。

本地化问题

  • 如果 vCloud Director 系统名称包含非 ASCII 字符,则主机代理升级将失败
    将 vCloud Director 系统从以前版本升级到 5.5.1 版本时,如果该系统的名称中包含非 ASCII 字符,则主机代理升级将失败。

    应对措施:取消准备主机并移除主机代理,然后重新准备主机代理。

  • 包含非 ASCII 字符的 CD/DVD 设备名称会导致尝试将 CD/DVD 添加到虚拟机失败
    尝试将名称中包含非 ASCII 字符的 CD/DVD 设备添加到虚拟机失败。

    应对措施:将 CD/DVD 设备名称更改为仅包含 ASCII 字符,然后再将其添加到虚拟机。

  • VPN 通道名称中的非 ASCII 字符在远程组织中显示为乱码字符
    如果将某一名称分配给包括非 ASCII 字符的 VPN 通道,则从其他组织查看该 VPN 通道时,名称中的非 ASCII 字符显示为乱码字符。VPN 通道继续正常运作。

    应对措施:请勿在 VPN 通道名称中使用非 ASCII 字符。

  • 无法使用名称中包括非 ASCII 字符的池服务器或虚拟服务器创建或更新 Edge 网关
    当尝试使用名称中包括非 ASCII 字符的池服务器或虚拟服务器创建 Edge 网关时,操作将会失败。将池服务器或虚拟服务器的名称更改为包括非 ASCII 字符时,与池服务器或虚拟服务器关联的所有 Edge 网关都将无法更新。

    应对措施:请勿在用于 Edge 网关的池服务器或虚拟服务器的名称中使用非 ASCII 字符。

  • vApp 模板名称不能只包含非 ASCII 字符
    如果在 vApp 模板名称中只使用非 ASCII 字符,vCloud Director 会显示错误消息 无效的计算机名称: 计算机名称只能包含字母数字字符和连字符,不能只包含数字 (Invalid computer name:Computer name can only contain alphanumeric characters and hyphens, and must not contain only digits)

  • 在除英语外的其他区域设置中,只能按包含用户生成内容的列过滤对象列表
    使用 vCloud Director 时,如果区域设置是除英语外的其他设置,只有使用包含用户生成内容的列(如 [名称] 或 [vApp 名称])进行过滤,对象列表的过滤器功能才有效。

  • 某些已本地化的消息在 Red Hat Enterprise Linux 和 CentOS 6.x 中显示为英文
    在 Red Hat Enterprise Linux 和 CentOS 6.x 上,某些 vCloud Director 单元在首次启动时或操作系统重新引导后检测不到正确的区域设置,导致某些消息显示为英文。

    应对措施:通过运行 /opt/vmware/vcloud-director/bin/vmware-vcd 命令手动重新启动单元。

  • 使用包含非 ASCII 字符的 Windows 帐户将文件导入目录或打开虚拟机控制台时,会重复提示安装 VMware 客户端集成插件
    尝试使用名称中包含非 ASCII 字符的 Windows 帐户将文件导入 vCloud Director 目录或打开虚拟机控制台时,vCloud Director 会提示您安装 VMware 客户端集成插件。即使已安装该插件,也会提示此消息。

    应对措施: 登录到名称中仅包含 ASCII 字符的 Windows 管理员帐户或用户帐户,然后上载文件或打开虚拟机。