vSphere Storage Appliance Manager 安装程序 5.5.1 | 2014 年 3 月 11 日 | 内部版本 1606928

vSphere Storage Appliance 自动安装程序 5.5.1 | 2014 年 3 月 11 日 | 内部版本 1606928

独立 VSA 群集服务 5.5.1 | 2014 年 3 月 11 日 | Windows 内部版本 1606662 | Linux 内部版本 1606311

请时常查看以了解这些发行说明的新增内容及更新。

上次更新时间:2014 年 3 月 11 日

发行说明内容

本发行说明包含以下主题:

本发行说明提供有关适用于 VMware vSphere 5.5 的分布式共享存储解决方案 VMware vSphere Storage Appliance 5.5.1 的信息。

vSphere Storage Appliance 5.5.1 的新增功能

本 vSphere Storage Appliance 版本包含增强功能,并提供了许多已列在 已解决的问题部分中的缺陷修复。

有关新功能的详细信息,请参见 VMware vSphere Storage Appliance 文档网页上的 《vSphere Storage Appliance 安装和管理指南》

早期版本

各个版本的发行说明中分别描述了 VMware vSphere Storage Appliance 5.5 的功能和已知问题。要查看 VMware vSphere Storage Appliance 5.5 早期版本的发行说明,请参见 《VMware vSphere Storage Appliance 5.5 发行说明》

安装说明

vSphere Storage Appliance 支持 VSA Manager 安装程序向导和 VSA 自动安装程序脚本作为安装工作流。下表显示了每个工作流要求的对比情况。请阅读《vSphere Storage Appliance 安装和管理》 文档,了解每个工作流的详细信息。

安装要求 VSA Manager 安装程序 VSA 自动安装程序
硬件要求
两台或三台采用同类硬件配置的服务器
  • CPU:64 位 x86 Intel 或 AMD 处理器,2 GHz 或更高
  • 内存
    • 6 GB,最小值
    • 24 GB,推荐大小
    • 72 GB,测试最大值
      注意:因为对于 VSA 群集没有内存限制,所以每个 ESXi 主机的内存可以超过 72 GB。
  • 网卡 4 个单端口或 2 个双端口 1 千兆以太网卡或 10 千兆以太网卡,或者 1 个四端口网卡(不提供网卡冗余)
  • RAID 控制器:RAID 控制器必须支持 RAID10、RAID6 或 RAID5
  • 硬盘:每个主机使用的所有磁盘必须具有相同的容量和性能特性。每个主机的最大磁盘数为 28。
    请勿混用 SATA 和 SAS 磁盘。有关可行配置的信息,请参见 RAID 设置和要求。尽管带有异构供应商和型号组合、驱动器容量和驱动器速度的磁盘驱动器配置可能可行,但是 RAID 适配器的写入 I/O 性能将是 RAID 集中最慢驱动器的倍数,且容量将是 RAID 集中最小驱动器的倍数。VMware 强烈建议您不要使用混合磁盘驱动器配置,除非在从稍有区别的服务器制造商处获取替换驱动器后必须重新构建 RAID 集的情况下,才可使用。替换容量小于当前最小容量的驱动器将导致 RAID 集重新构建失败并且不受支持。
在物理机或虚拟机上使用 vCenter Server 5.5 系统。您可以在 VSA 群集中的一个 ESXi 主机上运行 vCenter Server。vCenter Server 安装需要采用以下配置:
  • CPU:64 位 x86 Intel 或 AMD 处理器,2 GHz 或更高
  • 内存和硬盘空间:需要的内存和硬盘空间量取决于您的 vCenter Server 配置。有关详细信息,请参见《vSphere 安装和设置》 文档。
  • 网卡:千兆以太网网卡或万兆以太网网卡
对于 VSA Manager,需要更多硬盘空间:
  • VSA Manager:10 GB
  • VSA 群集服务:2 GB
网络硬件要求和配置
  • 两台千兆/万兆以太网交换机(建议配置)
    注意:采用两台交换机网络配置,可在物理网络层中消除单点故障
  • 一台千兆/万兆以太网交换机(最低配置)
  • 在 VSA 环境中,网络的运行速度必须达到 1 千兆或以上才能支持配置。
静态 IP 地址。vCenter Server 和 VSA Manager 不需要在与 VSA 群集相同的子网中。每个 VSA 群集的成员(包括用于双成员配置的 VSA 群集服务)都需要在相同的子网中。
(可选)在以太网交换机上配置一个或两个 VLAN ID
软件安装
在每个主机上使用 ESXi 5.5
Windows Server 2003 或 Windows Server 2008 64 位安装
在物理系统或虚拟机上使用 vCenter Server 5.5。您可以在 VSA 群集中的一个 ESXi 主机上运行 vCenter Server。
vSphere Web Client

请阅读《VMware vSphere Storage Appliance 安装和管理》 文档,了解每个工作流的详细信息。

RAID 设置和要求

RAID 类型
SATA 驱动器
SAS 驱动器
RAID5
不受支持
下列 RAID 配置示例显示了 SAS 磁盘的驱动器数和最大驱动器容量的有效组合形式。比本示例显示的容量小的容量也会受到支持:
  • 10 X 0.5T => 4.5T VMFS 数据存储
  • 8 X 0.75T => 5.25T VMFS 数据存储
  • 7 X 1T => 6T VMFS 数据存储
  • 6 X 1.5T => 7.5T VMFS 数据存储
  • 5 X 2T => 8T VMFS 数据存储
  • 3 X 3T => 6T VMFS 数据存储
  • 4 X 2.5T => 7.5T VMFS 数据存储
  • 4 X 3T => 9T VMFS 数据存储
RAID6
每台主机受支持的最大 VMFS 数据存储限制为 24T。 每台主机受支持的最大 VMFS 数据存储限制为 24T。此最大容量总体上适用于在 ESXi 主机上创建的所有 VMFS 数据存储。
RAID10
每台主机受支持的最大 VMFS 数据存储限制为 8T。该值不是 VMFS 数据存储限制,而是由 RAID 集的预期总磁盘驱动器弹性施加的限制。在此限制范围之外,存储弹性低于可接受限制。
磁盘转速
至少 7200 转/分
至少 10000 转/分
注意:为获得最佳性能,请选择 15000 转/分的磁盘。

升级说明

如果使用先前版本的 vSphere Storage Appliance,可将您的环境升级到版本 5.5 或更高版本。所使用的升级过程取决于 vSphere Storage Appliance 的当前版本。如果从 vSphere Storage Appliance 版本 1.x 进行升级,您要使用 VSA Manager 安装程序同时升级所有组件。单个升级过程会升级 VSA Manager、VSA 群集服务和 VSA 群集设备。

如果从 5.1.x 版本进行升级,VSA Manager 安装程序将仅升级 VSA Manager。任何现有群集设备将保持处于其原始版本,您可以单独对其进行升级。下表显示了 VSA Manager 和 VSA 群集设备的版本兼容性。

有关升级步骤,请参见 《vSphere Storage Appliance 安装和管理指南》 中的“3 升级 vSphere Storage Appliance 环境”

已解决的问题

下列问题在发布 vSphere Storage Appliance 5.5 之后已得到解决。

  • 安装 VSA Manager 后,vCenter Server 内存消耗增加
    waitforupdates 调用超时时,VSA Manager 不会取消该挂起的调用,这将导致 vCenter Server ( vpxd.exe) 的内存消耗稳步增加。
  • 本版本已解决该问题。

  • 通过自动安装程序使用 FQDN 创建 VSA 群集会显示 IP 无效错误
    用于创建 VSA 群集的自动安装程序仅通过主机的 IP 地址才能将该主机用作参数。这将导致脚本式安装程序检查主机的有效 IP 地址,并且不接受完全限定域名替代 IP 地址。

    本版本已解决该问题。

  • 当 vCenter Server 使用非默认 HTTPS 端口配置时,无法加载 VSA Manager 插件
    当在 vCenter Server 安装期间使用非默认值配置 HTTP 和 HTTPS 端口号时,VSA Manager 不会与 vCenter Server 建立正确连接。

    本版本已解决该问题。

  • VSA 从 5.1 升级到 5.5 后,vSphere Web Client 无法加载和显示 VSA 5.5 插件

    将 VSA Manager 从 5.1 升级到 5.5 后,vSphere Web Client 中未加载 VSA 5.5 Web Client 插件。即使已升级至 VSA 5.5,VSA Manager 插件仍报告版本为 5.1。出现此问题的原因是没有为次要升级重新注册插件,并且未更新扩展信息,导致版本号报告为 5.1.X。

    本版本已解决该问题。

已知问题

本 vSphere Storage Appliance 版本中的已知问题分组如下:

先前未记录的已知问题用星号 * 表示

升级问题

  • 如果 vCenter Server IP 更改,VSA 升级将失败*
    安装 VSA 后,如果修改了 vCenter Server IP 地址,则 VSA 升级将失败,并出现类似以下内容的错误消息:

    错误 29463。VSA Manager 应安装在 vCenter Server 上。请确保这是 vCenter Server,并键入正确的主机名 (Error 29463. VSA Manager should be installed on the vCenter Server. Please ensure this is the vCenter Server and type the correct host name)
    1. 在注册表中,转至 Computer\HKEY_LOCAL_MACHINE\SOFTWARE\VMware, Inc.\vSphere Storage Appliance Manager\VC
    2. 使用 vCenter Server 的新 IP 地址更新注册表项 VCServerAddress
      该地址在安装期间存储在注册表中。
  • 解决办法: 更改注册表项中的 IP 地址

  • 使用非默认密码时,VSA 群集升级失败
    在将 VSA 群集从版本 5.1.x 升级到 5.5 时,如果使用的密码不是默认密码,则尝试升级该群集将失败。将显示一条错误消息,指示该群集不可用。

    解决办法:升级 VSA 群集之前,请将密码更改为默认密码。升级完成后,可以将其更改回您选择的密码。

vSphere Web Client 问题

  • vSphere Web Client 中的 VSA Manager 页面可能不会按预期自动刷新
    通常,VSA Manager 页面会自动检索和显示新信息。在某些情况下,该页面不会进行自动刷新。

    解决办法:F5 按钮手动刷新 VSA Manager 页面。如果此操作无效,请重新启动 vSphere Web Client。

  • VSA Manager 页面无法加载到 vSphere Web Client 中
    VSA Manager 页面无法加载时,您可能会看到以下错误消息:
    出现内部错误 - 无法从 /vsa-ui/locales/vsa-ui-en_US.swf 加载资源模块 (An internal error has occurred - Unable to load resource module from /vsa-ui/locales/vsa-ui-en_US.swf)

    解决办法:禁用 VSA 5.5 插件,并恢复为 vSphere Web Client 5.1 插件以访问 VSA:

    1. 在 webclient.properties中,设置以下值以恢复 VSA 特定配置:
      scriptPlugin.enabled=true
      allowHttp=false
    2. 从 vCenter Server 的以下位置删除 VSA 5.5 插件的 vSphere Web Client 缓存数据:
      C:\ProgramData\VMware\vSphere Web Client\vc-packages\vsphere-client-serenity
      C:\ProgramData\VMware\vSphere Web Client\catalog\VirtualCenter\5.5.0\en
    3. 重新启动 vCenter Server 上的 vSphere Web Client 服务。
    4. 使用 vSphere Web Client 5.1 访问 VSA Manager。