Adobe® Acrobat® Connect™ Pro 7.5 and VMware ESX Server

Reaping the benefits of live web conferencing and seminars in a virtualized environment

Adobe Acrobat Connect Pro 7.5 offers organizations a secure, intuitive, and hassle-free way to engage in live and on-demand web conferencing, web seminars, and eLearning. Acrobat Connect Pro is an ideal solution for enterprises because it offers flexible deployment options, strong security, and an architecture based on open standards.

To extend the benefits of Acrobat Connect Pro to customers with virtualized server architectures, Adobe tested the application running VMware ESX Server to determine the application’s performance in a virtual environment. The tested configurations include a single application server setup that supports up to 500 concurrent users and a clustered three-server setup that supports up to 500 concurrent users per server. Each configuration uses a dedicated virtualized database. In these two configurations, Adobe found that Acrobat Connect Pro performed on par with an equivalent physical installation, showing minimal variations in performance. Any variations in performance were within acceptable limits, and the user experience was comparable. Customers who want to install Acrobat Connect Pro on VMware ESX Server can do so without negative impact on either performance or user experience.

This white paper describes the two tested configurations, provides in-depth performance comparisons, and advises customers on the best way to set up and configure Acrobat Connect Pro on VMware ESX Server.
**Tested environments**

An on-site installation of Acrobat Connect Pro includes the server software and the database, which stores information about users and content. To test the performance of Acrobat Connect Pro on VMware ESX Server, Adobe configured the Acrobat Connect Pro Server and database in two separate test environments.

**Single application server with separate database**—Two ESX servers, one hosting a virtual machine with an instance of Acrobat Connect Pro Server, and another hosting a virtual machine with an instance of the Acrobat Connect Pro database.

**Three application server cluster**—Three ESX servers hosting four virtual machines. One virtual machine running an instance of the Acrobat Connect Pro database server, and three virtual machines, each running an instance of Acrobat Connect Pro Server.
For detailed installation requirements, see page 7.

**Benchmarking tests**

To evaluate the performance of these deployments, we constructed a metric and end-user experience study to characterize back-end utilization under a typical user workload scenario, divided into three main uses: meeting, training, and a hybrid. The tested load included screenshare at standard resolution and concurrent playing of an audio sine wave. Performance metrics were collected for all servers. End-user metrics were collected to measure consistent performance.

We evaluated the following use case scenarios:

**Screenshare in medium and large groups**—Ten meetings were launched upon setup at the same time. Between 20 and 100 meeting users were entered at a rate of 10 users per second. After all of the users entered, we initiated screenshare at a resolution of 1024x768 pixels. The typical scenario ran for 30 minutes.

**Concurrent users taking a course on the cluster**—A sample course was created on the cluster by uploading a five-slide presentation deck with graphics ranging from simple to complex. Users logged in to the cluster at a rate of one to three users per second, depending on the test setup, and completed the course. The typical scenario ran for 20 minutes.

**Large or medium groups in a meeting and concurrent users taking a course on the cluster and sharing PowerPoint and PDF files**—Ten meetings were launched upon setup at the same time. Between 20 and 100 meeting users entered at a rate of 10 users per second. After all of the users entered, training users logged in to the cluster at a rate of 5 to 20 users per minute, depending on the test setup, and completed the course. At the same time, PDF and PowerPoint files were being uploaded and converted in the meeting rooms. The typical scenario ran for 40 minutes.

**Performance comparisons**

To validate that the performance of Acrobat Connect Pro 7.5 in a virtualized environment is comparable to a physical environment, we conducted identical tests in equivalent physical configurations.
<table>
<thead>
<tr>
<th>Hardware</th>
<th>Specifications</th>
</tr>
</thead>
<tbody>
<tr>
<td>Application server</td>
<td>HP ProLiant DL360 G4p – 2x dual-core 3.40GHz Intel Xeon</td>
</tr>
<tr>
<td></td>
<td>6114MB RAM</td>
</tr>
<tr>
<td></td>
<td>Storage 147GB @ 10K RPM RAID 1 (mirroring configuration)</td>
</tr>
<tr>
<td>Database server</td>
<td>HP ProLiant DL360 G4p – 2x dual-core 3.40GHz Intel Xeon</td>
</tr>
<tr>
<td></td>
<td>6114MB RAM</td>
</tr>
<tr>
<td></td>
<td>611x147GB RPM RAID 5 (distributed data guarding configuration)</td>
</tr>
</tbody>
</table>

Key findings of single application server tests
- End-user metrics for meeting and training scenarios are comparable.
- CPU usage of the Acrobat Connect Pro application server is within acceptable performance limits.
- CPU usage of the Acrobat Connect Pro database server is acceptable and below threshold limits.
- The performance of the Acrobat Connect Pro database is acceptable.
- No network packets were dropped, and latency was minimal.

The end-user VoIP experience in the single application server configuration matches the experience in the equivalent physical configuration.

Average transaction response time for training users under a single application server configuration
CPU consumption by Acrobat Connect Pro Server on a 4-core CPU configuration (a mean value of less than 25% is acceptable)

Key findings of tests of three application servers

- Acrobat Connect Pro performance in a clustered configuration is acceptable.
- End-user metrics for meeting and training scenarios are comparable.
- CPU usage of the Acrobat Connect Pro application server is within acceptable performance limits.
- CPU usage of the Acrobat Connect Pro database server is acceptable and below threshold limits.
- The performance of the Acrobat Connect Pro database is acceptable.
- No network packets were dropped, and latency was minimal.

The end-user VoIP experience in the three-server configuration matches the experience in the equivalent physical configuration.
Conclusion
Based on the test results comparing Acrobat Connect Pro physical and virtual environments, it is apparent that Acrobat Connect Pro on VMware ESX Server performs on par with a physical configuration for the tested usage scenarios. Variances in performance between physical and virtual environments are due to differences between CPU families and clock speeds and differences in storage hardware and configurations. Acrobat Connect Pro on VMware ESX Server does require special considerations depending on the particular usage pattern on which it is deployed. VMware support for capacity guidance is recommended for licensed customers when configuring two virtual 4-core application servers per 8-core physical VMware ESX box.
Installation requirements
Before setting up Acrobat Connect Pro software to use with VMware ESX server software, plan the number of ESX servers and CPU cores and RAM size per server based on the following guidelines:

- One CPU core reserved for the ESX server (recommended but not required)
- Four CPU cores and 6GB RAM for each Acrobat Connect Pro Server virtual machine
- Minimum of four CPU cores and 6GB RAM for the Acrobat Connect Pro database server virtual machine
- Support for a RAID 6 disk configuration
- At least two network interface cards (NICs)

If you are running vCenter Server, you need three NICs. The first NIC is configured during ESX installation and is used for Service Console. VMware recommends that customers dedicate the second NIC to virtual machine network traffic. VMware recommends customers have a third NIC dedicated to VMotion, DRS, and high-availability network traffic. Because the ESX hosts in our test environment have only two NICs, we configured the first NIC for Service Console and VMotion, and the second NIC for network traffic.

Installing and configuring the VMware environment
After you configure the ESX Server hardware, install the necessary and optional VMware software. You then create the virtual machines on which the Acrobat Connect Pro Server and the Acrobat Connect Pro database will run.

Configure VMware ESX Server hardware
The following steps for modifying BIOS settings are specific to HP ProLiant servers. If you are running servers from a different manufacturer and your BIOS menu options are different, see the manufacturer’s website for information on modifying BIOS settings.

1. Enable the MPS table.
   - From the main BIOS menu, select Advanced Options.
   - Select MPS Table.
   - Select Full Table APIC.

2. Enable Intel CPU virtualization.
   - From the main BIOS menu, select Advanced Menu.
   - Select Processor Options.
   - Select Intel Virtualization and set it to Enabled.

3. Connect to the network.
   - Connect both NICs to the network.

4. Configure storage.
   - Enter the RAID controller menu (on HP ProLiant servers, press the F8 key) to configure RAID. VMware recommends using RAID 6 for ESX servers hosting virtual machines with Acrobat Connect Pro Server, and RAID 6 for an ESX server hosting virtual machines with a database server.

Install the ESX operating system
Install VMware ESX Server according to installation instructions from VMware.

Install the vSphere client
Install the vSphere client according to installation instructions from VMware.
Optional: Install vCenter Server

VMware vCenter Server is a Windows-based application that provides a scalable and extensible platform that forms the foundation for virtualization management. It provides centralized control and visibility at every level of virtual infrastructure. With vCenter Server, virtualization environments are easier to manage. A single administrator can manage 100 or more workloads, more than doubling typical productivity in managing physical infrastructure.

vCenter Server enables efficient management of a large-scale enterprise, giving you the ability to manage more than 1,000 hosts and up to 10,000 virtual machines from a single console.

vCenter Server needs to be installed only when it is required to manage multiple ESX hosts and leverage VMware features like VMotion, Cold Migration, Cloning and Creation of template.


Create virtual machines

Now that you have installed the necessary VMware software, you must configure the VMware environment in preparation for installing Acrobat Connect Pro. The main step in this part of the installation involves the creation of virtual machines.

Before you can create the virtual machines, you must first connect the ESX hosts’ second NIC and, if you are running vCenter Server, connect it to the ESX hosts.

Note: If you are running vCenter Server, use the following steps to create the first virtual machine and then convert it to a template to create the other virtual machines. If you are not running vCenter Server, you must repeat the following steps for each virtual machine that you want to create.

1. In VSphere, right-click the ESX host and select **New Virtual Machine > Custom Configuration > Storage > Virtual Machine V7**.

2. Select the operating system type that will be installed on this virtual machine.

3. Specify the number of CPUs to allocate to this virtual machine.

4. Specify the amount of memory to allocate.

5. Select the virtual network adapter (VMXNET 3 network adapter).

6. Specify the virtual hard disk size.

7. To change the SCSI controller type for the second hard disk, right-click the virtual machine and select **Edit Settings > New SCSI Controller > Change Type > VMware Paravirtual**.

8. To point to the operating system installer ISO image, right-click VM > **Edit Settings > CD/DVD**. Select **Connect at power on**. Select the datastore ISO file, and browse to the operating system installer ISO file.

9. Power on the virtual machine and install the operating system.

10. Remove the floppy and CD devices from the virtual machine to improve performance.

11. To increase virtual machine performance, right-click the virtual machine and select **Edit Settings > Resources > Memory** and change the memory reservation setting to about 60% of the total allocated memory for this virtual machine.

12. To maximize performance, VMware recommends dedicating a separate virtual hard disk for running the Acrobat Connect Pro application servers and database. To add a virtual hard disk, power off the virtual machine and then right-click the virtual machine and select **Edit Settings > Add > Hard Disk > Specify size > SCSI 1:0**.
13. To maximize the performance of the virtual hard disk, align the partition of the second virtual hard disk.
   A. On the virtual machine, log in to Windows as the administrator.
   B. Launch CMD > diskpart > list disk > select disk 1 > create partition primary align=64 > exit.
   C. Start the Disk Management Utility by selecting My Computer > Manage.
   D. Right-click on the new partition and select Change drive letter and paths > Add > Select letter.
   E. Right-click on the new partition and select Format > Allocation Unit Size = 32K.

14. (vCenter Server users only) To convert the virtual machine to a template, right-click the virtual machine and select Template > Convert to Template.

If you are not using vCenter Server, you must repeat steps 1 – 12 to create each virtual machine.

Create a Windows 2003 Enterprise virtual machine customization profile (vCenter Server users only)
VMware Customization Specification Manager enables you to create a profile, which is used by a customization application that is executed when deploying new virtual machines from templates. It cuts deployment time by automatically changing host names, IP addresses, and machine hardware IDs, which all must be unique to each virtual machine. If you are not using VMware Customization Specification Manager, you must manually change this information for each virtual machine that you create. For more information about VMware Customization Specification Manager, see www.vmware.com/pdf/vsphere4/r40/vsp_40_admin_guide.pdf.

Create new virtual machines from a template for running Acrobat Connect Pro application server (vCenter Server users only)
If you are installing several Acrobat Connect Pro Servers, you can reduce installation time by installing Acrobat Connect Pro on one virtual machine and converting it to a template, and then using the template to create more Acrobat Connect Pro Server virtual machines. For more information, see the vSphere Basic System Administration document and the section “Deploy Virtual Machines from Templates” www.vmware.com/pdf/vsphere4/r40/vsp_40_admin_guide.pdf.

Validate installation
To validate your VMware ESX Server installation, ensure that you have completed the following steps:

- Install any necessary updates or patches to the operating system, application, and database.
- Install all VMware tools.
- Remove any unwanted devices.
- Complete partition alignment.
- Select the Vmxnet network interface driver.
- Assign adequate resources to the VM.
- Ensure separate virtual switches for the service console, VMkernel, and virtual machines.
- Set the appropriate reservations to provide the minimal amount of resources required for the operating system and critical applications.

You are now ready to deploy Acrobat Connect Pro.
## Supported virtual machine settings for Adobe Acrobat Connect Pro 7.5

### Virtual machine configured for Acrobat Connect Pro Server

<table>
<thead>
<tr>
<th>Setting</th>
<th>Setting Value</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>CPU</strong></td>
<td>Four vCPU</td>
</tr>
<tr>
<td><strong>CPU resource settings</strong></td>
<td>Reservation: 0Hz</td>
</tr>
<tr>
<td></td>
<td>Shares: Normal</td>
</tr>
<tr>
<td></td>
<td>Limit: Unlimited</td>
</tr>
<tr>
<td><strong>Memory resource settings</strong></td>
<td>Reservation: 4,096MB</td>
</tr>
<tr>
<td></td>
<td>Shares: Normal</td>
</tr>
<tr>
<td></td>
<td>Limit: Unlimited</td>
</tr>
<tr>
<td></td>
<td>Configured: 6,144MB</td>
</tr>
<tr>
<td><strong>Network adapter type</strong></td>
<td>VMXNET3</td>
</tr>
<tr>
<td><strong>Hard disk 1 provisioned size</strong></td>
<td>15GB</td>
</tr>
<tr>
<td><strong>Hard disk 2 provisioned size</strong></td>
<td>30GB</td>
</tr>
<tr>
<td><strong>CDROMs and floppy drives</strong></td>
<td>Removed</td>
</tr>
<tr>
<td><strong>vApp options</strong></td>
<td>Disabled</td>
</tr>
<tr>
<td><strong>Boot delay</strong></td>
<td>0ms</td>
</tr>
<tr>
<td><strong>Page file size</strong></td>
<td>2,046MB</td>
</tr>
<tr>
<td><strong>Hyperthreaded core sharing mode</strong></td>
<td>Any</td>
</tr>
<tr>
<td><strong>CPU/MMU virtualization</strong></td>
<td>Automatic</td>
</tr>
<tr>
<td><strong>Swap file location</strong></td>
<td>Default</td>
</tr>
<tr>
<td><strong>Datastore</strong></td>
<td>Local storage (hard disk 2)</td>
</tr>
<tr>
<td><strong>File system</strong></td>
<td>VMFS</td>
</tr>
</tbody>
</table>

### Virtual machine configured for Acrobat Connect Pro database

<table>
<thead>
<tr>
<th>Setting</th>
<th>Setting Value</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>CPU</strong></td>
<td>Four vCPU</td>
</tr>
<tr>
<td><strong>CPU resource settings</strong></td>
<td>Reservation: 0Hz</td>
</tr>
<tr>
<td></td>
<td>Shares: High</td>
</tr>
<tr>
<td></td>
<td>Limit: Unlimited</td>
</tr>
<tr>
<td><strong>Memory resource settings</strong></td>
<td>Reservation: 4,096MB</td>
</tr>
<tr>
<td></td>
<td>Shares: High</td>
</tr>
<tr>
<td></td>
<td>Limit: Unlimited</td>
</tr>
<tr>
<td></td>
<td>Configured: 6,144MB</td>
</tr>
<tr>
<td><strong>Network adapter type</strong></td>
<td>VMXNET3</td>
</tr>
<tr>
<td><strong>Hard disk 1 provisioned size</strong></td>
<td>15GB</td>
</tr>
<tr>
<td><strong>Hard disk 2 provisioned size</strong></td>
<td>30GB</td>
</tr>
<tr>
<td><strong>CDROMs and floppy drives</strong></td>
<td>Removed</td>
</tr>
<tr>
<td><strong>vApp options</strong></td>
<td>Disabled</td>
</tr>
<tr>
<td><strong>Boot delay</strong></td>
<td>0ms</td>
</tr>
<tr>
<td><strong>Page file size</strong></td>
<td>2,046MB</td>
</tr>
<tr>
<td><strong>Hyperthreaded core sharing mode</strong></td>
<td>Any</td>
</tr>
<tr>
<td><strong>CPU/MMU virtualization</strong></td>
<td>Automatic</td>
</tr>
<tr>
<td><strong>Swap file location</strong></td>
<td>Default</td>
</tr>
<tr>
<td><strong>Datastore</strong></td>
<td>Local storage (hard disk 2)</td>
</tr>
</tbody>
</table>
Installing and configuring Adobe Acrobat Connect Pro 7.5 on VMware ESX Server

Install Acrobat Connect Pro
Install Acrobat Connect Pro on a separate disk from the operating system using the installation steps described in the Acrobat Connect Pro documentation.


Install the MS-SQL database server and create the Acrobat Connect Pro database
If you are not using the embedded database engine, deploy Microsoft SQL Server 2005 Standard Edition on a disk separate from the operating system.

Support resources
If you need support when installing and operating VMware ESX Server, contact your VMware representative.

For support when installing and operating Acrobat Connect Pro, visit www.adobe.com/support/connect or contact your Acrobat Connect Pro representative.

About Adobe
Adobe revolutionizes how the world engages with ideas and information – anytime, anywhere and through any medium. For more information, visit www.adobe.com.

About VMware
VMware delivers solutions for business infrastructure virtualization that enable IT organizations to energize businesses of all sizes. With the industry-leading virtualization platform—VMware vSphere—customers rely on VMware to reduce capital and operating expenses, improve agility, ensure business continuity, strengthen security, and go green. With 2008 revenues of $1.9 billion and more than 150,000 customers and 22,000 partners, VMware is the leader in virtualization and consistently ranks as a top priority among CIOs. VMware is headquartered in Silicon Valley with offices throughout the world. For more information, visit www.vmware.com.