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Introduction

This best practices guide provides instructions for delivering Microsoft Office 2016 to managed macOS
devices using the VMware AirWatch® Enterprise Mobility Management™ Product Provisioning feature.
For a complex and nonstandard application such as Microsoft Office 2016, Product Provisioning serves
as an alternative to the standard practice of installing the application directly on a device.

The procedures in this guide do not apply to a specific macOS-based hardware model or to a particular
VMware AirWatch deployment model. The instructions provide guidance, but do not represent strict
design requirements.

Purpose

This white paper provides configuration guidelines for provisioning Microsoft Office 2016 as a product to
employees on managed macOS devices.

Use the procedure outlined in this paper in any of the following ways:

* Learn how to provision Microsoft Office 2016 to macOS devices.

» Customize the provided configurations to address Microsoft Office 2016 use cases not covered in this
paper.

» Use the provided configurations as a framework for identifying and provisioning other complex
applications.

What Is VMware AirWatch Enterprise Mobility Management?

VMware AirWatch Enterprise Mobility Management enables and secures the workspace for today’s
mobile operating systems. The AirWatch Console aggregates mobile endpoints of every platform,
operating system, and type into a single management space.

Unified endpoint management with VMware AirWatch provides standard enterprise mobility
management functionality, such as device restrictions, platform-specific features, and application
security. VMware AirWatch also offers additional security options, including device encryption, access
control for corporate resources, and data loss prevention.

AirWatch Enterprise Mobility Management

» Streamlines deployment options
* Simplifies over-the-air configurations

* Enables an interoperable framework for enterprise security with VMware NSX® integration, customer-
accessible APIs, and a broad ecosystem of partner integrations via the Mobile Security Alliance

* Provides an enterprise app storefront for Android, iOS, macOS, Windows 7 through 10, and rugged and
Internet of Things (loT) devices
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What Is AirWatch Product Provisioning?

Product Provisioning is a feature of VMware AirWatch Enterprise Mobility Management that delivers
custom or complex files to managed devices. In cases when you cannot directly install a file or set of
files, package the files in the AirWatch Console, creating a product. Then, provision that product to
managed devices, and monitor provisioning status from the AirWatch Console.

PRODUCT PROVISIONING

=W e

Attributes Files+Actions Agent-Managed

Devices

Figure 1: Overview of VMware AirWatch Product Provisioning
This guide shows how to configure:

* A custom XML profile to preset default values for the installed applications

» A Custom Attribute payload to detect pre-installed software, which avoids running the installer on pre-
installed devices

» Microsoft Office 2016 for Mac by adding files and actions

Intended Audience

This guide assumes a basic knowledge and understanding of VMware AirWatch and Microsoft Office
2016. It does not cover VMware AirWatch product deployment or managing macOS devices.

VMware AirWatch system administrators of macOS devices can use this document to deliver Microsoft
Office 2016 to managed devices using Product Provisioning.

Apple macOS system administrators can use this document to learn more about deploying complex
applications, such as Microsoft Office 2016, with Product Provisioning.

Apple macOS system engineers and administrators can learn about VMware AirWatch technical
capabilities that augment deploying software not available in the App Store.
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Microsoft Office 2016 Use Case for Product Provisioning

Figure 2 summarizes the use case covered in this guide and demonstrates the nested structure of a
provisioned product. Multiple application installers for Microsoft Office 2016 are bundled into a single
product for provisioning to managed macOS devices.

DEVICE: Agent-Managed macOS Devices

PRODUCT: Microsoft Office 2016

Custom Attributes

Devices with

Microsoft Office 2016

Installed

Device
1

Device
2

Device
oo

Figure 2: Managed macOS Devices Provisioned with the Microsoft Office 2016 Product
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Provision Office 2016 for macOS

The following sections provide step-by-step instructions to deploy Microsoft Office 2016 for macOS
using VMware AirWatch. The sections are in the recommended order of completion.

1. Skip Splash Screens - This optional section demonstrates how to use custom XML to modify
configurable parameters supported by Office 2016.

2. Report Devices Running Microsoft Office 2016 - This optional section demonstrates how to create
and use custom attributes to report information to the AirWatch Console that is not collected by
default. As demonstrated in following sections, you can leverage these attributes to further constrain
device and user scoping for a product.

3. Separate the Product Application Suite Install Scripts - This required section illustrates how a script
leverages the Microsoft Content Delivery Network to host the Office 2016 application installers and
instructs how to create individual application installation scripts.

4. Configure Files and Actions for the Product Application Suite - This required section describes how
to build each component of the Office 2016 product.

5. Create the Microsoft Office 2016 for Mac Product - This required section describes how to aggregate
all the files and actions components into a product that is deployed to managed devices and installs
Microsoft Office 2016.

Skip Splash Screens

Microsoft Office 2016 for Mac supports modifying plist file snippets to remove the splash screens that
appear when Office 2016 applications launch. This optional exercise creates a custom XML profile that
modifies the plist file for each application. You can complete the rest of the exercises if you choose to
skip this exercise.

1. Go to the Custom XML payloads for Microsoft Office 2016 for Mac page in the VMware Developer
Center.

2. Download the SetupMSOFirstRun.xml file, which contains the plist snippets used to skip the splash
screens.

3. In the AirWatch Console, navigate to Add > Profile > macOS > Device Profile.
4. On the General tab, provide basic information for the profile:

- Name - Enter macOS-CustomXxML-Microsoft Office 2016 to indicate the profile’s purpose and
application.

- Assighment Group(s) - Select an assignment group that contains the macOS devices or users
licensed to use Microsoft Office.
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5. In the menu on the left, click Custom Settings.
a. Click Configure.

b. From the XML file, copy the dictionary snippet (<dict> .. </dict>) for one of the Microsoft
Office applications into the Custom Settings text box.

macOS Add a New Apple macOS Profile

TH} Energy Saver

(© Time Machine Custom Settings
[ Finder Custom Settings * <dier
R Accessibility <key>PayloadType</key>
<string=com.microsoft Excel</string>
& Printing <key>PayloadVersion</key>
<integer>1</integer>
D Proxies <key>Payloadidentifier<ikey>
~ <String> Il d C87b-0133-5bcd-
& Moty 245260460665 alacarte m HEES
% Managed Domains ACHEEEUY S
<key=PayloadEnabled</key>
G VMware Fusion <true /=
<key>PayloadUUID</key>
@ Content Filter <string>2b1305b-6/5b-5cdb-a00f-cb2db73d1249</string>
<key>PayloadDisplayNames/key>
[l AirPlay Mirroring <string>Excel First Launch Settings</string>
<key>kSublIAppCompletedFirstRunSetup1507</key>
& AirPrint <true />
o> <idict>
san
i Firewall
M Firmware Password 4

£ Custom Attributes

c. To open another text box, click the + icon in the bottom right corner.

d. Add the dictionary snippet for another Office application, and continue this process until each
application is configured.

e. After all the snippets are added, click Save.
6. Click Publish, then click Publish again to deliver the profile to the assigned devices.

vmware
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Report Devices Running Microsoft Office 2016

The following procedure creates a Custom Attribute profile payload, which reports requested device
information to the AirWatch Console. In this use case, the payload reports devices with the 2016 version
of Microsoft Office currently installed.

The report serves its primary purpose in another configuration—the creation of the Microsoft Office 2016
product. When you create that product, use the reported attributes to determine exclusions for product
assignment. This use of exclusions prevents Microsoft Office 2016 from provisioning to devices that
already have the applications installed.

1. In the AirWatch Console, make sure that you are in a customer-level Organization Group.
2. Navigate to Add > Profile > macOS > Device Profile.

3. Configure the General tab.

- Name - Enter macOS-Attributes-Microsoft Office 2016 Versions to indicate the profile’s purpose
and application.

- Assighment Group - Select an assignment group that contains the macOS devices or users licensed
to use Microsoft Office.

4. Navigate to Custom Attributes > Configure.

5. Configure a Custom Attribute payload that reports values for each application in the Microsoft Office
2016 suite.

a. Enter one of the following attribute names, and paste the corresponding script into the text box.

ATTRIBUTE NAME SCRIPT/COMMAND

Word-Version if [ -x "/Applications/Microsoft Word.app" ]; then /usr/bin/defaults
read /Applications/Microsoft\ Word.app/Contents/Info.plist
CFBundleShortVersionString ; else echo "0.0"; fi

Excel-Version if [ -x "/Applications/Microsoft Excel.app" ]; then /usr/bin/defaults
read /Applications/Microsoft\ Excel.app/Contents/Info.plist
CFBundleShortVersionString ; else echo "0.0"; fi

OneNote-Version if [ -x "/Applications/Microsoft OneNote.app" ]; then /usr/bin/defaults
read /Applications/Microsoft\ OneNote.app/Contents/Info.plist
CFBundleShortVersionString ; else echo "0.0"; fi

PowerPoint- if [ -x "/Applications/Microsoft Powerpoint.app" ]; then /usr/bin/defaults
Version read /Applications/Microsoft\ Powerpoint.app/Contents/Info.plist
CFBundleShortVersionString ; else echo "0.0"; fi

Outlook-Version if [ -x "/Applications/Microsoft Outlook.app" ]; then /usr/bin/defaults
read /Applications/Microsoft\ Outlook.app/Contents/Info.plist
CFBundleShortVersionString ; else echo "0.0"; fi

b. Set the Execution Interval to Schedule to execute the script in hourly intervals.

From the Report Every drop-down menu, select a time frame of 4 hours to periodically refresh
the custom attribute’s value on the device.

d. To add the next attribute name, click + in the bottom right corner.
Repeat these steps to add the custom attribute for each application.
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6. To push the fully configured profile to devices, click Save & Publish.
Allow time for the profile to deliver to devices and return the results of the custom attribute scripts.

7. Navigate to Devices > Staging & Provisioning > Custom Attributes > List View to verify that the
configured Attribute names appear in the list view.

Devices » Staging & Provisioning » Custom Attributes »
List View
ADD -
T
Excel-Version Apple Demo AirWatchAgent Enabled
* Certificates
~ Staging & Provisioning
OneNote-Version Apple Demo AirWatchAgent Enabled
rd
Outlook-Version Apple Demo AlrWatchAgent Enabled
s,
Product Sets
PowerPoint-Version Apple Demo AirWatchAgent Enabled
w Custom Attributes rd
List View
Word-Version Apple Demao AirWatchAgent Enabled
s,

This report’s values get applied when configuring the product’s assignment rules to avoid unnecessary
provisioning to devices that already have the applications installed.

Separate the Product Application Suite Install Scripts
The following procedure demonstrates how to use a software vendor’s content delivery network (CDN)
as a source for applications installers.

Create a separate install script for each Microsoft Office application to generate a log for each
component that you are installing.

1. Go to Shell Script to Install Microsoft Office 2016 for Mac in the VMware Developer Center.
2. Download the InstallMS02016.sh script, and open it in a text editor.
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3. Locate the DOWNLOAD URLS code block, as in line 15 in the screenshot.
Each line represents an Office application.

DOWNLOAD_URLS=( \

4. Use a # to comment out all the URL lines in the code block, except for the one for which you are
creating an install file, and save the file as InstallMS02016-<App Name>.sh.

For example, to create an install file for Outlook, comment out every URL line, except the Outlook
URL on line 17. Then, save a local copy of the file. Name the file InstallMS02016-Outlook.sh.

DOWNLOAD_URLS=( \

5. Repeat the process for each application by reopening the InstallMsS02016.sh file, commenting out
the URL lines, and saving them as InstallMS02016-<App Name>.sh.
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6. Open the local storage location for the application install files. Verify that a file was created for each

application.
APP NAME FILE
Excel InstallMS02016-Excel.sh
MAU InstallMSO2016-MAU.sh
OneNote InstallMS02016-OneNote.sh
Outlook InstallMS02016-Outlook.sh
PowerPoint InstallMSO2016-PowerPoint.sh
Word InstallMS02016-Word.sh

Configure Files and Actions for the Product Application Suite

To provision Microsoft Office 2016 to macOS devices, it must become a product. Files and actions serve
as the product’s building blocks. For Product Provisioning, files refer to a literal file, and actions refer to a
behavior associated with a specific file.

For this use case, the Office files consist of each application in the Microsoft Office suite’s individual
install scripts, and the associated action is “Install.”

1. In the AirWatch Console, navigate to Devices > Staging & Provisioning > Components >
Files/Actions > Add Files/Actions > Apple macOS to configure files and actions for each
Office application.

2. Onthe General tab, enter a Files/Actions Name for each application using the format
MS02016 <App Name>.

Note: Because Volume Licensing has an extra configuration step, configure it last to streamline
configuration in alignment with the instructions in this white paper.

APP NAME FILES/ACTIONS NAME
Excel MSO2016 Excel

MAU MS0O2016 MAU
OneNote MS0O2016 OneNote
Outlook MS0O2016 Outlook
PowerPoint MS0O2016 PowerPoint
Word MS0O2016 Word
Volume Licensing MSO2016 VL Serializer
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3. On the Files tab, upload one of the application install files created in the Separate the Product
Application Suite Install Scripts procedure.

a. Select Add Files > Choose Files and browse for the install script file to upload.

APP NAME FILES

Excel InstalMSO2016-Excel.sh

MAU InstalIMSO2016-MAU.sh

OneNote InstalMSO2016-OneNote.sh

Outlook InstalMSO2016-Outlook.sh

PowerPoint InstalMSO2016-PowerPoint.sh

Word InstalMSO2016-Word.sh

Volume Licensing Microsoft_Office_2016_VL_Serializer_2.0.pkg

b. Click Save to open the Add File window.
c. Inthe text box, enter the download path.

APP NAME DOWNLOAD PATH

Excel /tmp/InstaliMSO2016-Excel.sh

MAU /tmp/InstallMSO2016-MAU.sh

OneNote /tmp/InstaliMSO2016-OneNote.sh

Outlook /tmp/InstallMS0O2016-Outlook.sh

PowerPoint /tmp/InstaliMSO2016-PowerPoint.sh

Word /tmp/InstallMSO2016-Word.sh

Volume Licensing /tmp/Microsoft_Office_2016_VL_Serializer 2.0.pkg

d. Click Save and review the file name and download path.

Mame 2atl Versior Type
InstallMSO2016-Outlock.sh ftmp/InstallMS02016-Outlook.sh 1.0 Local

Items 1-1 of
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4. On the Manifest tab, configure the options in the Install Manifest section.
Click Add Action.

o

b. From the Action(s) to Perform drop-down menu, select Execute Script.
c. Enter the appropriate script file path and name.
d. Select Execute As Root.

1 *
Action(s) To Perform Execute Script =

ScriptFile Path and Name * | jen 5 /1nstallMS02016-Outlook.sh

Execute As Root

e. Inthe Add Manifest window, click Save.

f. To upload the application’s files and actions to VMware AirWatch, in the Add Files/Actions
window, click Save.

5. To configure another Office 2016 application, repeat steps 1-4.

Important: Configure the volume license serializer last. First, repeat steps 1-4. Then, follow these
steps.

a. In the Add Files/Actions window, scroll down to the Uninstall Manifest section, and click
Add Action.

- Action(s) To Perform - Select Run from the drop-down menu.

- Command Line and Arguments to run - Enter rm -f /Library/Preferences/com.microsoft.
office.licensingV2.plist.

- TimeOut - Enter 0.

Action(s) To Perform * Run i

Command Line and

. rm -f /Library/Preferences/com.microsoft.office.licensir
Arguments to run

TimeOut (-1 for infinite) * 0

b. In the Add Manifest window, click Save.

c. To upload the files and actions for the volume license serializer to VMware AirWatch, in the
Add Files/Actions window, click Save.
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Create the Microsoft Office 2016 for Mac Product

The product contains all the individual application installers.

1. In the AirWatch Console, navigate to Devices > Staging & Provisioning > Product List View >
Add Product > Apple macOS.

2. On the General tab, complete the fields to provide basic product information.
- Name - Enter the name Microsoft Office 2016 for Mac.

- Assighment Group(s) - Select an assignment group that contains macOS devices or users licensed
to use Microsoft Office.

- Assighment Rules - Click to configure a rule for each custom attribute associated with Microsoft
Office 2016, and add a logical operator between each rule to define how the rules interact.

a. Inthe Add Product window, click Add Rules.

b. In the Create or Edit Assignment Rules window, click Add Rule and choose values from the
drop-down menus to configure assignment for the attributes.

MENU VALUE
Attribute/ Select a custom attribute value for a single application from the Microsoft Office
Application 2016 suite. This ensures that the product does not install on devices with

Microsoft Office 2016 already installed.
» Excel-Version

* OneNote-Version

» Outlook-Version

» PowerPoint-Version

» Word-Version

Operator From the drop-down menu, select <> (not equals).

Value From the drop-down menu, select Enter Manually, and enter the version
number of the install file used.

Note: At the time of publication of this document, the version number of the
available file was 15.28. Check Microsoft Office 2016 for Mac Downloads for the
current version number.

c. If configuring another Attribute and Value, select Add Logical Operator and select OR from the
drop-down menu.

vmware
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d. Review the configured rules and click Save.

Create Or Edit

nment Rules

016 FOR macOS BEST PRACTICES

Assignment Rule

Excel-Version @ AWe ~ Enter Manually

o’ v
GneNote-Version @A ~ - Enter Manually ~ |15.28

or v
Outlock-Version @ Air ~ o ~ Enter Manually 1]

or v
PowerPoint Version & + ~ Enter Manually - 8

oa -
Word-version @ Airw: v o v Enter Manually 28

© Add Rule

© Add Logical Operator

Rule Logic  Exeel-Viersion @ AirWatchAgent < '15,28' OR OneNote-Version @ AirWatchAgent == '15,28" OR Outlook-Version @
Airwatehagent <= 15 28 OR @ AirWatehAgent <> '15.2E" OR Word-Version @ AirWatchAgent <> '15.28

X X %X X

o 0 0 0 0 0 00 0 0
X x X%

3. On the Manifest tab, click Add, and configure the fields to create the Microsoft Office 2016 product.

a. Action(s) To Perform - Select Install Files / Actions.
b. Files/Actions - Enter the name of one of the files and actio

ns that you created.

*
Action(s) To Perform Install Files / Actions

Files/Actions * Microsoft Outlook 2016

c. Click Save.

es and Actions for the Product

Files/Actions = Microsoft Outlook 2016
Files/Actions = Microsoft Word 2016
Files/Actions = Microsoft Excel 2016
Files/Actions = Microsoft Powerpoint 2016
Files/Actions = Microsoft OneNote 2016
Files/Actions = Microsoft AutoUpdater

Files/Actions = Microsoft Voelume Licensing Seriali...

4. Repeat Step 4 for each file created in the section Configure Fil
Application Suite.
5. Review the manifest and ensure that all the applications are included.
u Down Step Numbe Action Type Persistent Description
A L 4 1 Install Files / Actions No
A ¥ 2 Install Files / Actions No
A v 3 Install Files / Actions No
A v 4 Install Files / Actions No
A v 5 Install Files / Actions No
A v 6 Install Files / Actions No
A v 7 Install Files / Actions No
Items 1-7 of
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On the Deployment tab, set the product type to Required, and click Activate for the Microsoft Office
2016 product.

7. Review the list of target devices, and click Activate.

. Navigate to Devices > Staging & Provisioning > Product Dashboard and review the status of the
product deployment. Available statuses include:

- In progress
- Successful
- Failed

vmware
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Summary

Product Provisioning, a VMware AirWatch Enterprise Mobility Management feature, provides a
customizable method for delivering applications to managed devices. You can use Product Provisioning
as an alternative to standard delivery methods for non-store applications like Microsoft Office 2016.

This document provided instructions for provisioning Microsoft Office 2016 as a product to managed
macOS devices. It described:

1.

vmware

How to use custom XML to modify configurable parameters supported by the third-party
software title.

How to create and use custom attributes to report information to the VMware AirWatch Console
that is not collected by default.

How to leverage a software vendor’s CDN as a source for application installers.

How to configure assignment rules to leverage custom attributes to further constrain device and
user scoping for a product.

How to turn all the files and actions required to install non-app-store software components into
a product that can be deployed to managed devices.
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Additional Resources

Microsoft Office for Mac Resources
* Microsoft Office Software Repository
» #Microsoft-Office Channel on MacAdmins Slack

AirWatch Product Provisioning Documentation
* FAQ: Product Provisioning for macOS (AirWatch knowledge base article)

* Software deployment guidance and common product recipes for macOS
(AirWatch knowledge base article)

Product Documentation for AirWatch 9.1
To learn more, search for keywords in the AirWatch Online Help system.

Product Provisioning keywords and phrases:

* Product Provisioning & Staging * macOS Custom Attributes
* Product Provisioning Feature Matrix * Files/Actions for Products
» Assign Organization Groups Using Custom Attributes * Create a Product

* Product Provisioning Overview

Mobile Device Management for macOS keywords and phrases:

* Architecture * macOS Enrollment Overview

» Directory Services Integration * Managing Devices Overview

» Certificate Management * macOS Device Profiles Overview
» Apple Device Enroliment Program » Compliance Policies Overview

» Apple Configurator * Mobile Application Management
* Accounts » Mobile Content Management

Finding PDF Guides for AirWatch 9.1
If you prefer to read a physical document, reference the Product Documentation for AirWatch v9.1 list,
available within the AirWatch Online Help system. Then, complete the following steps:

1. Search the list for the appropriate document. In this instance, the following choices are appropriate:

- AirWatch Assignment Groups - Chapter 6 (Groups) in the VMware AirWatch Mobile Device
Management Guide

- Product Provisioning - VMware AirWatch Product Provisioning for macOS Guide
2. Copy the address of the link beside the document title. Then, click the link.
3. Enter credentials on the myAirWatch authentication screen.
4. Paste the link address into the navigation bar.
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