Getting Started with VMware Fusion

VMware Fusion for Mac OS X

This document supports the version of each product listed and supports all subsequent versions until the document is replaced by a new edition. To check for more recent editions of this document, see http://www.vmware.com/support/pubs.

EN-001202-00
You can find the most up-to-date technical documentation on the VMware Web site at:
http://www.vmware.com/support/
The VMware Web site also provides the latest product updates.
If you have comments about this documentation, submit your feedback to:
docfeedback@vmware.com
Contents

1 Getting Started with VMware Fusion  5
   About VMware Fusion  5
   What Is a Virtual Machine?  6
   VMware Fusion Capabilities  6
   System Requirements for VMware Fusion  7
   Install VMware Fusion  7
   Upgrading VMware Fusion  7
      Upgrade VMware Fusion with Autoupdate  8
      Upgrade VMware Fusion from DVD or USB Key  8
      Upgrade VMware Fusion from a Download  9
   Start VMware Fusion  9
   Getting Up and Running  10
      Create a Virtual Machine Using Windows Easy Install and an Installation CD  10
      Power On the Boot Camp Partition as a Virtual Machine  11
      Import a Parallels or Virtual PC Virtual Machine  12
   Supported Guest Operating Systems  12
   Using Mac Keyboards in a Virtual Machine  13
   Suspend and Resume a Virtual Machine  13
   Take Advantage of VMware Fusion Online Resources  14

Index  15
Getting Started with VMware Fusion

With VMware Fusion™, you can run personal computer (PC) applications and devices on your Intel-based Mac.

Designed for the Mac user, VMware Fusion takes advantage of the security, flexibility, and portability of virtual machines to run Windows and other x86 operating systems at the same time as Mac OS X.

This chapter includes the following topics:
- “About VMware Fusion,” on page 5
- “VMware Fusion Capabilities,” on page 6
- “System Requirements for VMware Fusion,” on page 7
- “Install VMware Fusion,” on page 7
- “Upgrading VMware Fusion,” on page 7
- “Start VMware Fusion,” on page 9
- “Getting Up and Running,” on page 10
- “Supported Guest Operating Systems,” on page 12
- “Using Mac Keyboards in a Virtual Machine,” on page 13
- “Suspend and Resume a Virtual Machine,” on page 13
- “Take Advantage of VMware Fusion Online Resources,” on page 14

About VMware Fusion

Take a quick look at what VMware Fusion does and how it works.

What VMware Fusion Does

VMware Fusion enables you to run your Windows applications and PC-only devices on your Intel-based Mac. You can run multiple operating systems and applications at the same time, along with your Mac applications. The operating systems and applications are isolated in secure virtual machines.

How VMware Fusion Works

VMware Fusion maps the physical hardware resources to the virtual machine’s resources, so each virtual machine has its own processor, memory, disks, I/O devices and so on. Each virtual machine is the full equivalent of a standard x86 computer, although it is represented in a single file package on the Mac.
After you install VMware Fusion and create a virtual machine, you can install and run complete, unmodified operating systems, and associated application software in the virtual machine, just as on a physical PC. Operating systems you can use include Windows, Linux, Mac OS X Server, Novell NetWare, FreeBSD, and Sun Solaris x86. VMware Fusion offers the benefits of having a second PC without its added expense, physical setup, and maintenance.

The operating system of the computer on which you run VMware Fusion is called the host. Mac OS X and Mac OS X Server are the only hosts supported for VMware Fusion. The virtualized operating system you run inside VMware Fusion is called the guest.

What Is a Virtual Machine?

A virtual machine is a software computer that, like a physical computer, runs an operating system and applications.

A virtual machine contains a display, a hard disk or disks, one or more processors, memory, a CD/DVD drive, a network adapter, and a USB controller. All of these components are virtualized. That is, these elements of a virtual machine are all created by software and stored in files on your Mac.

The virtual machine runs in a window on your Intel-based Mac. You install an operating system and applications in the virtual machine and operate it as you would a physical computer. An operating system cannot distinguish between a virtual machine and a physical machine, nor can applications or other computers on a network. What you can do with a physical machine (install software, save files, add additional drives, and so on) you can do with a virtual machine.

Virtual machines are completely independent from their underlying physical hardware. For example, you can configure a virtual machine with virtual components that are completely different from the physical components that are present on the underlying hardware. Virtual machines on the same physical host can run different kinds of operating systems (Windows, Linux, Mac OS X Server, and others).

VMware Fusion Capabilities

With VMware Fusion, you can create, open, and run VMware virtual machines, and use PC-specific hardware with a Mac.

With VMware Fusion, you can perform the following tasks:

- Run x86 operating systems, including Windows, Linux, Mac OS X Server, Solaris and others, on Mac OS X without rebooting.
- Run Windows and Linux applications on your Intel-based Mac.
- Run most Windows 3D applications that require DirectX 9.0c with Shader Model 3, or OpenGL 2.1, on your Mac.
- Import virtual machines created with Parallels Desktop, Microsoft Virtual PC for Mac, or virtual machines that use the OVF (Open Virtualization Format) standard.
- Migrate your physical Windows PC to a VMware Fusion virtual machine with the integrated Migration Assistant.
- Access USB devices, such as video cameras and high-speed disks, from a virtual machine.
- Drag files between your Intel-based Mac OS X host machine and virtual machines running other x86 operating systems.
- VMware Fusion works with VMware virtual machines created with VMware Workstation 4.x and later, VMware Server 1.0.x and later, VMware ESX Server 2.x and later, and VMware GSX Server 3.2.
System Requirements for VMware Fusion

Verify that you have the following minimum system requirements for installing and using VMware Fusion.

- Any Mac with a 64-bit Intel processor (Intel Core 2 Duo or newer).
- Mac OS X 10.6.8 or later, Mac OS X 10.8 and later recommended.
- Mac OS X Server
- Operating system installation media (disk or disk image) for virtual machines. Windows operating systems are available separately from Microsoft and other retailers.

**IMPORTANT:** VMware Fusion does not provide any operating systems for installation onto virtual machines you create with VMware Fusion. You must provide the operating system installation media.

- 2GB of memory, 4GB recommended.
- 750MB of free disk space for VMware Fusion, and at least 5GB of free disk space for each virtual machine.

**NOTE:** Make sure that you have enough memory to run Mac OS X, plus the memory required for each guest operating system and for applications on the Mac and in the virtual machine.

Install VMware Fusion

Install VMware Fusion by dragging the VMware Fusion disk image to your Mac Applications folder.

**Prerequisites**

Verify that you have the administrator password for your Mac.

**Procedure**

1. Obtain the VMware Fusion disk image using one of the following methods:
   - Download the VMware Fusion disk image from the VMware Fusion Web site. The VMware Fusion disk image is saved to your default download directory.
     - Double-click the VMware Fusion .dmg file to mount it.
   - Insert the VMware Fusion USB install drive.
   - Insert the VMware Fusion DVD.

2. Drag the VMware Fusion icon onto the Applications folder icon.

   VMware Fusion installs. Installation of VMware Fusion does not modify existing virtual machines.

Upgrading VMware Fusion

You can upgrade to a new version of VMware Fusion in several ways.

Use these procedures to upgrade VMware Fusion.

- **Upgrade VMware Fusion with Autoupdate** on page 8
  VMware Fusion has a built-in software updater that checks for updates to VMware Fusion and VMware Tools and downloads and installs them for you.

- **Upgrade VMware Fusion from DVD or USB Key** on page 8
  If you have an earlier version of VMware Fusion, you can upgrade by using the DVD in the software packaging for the current version.
Upgrade VMware Fusion from a Download on page 9

If you have an earlier version of VMware Fusion, you can upgrade to the current version by manually downloading the VMware Fusion disk image from the VMware Web site.

Upgrade VMware Fusion with Autoupdate

VMware Fusion has a built-in software updater that checks for updates to VMware Fusion and VMware Tools and downloads and installs them for you.

When **Automatically check for updates** is enabled in Preferences, VMware Fusion checks for updates each time you start it. If VMware Fusion detects a new version, it displays the Software Update window, which has three options.

- **Skip This Version**. Select this if you do not want to upgrade to the version described. VMware Fusion ignores this version in any later Autoupdate checks. However, if you change your mind you can select **VMware Fusion > Check for Updates** to have VMware Fusion display the Software Update window again.

- **Remind Me Later**. If you select this, VMware Fusion closes the window. The next time you start up VMware Fusion the **Software Update** window appears.

- **Download and Install**. See the procedure.

Prerequisites

In the General pane of VMware Fusion Preferences, **Automatically check for updates** must be selected.

VMware Fusion can shut down your running virtual machines as part of this procedure. However, it is a good idea for you to shut down or suspend them manually before you start.

Procedure

1. Click **Download and Install**.
   
   VMware Fusion downloads the update files to your Mac.

2. At the Ready to install update prompt, shut down all your running virtual machines if you have not done so already and click **Install and Restart**.
   
   VMware Fusion displays a progress bar during the installation, and restarts when the installation is complete.

Upgrade VMware Fusion from DVD or USB Key

If you have an earlier version of VMware Fusion, you can upgrade by using the DVD in the software packaging for the current version.

If you are upgrading VMware Fusion, you must uninstall the version that is installed on your Mac. Installing, upgrading, and uninstalling of VMware Fusion does not modify existing virtual machines.

Prerequisites

Verify that all of your virtual machines are shut down and that VMware Fusion is not running.

Procedure

1. Drag the previous version of VMware Fusion to the trash.
   
   VMware Fusion is located in the Applications folder on your Mac.

2. Insert the VMware Fusion DVD or USB key.

3. Drag the VMware Fusion icon onto the Applications folder icon.
Upgrade VMware Fusion from a Download

If you have an earlier version of VMware Fusion, you can upgrade to the current version by manually downloading the VMware Fusion disk image from the VMware Web site.

If you are upgrading VMware Fusion, you must uninstall the version that is installed on your Mac. Installing, upgrading, and uninstalling of VMware Fusion does not modify existing virtual machines.

You can select the full version or the light version. The full version has the VMware Tools suite of utilities for all supported operating systems, and the light version has VMware Tools for Windows and Mac OS X Server only. The VMware Fusion application itself is the same in both versions, but reducing the coverage for VMware Tools makes the light version disk image half the size of the full version.

**Prerequisites**

Verify that all of your virtual machines are shut down and that VMware Fusion is not running.

**Procedure**

1. Drag the previous version of VMware Fusion to the trash.
   VMware Fusion is located in the Applications folder on your Mac.
   a. Click the **Download** link and follow the subsequent links for an Electronic Download Distribution.
   b. Click the download link and save the application to your Mac.
   The VMware Fusion disk image is saved to your default download directory. For the full version the filename is `VMware-Fusion-x.x.x-xxxxxx.dmg`, where `x.x.x` is the application version and `xxxxxx` is the build number for the download release. The light version name is `VMware-Fusion-x.x.x-xxxxxx-light.dmg`.
3. Double-click `VMware-Fusion-x.x.x-xxxxxx.dmg` or `VMware-Fusion-x.x.x-xxxxxx-light.dmg` to mount it.
4. Drag the VMware Fusion icon onto the Applications folder icon.

Start VMware Fusion

Start using VMware Fusion.

**Prerequisites**

Verify that you have the administrator password for your Mac.

**Procedure**

1. In the Applications folder, double-click **VMware Fusion**.
   The Virtual Machine Library window appears. From this window, you can start working with virtual machines.
2. (Optional) To save VMware Fusion in the Dock, right-click the icon, and select **Options > Keep in Dock**.
Getting Up and Running

You can use one of the following methods to start using VMware Fusion quickly:

- **Create a Virtual Machine Using Windows Easy Install and an Installation CD** on page 10
  
  When you create a Microsoft Windows virtual machine, you can use the VMware Fusion Windows Easy Install feature to install the Windows operating system you supply and to install VMware Tools in your virtual machine.

- **Power On the Boot Camp Partition as a Virtual Machine** on page 11
  
  You can use the contents of your Boot Camp partition at the same time that you are running your Mac operating system. To do so, you use VMware Fusion to power on the Boot Camp partition as a virtual machine.

- **Import a Parallels or Virtual PC Virtual Machine** on page 12
  
  You can import existing third-party virtual machines and run them in VMware Fusion.

Create a Virtual Machine Using Windows Easy Install and an Installation CD

When you create a Microsoft Windows virtual machine, you can use the VMware Fusion Windows Easy Install feature to install the Windows operating system you supply and to install VMware Tools in your virtual machine.

**Prerequisites**

- Insert the operating system installation CD into your Mac.

**IMPORTANT** VMware Fusion does not include any operating systems to install in virtual machines that you create. You must obtain the operating system and any necessary product keys.

**Procedure**

1. Select **File > New**.
   
   The Create a New Virtual Machine assistant starts.

2. Click **Install from disc or image**.

3. Select the disc you inserted into the Mac from the list and click **Continue**.
   
   If the disc does not appear in the list, click **Use another disc or disc image** and browse to the location of the disc.

4. In the Windows Easy Install panel, select **Use Easy Install**.

5. Enter your **Display Name** or **Account Name**, **Password** (optional), and **Windows Product key**.
   
   For Windows XP and earlier, the entry in the **Display Name** field appears in Info windows as the name your Windows software is registered to. It is not the Windows user name.

   The entry in the **Password** field is the password for the Windows administrator account only. VMware does not provide the product key. The product key is on the sticker attached to the packaging for the Windows operating system CD-ROM.

6. Click **Continue**.
7 In the Integration panel, indicate how basic file sharing is handled in the new virtual machine.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>More Seamless</td>
<td>VMware Fusion shares your Mac’s documents and applications with Windows. Files on your Mac that Windows supports open in Windows. Windows can modify your Mac’s documents, so install and regularly update Windows antivirus software.</td>
</tr>
<tr>
<td>More Isolated</td>
<td>VMware Fusion does not share your Mac’s documents and applications with Windows. To copy files between your Mac and Windows, use drag and drop.</td>
</tr>
</tbody>
</table>

You can change these settings after the virtual machine is created by selecting Virtual Machine > Settings and using the Sharing panel.

8 In the Finish panel, you can use default settings to finish the virtual machine creation, or you can customize the settings before the creation is finished.

<table>
<thead>
<tr>
<th>Option</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>To create the virtual machine</td>
<td>a Click Finish.</td>
</tr>
<tr>
<td>according to the specifications listed in</td>
<td>b Indicate the folder in which to save the virtual machine. The default is your user/Documents/Virtual Machines folder.</td>
</tr>
<tr>
<td>the Finish panel</td>
<td></td>
</tr>
<tr>
<td>To change disk size or other</td>
<td>a Click Customize Settings.</td>
</tr>
<tr>
<td>standard settings of the virtual machine</td>
<td>b Save the new virtual machine.</td>
</tr>
<tr>
<td></td>
<td>c Make changes to the virtual machine’s disk size, processor usage, removable devices, and other configurations on the Settings window.</td>
</tr>
</tbody>
</table>

VMware starts the new virtual machine, installs the operating system, and installs VMware Tools.

**Power On the Boot Camp Partition as a Virtual Machine**

You can use the contents of your Boot Camp partition at the same time that you are running your Mac operating system. To do so, you use VMware Fusion to power on the Boot Camp partition as a virtual machine.

Boot Camp is Apple software that enables an Intel-based Mac to run Windows operating systems. Boot Camp requires you to choose between Mac or Windows at boot time. Boot Camp creates separate Mac and Windows partitions on your hard disk to create a dual-boot environment. When you use your Windows Boot Camp partition as a VMware Fusion virtual machine, you can perform the following tasks:

- Use your Boot Camp virtual machine and your Mac without rebooting and switching between them.
- Share files between your Boot Camp virtual machine and your Mac, through shared folders, dragging files, or cutting and pasting text.

**Note** Windows reactivation complications can occur if you do not install VMware Tools. In such a case, if you reactivate Windows in your Boot Camp virtual machine, and subsequently boot your Boot Camp partition natively, you will be prompted to reactivate Windows. Reactivating Windows in your native Boot Camp partition will result in your Boot Camp virtual machine requiring reactivation the next time you power it on, and so forth. Installing VMware Tools solves this problem.

**Prerequisites**

You must have a Boot Camp partition in place before you start this procedure.

You must have administrator privileges to use the Boot Camp partition as a virtual machine.

**Procedure**

1 From the VMware Fusion menu bar, select Window > Virtual Machine Library.
2 In the Virtual Machine Library window, click the Boot Camp thumbnail in the list of virtual machines, which identifies the partition that VMware Fusion detected.

3 (Optional) Enter your Mac password to access the Boot Camp partition. VMware Fusion creates a virtual machine that uses your Boot Camp partition and starts Windows.

4 Follow the onscreen instructions and restart your virtual machine when prompted. After Windows boots from your Boot Camp virtual machine, VMware Fusion starts the installation of VMware Tools. VMware Tools enables full virtual machine functionality and optimizes performance for your Boot Camp partition when you use the partition as a virtual machine.

5 When the VMware Tools installation is complete, reboot your computer.

What to do next
The first time you power on your Boot Camp virtual machine after you install VMware Tools, you must reactivate Windows.

Import a Parallels or Virtual PC Virtual Machine
You can import existing third-party virtual machines and run them in VMware Fusion.

Procedure
1 Select Window > Virtual Machine Library.
2 Click Add > Import.
3 Browse to the existing virtual machine you want to import and click Open.
4 Type the name for the imported virtual machine in the Save As field and indicate where to save it. The default destination is the Virtual Machines folder created by VMware Fusion. VMware Fusion displays the disk space needed for the import, and the space available on the current disk.
5 Click Import. When the import is complete, you see the virtual machine added to the virtual machine list, in the powered-off state.
6 Click Start Up.
VMware Fusion installs VMware Tools after the virtual machine powers on, and reboots the system after the Tools installation is complete.

You have a separate VMware Fusion version of the third-party virtual machine.

Supported Guest Operating Systems
VMware Fusion supports over 60 guest operating systems, including Windows 3.1 through Windows 7, Mac OS X Server, Linux, Solaris, and FreeBSD.

For the most recent list of guest operating systems that VMware products support, see the VMware Compatibility Guide site: http://www.vmware.com/resources/compatibility/search.php.

For instructions about how to install the most common guest operating systems, see the VMware Guest Operating System Installation Guide: http://partnerweb.vmware.com/GOSIG/home.html.
Using Mac Keyboards in a Virtual Machine

Because PC and Mac keyboards differ, you must press certain key combinations to enable certain PC commands on a Mac keyboard.

For keys with no keyboard equivalent, VMware Fusion provides the **Send Key** item in the Virtual Machine menu.

<table>
<thead>
<tr>
<th>Table 1-1. PC and Mac Keyboard Equivalents</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>PC Keyboard</strong></td>
</tr>
<tr>
<td>F1-F12</td>
</tr>
<tr>
<td>Print Screen</td>
</tr>
<tr>
<td>Scroll Lock</td>
</tr>
<tr>
<td>Pause/Break</td>
</tr>
<tr>
<td>Backspace</td>
</tr>
<tr>
<td>delete (Forward Delete)</td>
</tr>
<tr>
<td>Insert (toggles overwrite)</td>
</tr>
<tr>
<td>Num Lock</td>
</tr>
<tr>
<td>Command (Windows logo key—between Ctrl and Alt keys)</td>
</tr>
<tr>
<td>Alt</td>
</tr>
</tbody>
</table>

Suspend and Resume a Virtual Machine

The suspend and resume feature is useful to save the current state of a virtual machine and continue work later from the same state, even if you quit VMware Fusion in the interim.

VMware Fusion does not support suspending and resuming in Boot Camp virtual machines. Suspending and resuming rely on being able to save a known state that will not change. You can boot natively into Windows in the Boot Camp partition. When you do so, the known state is lost and data loss occurs.

**Procedure**

1. Take one of the following actions.
   - Select **Virtual Machine > Suspend** to suspend your virtual machine.
     
     You can also set a VMware Fusion preference to suspend the virtual machine when you close the virtual machine window.
   - Select **Virtual Machine > Resume** to resume your virtual machine.

2. (Optional) Take a snapshot to preserve a particular state of the virtual machine so you can return to that state repeatedly.
Take Advantage of VMware Fusion Online Resources

Go to the VMware Fusion home page and support page for product news, FAQs, more resources, and the online community.

To learn about available VMware support offerings, registering a product, or creating a technical support request, see the VMware support portal at http://www.vmware.com/go/fusionsupport

You can also find information about using VMware Fusion at the following self-help sources:

- The VMware Fusion Learning Center has video tutorials, FAQs, community forums, and more to help you get up and running with VMware Fusion. In Fusion, click Help > Video Tutorials.

- Self-paced video tutorials and answers to frequently asked questions through the VMware support portal at http://www.vmware.com/go/fusionsupport. (In English.) Use the Advanced Help tab to view the list of tutorials.

- VMware recommends joining the VMware Fusion Community at http://www.vmware.com/go/fusionforums. (In English.) The VMware Fusion Community is where VMware Fusion users can exchange information, questions, and comments to get the most out of VMware Fusion.

- The VMware Knowledge Base provides troubleshooting information, solutions to error messages, and some best practice information for most VMware products. To find information on a specific problem you encounter in VMware Fusion, select VMware Fusion in the product list and search for your problem by key word at http://kb.vmware.com.

- For answers to frequently asked questions about VMware Fusion, go to http://www.vmware.com/products/fusion/faqs.html.
Index

A
Autoupdate 8

B
Boot Camp, partition, creating a virtual machine from 11

D
doc Fusion in your Mac 9
download install 7
DVD install 7

F
function keys 13

G
GOS 12
guest operating system 12
guest OS 12

I
importing, virtual machines into VMware Fusion 12
install 7
introduction 5

K
keyboard
equivalent Mac and PC commands 13
function keys 13

O
operating system, installing using Windows Easy Install 10

P
Parallels Desktop, importing into VMware Fusion 12

R
resuming virtual machines 13

S
start 9
suspending virtual machines 13

U
upgrading VMware Fusion 7–9
USB install 7
use Fusion 10

V
virtual machines
creating from the Boot Camp partition 11
description 6
importing from Microsoft Virtual PC 12
importing from Parallels Desktop 12
resuming 13
suspending 13
using Mac keyboards with 13
Virtual PC, importing into VMware Fusion 12
VMware Fusion
about 5
capabilities 6
checking for software updates automatically 8
installing or upgrading 7
online resources for support and news 14
upgrading 8
upgrading manually 9

W
what to do next 10
Windows 5
Windows Easy Install, creating a virtual machine with 10

X
x86 5