This document supports the version of each product listed and supports all subsequent versions until the document is replaced by a new edition. To check for more recent editions of this document, see http://www.vmware.com/support/pubs.
You can find the most up-to-date technical documentation on the VMware Web site at:

http://www.vmware.com/support/

The VMware Web site also provides the latest product updates.

If you have comments about this documentation, submit your feedback to:

docfeedback@vmware.com

Copyright © 2014 VMware, Inc. All rights reserved. Copyright and trademark information.
Contents

Getting Started with VMware Player 5

1 Introduction and System Requirements 7
   Host System Requirements 7
   Virtual Machine Features and Specifications 10

2 Installing and Using Player 13
   Install Player on a Windows Host 13
   Install Player on a Linux Host 14
   Uninstall Player 15
   Start Player 16
   Email Address Collection in Player 16
   Use the Player Window 16

3 Creating Virtual Machines 19
   Understanding Virtual Machines 19
   Preparing to Create a Virtual Machine 19
   Create a Virtual Machine 23
   Use Easy Install to Install a Guest Operating System 24
   Install a Guest Operating System Manually 24
   Importing Virtual Machines 26
   Installing and Upgrading VMware Tools 27
   Virtual Machine Files 38

4 Using Virtual Machines 41
   Starting Virtual Machines in Player 41
   Stopping Virtual Machines in Player 44
   Transferring Files and Text 46
   Add a Host Printer to a Virtual Machine 54
   Using Removable Devices in Virtual Machines 54
   Install New Software in a Virtual Machine 61
   Changing the Virtual Machine Display 62
   Download a Virtual Appliance in Player 67
   Remove a Virtual Machine from the Library in Player 68

5 Configuring and Managing Virtual Machines 69
   Change the Name of a Virtual Machine 69
   Change the Guest Operating System for a Virtual Machine 70
   Change the Working Directory for a Virtual Machine 70
   Change the Virtual Machine Directory for a Virtual Machine 70
   Change the Memory Allocation for a Virtual Machine 71
Configuring Video and Sound 71
Moving Virtual Machines 75
Delete a Virtual Machine 77
View the Message Log for a Virtual Machine 78
Using the VIX API 78

6 Configuring and Managing Devices 79
   Configuring DVD, CD-ROM, and Floppy Drives 79
   Configuring a USB Controller 81
   Configuring and Maintaining Virtual Hard Disks 83
   Configuring Virtual Ports 89
   Configuring Generic SCSI Devices 93
   Configuring Eight-Way Virtual Symmetric Multiprocessing 97
   Configuring Keyboard Features 98
   Modify Hardware Settings for a Virtual Machine 105

7 Configuring Network Connections 107
   Understanding Virtual Networking Components 107
   Understanding Common Networking Configurations 108
   Configuring Bridged Networking 109
   Configuring Network Address Translation 110
   Configuring Host-Only Networking 111
   Changing a Networking Configuration 112

Index 115
Getting Started with VMware Player

Getting Started with VMware Player describes how to install and use VMware® Player.

Intended Audience

This guide is intended for anyone who wants to install and use Player.

Where to Find Additional Information

For additional information about using Player, see the following documents. All of the documents are available from the VMware Web site.

- Installing and Configuring VMware Tools contains complete information about using VMware Tools.
- The VMware Guest Operating System Installation Guide contains information about installing specific guest operating systems.
- The online VMware Compatibility Guide lists the supported host and guest operating systems for Player.

The Player online help provides quick reference information about Player settings and common tasks. It is available from the Player Help menu and when you click Help on a Player dialog box.
Introduction and System Requirements

Player is a desktop application that lets you create, configure, and run virtual machines. You can also use Player to download and run virtual appliances.

Host computers that run Player must meet specific hardware and software requirements. Virtual machines that run in Player support specific devices and provide certain features.

This chapter includes the following topics:

- “Host System Requirements,” on page 7
- “Virtual Machine Features and Specifications,” on page 10

Host System Requirements

The physical computer on which you install Player is called the host system and its operating system is called the host operating system. To run Player, the host system and the host operating system must meet specific hardware and software requirements.

Processor Requirements for Host Systems

You must install Player on a host system that meets certain processor requirements.

Supported Processors

The host system must have a 64-bit x86 CPU that meets the following requirements.

- LAHF/SAHF support in long mode
- 1.3GHz or faster core speed

Multiprocessor systems are supported.

When you install Player, the installer performs checks to make sure the host system has a supported processor. You cannot install Player if the host system does not meet the processor requirements.

Processor Requirements for 64-Bit Guest Operating Systems

The operating system that runs inside a virtual machine is called the guest operating system. To run 64-bit guest operating systems, the host system must have one of the following processors.

- An AMD CPU that has segment-limit support in long mode
- An Intel CPU that has VT-x support
If you have an Intel CPU that has VT-x support, you must verify that VT-x support is enabled in the host system BIOS. The BIOS settings that must be enabled for VT-x support vary depending on the system vendor. See the VMware knowledge base article at http://kb.vmware.com/kb/1003944 for information about how to determine if VT-x support is enabled.

When you install a 64-bit operating system, Player performs checks to make sure the host system has a supported processor. You cannot install a 64-bit operating system if the host system does not meet the processor requirements.

**Processor Requirements for Windows 7 Aero Graphics**

To support Windows 7 Aero graphics, the host system should have either an Intel Dual Core 2.2GHz or later CPU or an AMD Athlon 4200+ or later CPU.

**Supported Host Operating Systems**

You can install Player on Windows and Linux host operating systems.

To see a list of the supported host operating systems, search the online VMware Compatibility Guide on the VMware Web site.

Player is not listed, but the information for Workstation is applicable to Player. Operating systems that are not listed are not supported for use in a virtual machine.

**Memory Requirements for Host Systems**

The host system must have enough memory to run the host operating system, the guest operating systems that run inside the virtual machines on the host system, and the applications that run in the host and guest operating systems.

The minimum memory required on the host system is 1GB. 2GB and above is recommended.

To support Windows 7 Aero graphics in a virtual machine, at least 3GB of host system memory is required. 1GB of memory is allocated to the guest operating system and 256MB is allocated to graphics memory.

See your guest operating system and application documentation for more information on memory requirements.

**Display Requirements for Host Systems**

The host system must have a 16-bit or 32-bit display adapter. Use the latest graphics driver recommended for the host system.

To support Windows 7 Aero graphics, the host system should have either an NVIDIA GeForce 8800GT or later or an ATI Radeon HD 2600 or later graphics processor.

**IMPORTANT** 3D benchmarks, such as 3DMark ‘06, might not render correctly or at all when running Windows Vista or Windows 7 virtual machines on some graphics hardware.
Disk Drive Requirements for Host Systems

Host systems must meet certain disk drive requirements. Guest operating systems can reside on physical disk partitions or in virtual disk files.

Table 1-1. Disk Drive Requirements for Host Systems

<table>
<thead>
<tr>
<th>Drive Type</th>
<th>Requirements</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hard disk</td>
<td>- IDE, SATA, and SCSI hard drives are supported.</td>
</tr>
<tr>
<td></td>
<td>- At least 1GB free disk space is recommended for each guest operating system</td>
</tr>
<tr>
<td></td>
<td>and the application software used with it. If you use a default setup, the</td>
</tr>
<tr>
<td></td>
<td>actual disk space needs are approximately the same as those for installing</td>
</tr>
<tr>
<td></td>
<td>and running the guest operating system and applications on a physical</td>
</tr>
<tr>
<td></td>
<td>computer.</td>
</tr>
<tr>
<td></td>
<td>- For installation, approximately 200MB free disk space is required on Linux</td>
</tr>
<tr>
<td></td>
<td>and 250MB free disk space is required on Windows. You can delete the</td>
</tr>
<tr>
<td></td>
<td>installer after installation is complete to reclaim disk space.</td>
</tr>
<tr>
<td>Optical CD-ROM and DVD</td>
<td>- IDE, SATA, and SCSI optical drives are supported.</td>
</tr>
<tr>
<td></td>
<td>- CD-ROM and DVD drives are supported.</td>
</tr>
<tr>
<td></td>
<td>- ISO disk image files are supported.</td>
</tr>
<tr>
<td>Floppy</td>
<td>Virtual machines can connect to disk drives on the host computer. Floppy disk</td>
</tr>
<tr>
<td></td>
<td>image files are also supported.</td>
</tr>
</tbody>
</table>

Solid-State Drives

If your host machine has a physical solid-state drive (SSD), the host informs guest operating systems they are running on an SSD.

This allows the guest operating systems to optimize behavior. How the virtual machines recognize SSD and use this information depends on the guest operating system and the disk type of the virtual disk (SCSI, SATA, or IDE).

- On Windows 8, Ubuntu, and Red Hat Enterprise Linux virtual machines, all drive types can report their virtual disks as SSD drives.
- On Windows 7 virtual machines, only IDE and SATA virtual disks can report their virtual disks as SSD. SCSI virtual disks only report as SSD when used as a system drive in a virtual machine, or as a mechanical drive when used as a data drive inside a virtual machine.
- On Mac virtual machines, only SATA virtual disks are reported as SSD. IDE and SCSI virtual disks are reported as mechanical drives.

Use the virtual machine operating system to verify your virtual machine is using SSD as its virtual disk.

Local Area Networking Requirements for Host Systems

You can use any Ethernet controller that the host operating system supports.

Non-Ethernet networks are supported by using built-in network address translation (NAT) or by using a combination of host-only networking and routing software on the host operating system.

Help System Requirements

You must have a supported Web browser installed on the host system to use the Player Help system.

The following Web browser versions are supported.

- Internet Explorer 6 or later
- Mozilla Firefox 1.x or later
Netscape 7.x or later
- Safari 1.x or later
- Opera 7.54u2 or later

Because Chrome does not support JavaScript on local systems, you cannot display the Player Help system in Chrome.

**Virtual Machine Features and Specifications**

Player virtual machines support specific devices and provide certain features.

**Supported Guest Operating Systems**

A guest operating system can be Windows, Linux, and other commonly used operating systems.

To see a list of the supported guest operating systems, search the online VMware Compatibility Guide on the VMware Web site.

Player is not listed, but the information for Workstation is applicable to Player. Operating systems that are not listed are not supported for use in a virtual machine.

See the [VMware Guest Operating System Installation Guide](#) for information on installing the most common guest operating systems.

**Virtual Machine Processor Support**

Virtual machines support certain processor features.

- The same as the processor on the host computer.
- One virtual processor on a host system that has one or more logical processors.
- Up to eight virtual processors (eight-way virtual symmetric multiprocessing, or Virtual SMP) on a host system that has at least two logical processors.

**NOTE** Player considers multiprocessor hosts that have two or more physical CPUs, single-processor hosts that have a multicore CPU, and single-processor hosts that have hyperthreading enabled, to have two logical processors.

**Virtual Machine Memory Allocation**

The total amount of memory that you can assign to all virtual machines running on a single host system is limited only by the amount of RAM on the host.

On 64-bit hosts, the maximum amount of memory for each virtual machine is 64GB. On 32-bit hosts, the maximum amount of memory for each virtual machine is 8GB. Player prevents powering on virtual machines that are configured to use more than 8GB of memory on 32-bit hosts. Memory management limitations on 32-bit operating systems cause virtual machine memory to overcommit, which severely affects system performance.
Compatible Virtual Machines and System Images

Player can run virtual machines and system images that other VMware products create and some non-VMware products.

**VMware virtual machines**

Player runs virtual machines that were created by using Workstation 4 and later, GSX Server 3.x, VMware Server, and ESX Server 2.5 and later. Workstation 4 virtual machines run in legacy mode. You must use another VMware product to upgrade virtual machines created in versions earlier than Workstation 4 before you can run them in Player.

**Microsoft Virtual PC and Virtual Server virtual machines**

On Windows hosts, Player can run Microsoft Virtual PC and Virtual Server virtual machines. When you open a Virtual PC virtual machine in Player, Player creates a configuration file that is VMware product compatible and that has a `.vmx` file extension. Player preserves the original Virtual PC configuration file and gives the file a `.vmc` file extension. You can save the VMware product-compatible virtual machine without changing the original Virtual PC configuration file.

**Symantec Backup Exec System Recovery system images**

On Windows hosts, Player can run system images that were created by using Symantec Backup Exec System Recovery, formerly Symantec LiveState Recovery. When you open a Backup Exec System Recovery system image in Player, Player creates a configuration file that is VMware product compatible and that has a `.vmx` extension. Player preserves the original Backup Exec System Recovery system image file and gives the file a `.sv2i` file extension.
You can install Player on a Linux or Windows host system. Installing Player typically involves running a standard GUI wizard.

This chapter includes the following topics:

- “Install Player on a Windows Host,” on page 13
- “Install Player on a Linux Host,” on page 14
- “Uninstall Player,” on page 15
- “Start Player,” on page 16
- “Email Address Collection in Player,” on page 16
- “Use the Player Window,” on page 16

**Install Player on a Windows Host**

You install Player on a Windows host system by running the installation wizard.

**Prerequisites**

- Verify that the host system meets the host system requirements. See “Host System Requirements,” on page 7.
- Obtain the Player software. You can install Player from a product CD, or you can download Player from the VMware Web site.

**Procedure**

1. Log in to the host system.
2. If you are installing Player from a CD, insert the CD in the CD-ROM drive on the host system.
   - If autorun is enabled, the installation program begins.
3. If autorun is not enabled, or if you downloaded the installation software, double-click the installer file.
   - The installer filename is similar to `VMware-Player-xxxx-xxxx.exe`, where `xxxx-xxxx` is the version and build numbers.
4. Follow the prompts to finish the installation.
Install Player on a Linux Host

You run the Linux bundle installer to install Player on a Linux host system. On most Linux distributions, the Linux bundle installer starts a GUI wizard. On some Linux distributions, including Red Hat Enterprise Linux 5.1, the bundle installer starts a command-line wizard instead of a GUI wizard. You can also run the installer with the --console option to install Player in a terminal window.

Prerequisites

- Verify that the host system meets the host system requirements. See “Host System Requirements,” on page 7.
- Obtain the Player software. You can install Player from a product CD, or you can download Player from the VMware Web site.
- Familiarize yourself with the Linux command-line installation options. See “Linux Command Line Installation Options,” on page 15.
- Verify that you have root access on the host system.

Procedure

1. Log in to the Linux host system with the user name that you plan to use when you run Player.
2. Become root.
   For example: su root
   The command that you use depends on your Linux distribution and configuration.
3. If you are installing Player from the installation media, mount the Player installation media.
4. Change directories to the directory that contains the Player installer file.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>If you are installing the software from a CD</td>
<td>The installer file is in the Linux directory.</td>
</tr>
<tr>
<td>If you downloaded the software</td>
<td>The installer file is in the download directory.</td>
</tr>
</tbody>
</table>

5. Run the appropriate Player installer file for the host system.
   For example: sh VMware-Player-e.x.p-xxxx-xxxx.architecture.bundle --[option]
   xxxx-xxxx is the version and build numbers, architecture is i386 or x86_64, and option is a command line option.
6. Accept the license agreement.
   If you are using the --console option or installing Player on a host system that does not support the GUI wizard, press Enter to scroll through and read the license agreement or type q to skip to the [yes/no] prompt.
7. Follow the prompts to finish the installation.

What to do next

After Player is installed, you can exit from the root account. You do not need to be root to run Player.
Linux Command Line Installation Options

You can use command line installation options to install Player on a Linux host system.

To use the installation options, you must be logged in as root. Exit from the root account after the installation is finished.

Table 2-1. Linux Command Line Installation Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>--console</td>
<td>Enables you to use the terminal for installation.</td>
</tr>
<tr>
<td>--custom</td>
<td>Use this option to customize the locations of the installation directories and set the hard limit for the number of open file descriptors.</td>
</tr>
<tr>
<td>--eulas-agreed</td>
<td>Allows you to silently accept the product EULAs.</td>
</tr>
<tr>
<td>--gtk</td>
<td>Opens the GUI-based VMware installer, which is the default option.</td>
</tr>
<tr>
<td>--ignore-errors or -I</td>
<td>Allows the installation to continue even if there is an error in one of the installer scripts. Because the section that has an error does not complete, the component might not be properly configured</td>
</tr>
<tr>
<td>--regular</td>
<td>Shows installation questions that have not been answered before or are required. This is the default option.</td>
</tr>
<tr>
<td>--required</td>
<td>Shows the license agreement only and then proceeds to install Player.</td>
</tr>
<tr>
<td>--set-setting vmware-installer installShortcuts</td>
<td>Adds shortcuts when Workstation is installed. The default is yes.</td>
</tr>
</tbody>
</table>
| --set-setting vmware-installer libdir /opt | Creates: /opt/vmware (Workstation or Player)  
  /opt/vmware-installer  
  /opt/vmware-vix  
  The default is /usr/lib .|
| --set-setting vmware-installer prefix /usr/local | Installs executable files you run directly (ex: vmware, vmplayer, vmware-networks, etc.) here. Remainder of the product distributed under libdir-derived paths. The default is /usr . |
| --set-setting vmware-player serialNumber | Lets you enter the license key when Player is installed. Enter the license key with hyphens, for example, xxxxx-xxxxx-xxxxx-xxxxx-xxxxx. |
| --set-setting vmware-player-app simplifiedUI | Turn on or off certain UI features of Player. The default is no. |
| --set-setting vmware-player-app softwareUpdateEnabled | Enables automatic upgrades for VMware Player when a new build becomes available. |
| --set-setting vmware-player-app softwareUpdateURL | Specifies a custom URL for managing software updates (separate from vmware.com). |
| --set-setting vmware-player-app supportURL | Set a support URL or email alias specifically for your users to contact with product issues through the or Player Help menu. |
| --set-setting vmware-workstation serialNumber | Lets you enter the license key when Workstation is installed. Enter the license key with hyphens, for example, xxxxx-xxxxx-xxxxx-xxxxx-xxxxx. |

Uninstall Player

You must uninstall the previous version of Player before you can install the latest version.

How you uninstall Player depends on the host system platform.
Procedure

- To uninstall Player on a Windows host system, use the Windows uninstall feature.
  
  For example, on Windows 7, select Start > Control Panel > Programs > Programs and Features > Uninstall a program.

- To uninstall Player on a Linux host system, type the command `vmware-installer -u vmware-player`.
  
  The uninstall program lets you specify whether to preserve your configuration files.

Start Player

How you start Player depends on the host system platform and the options that you select when you install Player.

On Windows host systems, you might have a desktop shortcut, a quick launch shortcut, or a combination of these options in addition to a Start menu item.

On Linux host systems, you start Player from the command line. On some Linux distributions, including Red Hat Enterprise Linux 5.1, you can also start Player from the System Tools menu under Applications.

Procedure

- To start Player on a Windows host system, select Start > Programs > VMware Player.

- To start Player on a Linux host system, type the `vmplayer` command.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>/usr/bin is in your default path</code></td>
<td>vmplayer &amp;</td>
</tr>
<tr>
<td><code>/usr/bin is not in your default path</code></td>
<td><code>/usr/bin/vmplayer &amp;</code></td>
</tr>
</tbody>
</table>

When you start Player, the Player window opens.

Email Address Collection in Player

The trial version of VMware Player prompts you for your email address when you use it for the first time.

You can use VMware Player free of charge for noncommercial use. When you use Player for the first time, you can enter your email address and use it free of charge, or you can enter your purchased license key to use VMware Player Pro and have access to additional features.

Use the Player Window

You interact with Player and virtual machines through the Player window. The best way to learn how to use Player is to use it. The Player window is designed to be intuitive and easy to use.

Procedure

- Use the icons on the Home tab to create a new virtual machine, open an existing virtual machine, download a virtual appliance, or view the Player help system.

- Select a powered-off virtual machine in the library see the summary view.
  
  The summary view shows a summary of configuration information and the virtual machine state. You can start the virtual machine and edit virtual machine settings from the summary view.

- Select a powered-off virtual machine in the library and click Play virtual machine to start the virtual machine and see the console view.
  
  The console view is like the monitor display of a physical computer.
Select a virtual machine in the library and use the Virtual Machine menu on the menu bar to perform all virtual machine operations for the selected virtual machine.

When a virtual machine is powered on, use the icons on the status bar at the bottom of the Player window to perform actions on virtual devices such as hard disks, CD/DVD drives, floppy drives, and network adapters.

You can click or right-click on a removable device icon to connect or disconnect the device or edit its settings.

Use the About VMware Player window to access information about your installation of Player, including license key information. Click Player > Help > About VMware Player.

- If you have an individual license for Player, the key is displayed in the License Information section under Type. It is labeled Individual and followed by your license key.

- If you have a version of Player licensed for multiple users, the Type field displays Volume and your license key is not displayed.

- If you did not enter a license for Player, the Type field displays Not applicable and a license key is not displayed.

- If you have an evaluation license key for Player, the Type field displays Not applicable. The date the evaluation license key expires is also displayed.
Creating Virtual Machines

You create a new virtual machine in Player by using the New Virtual Machine wizard and import third-party and Open Virtualization Format (OVF) virtual machines.

This chapter includes the following topics:

- “Understanding Virtual Machines,” on page 19
- “Preparing to Create a Virtual Machine,” on page 19
- “Create a Virtual Machine,” on page 23
- “Use Easy Install to Install a Guest Operating System,” on page 24
- “Install a Guest Operating System Manually,” on page 24
- “Importing Virtual Machines,” on page 26
- “Installing and Upgrading VMware Tools,” on page 27
- “Virtual Machine Files,” on page 38

Understanding Virtual Machines

A virtual machine is a software computer that, like a physical machine, runs an operating system and applications. A virtual machine uses the physical resources of the physical machine on which it runs, which is called the host system. Virtual machines have virtual devices that provide the same functionality as physical hardware, but with the additional benefits of portability, manageability, and security.

A virtual machine has an operating system and virtual resources that you manage in much the same way that you manage a physical computer. For example, you install an operating system in a virtual machine in the same way that you install an operating system on a physical computer. You must have a CD-ROM, DVD, or ISO image that contains the installation files from an operating system vendor.

Preparing to Create a Virtual Machine

When you create a virtual machine, you specify or accept defaults for a few basic virtual machine settings.

- How you want to install the guest operating system.
- A name for the virtual machine and a location for the virtual machine files.
- The size of the virtual disk and whether to split the disk into multiple virtual disk files.
- Whether to customize hardware settings, including memory allocation, number of virtual processors, and network connection type.
Selecting a Guest Operating System

The New Virtual Machine prompts you to select the source media for the operating system that will run inside the virtual machine. You can specify an installer disc inserted in a physical drive, an ISO image file, or you can instruct the New Virtual Machine wizard to create a virtual machine that has a blank hard disk.

If you select an installer disc or an ISO image file and the operating system supports Easy Install, the guest operating system installation is automated and VMware Tools is installed. If the installer disc or ISO image file contains a product key number and is already set up to perform an unattended installation, the only benefit of using Easy Install is the automatic installation of VMware Tools.

If you instruct the New Virtual Machine wizard to create a virtual machine that has a blank hard disk, the wizard prompts you to specify an operating system and version and you must install the guest operating system manually after the virtual machine is created. Player uses this information to set the appropriate default values, name files associated with the virtual machine, adjust performance settings, and work around special behaviors and bugs in the guest operating system. If the operating system you plan to install is not listed in the wizard, select Other for both the operating system and version.

If you are installing an operating system that supports Easy Install but you do not want to use Easy Install, you can instruct the wizard to create a virtual machine that has a blank disk and install the guest operating system manually.

Supported Guest Operating Systems

A guest operating system can be Windows, Linux, and other commonly used operating systems.

To see a list of the supported guest operating systems, search the online VMware Compatibility Guide on the VMware Web site.

Player is not listed, but the information for Workstation is applicable to Player. Operating systems that are not listed are not supported for use in a virtual machine.

See the VMware Guest Operating System Installation Guide for information on installing the most common guest operating systems.

Providing Easy Install Information

When the New Virtual Wizard detects an operating system that supports Easy Install, the wizard prompts you for information about the guest operating system. After the virtual machine is created, the guest operating system installation is automated and VMware Tools is installed.

For Windows guest operating systems, you must provide the following Easy Install information.

<table>
<thead>
<tr>
<th>Table 3-1. Easy Install Information for Windows Guests</th>
</tr>
</thead>
<tbody>
<tr>
<td>Easy Install Prompt</td>
</tr>
<tr>
<td>---------------------</td>
</tr>
<tr>
<td>Windows product key</td>
</tr>
<tr>
<td>Version of Windows to install</td>
</tr>
<tr>
<td>Full name</td>
</tr>
</tbody>
</table>
Table 3-1. Easy Install Information for Windows Guests (Continued)

<table>
<thead>
<tr>
<th>Easy Install Prompt</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Password</td>
<td>(Optional) The password to use for an account with Administrator permissions on Windows operating systems other than Windows 2000. On Windows 2000, this is the password for the Administrator account. On Windows XP Home, an Administrator account without a password is created and you are automatically logged in to the guest operating system.</td>
</tr>
<tr>
<td>Log on automatically (requires a password)</td>
<td>(Optional) Save your login credentials and bypass the login dialog box when you power on the virtual machine. You must enter a name and password to use this feature.</td>
</tr>
</tbody>
</table>

For Linux guest operating systems, you must provide the following Easy Install information.

Table 3-2. Easy Install Information for Linux Guests

<table>
<thead>
<tr>
<th>Prompt</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Full name</td>
<td>The name to use to register the guest operating system, if registration is required. Player uses the first name to create the host name for the virtual machine.</td>
</tr>
<tr>
<td>User name</td>
<td>Your user name. You can use lowercase letters, numbers, and dashes, but avoid using user names that begin with a dash. Do not use the name root. Some operating systems set up sudo access for this user and other operating systems require this user to use <code>su</code> to obtain root privileges.</td>
</tr>
<tr>
<td>Password</td>
<td>The password for the User name and the root user.</td>
</tr>
</tbody>
</table>

Specifying the Virtual Machine Name and File Location

The New Virtual Machine wizard prompts you for a virtual machine name and a directory for the virtual machine files.

The name of the default directory for virtual machine files is derived from the name of the guest operating system, for example, Microsoft Windows 7 (32-bit).

For standard virtual machines, the default directory for virtual machine files is located in the virtual machine directory. For best performance, do not place the virtual machines directory on a network drive. If other users need to access the virtual machine, consider placing the virtual machine files in a location that is accessible to those users.

Virtual Machines Directory

Player stores standard virtual machines in the virtual machines directory.

The default location of the virtual machines directory depends on the host operating system.

Table 3-3. Default Virtual Machines Directory

<table>
<thead>
<tr>
<th>Host Operating System</th>
<th>Default Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows XP</td>
<td>C:\Documents and Settings\username\My Documents\My Virtual Machines</td>
</tr>
<tr>
<td>Windows Server 2003</td>
<td>C:\Documents and Settings\username\My Documents\My Virtual Machines</td>
</tr>
<tr>
<td>Windows Server 2008</td>
<td>C:\Documents and Settings\username\My Documents\My Virtual Machines</td>
</tr>
<tr>
<td>Windows Vista</td>
<td>C:\Users\username\Documents\Virtual Machines</td>
</tr>
<tr>
<td>Windows 7</td>
<td>C:\Users\username\Documents\Virtual Machines</td>
</tr>
<tr>
<td>Windows 8</td>
<td>C:\Users\username\Documents\Virtual Machines</td>
</tr>
<tr>
<td>Linux</td>
<td>homedir/vmware</td>
</tr>
<tr>
<td></td>
<td>homedir is the home directory of the currently logged in user.</td>
</tr>
</tbody>
</table>
Specifying Disk Capacity for a Virtual Machine

If you instruct the New Virtual Machine wizard to create a new virtual disk during a custom configuration, the wizard prompts you to set the size of the virtual disk and specify whether to split the disk into multiple virtual disk (.vmdk) files.

A virtual disk is made up of one or more virtual disk files. Virtual disk files store the contents of the virtual machine hard disk drive. Almost all of the file content is virtual machine data. A small portion of the file is allotted to virtual machine overhead. If the virtual machine is connected directly to a physical disk, the virtual disk file stores information about the partitions that the virtual machine is allowed to access.

You can set a size between 0.001GB and 8TB for a virtual disk file. You can also select whether to store a virtual disk as a single file or split it into multiple files.

Select Split virtual disk into multiple files if the virtual disk is stored on a file system that has a file size limitation. When you split a virtual disk less than 950GB, a series of 2GB virtual disk files are created. When you split a virtual disk greater than 950GB, two virtual disk files are created. The maximum size of the first virtual disk file is 1.9TB and the second virtual disk file stores the rest of the data.

Disk space is not preallocated for the disk. The actual files that the virtual disk uses start small and expand to their maximum size as needed. The main advantage of this approach is the smaller file size. Smaller files require less disk space and are easier to move to a new location.

After you create a virtual machine, you can edit virtual disk settings and add additional virtual disks.

Customizing Virtual Machine Hardware

You can click Customize Hardware on the last page of the New Virtual Machine wizard to customize the virtual machine hardware.

You can change the default hardware settings, including memory allocation, number of virtual CPUs, CD/DVD and floppy drive settings, and the network connection type.

Worksheet for Creating a Typical Virtual Machine

You can print this worksheet and write the values to specify when you create a typical virtual machine.

Table 3-4. Worksheet: Typical Virtual Machine

<table>
<thead>
<tr>
<th>Option</th>
<th>Write Your Value Here</th>
</tr>
</thead>
<tbody>
<tr>
<td>Guest operating system source</td>
<td></td>
</tr>
<tr>
<td>Guest operating system type for manual installation</td>
<td></td>
</tr>
<tr>
<td>Easy Install information for Windows guests</td>
<td></td>
</tr>
<tr>
<td>■ Product key</td>
<td></td>
</tr>
<tr>
<td>■ Operating system version</td>
<td></td>
</tr>
<tr>
<td>■ Full name</td>
<td></td>
</tr>
<tr>
<td>■ Password</td>
<td></td>
</tr>
<tr>
<td>■ Credentials for automatic login</td>
<td></td>
</tr>
<tr>
<td>Easy Install information for Linux guests</td>
<td></td>
</tr>
<tr>
<td>■ Full name</td>
<td></td>
</tr>
<tr>
<td>■ User name</td>
<td></td>
</tr>
<tr>
<td>■ Password</td>
<td></td>
</tr>
<tr>
<td>Virtual machine name</td>
<td></td>
</tr>
<tr>
<td>Virtual machine location</td>
<td></td>
</tr>
<tr>
<td>Disk capacity</td>
<td></td>
</tr>
</tbody>
</table>
Create a Virtual Machine

You create a virtual machine in Player by running the New Virtual Machine wizard.

Prerequisites

- Verify that you have the information the New Virtual Machine wizard requires to create a virtual machine. See “Preparing to Create a Virtual Machine,” on page 19.
- Verify that the guest operating system you plan to install is supported. See the online VMware Compatibility Guide, which is available on the VMware Web site.
- See the VMware Guest Operating System Installation Guide for information about the guest operating system you plan to install.
- If you are installing the guest operating system from an installer disc, insert the installer disc in the CD-ROM drive in the host system.
- If you are installing the guest operating system from an ISO image file, verify that the ISO image file is in a directory that is accessible to the host system.

Procedure

2. Select the source of the guest operating system.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use a physical disc</td>
<td>Select the physical drive where you inserted the installation disc.</td>
</tr>
<tr>
<td>Use an ISO image</td>
<td>Type or browse to the location of the ISO image file.</td>
</tr>
<tr>
<td>Install the guest operating system later</td>
<td>Create a virtual machine that has a blank disk. You must install the guest operating system manually after the virtual machine is created.</td>
</tr>
</tbody>
</table>

3. Specify information about the guest operating system.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>You are using Easy Install</td>
<td>Type the Easy Install information for the guest operating system.</td>
</tr>
<tr>
<td>You are not using Easy Install</td>
<td>Select the guest operating system type and version. If the guest operating system is not listed, select Other.</td>
</tr>
</tbody>
</table>

4. Type a virtual machine name and type or browse to the directory for the virtual machine files.
5. Select the virtual disk size and specify whether the disk should be split into multiple files.
6. (Optional) Click Customize Hardware to change the default hardware settings.
   You can also modify virtual hardware settings after you create the virtual machine.
7. (Optional) Select Power on this virtual machine after creation to power on the virtual machine after it is created.
   This option is not available if you are installing the guest operating system manually.
8. Click Finish to create the virtual machine.

If you are using Easy Install, guest operating system installation begins when the virtual machine powers on. The guest operating system installation is automated and typically runs without requiring any input from you. After the guest operating system is installed, Easy Install installs VMware Tools.

If you are not using Easy Install, the virtual machine appears in the library.
What to do next

If you used Easy Install and the virtual machine did not power on when the installation finished, power on the virtual machine to start the guest operating system installation. See “Use Easy Install to Install a Guest Operating System,” on page 24.

If you did not use Easy Install, install the guest operating system manually. See “Install a Guest Operating System Manually,” on page 24.

Use Easy Install to Install a Guest Operating System

When you use Easy Install, you usually do not need to provide information during guest operating system installation.

If you did not provide all of the Easy Install information in the New Virtual Machine wizard, you might be prompted for a product key, username, or password.

Also, if the guest operating system installation consists of multiple discs or ISO image files, the installer might prompt you for the next disk.

Procedure

- If the installer prompts you for a product key, username, or password, click in the virtual machine window and type the required information.
  
  Mouse and keyboard input are captured by the virtual machine.

- If you are using physical discs and the installer prompts you for the next disk, use the CD-ROM or DVD drive on the host system.

- If you are using multiple ISO image files and the installer prompts you for the next disk, select the next ISO image file.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows host</td>
<td>Click Change Disk and browse to the next ISO image file.</td>
</tr>
<tr>
<td>Linux host</td>
<td>a Select Virtual Machine &gt; Removable Devices &gt; CD/DVD &gt; Settings and browse to the next ISO image file.</td>
</tr>
<tr>
<td></td>
<td>b Select Connected.</td>
</tr>
<tr>
<td></td>
<td>c Click Save.</td>
</tr>
</tbody>
</table>

Install a Guest Operating System Manually

Installing a guest operating system in a virtual machine is similar to installing an operating system on a physical computer. If you do not use Easy Install when you create a virtual machine in the New Virtual Machine wizard, you must install the guest operating system manually.

You can install a guest operating system from an installer disc or ISO image file. You can also use a PXE server to install the guest operating system over a network connection. If the host configuration does not permit the virtual machine to boot from an installer disc, you can create an ISO image file from the installer disc.

Prerequisites

- Verify that the operating system is supported. See the online VMware Compatibility Guide on the VMware Web site.

- See the VMware Guest Operating System Installation Guide for information on the guest operating system that you are installing.
Procedure

1. If you are installing the guest operating system from an installer disc, configure the virtual machine to use a physical CD-ROM or DVD drive and configure the drive to connect at power on.
   a. Select the virtual machine and select Player > Manage > Virtual Machine Settings.
   b. On the Hardware tab, select CD/DVD drive.
   c. Select Connect at power on.
   d. Select Use physical drive and select a the drive.
   e. Click OK to save your changes.

2. If you are installing the guest operating system from an ISO image file, configure the CD/DVD drive in the virtual machine to point to the ISO image file and configure the drive to connect at power on.
   a. Select the virtual machine and select Player > Manage > Virtual Machine Settings.
   b. On the Hardware tab, select CD/DVD drive.
   c. Select Connect at power on.
   d. Select Use ISO image file and browse to the location of the ISO image file.
   e. Click OK to save your changes.

3. If you are installing the guest operating system from an installer disc, insert the disc in the CD-ROM or DVD drive.

4. Power on the virtual machine.

5. Follow the installation instructions provided by the operating system vendor.

6. If the operating system consists of multiple installer discs and you are prompted to insert the next disc, insert the next disc in the physical drive.

7. If the operating system consists of multiple ISO image files, select the image file for the next CD.
   a. Select Player > Removable Devices > CD/DVD > Disconnect and disconnect from the current ISO image file.
   b. Select Player > Removable Devices > CD/DVD > Settings and select the next ISO image file.
   c. Select Connected and click OK.

8. Use the standard tools in the operating system to configure its settings.

What to do next

Install VMware Tools. You should install VMware Tools before you activate the license for the operating system. See “Installing VMware Tools,” on page 28.
Importing Virtual Machines

You can import Windows XP Mode, Open Virtualization Format (OVF), and Windows Virtual PC virtual machines in Player.

Import a Windows XP Mode Virtual Machine

You can import a Windows XP Mode virtual machine and run it in Player. When you import a Windows XP Mode virtual machine, Player creates a new virtual machine in VMware runtime (.vmx) format.

You can power on only one Windows XP Mode virtual machine at a time in Player. If you move a Windows XP Mode virtual machine to another host system, it becomes a new virtual machine and you must activate it.

Note Changes made to the original Windows XP Mode virtual machine through Virtual PC do not affect the virtual machine imported in Player.

Prerequisites

- Verify that the Windows 7 Professional, Enterprise, or Ultimate edition operating system is running on the host system. Importing Windows XP Mode virtual machines is not supported on Linux host systems or on host systems that are running other versions of Windows.
- Download and install the Windows XP Mode virtual machine on the host system.

Procedure

1. Select Player > File > Import Windows XP Mode VM, or select File > Open and browse to the virtual machine configuration (.vmc) file.
   - If you have never imported a third-party virtual machine in Player, Player installs VMware vCenter Converter Standalone. After the installation is finished, you must restart the import.

2. Type a name for the new virtual machine, type or browse to the directory for the virtual machine files, and click Import.
   - Player begins importing the Windows XP Mode virtual machine.

After Player successfully imports the Windows XP Mode virtual machine, a new virtual machine appears in the virtual machine library.

Import an Open Virtualization Format Virtual Machine

You can import an Open Virtualization Format (OVF) virtual machine and run it in Player. Player converts the virtual machine from OVF format to VMware runtime (.vmx) format. You can import both .ovf and .ova files.

OVF is a platform-independent, efficient, extensible, and open packaging and distribution format for virtual machines. For example, you can import OVF virtual machines exported from VMware Fusion™ or Oracle VM VirtualBox into Player. You can import OVF 1.0 and later files only.

You can also use the standalone OVF Tool to convert an OVF virtual machine to VMware runtime format. The standalone version of the OVF Tool is installed in the Player installation directory under OVFTool. See the OVF Tool User Guide on the VMware Web site for information on using the OVF Tool.

Procedure

1. In Player, select Player > File > Open.

2. Browse to the .ovf or .ova file and click Open.
3 Type a name for the virtual machine, type or browse to the directory for the virtual machine files, and click Import.

Player performs OVF specification conformance and virtual hardware compliance checks. A status bar indicates the progress of the import process.

4 If the import fails, click Retry to try again, or click Cancel to cancel the import.

If you retry the import, Player relaxes the OVF specification conformance and virtual hardware compliance checks and you might not be able to use the virtual machine in Player.

After Player successfully imports the OVF virtual machine, the virtual machine appears in the virtual machine library.

Import a Windows Virtual PC Virtual Machine

You can import a Windows Virtual PC virtual machine and run it in Player. Player converts the virtual machine from Virtual PC (.vmc) format to VMware runtime (.vmx) format. This feature is supported only on Windows host systems.

**Prerequisites**

Download and install the Virtual PC virtual machine on the Windows host system.

**Procedure**

1 Select Player > File > Open.

If you have never imported a third-party virtual machine in Player, Player installs VMware vCenter Converter Standalone. After the installation is finished, you must restart the import.

2 Browse to the .vmc file and click Open.

3 Type a name for the virtual machine, type or browse to the directory for the virtual machine files, and click Import.

After Player successfully imports the Virtual PC virtual machine, the virtual machine appears in the virtual machine library.

Installing and Upgrading VMware Tools

Installing VMware Tools is part of the process of creating a new virtual machine. Upgrading VMware Tools is part of the process of keeping virtual machines up to current standards.

For the best performance and latest updates, install or upgrade VMware Tools to match the version of Player that you are using. Other compatibility options are also available.

- **Installing VMware Tools** on page 28
  
  VMware Tools is a suite of utilities that enhances the performance of the virtual machine’s guest operating system and improves management of the virtual machine.

- **Upgrading VMware Tools** on page 28
  
  You can upgrade VMware Tools manually, or you can configure virtual machines to check for and install newer versions of VMware Tools.

- **Configure Software Update Preferences** on page 29
  
  You can configure Player to automatically download software updates, including new versions of VMware Tools. When you select automatic software updates, Player always includes the latest support for guest operating systems and virtual machines always have the latest version of VMware Tools.
Installing VMware Tools

VMware Tools is a suite of utilities that enhances the performance of the virtual machine’s guest operating system and improves management of the virtual machine.

Although the guest operating system can run without VMware Tools, many VMware features are not available until you install VMware Tools. For example, if you do not have VMware Tools installed in your virtual machine, you cannot use the shutdown or restart options from the toolbar. You can use only the power options.

You can use the Windows Easy Install or Linux Easy Install feature to install VMware Tools as soon as the operating system is finished installing.

The installers for VMware Tools are ISO image files. An ISO image file looks like a CD-ROM to your guest operating system. Each type of guest operating system, including Windows, Linux, Solaris, FreeBSD, and NetWare, has an ISO image file. When you select the command to install or upgrade VMware Tools, the virtual machine’s first virtual CD-ROM disk drive temporarily connects to the VMware Tools ISO file for your guest operating system.

The most recent versions of the ISO files are stored on a VMware Web site. When you select the command to install or upgrade VMware Tools, the VMware product determines whether it has downloaded the most recent version of the ISO file for the specific operating system. If the latest version has not been downloaded or if no VMware Tools ISO file for that operating system has ever been downloaded, you are prompted to download the file.

The installation procedure varies, depending on the operating system.

Upgrading VMware Tools

You can upgrade VMware Tools manually, or you can configure virtual machines to check for and install newer versions of VMware Tools.

The guest operating system checks the version of VMware Tools when you power on a virtual machine. The status bar of the virtual machine displays a message when a new version is available.

In Windows virtual machines, you can set VMware Tools to notify you when an upgrade is available. If this notification option is enabled, the VMware Tools icon in the Windows taskbar includes a yellow caution icon when a VMware Tools upgrade is available.

To install a VMware Tools upgrade, you can use the same procedure that you used for installing VMware Tools the first time. Upgrading VMware Tools means installing a new version.
For Windows and Linux guest operating systems, you can configure the virtual machine to automatically upgrade VMware Tools. Although the version check is performed when you power on the virtual machine, on Windows guest operating systems, the automatic upgrade occurs when you power off or restart the virtual machine. The status bar displays the message **Installing VMware Tools ...** when an upgrade is in progress.

**IMPORTANT** When you upgrade VMware Tools on Linux guest operating systems, new network modules are available but are not used until you either restart the guest operating system or stop networking, unload and reload the VMware networking kernel modules, and restart networking. This behavior means that even if VMware Tools is set to automatically upgrade, you must restart or reload network modules to make new features available.

This strategy avoids network interruptions and allows you to install VMware Tools over SSH.

Some features in a particular release of a VMware product might depend on installing or upgrading to the version of VMware Tools included in that release. Upgrading to the latest version of VMware Tools is not always necessary. Newer versions of VMware Tools are compatible with several host versions. To avoid unnecessary upgrades, evaluate whether the added features and capabilities are necessary for your environment.

### Configure Software Update Preferences

You can configure Player to automatically download software updates, including new versions of VMware Tools. When you select automatic software updates, Player always includes the latest support for guest operating systems and virtual machines always have the latest version of VMware Tools.

**Procedure**

1. Select **Player > File > Player Preferences**.
2. Select when Player checks for software updates.

   You can select one, both, or neither option. If you deselect all of the software update options, automatic software updates are disabled.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Check for product updates on startup</strong></td>
<td>Checks for new versions of Player available to download and install when you start Player. This option is enabled by default. If you do not select this option, your system does not get the latest product updates.</td>
</tr>
<tr>
<td><strong>Check for software components as needed</strong></td>
<td>When a software component is required, for example, when you install VMware Tools, Player checks for a new version of the component.</td>
</tr>
<tr>
<td><strong>Download All Components Now</strong></td>
<td>Immediately download all of the available software components to the host system. This option is useful if you are planning to use the virtual machine at a later time when you do not have access to the Internet.</td>
</tr>
</tbody>
</table>
If you use a proxy server to connect to the VMware Update Server, click **Connection Settings** to configure the proxy settings.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>No proxy</td>
<td>Select this option if you do not use a proxy server. This is the default setting.</td>
</tr>
<tr>
<td>Windows proxy settings</td>
<td>(Windows hosts only) Player uses the host proxy settings from the Connections tab in the Internet Options control panel to access the VMware Update Server.</td>
</tr>
<tr>
<td></td>
<td>a  Click <strong>Internet Options</strong> to set the guest connection options.</td>
</tr>
<tr>
<td></td>
<td>b  Type a username and password to use for proxy server authentication.</td>
</tr>
<tr>
<td></td>
<td>If you leave either the <strong>Username</strong> or the <strong>Password</strong> text box blank, Player does not use either value.</td>
</tr>
<tr>
<td>System proxy settings</td>
<td>(Linux hosts only) Player uses the host proxy settings to access the VMware Update Server.</td>
</tr>
<tr>
<td>Manual proxy settings</td>
<td>a  Select HTTP or SOCKS, specify the proxy server address and designate a port number to access the VMware Update Server.</td>
</tr>
<tr>
<td></td>
<td>b  Type a username and password to use for proxy authentication.</td>
</tr>
<tr>
<td></td>
<td>If you leave either the <strong>Username</strong> or the <strong>Password</strong> text box blank, Player does not use either value (Windows hosts) or it uses the username and password set in the gnome settings (Linux hosts).</td>
</tr>
</tbody>
</table>

4  Click **OK** to save your changes.

### Configure VMware Tools Updates for a Specific Virtual Machine

You can configure virtual machines that have Windows or Linux guest operating systems to update VMware Tools automatically. For other guest operating systems, you must manually update VMware Tools.

Automatic VMware Tools updates are supported for versions of VMware Tools included in Workstation 5.5 and later virtual machines only. Automatic updates are not supported for versions of VMware Tools included in virtual machines created with VMware Server 1.x.

**IMPORTANT**  If you update VMware Tools in a Windows virtual machine that was created with Workstation 4 or 5.x, some new components are not installed. To install the new components, you must uninstall the old version of VMware Tools and install the new version of VMware Tools.

#### Procedure

1  Select the virtual machine and select **Player > Manage > Virtual Machine Settings**.

2  On the **Options** tab, select **VMware Tools**.
3  Select a VMware Tools update setting.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Update manually (do nothing)</td>
<td>You must update VMware Tools manually. The virtual machine status bar indicates when a new version of VMware Tools is available.</td>
</tr>
<tr>
<td>Update automatically</td>
<td>VMware Tools is updated automatically. The virtual machine status bar indicates when an update is in progress. If you are logged in to a Windows guest, a restart prompt appears after the update is complete. If you are not logged in, the operating system restarts without prompting. An auto-update check is performed as part of the boot sequence when you power on the virtual machine. If the virtual machine was suspended and you resume it or restore it to a snapshot during the boot sequence before this check, the automatic update occurs as planned. If you resume the virtual machine or restore it to a snapshot after the check, the automatic update does not occur.</td>
</tr>
<tr>
<td>Use application default (currently update manually)</td>
<td>Use the default VMware Tools update behavior. The default behavior is set in Player preferences.</td>
</tr>
</tbody>
</table>

4  Click **OK** to save your changes.

**Manually Installing and Upgrading VMware Tools**

You can manually install or upgrade VMware Tools on Windows, Linux, NetWare, Solaris, and FreeBSD virtual machines.

If you are installing VMware Tools in a number of Windows virtual machines, you can automate its installation by using the VMware Tools `setup.exe` at a command prompt in the guest operating system. See *Installing and Configuring VMware Tools* for more information.

- **Manually Install or Upgrade VMware Tools in a Windows Virtual Machine** on page 31
  All supported Windows guest operating systems support VMware Tools.

- **Manually Install or Upgrade VMware Tools in a Linux Virtual Machine** on page 32
  For Linux virtual machines, you manually install or upgrade VMware Tools by using the command line.

- **Manually Install or Upgrade VMware Tools in a NetWare Virtual Machine** on page 34
  For NetWare virtual machines, you manually install or upgrade VMware Tools by using the command line.

- **Manually Install or Upgrade VMware Tools in a Solaris Virtual Machine** on page 35
  For Solaris virtual machines, you manually install or upgrade VMware Tools by using the command line.

- **Manually Install or Upgrade VMware Tools in a FreeBSD Virtual Machine** on page 36
  For FreeBSD virtual machines, you manually install or upgrade VMware Tools by using the command line.

**Manually Install or Upgrade VMware Tools in a Windows Virtual Machine**

All supported Windows guest operating systems support VMware Tools.

Before you upgrade VMware Tools, consider the environment that the virtual machine runs in and weigh the benefits of different upgrade strategies. For example, you can install the latest version of VMware Tools to enhance the performance of the virtual machine’s guest operating system and improve virtual machine management, or you can continue using the existing version to provide more flexibility in your environment.
Prerequisites

- Power on the virtual machine.
- Verify that the guest operating system is running.
- If you connected the virtual machine’s virtual CD/DVD drive to an ISO image file when you installed the operating system, change the setting so that the virtual CD/DVD drive is configured to autodetect a physical drive.

The autodetect setting enables the virtual machine’s first virtual CD/DVD drive to detect and connect to the VMware Tools ISO file for a VMware Tools installation. This ISO file looks like a physical CD to your guest operating system. Use the virtual machine settings editor to set the CD/DVD drive to autodetect a physical drive.

- Log in as an administrator unless you are using an older Windows operating system. Any user can install VMware Tools in a Windows 95, Windows 98, or Windows ME guest operating system. For operating systems newer than these, you must log in as an administrator.

Procedure

1. On the host, from the Player menu bar, select Player > Manage > Install VMware Tools.

   If an earlier version of VMware Tools is installed, the menu item is Update VMware Tools.

2. If you are installing VMware Tools for the first time, click OK on the Install VMware Tools information page.

   If autorun is enabled for the CD-ROM drive in the guest operating system, the VMware Tools installation wizard starts.

3. If autorun is not enabled, to manually launch the wizard, click Start > Run and enter D:\setup.exe, where D: is your first virtual CD-ROM drive.

4. Follow the on-screen instructions.

5. If the New Hardware wizard appears, follow the prompts and accept the defaults.

6. If you are installing a beta or RC version of VMware Tools and you see a warning that a package or driver is not signed, click Install Anyway to complete the installation.

7. When prompted, reboot the virtual machine.

What to do next

If a new virtual hardware version is available for the virtual machine, upgrade the virtual hardware.

Manually Install or Upgrade VMware Tools in a Linux Virtual Machine

For Linux virtual machines, you manually install or upgrade VMware Tools by using the command line.

Before you upgrade VMware Tools, consider the environment that the virtual machine runs in and weigh the benefits of different upgrade strategies. For example, you can install the latest version of VMware Tools to enhance the performance of the virtual machine’s guest operating system and improve virtual machine management, or you can continue using the existing version to provide more flexibility in your environment.

Prerequisites

- Power on the virtual machine.
- Verify that the guest operating system is running.
- Because the VMware Tools installer is written in Perl, verify that Perl is installed in the guest operating system.
Procedure

1. On the host, from the Player menu bar, select Player > Manage > Install VMware Tools.
   If an earlier version of VMware Tools is installed, the menu item is Update VMware Tools.
2. In the virtual machine, log in to the guest operating system as root and open a terminal window.
3. Run the `mount` command with no arguments to determine whether your Linux distribution automatically mounted the VMware Tools virtual CD-ROM image.
   If the CD-ROM device is mounted, the CD-ROM device and its mount point are listed as something like this:
   
   ```
   /dev/cdrom on /mnt/cdrom type iso9660 (ro,nosuid,nodev)
   ```
4. If the VMware Tools virtual CD-ROM image is not mounted, mount the CD-ROM drive.
   a. If a mount point directory does not already exist, create it.
      ```
      mkdir /mnt/cdrom
      ```
      Some Linux distributions use different mount point names. For example, on some distributions the mount point is `/media/VMware Tools` rather than `/mnt/cdrom`. Modify the command to reflect the conventions that your distribution uses.
   b. Mount the CD-ROM drive.
      ```
      mount /dev/cdrom /mnt/cdrom
      ```
      Some Linux distributions use different device names or organize the `/dev` directory differently. If your CD-ROM drive is not `/dev/cdrom` or if the mount point for a CD-ROM is not `/mnt/cdrom`, modify the command to reflect the conventions that your distribution uses.
5. Change to a working directory, for example, `/tmp`.
   ```
   cd /tmp
   ```
6. Delete any previous `vmware-tools-distrib` directory before you install VMware Tools.
   The location of this directory depends on where you placed it during the previous installation. Often this directory is placed in `/tmp/vmware-tools-distrib`.
7. List the contents of the mount point directory and note the filename of the VMware Tools tar installer.
   ```
   ls mount-point
   ```
8. Uncompress the installer.
   ```
   tar zxf /mnt/cdrom/VMwareTools-x.x.x-yyyy.tar.gz
   ```
   The value `x.x.x` is the product version number, and `yyyy` is the build number of the product release.
   If you attempt to install a tar installation over an RPM installation, or the reverse, the installer detects the previous installation and must convert the installer database format before continuing.
9. If necessary, unmount the CD-ROM image.
   ```
   umount /dev/cdrom
   ```
   If your Linux distribution automatically mounted the CD-ROM, you do not need to unmount the image.
10. Run the installer and configure VMware Tools.
    ```
    cd vmware-tools-distrib
    ./vmware-install.pl
    ```
    Usually, the `vmware-config-tools.pl` configuration file runs after the installer file finishes running.
Follow the prompts to accept the default values, if appropriate for your configuration.

Follow the instructions at the end of the script.

Depending on the features you use, these instructions can include restarting the X session, restarting networking, logging in again, and starting the VMware User process. You can alternatively reboot the guest operating system to accomplish all these tasks.

What to do next

If a new virtual hardware version is available for the virtual machine, upgrade the virtual hardware.

Manually Install or Upgrade VMware Tools in a NetWare Virtual Machine

For NetWare virtual machines, you manually install or upgrade VMware Tools by using the command line.

Before you upgrade VMware Tools, consider the environment that the virtual machine runs in and weigh the benefits of different upgrade strategies. For example, you can install the latest version of VMware Tools to enhance the performance of the virtual machine’s guest operating system and improve virtual machine management, or you can continue using the existing version to provide more flexibility in your environment.

Prerequisites

- Power on the virtual machine.
- Verify that the guest operating system is running.
- Because the VMware Tools installer is written in Perl, verify that Perl is installed in the guest operating system.

Procedure

1. On the host, from the Player menu bar, select Player > Manage > Install VMware Tools.
   - If an earlier version of VMware Tools is installed, the menu item is Update VMware Tools.
2. Load the CD-ROM driver so that the virtual CD-ROM device mounts the ISO image as a volume.

<table>
<thead>
<tr>
<th>Operating System</th>
<th>Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>NetWare 6.5</td>
<td>LOAD CDDVD</td>
</tr>
<tr>
<td>NetWare 6.0 or NetWare 5.1</td>
<td>LOAD CD9660.NSS</td>
</tr>
<tr>
<td>NetWare 4.2 (not available in vSphere)</td>
<td>load cdrom</td>
</tr>
</tbody>
</table>

When the installation finishes, the message VMware Tools for NetWare are now running appears in the Logger Screen for NetWare 6.5 and NetWare 6.0 guest operating systems and in the Console Screen for NetWare 4.2 and 5.1 operating systems.

3. If the VMware Tools virtual disc (netware.iso) is attached to the virtual machine, right-click the CD-ROM icon in the status bar of the console window and select Disconnect to disconnect it.

What to do next

If a new virtual hardware version is available for the virtual machine, upgrade the virtual hardware.
Manually Install or Upgrade VMware Tools in a Solaris Virtual Machine

For Solaris virtual machines, you manually install or upgrade VMware Tools by using the command line.

Before you upgrade VMware Tools, consider the environment that the virtual machine runs in and weigh the benefits of different upgrade strategies. For example, you can install the latest version of VMware Tools to enhance the performance of the virtual machine’s guest operating system and improve virtual machine management, or you can continue using the existing version to provide more flexibility in your environment.

Prerequisites

- Power on the virtual machine.
- Verify that the guest operating system is running.
- Because the VMware Tools installer is written in Perl, verify that Perl is installed in the guest operating system.

Procedure

1. On the host, from the Player menu bar, select Player > Manage > Install VMware Tools.
   
   If an earlier version of VMware Tools is installed, the menu item is Update VMware Tools.

2. In the virtual machine, log in to the guest operating system as root and open a terminal window.

3. If the Solaris volume manager does not mount the CD-ROM under /cdrom/vmwaretools, restart the volume manager.

   /etc/init.d/volmgt stop
   /etc/init.d/volmgt start

4. Change to a working directory, for example, /tmp.

   cd /tmp

5. Extract VMware Tools.

   gunzip -c /cdrom/vmwaretools/vmware-solaris-tools.tar.gz | tar xf -

6. Run the installer and configure VMware Tools.

   cd vmware-tools-distrib
   ./vmware-install.pl

   Usually, the vmware-config-tools.pl configuration file runs after the installer file finishes running.

7. Follow the prompts to accept the default values, if appropriate for your configuration.

8. Follow the instructions at the end of the script.

   Depending on the features you use, these instructions can include restarting the X session, restarting networking, logging in again, and starting the VMware User process. You can alternatively reboot the guest operating system to accomplish all these tasks.

What to do next

If a new virtual hardware version is available for the virtual machine, upgrade the virtual hardware.
Manually Install or Upgrade VMware Tools in a FreeBSD Virtual Machine

For FreeBSD virtual machines, you manually install or upgrade VMware Tools by using the command line.

Before you upgrade VMware Tools, consider the environment that the virtual machine runs in and weigh the benefits of different upgrade strategies. For example, you can install the latest version of VMware Tools to enhance the performance of the virtual machine’s guest operating system and improve virtual machine management, or you can continue using the existing version to provide more flexibility in your environment.

Prerequisites

- Power on the virtual machine.
- Verify that the guest operating system is running.
- Because the VMware Tools installer is written in Perl, verify that Perl is installed in the guest operating system.

Procedure

1. On the host, from the Player menu bar, select Player > Manage > Install VMware Tools.
   If an earlier version of VMware Tools is installed, the menu item is Update VMware Tools.
2. In the virtual machine, log in to the guest operating system as root and open a terminal window.
3. If the distribution does not automatically mount CD-ROMs, mount the VMware Tools virtual CD-ROM image.
   For example, type `mount /cdrom`.
4. Change to a working directory, for example, `/tmp`.
   `cd /tmp`
5. Untar the VMware Tools tar file.
   `tar xzpf /cdrom/vmware-freebsd-tools.tar.gz`
6. If the distribution does not use automounting, unmount the VMware Tools virtual CD-ROM image.
   `umount /cdrom`
7. Run the installer and configure VMware Tools.
   `cd vmware-tools-distrib`
   `./vmware-install.pl`
   Usually, the `vmware-config-tools.pl` configuration file runs after the installer file finishes running.
8. Follow the prompts to accept the default values, if appropriate for your configuration.
9. Follow the instructions at the end of the script.
   Depending on the features you use, these instructions can include restarting the X session, restarting networking, logging in again, and starting the VMware User process. You can alternatively reboot the guest operating system to accomplish all these tasks.

What to do next

If a new virtual hardware version is available for the virtual machine, upgrade the virtual hardware.
Start the VMware User Process Manually If You Do Not Use a Session Manager

VMware Tools in Linux, Solaris, and FreeBSD guest operating systems uses the VMware User process executable file. This program implements the fit-guest-to-window feature and Unity mode, among other features.

Normally, this process starts after you configure VMware Tools, log out of the desktop environment, and log back in. The vmware-user program is located in the directory in which you selected to install binary programs, which defaults to /usr/bin. The startup script that you need to modify depends on your system. You must start the process manually in the following environments:

- If you run an X session without a session manager. For example, if you use startx to start a desktop session and do not use xdm, kdm, or gdm.
- If you are using an older version of GNOME without gdm or xdm.
- If you are using a session manager or environment that does not support the Desktop Application Autostart Specification, available from http://standards.freedesktop.org.
- If you upgrade VMware Tools.

Procedure

- **Start the VMware User process.**

<table>
<thead>
<tr>
<th>Option</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Start the VMware User process when you start an X session.</strong></td>
<td>Add vmware-user to the appropriate X startup script, such as the .xsession or .xinitrc file.</td>
</tr>
<tr>
<td><strong>Start the process after a VMware Tools software upgrade, or if certain features are not working.</strong></td>
<td>Open a terminal window and type the vmware-user command.</td>
</tr>
</tbody>
</table>

Uninstall VMware Tools

Occasionally, an upgrade of VMware Tools is incomplete. You can usually solve the problem by uninstalling VMware Tools and then reinstalling.

Prerequisites

- Power on the virtual machine.
- Log in to the guest operating system.

Procedure

- **Select a method to uninstall VMware Tools.**

<table>
<thead>
<tr>
<th>Operating System</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows 7, 8</td>
<td>In the guest operating system, select Programs &gt; Uninstall a program.</td>
</tr>
<tr>
<td>Windows Vista and Windows Server 2008</td>
<td>In the guest operating system, select Programs and Features &gt; Uninstall a program.</td>
</tr>
<tr>
<td>Windows XP and earlier</td>
<td>In the guest operating system, select Add/Remove Programs.</td>
</tr>
<tr>
<td>Linux</td>
<td>On a Linux guest operating system that has VMware Tools installed by using an RPM installer, enter rpm –e VMwareTools in a terminal window.</td>
</tr>
<tr>
<td>Linux, Solaris, FreeBSD, NetWare</td>
<td>Log in as root and enter vmware-uninstall-tools.pl in a terminal window.</td>
</tr>
<tr>
<td>Mac OS X Server</td>
<td>Use the Uninstall VMware Tools application, found in /Library/Application Support/VMware Tools.</td>
</tr>
</tbody>
</table>
What to do next

Reinstall VMware Tools.

Virtual Machine Files

When you create a virtual machine, Player creates a set of files for that specific virtual machine. Virtual machine files are stored in either the virtual machines directory or the working directory. Both directories are typically on the host system.

Table 3-5. Virtual Machine Files

<table>
<thead>
<tr>
<th>Extension</th>
<th>File Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>.vmx</td>
<td>vmname.vmx</td>
<td>The primary configuration file, which stores virtual machine settings. If you created the virtual machine with an earlier version of Player on a Linux host, this file might have a .cfg extension.</td>
</tr>
<tr>
<td>.log</td>
<td>vmname.log or vmware.log</td>
<td>The main log file. If you need to troubleshoot a problem, refer to this file. This file is stored in the same directory as the .vmx file.</td>
</tr>
<tr>
<td>.nvram</td>
<td>vmname.nvram or nvram</td>
<td>The NVRAM file, which stores the state of the virtual machine BIOS. This file is stored in the same directory as the .vmx file.</td>
</tr>
<tr>
<td>.vmdk</td>
<td>vmname.vmdk</td>
<td>Virtual disk files, which store the contents of the virtual machine hard disk drive. These files are stored in the same directory as the .vmx file. A virtual disk is made up of one or more virtual disk files. The virtual machine settings show the name of the first file in the set. This file contains pointers to the other files in the set. If you specify that all disk space should be allocated when the virtual disk is created, these files start at the maximum size and do not grow. Almost all of the file content is virtual machine data. A small portion of the file is allotted to virtual machine overhead. If the virtual machine is connected directly to a physical disk, the virtual disk file stores information about the partitions that the virtual machine is allowed to access. <strong>Note</strong>: Earlier VMware products use the .dsk extension for virtual disk files. If you specified that the files can increase, filenames include an s in the file number, for example, Windows 7-s001.vmdk. If you specified that the virtual disk is divided into 2GB sections, the number of files depends on the size of the virtual disk. As data is added to a virtual disk, the files increase to a maximum of 2GB each. If all disk space was allocated when the disk was created, filenames include an f, for example, Windows 7-f001.vmdk. If the virtual machine has one or more snapshots, some files are redo log files. These files store changes made to a virtual disk while the virtual machine is running. The ### indicates a unique suffix that Player adds to avoid duplicate file names.</td>
</tr>
<tr>
<td>.vmem</td>
<td>uuid.vmem</td>
<td>The virtual machine paging file, which backs up the guest main memory on the host file system. This file exists only when the virtual machine is running or if the virtual machine fails. It is stored in the working directory.</td>
</tr>
<tr>
<td></td>
<td>snapshot_name_number.vmem</td>
<td>Each snapshot of a virtual machine that is powered on has an associated .vmem file, which contains the guest operating system main memory, saved as part of the snapshot.</td>
</tr>
<tr>
<td>.vmsd</td>
<td>vmname.vmsd</td>
<td>A centralized file for storing information and metadata about snapshots. It is stored in the working directory.</td>
</tr>
</tbody>
</table>
Table 3-5. Virtual Machine Files (Continued)

<table>
<thead>
<tr>
<th>Extension</th>
<th>File Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>.vmsn</td>
<td>vmname.Snapshot.vmsn</td>
<td>The snapshot state file, which stores the running state of a virtual machine at the time you take that snapshot. It is stored in the working directory.</td>
</tr>
<tr>
<td></td>
<td>vmname.Snapshot#.vmsn</td>
<td>The file that stores the state of a snapshot.</td>
</tr>
<tr>
<td>.vmss</td>
<td>vmname.vmss</td>
<td>The suspended state file, which stores the state of a suspended virtual machine. It is stored in the working directory. Some earlier VMware products used the .std extension for suspended state files.</td>
</tr>
</tbody>
</table>

Other files, such as lock files, might also be present in the virtual machines directory. Some files are present only while a virtual machine is running.
Using Virtual Machines

You can use Player to run new and existing virtual machines on the host system, including virtual machines and system images that were created by other VMware products and some non-VMware products. You can also stream virtual machines from a Web server.

When you use virtual machines in Player, you can download virtual appliances, transfer files and text between virtual machines and the host system, print to host printers, connect removable devices, and change display settings.

This chapter includes the following topics:

- “Starting Virtual Machines in Player,” on page 41
- “Stopping Virtual Machines in Player,” on page 44
- “Transferring Files and Text,” on page 46
- “Add a Host Printer to a Virtual Machine,” on page 54
- “Using Removable Devices in Virtual Machines,” on page 54
- “Install New Software in a Virtual Machine,” on page 61
- “Changing the Virtual Machine Display,” on page 62
- “Download a Virtual Appliance in Player,” on page 67
- “Remove a Virtual Machine from the Library in Player,” on page 68

Starting Virtual Machines in Player

When you start a virtual machine in Player, the guest operating system starts and you can interact with the virtual machine in a console window.

- **Start a Virtual Machine in Player** on page 42
  
  You can start a virtual machine from the Player window.

- **Start an Encrypted Virtual Machine in Player** on page 42
  
  An encrypted virtual machine is a virtual machine that has been secured from unauthorized use. A lock icon appears next to an encrypted virtual machine in the virtual machine library.

- **Stream a Virtual Machine from a Web Server** on page 42
  
  When you stream a virtual machine, you can start the virtual machine as soon as the download process begins. When you power off a streamed virtual machine, you are prompted to save or discard changes. If you discard changes, the directory that was created on the local computer and all the virtual machine data are deleted.
Enable Autologon in a Windows Virtual Machine on page 43

With Autologon, you can save your login credentials and bypass the login dialog box when you power on a Windows virtual machine. The guest operating system securely stores the password.

Start a Virtual Machine in Player

You can start a virtual machine from the Player window.

Prerequisites

Verify that the virtual machine files are accessible to the host system.

Procedure

1. If the virtual machine does not appear in the library, select Player > File > Open.
2. Browse to and select the virtual machine configuration (.vmx) file, and click Open.
   The virtual machine appears in the library.
3. Select the virtual machine in the library and select Player > Power > Power On.
4. Click anywhere inside the virtual machine console to give the virtual machine control of the mouse and keyboard on the host system.
5. Log in to the guest operating system.

Start an Encrypted Virtual Machine in Player

An encrypted virtual machine is a virtual machine that has been secured from unauthorized use. A lock icon appears next to an encrypted virtual machine in the virtual machine library.

You cannot create encrypted virtual machines in Player. You can create encrypted virtual machines only by using Workstation 7.x and later.

Prerequisites

Obtain the encryption password for the virtual machine.

Procedure

1. Select the virtual machine in the library and select Player > Power > Power On.
2. Type the encryption password.
3. Click Continue to start the virtual machine.

Stream a Virtual Machine from a Web Server

When you stream a virtual machine, you can start the virtual machine as soon as the download process begins. When you power off a streamed virtual machine, you are prompted to save or discard changes. If you discard changes, the directory that was created on the local computer and all the virtual machine data are deleted.

Prerequisites

- Determine the URL of the virtual machine.
Procedure

1. Run the `vmplayer` command and specify the URL of the virtual machine.
   
   Both HTTP and HTTPS are supported.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows host</td>
<td><code>vmplayer.exe http://path_to_vm.vmx</code></td>
</tr>
<tr>
<td>Linux host</td>
<td><code>vmplayer http://path_to_vm.vmx</code></td>
</tr>
</tbody>
</table>

2. Select the virtual machine and select Player > Power > Power On.

   Player fetches virtual disk data on demand so that you can begin using the virtual machine before it finishes downloading. The status bar indicates the progress of the download. When you point to the VM streaming icon on the status bar, a tooltip indicates whether streaming is active and provides the URL of the Web server.

**Make a Virtual Machine Available for Streaming**

You can make a virtual machine available for streaming from a Web server.

**Prerequisites**

- (Optional) To improve streaming performance, use Virtual Disk Manager (`vmware-diskmanager`) to compress the virtual disk (.vmdk) files for the virtual machine. See the Virtual Disk Manager User’s Guide for more information. This guide is available on the VMware Web site.
- If the virtual machine has any snapshots, delete them.

**Procedure**

1. Configure the Web server to support HTTP keep-alive connections.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Apache HTTP Server 1.2 and later</td>
<td>Turn the <code>KeepAlive</code> option on, set <code>MaxKeepAliveRequests</code> to 2000 to 5000, and set <code>KeepAliveTimeout</code> to 2000 to 5000 seconds, depending on server load.</td>
</tr>
<tr>
<td>Microsoft Internet Information Services (IIS) 6.0 or later</td>
<td>Set the connection timeout to a value above 300 seconds and load HTTP Keep-Alives.</td>
</tr>
</tbody>
</table>

2. If you use a proxy server, set the proxy connection to `Keep-alive`.

3. Upload the virtual machines directory to the Web server.

   Do not compress the directory. Depending on the size of the virtual machine, downloading a virtual machine in a `.zip` or `.tar` file from a Web server can take a considerable amount of time.

   After it is uploaded to the Web server, users can use a URL to stream the virtual machine and start it in Player.

**Enable Autologon in a Windows Virtual Machine**

With Autologon, you can save your login credentials and bypass the login dialog box when you power on a Windows virtual machine. The guest operating system securely stores the password.

Use the Autologon feature if you restart the guest operating system frequently and want to avoid entering your login credentials. You can also use the Autologon feature to grant users access to the guest operating system without sharing your password.
Prerequisites

- Verify that the guest operating system is Windows 2000 or later.
- Verify that you have an existing user account to enable Autologon. The account must be a local machine account, not a domain account.
- Verify that the latest version of VMware Tools is running in the guest operating system.
- Power on the virtual machine.

Procedure

1. Select the virtual machine and select Player > Manage > Virtual Machine Settings.
2. On the Options tab, select Autologon.
3. Click Enable, type your login credentials, and click OK.
   
   If you type an incorrect or expired password, you must type your login credentials when you power on the virtual machine.
4. Click OK to save your changes.
   
   When you enable Autologon or change your login credentials, the Autologon settings are saved immediately. Clicking Cancel in the Virtual Machine Settings dialog box does not affect the changes applied to the Autologon settings.

Stopping Virtual Machines in Player

You can use Player to power off, reset, and suspend virtual machines. You can also configure Player preferences to control how virtual machines behave when you close them.

- **Power Off a Virtual Machine in Player** on page 44
  
  As with physical computers, you should shut down a guest operating system before you power off a virtual machine.

- **Use Ctrl+Alt+Delete to Shut Down a Guest** on page 45
  
  You can use the Ctrl+Alt+Delete key sequence to shut down or log off of a guest operating system.

- **Suspend and Resume a Virtual Machine in Player** on page 45
  
  Suspending a virtual machine saves its current state. When you resume the virtual machine, applications that were running before the virtual machine was suspended resume in their running state and their content is unchanged.

- **Reset a Virtual Machine in Player** on page 45
  
  You can reset a virtual machine in Player. Resetting a virtual machine causes it to abruptly power off and restart.

- **Set Player Preferences for Virtual Machine Closing Behavior** on page 46
  
  You can configure how virtual machines behave when you close them.

**Power Off a Virtual Machine in Player**

As with physical computers, you should shut down a guest operating system before you power off a virtual machine.

**Procedure**

- To shut down the guest operating system, shut down the operating system as you would if you were using a physical machine.
  
  When the guest operating system shuts down, the virtual machine is powered off and Player exits.
To power off a virtual machine without shutting down the guest operating system, select **Player > Power > Power Off**.

If soft power operations are configured for the virtual machine in Workstation, **Power Off Guest** appears in the menu instead of **Power Off**.

**Use Ctrl+Alt+Delete to Shut Down a Guest**

You can use the Ctrl+Alt+Delete key sequence to shut down or log off of a guest operating system.

**Prerequisites**

Power on the virtual machine.

**Procedure**

- Select the virtual machine and select **Player > Send Ctrl+Alt+Delete**.

  This option is the same as pressing Ctrl+Alt+Delete on your keyboard. On Windows hosts, this command might be received by both the host operating system and the virtual machine, even when Player has control of input.

- If the command is received by both the host operating system and the virtual machine, press Ctrl+Alt+Ins on the keyboard.

  The command is received solely by the virtual machine and shuts down or logs out of the guest operating system.

**Suspend and Resume a Virtual Machine in Player**

Suspending a virtual machine saves its current state. When you resume the virtual machine, applications that were running before the virtual machine was suspended resume in their running state and their content is unchanged.

How quickly the suspend and resume operations perform depends on how much data changed after you started the virtual machine. The first suspend typically takes longer than subsequent suspend operations.

**Procedure**

- To suspend a virtual machine, select **Player > Power > Suspend** and click **Yes** to confirm.

  If soft power operations are configured for the virtual machine in Workstation, **Suspend Guest** appears in the menu instead of **Suspend**.

  Player returns the virtual machine to the library in the Suspended state.

- To resume a suspended virtual machine, select the virtual machine and select **Player > Power > Power On**.

**Reset a Virtual Machine in Player**

You can reset a virtual machine in Player. Resetting a virtual machine causes it to abruptly power off and restart.

**Prerequisites**

- Power on the virtual machine.

- Verify that the virtual machine is in a safe state. Resetting a virtual machine can damage data. When possible, shut down the virtual machine with its operating system.
Procedure

- Select Player > Power > Reset.

If soft power operations are configured for the virtual machine in Workstation, Reset Guest appears in the menu instead of Reset.

Set Player Preferences for Virtual Machine Closing Behavior

You can configure how virtual machines behave when you close them.

Procedure

1. Select Player > File > Player Preferences.
2. Select how Player behaves when you close a virtual machine.
   You can select one, both, or neither option.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Confirm before closing a virtual machine</td>
<td>Confirm whether you intend to exit Player or click Cancel to continue using Player.</td>
</tr>
<tr>
<td>Return to the VM Library after closing a virtual machine</td>
<td>Player either suspends or powers off the virtual machine and returns it to the virtual machine library. From the library, you can either open another virtual machine or edit the virtual machine settings.</td>
</tr>
</tbody>
</table>

3. Select whether Player suspends or powers off a virtual machine when you close it.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Suspend the virtual machine</td>
<td>Player suspends the virtual machine. The next time you start Player, the virtual machine resumes operation from the point where it was suspended.</td>
</tr>
<tr>
<td>Power off the virtual machine</td>
<td>Player powers off the virtual machine. The next time you start Player, the virtual machine starts from a powered-off state and the guest operating system starts.</td>
</tr>
</tbody>
</table>

4. Click OK to save your changes.

Transferring Files and Text

You can use the drag-and-drop and copy and paste features, shared folders, and mapped drives to transfer text and files between the host system and virtual machines.

- **Using the Drag-and-Drop Feature** on page 47
  You can use the drag-and-drop feature to move files and directories, email attachments, plain text, formatted text, and images between the host system and virtual machines. Dragging email attachments is especially useful in Unity mode.

- **Using the Copy and Paste Feature** on page 48
  You can cut, copy, and paste text between virtual machines and between applications running in virtual machines.

- **Using Shared Folders** on page 48
  You can use shared folders to share files among virtual machines and between virtual machines and the host system. The directories that you add as shared folders can be on the host system, or they can be network directories that are accessible from the host computer.
Instead of using shared folders or copying data between a virtual machine and the host system, you can map a virtual disk to the host system. In this case, you map a virtual disk in the host file system as a separate mapped drive. Using a mapped drive lets you connect to the virtual disk without going into a virtual machine.

**Using the Drag-and-Drop Feature**

You can use the drag-and-drop feature to move files and directories, email attachments, plain text, formatted text, and images between the host system and virtual machines. Dragging email attachments is especially useful in Unity mode.

You can drag files or directories between the following locations.

- File managers, such as Windows Explorer, on the host system and virtual machines.
- A file manager to an application that supports drag-and-drop.
- Applications, such as zip file managers, which support drag-and-drop extraction of individual files.
- Different virtual machines.

When you drag a file or folder between the host and a virtual machine, Player copies the file or folder to the location where you drop it. For example, if you drop a file on the desktop icon of a word processor, the word processor opens a copy of the original file. The original file does not include changes that you make to the copy.

Initially, the application opens a copy of the file that is stored in the temp directory. On Windows, the temp directory is specified in the %TEMP% environment variable. On Linux and Solaris, the temp directory is /tmp/VMwareDnD. Save the file in a different directory to protect changes that you make.

**Drag-and-Drop Requirements and Restrictions**

The drag-and-drop feature has certain requirements and restrictions.

- You must install VMware Tools in a virtual machine to use the drag-and-drop feature.
- The drag-and-drop feature requires Linux hosts and guests to run X Windows and Solaris 10 guests to run an Xorg X server and JDS/Gnome.
- You can drag images between applications on Windows hosts and applications on Windows guests only. Dragging images is not supported for Linux hosts or guests.
- You can drag files and directories, email attachments, plain text, and formatted text between Linux and Windows hosts and Linux, Windows, and Solaris 10 guests only.
- Dragging email attachments is restricted to images or files smaller than 4MB.
- Dragging plain text and formatted text (including the formatting) is restricted to amounts less than 4MB.
- Dragging text is restricted to text in languages that can be represented by Unicode characters.
- Player uses the PNG format to encode images that are dragged. Dragging images is restricted to images smaller than 4MB after conversion to PNG format.
- On Windows 95 and Windows 98 guests, the drag-and-drop feature is supported only for files and directories.
Using the Copy and Paste Feature

You can cut, copy, and paste text between virtual machines and between applications running in virtual machines.

You can also cut, copy, and paste images, plain text, formatted text, and email attachments between applications running on the host system and applications running in virtual machines.

Copying and pasting email attachments is especially useful in Unity mode. Use the normal hot keys or menu choices to cut or copy and paste.

Copy and Paste Requirements and Restrictions

The copy and paste feature has certain requirements and restrictions.

- You must install VMware Tools in a virtual machine to use the copy and paste feature.
- The copy and paste feature works with Linux and Windows hosts and Linux, Windows, and Solaris 10 guests only.
- The copy and paste feature requires Linux hosts and guests to run X Windows and Solaris 10 guests to run an Xorg X server and JDS/Gnome.
- Copying and pasting email attachments is restricted to images or files smaller than 4MB.
- Copying and pasting plain text and formatted text (including the formatting) is restricted to amounts less than 4MB.
- Copying and pasting text is restricted to text in languages that can be represented by Unicode characters.
- Player uses the PNG format to encode images that are copied and pasted. Copying and pasting images is restricted to images smaller than 4MB after conversion to PNG format.
- You cannot copy and paste files between virtual machines.
- On Windows 95 and Windows 98 guests, copying and pasting is restricted to plain text in amounts less than 64KB.

Using Shared Folders

You can use shared folders to share files among virtual machines and between virtual machines and the host system. The directories that you add as shared folders can be on the host system, or they can be network directories that are accessible from the host computer.

IMPORTANT You cannot open a file in a shared folder from more than one application at a time. For example, do not open the same file in an application on the host operating system and in another application in the guest operating system. If one of the applications writes to the file, data might be corrupted.

- Guest Operating Systems that Support Shared Folders on page 49
  To use shared folders, a virtual machine must have a supported guest operating system.

- Enable a Shared Folder for a Virtual Machine on page 49
  You can enable folder sharing for a specific virtual machine. To set up a folder for sharing between virtual machines, you must configure each virtual machine to use the same directory on the host system or network share.

- View Shared Folders in a Windows Guest on page 50
  In a Windows guest operating system, you can view shared folders by using desktop icons.
Mounting Shared Folders in a Linux Guest on page 51
After you have enabled a shared folder, you can mount one or more directories or subdirectories in the shared folder to any location in the file system in addition to the default location of /mnt/hgfs.

Change Shared Folder Properties on page 52
After you create a shared folder, you can change the folder name, the host path, and other attributes.

Change the Folders That a Virtual Machine Can Share on page 52
You can change the folders that a specific virtual machine is allowed to share.

Disable Folder Sharing for a Virtual Machine on page 53
You can disable folder sharing for a specific virtual machine.

Guest Operating Systems that Support Shared Folders
To use shared folders, a virtual machine must have a supported guest operating system. The following guest operating systems support shared folders.
- Windows Server 2003
- Windows XP
- Windows 2000
- Windows NT 4.0
- Windows Vista
- Windows 7
- Linux with a kernel version of 2.6 or later
- Solaris x86 10
- Solaris x86 10 Update 1 and later

Enable a Shared Folder for a Virtual Machine
You can enable folder sharing for a specific virtual machine. To set up a folder for sharing between virtual machines, you must configure each virtual machine to use the same directory on the host system or network share.

Prerequisites
- Verify that the virtual machines use a guest operating system that supports shared folders. See “Guest Operating Systems that Support Shared Folders,” on page 49.
- Verify that the latest version of VMware Tools is installed in the guest operating system.
- Verify that permission settings on the host system allow access to files in the shared folders. For example, if you are running Player as a user named User, the virtual machine can read and write files in the shared folder only if User has permission to read and write them.

Procedure
1. Select the virtual machine and select Player > Manage > Virtual Machine Settings.
2. On the Options tab, select Shared Folders.
3 Select a folder sharing option.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Always enabled</td>
<td>Keep folder sharing enabled, even when the virtual machine is shut down, suspended, or powered off.</td>
</tr>
<tr>
<td>Enabled until next power off or suspend</td>
<td>Enable folder sharing temporarily, until you power off, suspend, or shut down the virtual machine. If you restart the virtual machine, shared folders remain enabled. This setting is available only when the virtual machine is powered on.</td>
</tr>
</tbody>
</table>

4 (Optional) To map a drive to the Shared Folders directory, select **Map as a network drive in Windows guests**.

This directory contains all of the shared folders that you enable. Player selects the drive letter.

5 Click **Add** to add a shared folder.

On Windows hosts, the Add Shared Folder wizard starts. On Linux hosts, the Shared Folder Properties dialog box opens.

6 Type the path on the host system to the directory to share.

   If you specify a directory on a network share, such as `D:\share`, Player always attempts to use that path. If the directory is later connected to the host on a different drive letter, Player cannot locate the shared folder.

7 Specify the name of the shared folder as it should appear inside the virtual machine.

   Characters that the guest operating system considers illegal in a share name appear differently when viewed inside the guest. For example, if you use an asterisk in a share name, you see `%002A` instead of * in the share name on the guest. Illegal characters are converted to their ASCII hexadecimal value.

8 Select shared folder attributes.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable this share</td>
<td>Enable the shared folder. Deselect this option to disable a shared folder without deleting it from the virtual machine configuration.</td>
</tr>
<tr>
<td>Read-only</td>
<td>Make the shared folder read-only. When this property is selected, the virtual machine can view and copy files from the shared folder, but it cannot add, change, or remove files. Access to files in the shared folder is also governed by permission settings on the host computer.</td>
</tr>
</tbody>
</table>

9 Click **Finish** to add the shared folder.

   The shared folder appears in the Folders list. The check box next to folder name indicates that the folder is being shared. You can deselect this check box to disable sharing for the folder.

10 Click **OK** to save your changes.

**What to do next**


**View Shared Folders in a Windows Guest**

In a Windows guest operating system, you can view shared folders by using desktop icons.

**Note** If the guest operating system has VMware Tools from Workstation 4.0, shared folders appear as folders on a designated drive letter.
Procedure

- Depending on the Windows operating system version, look for **VMware Shared Folders** in *My Network Places*, *Network Neighborhood*, or *Network*.
- If you mapped the shared folder as a network drive, open **My Computer** and look for **Shared Folders on 'vmware-host'** under *Network Drives*.
- To view a specific shared folder, go directly to the folder by using the UNC path `\vmware-host\Shared Folders\shared_folder_name`.

**Mounting Shared Folders in a Linux Guest**

After you have enabled a shared folder, you can mount one or more directories or subdirectories in the shared folder to any location in the file system in addition to the default location of `/mnt/hgfs`.

Use the `mount` command to mount all shares, one share, or a subdirectory within a share to any location in the file system.

<table>
<thead>
<tr>
<th>Table 4-1. Mount Command Syntax</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Command</strong></td>
</tr>
<tr>
<td><code>mount -t vmhgfs .host:/ /home/user1/shares</code></td>
</tr>
<tr>
<td><code>mount -t vmhgfs .host:/foo /tmp/foo</code></td>
</tr>
<tr>
<td><code>mount -t vmhgfs .host:/foo/bar /var/lib/bar</code></td>
</tr>
</tbody>
</table>

You can use VMware-specific options in addition to the standard `mount` syntax. For usage information for the host-guest file system options, type the command `/sbin/mount.vmhgfs -h`.

When you install VMware Tools, an entry is made to `etc/fstab` to specify the location of shared folders. You can edit this file to change or add entries. For example, to auto-mount at startup, edit `/etc/fstab` and add the line:

```
.host:/ /mnt/hgfs vmhgfs defaults 0 0
```

The VMware Tools services script loads a driver that performs the mount. If the mount fails, a message appears regarding mounting HGFS shares.

**NOTE** The mount can fail if shared folders are disabled or if the share does not exist. You are not prompted to run the VMware Tools `vmware-config-tools.pl` configuration program again.

**Using Permissions to Restrict Access to Shared Files in a Linux Guest**

You can use permissions to restrict access to the files in a shared folder on a Linux guest operating system.

On a Linux host, if you create files that you want to share with a Linux guest operating system, the file permissions shown on the guest operating system are the same as the permissions on the host system. You can use the `fmask` and `dmask` commands to mask permissions bits for files and directories.

If you create files on a Windows host system that you want to share with a Linux guest operating system, read-only files are displayed as having read and execute permission for everyone and other files are shown as fully writable by everyone.

If you use a Linux guest operating system to create files for which you want to restrict permissions, use the `mount` program with the following options in the guest operating system.

- `uid`
- `gid`
- `fmask`
dmask
ro (read only)
rw (read-write)

rw is the default.

If you are using a virtual machine that was created with the Windows version of Player, or a previous release of the Linux version of Player, you can change the owner permissions only.

**Change Shared Folder Properties**

After you create a shared folder, you can change the folder name, the host path, and other attributes.

**Prerequisites**

Create a shared folder. See “Enable a Shared Folder for a Virtual Machine,” on page 49.

**Procedure**

1. Select the virtual machine and select **Player > Manage > Virtual Machine Settings**.
2. On the **Options** tab, select **Shared Folders**.
3. Select the shared folder in the folders list and click **Properties**.
4. To change the name of the shared folder as it appears inside the virtual machine, type the new name in the **Name** text box.
   
   Characters that the guest operating system considers illegal in a share name appear differently when viewed inside the guest. For example, if you use an asterisk in a share name, you see %002A instead of * in the share name on the guest. Illegal characters are converted to their ASCII hexadecimal value.

5. To change the host path for the shared folder, browse to or type the new path in the **Host path** text box.

   If you specify a directory on a network share, such as D:\share, Player always attempts to use that path. If the directory is later connected to the host on a different drive letter, Player cannot locate the shared folder.

6. To change an attribute for the shared folder, select or deselect the attribute.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Enabled</strong></td>
<td>Enable the shared folder. Deselect this option to disable a shared folder without deleting it from the virtual machine configuration.</td>
</tr>
<tr>
<td><strong>Read-only</strong></td>
<td>Make the shared folder read-only. When this property is selected, the virtual machine can view and copy files from the shared folder, but it cannot add, change, or remove files. Access to files in the shared folder is also governed by permission settings on the host computer.</td>
</tr>
</tbody>
</table>

7. Click **OK** to save your changes.

**Change the Folders That a Virtual Machine Can Share**

You can change the folders that a specific virtual machine is allowed to share.

**Procedure**

1. Select the virtual machine and select **Player > Manage > Virtual Machine Settings**.
2. On the **Options** tab, select **Shared Folders**.
3. In the folders list, select the check boxes next to the folders to share and deselect the check boxes next to the folders to disable.
4 Click OK to save your changes.

**Disable Folder Sharing for a Virtual Machine**

You can disable folder sharing for a specific virtual machine.

**Procedure**

1. Select the virtual machine and select **Player > Manage > Virtual Machine Settings**.
2. On the **Options** tab, select **Shared Folders**.
3. Select **Disabled** to disable folder sharing.
4. Click OK to save your changes.

**Mapping a Virtual Disk to the Host System**

Instead of using shared folders or copying data between a virtual machine and the host system, you can map a virtual disk to the host system. In this case, you map a virtual disk in the host file system as a separate mapped drive. Using a mapped drive lets you connect to the virtual disk without going into a virtual machine.

**Map or Mount a Virtual Disk to a Drive on the Host System**

When you map a virtual disk and its associated volume to a drive on the host system, you can connect to the virtual disk without opening a virtual machine.

After you map the virtual disk to a drive on the host system, you cannot power on any virtual machine that uses the disk until you disconnect the disk from the host system.

**Important** If you mount a virtual disk that has a snapshot and then write to the disk, you can irreparably damage a snapshot or linked clone created from the virtual machine.

**Prerequisites**

- Power off all virtual machines that use the virtual disk.
- Verify that the virtual disk (.vmdk) files on the virtual disk are not compressed and do not have read-only permissions.
- On a Windows host, verify that the volume is formatted with FAT (12/16/32) or NTFS. Only FAT (12/16/32) and NTFS formatting is supported. If the virtual disk has mixed partitions, for example, one partition is formatted with a Linux operating system and another partition is formatted with a Windows operating system, you can map the Windows partition only.
- Verify that the virtual disk is unencrypted. You cannot map or mount encrypted disks.

**Procedure**

1. Select the virtual machine and select **Player > Manage > Virtual Machine Settings**.
2. On the **Hardware** tab, select **Hard Disk**, click **Utilities**, and select **Map**.
3. On a Windows host, leave the check box **Open file in read-only mode** selected in the Map Virtual Disk dialog box.
   
   This setting prevents you from accidentally writing data to a virtual disk that might be the parent of a snapshot or linked clone. Writing to such a disk might make the snapshot or linked clone unusable.
4. On a Linux host, select the **Mount in read-only mode** check box in the Mount Disk dialog box.
   
   This setting prevents you from accidentally writing data to a virtual disk that might be the parent of a snapshot or linked clone. Writing to such a disk might make the snapshot or linked clone unusable.
5 Browse to a virtual disk (.vmdk) file, select it, and click Open.

6 Select the volume to map or mount and select an unused drive letter on the host system.

7 (Optional) On a Windows host, if you do not want the drive to open in Windows Explorer after it is mapped, deselect the Open drive in Windows Explorer after mapping check box.

8 Click OK or Mount.

The drive appears on the host system. You can read from or write to files on the mapped virtual disk on the host system.

---

**Disconnect a Virtual Disk from the Host System**

To use a virtual disk from a virtual machine after it has been mapped or mounted on the host system, you must disconnect it from the host system.

On Windows hosts, you must use Player to disconnect the drive from the host system. The mapped drive letter does not appear in the list of network drives when you use the Windows Disconnect Network Drive command.

**Procedure**

1 Select the virtual machine and select Player > Manage > Virtual Machine Settings.

2 On the Hardware tab, select Hard Disk, click Utilities, and select Disconnect.

You can now power on any virtual machine that uses this disk.

---

**Add a Host Printer to a Virtual Machine**

You can print from a virtual machine to any printer available to the host computer without having to install additional drivers in the virtual machine.

The Player printer feature uses ThinPrint technology to replicate the host system printer mapping in the virtual machine. When you enable the virtual machine printer, Player configures a virtual serial port to communicate with the host printers.

**Procedure**

1 Select the virtual machine and select Player > Manage > Virtual Machine Settings.

2 On the Hardware tab, select Add.

3 In the Add Hardware wizard, select Printer and Finish.

The default device setting is to connect the virtual machine printer when the virtual machine is powered on.

**What to do next**

In a Print window, when you attempt to select a printer in Windows 7 virtual machines, you might see only the default printer, even though other printers are available. To see the other printers, right-click the default printer and point to Printer properties.

---

**Using Removable Devices in Virtual Machines**

You can use removable devices such as floppy drives, DVD and CD-ROM drives, USB devices, and smart card readers in virtual machines.

Some devices cannot be used by the host system and a guest operating system, or by multiple guest operating systems, simultaneously.
For example, if the host system is using a floppy drive, you must connect the floppy drive to the virtual machine before you can use it in the virtual machine. To use the floppy drive on the host again, you must disconnect it from the virtual machine. By default, a floppy drive is not connected when a virtual machine powers on.

- Use a Removable Device in a Virtual Machine on page 55
  You can connect and disconnect removable devices in a virtual machine. You can also change the settings for a removable device by modifying virtual machine settings.

- Connecting USB Devices to Virtual Machines on page 56
  When a virtual machine is running, its window is the active window. If you plug a USB device into the host system, the device connects to the virtual machine instead of the host by default. If a USB device connected to the host system does not connect to a virtual machine at power on, you must manually connect the device to the virtual machine.

- Troubleshooting USB Device Control Sharing on page 58
  Only the host system or the virtual machine can have control of a particular USB device at any one time. Device control operates differently, depending on whether the host system is a Linux or a Windows computer.

- Using Smart Cards in Virtual Machines on page 59
  Virtual machines can connect to smart card readers that interface to serial ports, parallel ports, USB ports, PCMCIA slots, and PCI slots. A virtual machine considers a smart card reader to be a type of USB device.

Use a Removable Device in a Virtual Machine

You can connect and disconnect removable devices in a virtual machine. You can also change the settings for a removable device by modifying virtual machine settings.

Prerequisites

- Power on the virtual machine.

- If you are connecting or disconnecting a USB device, familiarize yourself with the way Player handles USB devices. See “Connecting USB Devices to Virtual Machines,” on page 56.

- If you are connecting or disconnecting a USB device on a Linux host and the USB device file system is not located in `/proc/bus/usb`, mount the USB file system to that location. See “Mount the USB File System on a Linux Host,” on page 57.

Procedure

- To connect a removable device, select the virtual machine, select Player > Removable Devices, select the device, and select Connect.

  If the device is connected to the host system through a USB hub, the virtual machine sees only the USB device, not the hub.

  A check mark appears next to the name of the device when the device is connected to the virtual machine and a device icon appears on the virtual machine taskbar.

- To change the settings for a removable device, select Player > Removable Devices, select the device, and select Settings.

- To disconnect a removable device, select the virtual machine, select Player > Removable Devices, select the device, and select Disconnect.

  You can also disconnect the device by clicking or right-clicking the device icon on the virtual machine taskbar. Using the taskbar icon is especially useful if you run the virtual machine in full screen mode.
Connecting USB Devices to Virtual Machines

When a virtual machine is running, its window is the active window. If you plug a USB device into the host system, the device connects to the virtual machine instead of the host by default. If a USB device connected to the host system does not connect to a virtual machine at power on, you must manually connect the device to the virtual machine.

When you connect a USB device to a virtual machine, Player retains the connection to the affected port on the host system. You can suspend or power off the virtual machine, or unplug the device. When you plug in the device again or resume the virtual machine, Player reconnects the device. Player retains the connection by writing an autoconnect entry to the virtual machine configuration (.vmx) file.

If Player cannot reconnect to the device, for example, because you disconnected the device, the device is removed and Player displays a message to indicate that it cannot connect to the device. You can connect to the device manually if it is still available.

Follow the device manufacturer’s procedures for unplugging the device from the host computer when you physically unplug the device, move the device from host system to a virtual machine, move the device between virtual machines, or move the device from a virtual machine to the host computer. Following these procedures is especially important for data storage devices, such as zip drives. If you move a data storage device too soon after saving a file and the operating system did not actually write the data to the disk, you can lose data.

- Installing USB Drivers on Windows Hosts on page 56
  When a particular USB device is connected to a virtual machine for the first time, the host detects it as a new device named VMware USB Device and installs the appropriate VMware driver.

- Disable Automatic Connection of USB Devices on page 56
  You can disable the autoconnect feature if you do not want USB devices to connect to a virtual machine when you power it on.

- Mount the USB File System on a Linux Host on page 57
  On Linux hosts, Player uses the USB device file system to connect to USB devices. If the USB device file system is not located in /proc/bus/usb, you must mount the USB file system to that location.

- Connect USB HIDs to a Virtual Machine on page 57
  To connect USB human interface devices (HIDs) to a virtual machine, you must configure the virtual machine to show all USB input devices in the Removable Devices menu.

- Install a PDA Driver and Synchronize With a Virtual Machine on page 58
  To install a PDA driver in a virtual machine, you must synchronize the PDA with the virtual machine.

Installing USB Drivers on Windows Hosts

When a particular USB device is connected to a virtual machine for the first time, the host detects it as a new device named VMware USB Device and installs the appropriate VMware driver.

The Windows operating system prompts you to run the Microsoft Windows Found New Hardware wizard. Select the default action to install the software automatically. After the software is installed, the guest operating system detects the USB device and searches for a suitable driver.

Disable Automatic Connection of USB Devices

You can disable the autoconnect feature if you do not want USB devices to connect to a virtual machine when you power it on.

Prerequisites

Power off the virtual machine.
Procedure
1. Select the virtual machine and select Player > Manage > Virtual Machine Settings.
2. On the Hardware tab, select USB Controller.
3. Deselect Automatically connect new USB devices to disable automatic connection of USB devices.
4. Click OK to save your changes.

Mount the USB File System on a Linux Host
On Linux hosts, Player uses the USB device file system to connect to USB devices. If the USB device file system is not located in /proc/bus/usb, you must mount the USB file system to that location.

**IMPORTANT** Do not attempt to add a USB drive device node directory, for example, /dev/sda, to the virtual machine as a hard disk.

Prerequisites
Verify that you have root access to the host system.

Procedure
1. As root, mount the USB file system.
   ```bash
   mount -t usbfs none /proc/bus/usb
   ```
2. Connect the USB device to the host system.

Connect USB HIDs to a Virtual Machine
To connect USB human interface devices (HIDs) to a virtual machine, you must configure the virtual machine to show all USB input devices in the Removable Devices menu.

By default, USB HIDs, such as USB 1.1 and 2.0 mouse and keyboard devices, do not appear in the Removable Devices menu in a virtual machine, even though they are plugged in to USB ports on the host system.

An HID that is connected to a virtual machine is not available to the host system.

Prerequisites
- Power off the virtual machine.
- If you are using a KVM switch for a mouse or keyboard, disable automatic connection of USB devices. See “Disable Automatic Connection of USB Devices,” on page 56.

Procedure
1. Select the virtual machine and select Player > Manage > Virtual Machine Settings.
2. On the Hardware tab, select USB Controller.
3. Select Show all USB input devices.
   This option allows users to use special USB HIDs inside the virtual machine.
4. Click OK to save your changes.
5. Power on the virtual machine.
   HIDs appear in the Removable Devices menu.
Install a PDA Driver and Synchronize With a Virtual Machine

To install a PDA driver in a virtual machine, you must synchronize the PDA with the virtual machine.

Procedure
1. Connect the PDA to the host system and synchronize it with the host system.
   The PDA driver should begin installing in the virtual machine.
2. Allow the virtual machine to install the PDA driver.
3. If connection warning messages appear, dismiss them.
4. If the PDA disconnects from the host system before the virtual machine can synchronize with it, synchronize the PDA with the host system again.
   The total time required to load the VMware USB device driver in the host system and install the PDA driver in the virtual machine might exceed the device connection timeout value. A second synchronization attempt usually succeeds.

Troubleshooting USB Device Control Sharing

Only the host system or the virtual machine can have control of a particular USB device at any one time. Device control operates differently, depending on whether the host system is a Linux or a Windows computer.

When you connect a device to a virtual machine, it is disconnected from the host system or from the virtual machine that previously had control of the device. When you disconnect a device from a virtual machine, it is returned to the host system.

Under some circumstances, if a USB storage device is in use on the host system, for example, one or more files stored on the device are open on the host, an error appears in the virtual machine when you try to connect to the device. You must let the host system complete its operation or close any application connected to the device on the host system and connect to the device in the virtual machine again.

On Windows XP and Windows Server 2003 host systems, a message might appear that says the device can be removed safely when you connect a USB network or storage device to a virtual machine. This is normal behavior and you can dismiss the dialog box, but do not remove the device from the physical computer. If the network or storage device does not disconnect from the host system, use the appropriate system tray icon to disconnect it. On Windows XP and Windows Server 2003, the system tray icon is called Safely Remove Hardware.

Troubleshoot USB Device Control Issues on a Linux Host

You have problems connecting or disconnecting USB devices on a Linux host system.

Problem
You are prompted to disconnect the driver on the host system when you connect a USB device to the virtual machine or disconnecting the device fails.

Cause
On Linux host systems, guest operating systems can use devices that are not claimed by a host operating system driver. A related issue sometimes affects devices that rely on automatic connection, such as PDAs. Occasionally, even if you successfully use autoconnection to connect the device to the virtual machine, you might experience problems with the connection to the device.
Solution

1 If you have problems with autoconnection, perform these steps.
   a Select the virtual machine and select Player > Removable Devices to disconnect and reconnect the device.
   b If the problem persists, unplug the device and plug it in again.
   c If a warning message indicates that the device is in use, disable the device in the hotplug configuration files in the /etc/hotplug directory.
      The documentation for the Linux distribution contains information on editing these configuration files.

2 If disconnection fails, either disable the driver or unload the driver manually.

   **Option** | **Description**
   --- | ---
   Disable the driver | If the driver was automatically loaded by hotplug, disable it in the hotplug configuration files in the /etc/hotplug directory. See the documentation for your Linux distribution for information on editing these configuration files.
   Unload the driver manually | Become root (su -) and use the rmmod command.

Using Smart Cards in Virtual Machines

Virtual machines can connect to smart card readers that interface to serial ports, parallel ports, USB ports, PCMCIA slots, and PCI slots. A virtual machine considers a smart card reader to be a type of USB device.

A smart card is a plastic card that has an embedded computer chip. Many government agencies and large enterprises use smart cards to send secure communication, digitally sign documents, and authenticate users who access their computer networks. Users plug a smart card reader into their computer and insert their smart card in the reader. They are then prompted for their PIN to log in.

You can select a smart card reader from the Removable Devices menu in a virtual machine. A smart card can be shared between virtual machines, or between the host system and one or more virtual machines. Sharing is enabled by default.

When you plug a smart card reader into the host system, the reader appears as two separate USB devices in Player. This is because you can use smart cards in one of two mutually exclusive modes.

**Shared mode**  
(Recommended) The smart card reader device is available as Shared smart_card_reader_model in the Removable Devices menu. In Windows XP guest operating systems, the shared reader appears as USB Smart Card Reader after it is connected to the virtual machine. In Windows Vista and Windows 7 guest operating systems, the generic smart card reader device name appears under the Windows Device Manager list. The smart card reader can be shared among applications on the host system and among applications in different guest operating systems.

**USB passthrough mode**  
The smart card reader device is available as smart_card_reader_model in the Removable Devices menu. In USB passthrough mode, a single virtual machine directly controls the physical smart card reader. A USB passthrough smart card reader cannot be used by applications on the host system or by applications in other virtual machines. You should use USB passthrough mode only if connection in shared mode does not work well for your scenario. You might need to install the driver provided by the manufacturer to use USB passthrough mode.
You can use smart cards with Windows operating systems and most Linux distributions. VMware provides full smart card support for Windows virtual machines running on Linux hosts. Using smart cards in Linux typically requires third-party software to effectively authenticate to a domain or enable secure communications.

**Note** Although smart cards should work with common Linux browsers, email applications, and directory services, these products have not been tested or certified by VMware.

### Use a Smart Card in a Virtual Machine

You can configure a virtual machine to use the smart card reader on the host system.

**Prerequisites**

- On a Windows host, start the `SCardSvr.exe` service.
- On a Linux host, verify that the `libpcsclite` library is installed and that the `pcscd` daemon is running.
- Verify that the virtual machine has a USB controller. A USB controller is required, regardless of whether the smart card reader is a USB device. A USB controller is added by default when you create a virtual machine.
- Connect the smart card reader to the host system.
- Start the virtual machine

**Procedure**

- To connect the smart card reader to the virtual machine, select the virtual machine and select Player > Removable Devices > Shared <smart_card_reader_model> > Connect.
  
  If the smart card reader is a USB device, two items appear for it in the menu. Both items use the model name of the reader, but one item name begins with Virtual.

- To disconnect the smart card reader from the virtual machine, select Player > Removable Devices > Shared <smart_card_reader_model> > Disconnect.

- To remove the smart card from the virtual machine, select Player > Removable Devices > Shared <smart_card_reader_model> > Remove Smart Card.
  
  The smart card is removed from the virtual machine, but it remains connected on the host system. If the smart card is physically removed from the smart card reader, this option is disabled.

- To insert the smart card to the virtual machine, select Player > Removable Devices > Shared <smart_card_reader_model> > Insert Smart Card.
  
  If the smart card is physically inserted in the smart card reader, the smart card is also inserted in the virtual machine.

### Disable Smart Card Sharing

By default, you can share a smart card between virtual machines or between the host system and one or more virtual machines. You might want to disable smart card sharing if you are using a PCMCIA smart card reader, deploying virtual machines for enterprise use and do not want to support drivers for various smart card readers, or the host system has drivers but the virtual machines do not.

The setting that controls smart card sharing is located in the Player global configuration file.
Procedure

1. Find the global configuration file on the host system.

<table>
<thead>
<tr>
<th>Operating System</th>
<th>Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>Most Windows hosts</td>
<td>C:\Documents and Settings\All Users\Application Data\VMware\VMware Player\config.ini</td>
</tr>
<tr>
<td>Windows Vista and Windows 7 hosts</td>
<td>C:\ProgramData\VMware\VMware Player\config.ini</td>
</tr>
<tr>
<td>Linux hosts</td>
<td>/etc/vmware/config</td>
</tr>
</tbody>
</table>

2. If the global configuration file does not yet exist on the host system, select Player > File > Player Preferences and change at least one Player preference settings. Player creates the global configuration file when you change Player preference settings.

3. Open the global configuration file in a text editor and set the usb.ccid.useSharedMode property to FALSE.
   
   For example: `usb.ccid.useSharedMode = "FALSE"

4. Save and close the global configuration file.

5. Set permissions on the global configuration file so that other users cannot change it.

Switch to a Virtual Smart Card Reader on a Linux Host

Because of the way smart card reader functionality is implemented on Linux hosts, you must exit Player and restart the pcscd daemon on the host system before you can switch from the non-virtual smart card reader to the virtual smart card reader.

Procedure

1. Select the virtual machine, select Virtual Machine > Removable Devices, select the smart card reader, and select Disconnect.

2. Power off the virtual machine and exit Player.

3. Physically disconnect the smart card reader from the host system.

4. Restart the pcscd daemon on the host system.

5. Physically connect the smart card reader to the host system.

6. Start Player and start the virtual machine.

7. Select the virtual machine, select Virtual Machine > Removable Devices, select the smart card reader, and select Connect.

Install New Software in a Virtual Machine

Installing new software in a virtual machine is similar to installing new software on a physical computer. Only a few additional steps are required.

Prerequisites

- Verify that VMware Tools is installed in the guest operating system. Installing VMware Tools before installing the software minimizes the likelihood that you will have to reactivate the software if the virtual machine configuration changes.

- Verify that the virtual machine has access to the CD-ROM drive, ISO image file, or floppy drive where the installation software is located.
Procedure

1. Select the virtual machine and select Player > Manage > Virtual Machine Settings.
2. On the Hardware tab, select Memory, set the final memory size for the virtual machine, and click OK.
   
   Some applications use a product activation feature that creates a key based on the virtual hardware in the virtual machine where it is installed. Changes in the configuration of the virtual machine might require you to reactivate the software. Setting the memory size minimizes the number of significant changes.
3. Install the new software according to the manufacturer’s instructions.

Disable Acceleration if a Program Does Not Run

When you install or run software inside a virtual machine, Player might appear to stop responding. This problem typically occurs early in the program’s execution. In many cases, you can get past the problem by temporarily disabling acceleration in the virtual machine.

Procedure

1. Select the virtual machine and select Player > Manage > Virtual Machine Settings.
2. On the Hardware tab, select Processors.
3. Select Disable acceleration for binary translation to disable acceleration.
4. Click OK to save your changes.

What to do next

After you pass the point where the program encountered problems, re-enable acceleration. Because disabling acceleration slows down virtual machine performance, you should use it only for getting past the problem with running the program.

Changing the Virtual Machine Display

You can change the way Player displays virtual machines and virtual machine applications. You can use full screen mode to make the virtual machine display fill the screen and use multiple monitors, and you can use Unity mode to display applications directly on the host system desktop.

- Configure Display Settings for a Virtual Machine on page 63
  
  You can specify monitor resolution settings, configure multiple monitors, and select accelerated graphics capabilities for a virtual machine. You can use the multiple-monitor feature when the virtual machine is in full screen mode.

- Use Full Screen Mode in Player on page 63
  
  In full screen mode, the virtual machine display fills the screen, so that you cannot see the borders of the Player window.

- Use Unity Mode on page 64
  
  You can switch virtual machines that have Linux or Windows 2000 or later guest operating systems to Unity mode to display applications directly on the host system desktop.

- Use Multiple Monitors for One Virtual Machine in Player on page 67
  
  If the host system has multiple monitors, you can configure a virtual machine to use multiple monitors. You can use the multiple-monitor feature when the virtual machine is in full screen mode.
Configure Display Settings for a Virtual Machine

You can specify monitor resolution settings, configure multiple monitors, and select accelerated graphics capabilities for a virtual machine. You can use the multiple-monitor feature when the virtual machine is in full screen mode.

To use DirectX 9 accelerated graphics, the guest operating system must be Windows XP, Windows Vista, or Windows 7. Only Player 3.x and later virtual machines support specifying resolution settings and setting the number of monitors that the guest operating system can use.

Prerequisites

- Verify that the latest version of VMware Tools is installed in the guest operating system.
- Verify that the guest operating system in the virtual machine is Windows XP, Windows Vista, Windows 7, or Linux.
- If you plan to use DirectX 9 accelerated graphics, prepare the host system. See “Prepare the Host System to Use DirectX 9 Accelerated Graphics,” on page 72.

Procedure

1. Select the virtual machine and select Player > Manage > Virtual Machine Settings.
2. On the Hardware tab, select Display.
3. Specify whether host settings determine the number of monitors.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use host setting for monitors</td>
<td>When you select this setting, the SVGA driver uses two monitors, a maximum bounding box width of 3840, and a maximum bounding box height of 1920. The virtual machine is configured to have a minimum of two 1920x1200 monitors, in a side-by-side topology, in both normal and rotated orientations. If the host system has more than two monitors, the virtual machine uses the number of monitors on the host system instead. If the host system’s bounding box is wider or taller than the defaults, the virtual machine uses the larger size. You should select this setting in most cases.</td>
</tr>
<tr>
<td>Specify monitor settings</td>
<td>Set the number of monitors that the virtual machine will see, regardless of the number of monitors on the host system. This setting is useful if you use a multimonitor host system and you need to test in a virtual machine that has only one monitor. It is also useful if you are developing a multimonitor application in a virtual machine and the host system has only one monitor. After you power on the virtual machine, the guest operating system sees the number of monitors that you specified. Select a resolution from the list or type a setting that has the format width x height, where width and height are the number of pixels.</td>
</tr>
</tbody>
</table>

4. (Optional) To run applications that use DirectX 9 accelerated graphics, select Accelerate 3D graphics.
5. Click OK to save your changes.

Use Full Screen Mode in Player

In full screen mode, the virtual machine display fills the screen, so that you cannot see the borders of the Player window.

Prerequisites

- Power on the virtual machine.
Verify that the guest operating system display mode is larger than the host system display mode. If the guest operating system display mode is smaller than the host system display mode, you might not be able to enter full screen mode. If you cannot enter full screen mode, add the line `mks.maxRefreshRate=1000` to the virtual machine configuration (.vmx) file.

Verify that the latest version of VMware Tools is installed in the guest operating system.

If you are running the virtual machine in full screen mode on a laptop, configure the guest operating system to report battery information. See “Report Battery Information in the Guest,” on page 64.

**Procedure**

To enter full screen mode, select the virtual machine and select **Player > Full Screen**.

To hide the full screen toolbar and menus while you are using full screen mode, click the push pin icon and move the pointer off of the toolbar.

This action unpins the toolbar. The toolbar slides up to the top of the monitor and disappears. To display the toolbar again, point to the top of the screen until the toolbar appears.

To exit full screen mode and return to windowed mode, select **Player > Full Screen** from the full screen toolbar. The check mark next to **Full Screen** is removed.

**Report Battery Information in the Guest**

If you run a virtual machine on a laptop in full screen mode, configure the option to report battery information in the guest so that you can determine when the battery is running low.

**Prerequisites**

Power off the virtual machine.

**Procedure**

1. Select the virtual machine and select **Player > Manage > Virtual Machine Settings**.
2. On the **Options** tab, select **Power**.
3. Select **Report battery information to guest**.
4. Click **OK** to save your changes.

**Use Unity Mode**

You can switch virtual machines that have Linux or Windows 2000 or later guest operating systems to Unity mode to display applications directly on the host system desktop.

In Unity mode, virtual machine applications appear on the host system desktop, you can use the virtual machine **Start** or **Applications** menu from the host system, and the virtual machine console view is hidden. Items for open virtual machine applications appear on the host system taskbar in the same way as open host applications.

On host system and virtual machine applications that are displayed in Unity mode, you can use keyboard shortcuts to copy, cut, and paste images, plain text, formatted text, and email attachments between applications. You can also drag and drop and copy and paste files between the host system and the guest operating system.

If you save a file or attempt to open a file from an application in Unity mode, the file system you see is the file system inside the virtual machine. You cannot open a file from the host operating system or save a file to the host operating system.

For some guest operating systems, application windows in Unity mode can appear only on the monitor that is set as the primary display when you have multiple monitors. If the host and guest operating systems are Windows XP or later, the application windows can appear on additional monitors.
Unity mode is not available in full screen mode on Windows.

**Prerequisites**

- Verify that the virtual machine is a Player 3.x or later virtual machine.
- Verify that the latest version of VMware Tools is installed in the guest operating system.
- Verify that the guest operating system is Linux or Windows 2000 or later.
- For Linux guests and hosts, verify that a modern version of Metacity or KDE is installed. Performance on Linux depends on a combination of variables such as the system, the applications that are running, and the amount of RAM.
- Power on the virtual machine.
- If you are entering Unity mode, open applications in the virtual machine to use in Unity mode.

**Procedure**

- To enter Unity mode, select **Player > Unity**.
  
  The console view in the Player window is hidden, and open applications appear in application windows on the host system desktop. A check mark appears next to **Unity** in the menu.
- To display the virtual machine **Start** menu on a Windows host system, point to the **Start** menu on a Windows host system.
- To display the virtual machine **Applications** menu on a Linux host system, point to the upper-left corner of the primary monitor on the Linux host system.
- To navigate between multiple **Start** or **Applications** menus when multiple virtual machines are in Unity mode, press the arrow keys, Tab, or Shift+Tab to cycle through the virtual machine menus and press Enter and the spacebar to select a virtual machine.
- To exit Unity mode, display the Player window and click **Exit Unity** in the virtual machine console view.

**Set Preferences for Unity Mode**

You can set preferences for Unity mode to control whether the virtual machine **Start** or **Applications** menu is available from the host system desktop. You can also select the border color that appears around applications that run in Unity mode when they appear on the host system desktop.

When you use the virtual machine **Start** or **Applications** menu from the host system desktop, you can start applications in the virtual machine that are not open in Unity mode. If you do not enable this feature, you must exit Unity mode to display the virtual machine **Start** or **Applications** menu in the console view.

**Procedure**

1. Select the virtual machine and select **Player > Manage > Virtual Machine Settings**.
2. On the **Options**, select **Unity**.
3 Select a Unity window decoration option.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Show borders</strong></td>
<td>Set a window border that identifies the application as belonging to the</td>
</tr>
<tr>
<td></td>
<td>virtual machine rather than to the host computer.</td>
</tr>
<tr>
<td><strong>Show badges</strong></td>
<td>Display a logo in the title bar.</td>
</tr>
<tr>
<td>**Use a custom color in</td>
<td>Use a custom color in window borders to help distinguish between the</td>
</tr>
<tr>
<td>window borders**</td>
<td>application windows that belong to various virtual machines. For example,</td>
</tr>
<tr>
<td></td>
<td>you can set the applications for one virtual machine to have a blue border</td>
</tr>
<tr>
<td></td>
<td>and set the applications for another virtual machine to have a yellow</td>
</tr>
<tr>
<td></td>
<td>border. On Linux hosts, click the colored rectangle to use the color chooser.</td>
</tr>
<tr>
<td></td>
<td>On Windows hosts, click <strong>Choose color</strong> to use the color chooser.</td>
</tr>
</tbody>
</table>

4 To control whether the virtual machine **Start** or **Application** menu available on the host system desktop, select or deselect **Enable applications menu**.

5 Click **OK** to save your changes.

**Create Virtual Machine Application Shortcuts on the Host in Unity Mode**

You can create a shortcut for a virtual machine application on the host system in Unity mode.

You open the application in the same way that you open an application on the host system. You can open a virtual machine application shortcut from the host system even when the virtual machine is powered off or suspended.

**Prerequisites**

- Verify that the virtual machine is configured to display the virtual machine **Start** or **Application** menu on the host system desktop. See “Set Preferences for Unity Mode,” on page 65.
- Verify that the latest version of VMware Tools is running in the guest operating system.
- Power on the virtual machine.

**Procedure**

1 To enter Unity mode, select **Player > Unity**. The console view in the Player window is hidden, and open applications appear in application windows on the host system desktop. A check mark appears next to **Unity** in the menu.

2 Select a virtual machine application.

<table>
<thead>
<tr>
<th>Option</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Windows host</strong></td>
<td>Point to the <strong>Start</strong> button to display the virtual machine <strong>Start</strong> menu on the host system desktop, click the <strong>Start</strong> menu, and select the application.</td>
</tr>
<tr>
<td><strong>Linux host</strong></td>
<td>Point to the upper-left corner of the primary monitor to display the virtual machine <strong>Applications</strong> menu on the host system desktop, click <strong>Applications</strong> menu, and select the application.</td>
</tr>
</tbody>
</table>

3 Create a shortcut to the application on the host system.

<table>
<thead>
<tr>
<th>Option</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Windows host</strong></td>
<td>Right-click the application and select <strong>Create Shortcut on Desktop</strong>, or drag the application to the host system.</td>
</tr>
<tr>
<td><strong>Linux host</strong></td>
<td>Drag the application to the host system.</td>
</tr>
</tbody>
</table>
Use Multiple Monitors for One Virtual Machine in Player

If the host system has multiple monitors, you can configure a virtual machine to use multiple monitors. You can use the multiple-monitor feature when the virtual machine is in full screen mode.

Prerequisites

- Verify that the virtual machine is a Player 3.x or later virtual machine.
- Verify that the latest version of VMware Tools is installed in the guest operating system.
- Verify that the guest operating system is Windows XP, Windows Vista, Windows 7, or Linux.
- On the host system, verify that the left-most monitor is not placed lower than any other monitor in the display topology. When you enter full screen mode, the monitor that contains the Player window cannot be lower than another monitor.

Procedure

1. Power on the virtual machine and click the maximize button.
2. On the full screen toolbar, click the Cycle multiple monitors button.
   
   On a Windows host, you can mouse over a button on the toolbar to see its name.
   
   If your virtual machine supports more than two monitors, use the Cycle multiple monitors button to select a configuration with more than two monitors. The monitor in which the virtual machine entered full screen mode is marked with an asterisk.
   
   The guest operating system desktop extends to the additional monitor or monitors.
3. If the host system has more than two monitors and you want the virtual machine to use all of the monitors, click the Cycle multiple monitors button again.
   
   The order in which the monitors are used depends on the order in which the monitors were added to the host operating system. If you continue to click the button, you return to fewer monitors.

Limitations for Multiple Monitors

The use of more than two monitors with a virtual machine has certain limitations.

- If you attempt to use more than two monitors with a virtual machine, your virtual machine must support more than two monitors for this feature to function.
- More than two monitors is supported on Windows and Linux host and guest operating systems.
- Windows XP guests support more than three monitors. However, only three monitors can be in use by a Windows XP guest at one time. If more than three monitors are connected to a Windows XP guest, use the Cycle multiple monitors button to cycle through the monitors to the configuration you want to use.

Download a Virtual Appliance in Player

You can download a virtual appliance in Player. A virtual appliance is a prebuilt, preconfigured, and ready-to-run software application that is packaged with the operating system in a virtual machine.

Procedure

- Select Player > File > Download a Virtual Appliance.
A Web browser opens to the Virtual Appliance Marketplace page on the VMware Web site. You can browse to and download virtual appliances from this page.

Remove a Virtual Machine from the Library in Player

When you open a virtual machine in Player, it is added to the virtual machine library. You can remove a virtual machine that you are not using from the library.

Removing a virtual machine from the library does not delete the virtual machine or any of its files from the host file system. The virtual machine is removed only from the library. If you open the virtual machine again, the virtual machine is added back to the library.

Prerequisites

Power off the virtual machine.

Procedure

- Select the virtual machine, right-click, and select Remove VM from the Library.

The virtual machine is removed from the library without any confirmation.
You can change virtual machine options, configure video and sound card settings, and move virtual machines to another host system or to a different location on the same host system.

This chapter includes the following topics:

- “Change the Name of a Virtual Machine,” on page 69
- “Change the Guest Operating System for a Virtual Machine,” on page 70
- “Change the Working Directory for a Virtual Machine,” on page 70
- “Change the Virtual Machine Directory for a Virtual Machine,” on page 70
- “Change the Memory Allocation for a Virtual Machine,” on page 71
- “Configuring Video and Sound,” on page 71
- “Moving Virtual Machines,” on page 75
- “Delete a Virtual Machine,” on page 77
- “View the Message Log for a Virtual Machine,” on page 78
- “Using the VIX API,” on page 78

Change the Name of a Virtual Machine

When you run a virtual machine, its name appears in the title bar. Player uses the original name of the virtual machine to name the directory where the virtual machine files are stored.

Changing the name of a virtual machine does not change the name of the virtual machine directory or rename the virtual machine files on the host system.

Procedure

1. Select the virtual machine and select Player > Manage > Virtual Machine Settings.
2. On the Options tab, select General.
3. Type the new name.
4. Click OK to save your changes.

What to do next

When you restart the virtual machine the new name appears in the library.
Change the Guest Operating System for a Virtual Machine

If you upgrade the guest operating system that is installed in a virtual machine, or if you specify the wrong operating system version when you create the virtual machine, you must change the guest operating system type that is configured for the virtual machine.

When you change the operating system type, the virtual machine configuration (.vmx) file changes. The guest operating system itself does not change. To upgrade the guest operating system, obtain the appropriate software from the operating system vendor.

Prerequisites

Power off the virtual machine.

Procedure

1. Select the virtual machine and select Player > Manage > Virtual Machine Settings.
2. On the Options tab, select General.
3. Select the new operating system and version.
4. Click OK to save your changes.

Change the Working Directory for a Virtual Machine

By default, the working directory and the virtual machine directory are the same. You might want to change the working directory to improve performance. For example, to create a paging file on a fast disk that has a lot of disk space but leave the virtual disk and configuration file on a different disk, you can change the working directory so that it is located on the fast disk.

The working directory is where Player stores suspended state (.vmss), snapshot (.vmsn), virtual machine paging (.vmem), and redo log files for a virtual machine.

Changing the working directory does not change the directory where the virtual machine configuration (.vmx) file or the log files are stored.

Prerequisites

Power off the virtual machine.

Procedure

1. Select the virtual machine and select Player > Manage > Virtual Machine Settings.
2. On the Options tab, select General.
3. Type or browse to the location of the new working directory.
4. Click OK to save your changes.

Change the Virtual Machine Directory for a Virtual Machine

The virtual machine directory is where Player stores virtual machine files, including the virtual machine configuration (.vmx) file. By default, the virtual machine directory and the working directory are the same.

Prerequisites

Power off the virtual machine.

Procedure

1. In the host file system, rename the directory where the .vmx file is stored.
2 Select File > Open a Virtual Machine.

3 Browse to the new location of the .vmx file and click Open.

**Change the Memory Allocation for a Virtual Machine**

You can adjust the amount of memory that is allocated to a virtual machine.

On 64-bit hosts, the maximum amount of memory for each virtual machine is 32GB. On 32-bit hosts, the maximum amount of memory for each virtual machine is 8GB. The total amount of memory that you can assign to all virtual machines running on a single host system is limited only by the amount of RAM on the host system.

**Prerequisites**

Power off the virtual machine.

**Procedure**

1 Select the virtual machine and select Player > Manage > Virtual Machine Settings.

2 On the Hardware tab, select Memory.

   The Memory panel includes information to help you select the appropriate amount of memory for the virtual machine. The high end of the range is determined by the amount of memory that is allocated to all running virtual machines.

3 Align the slider with the corresponding icon to change the amount of memory.

   The color-coded icons indicate the maximum recommended memory, the recommended memory, and the guest operating system minimum memory amounts.

4 Click OK to save your changes.

5 Power on the virtual machine to implement the changes.

**Configuring Video and Sound**

For best color and graphics display, coordinate host and guest operating system color settings. Player supports games and applications that use DirectX 9 accelerated graphics, but you must perform some 3D preparation tasks on the host and guest operating systems.

Player usually installs the necessary drivers for sound support, but you must manually install a driver on some of the oldest and newest guest operating systems.

- **Setting Screen Color Depth** on page 72
  The number of screen colors available in the guest operating system depends on the screen color setting of the host operating system.

- **Using Accelerated 3D Graphics** on page 72
  You must perform certain preparation tasks on the host system and on virtual machines to use accelerated 3D graphics.

- **Configuring Sound** on page 74
Setting Screen Color Depth

The number of screen colors available in the guest operating system depends on the screen color setting of the host operating system.

Virtual machines support the following screen colors.

- 16-color (VGA) mode
- 8-bit pseudocolor
- 16 bits per pixel (16 significant bits per pixel)
- 32 bits per pixel (24 significant bits per pixel)

If the host operating system is in 15-bit color mode, the guest operating system color setting controls offer 15-bit mode in place of 16-bit mode. If the host operating system is in 24-bit color mode, the guest operating system color setting controls offer 24-bit mode in place of 32-bit mode.

If you run a guest operating system set for a greater number of colors than the host operating system, the colors in the guest operating system might not be correct or the guest operating system might not be able to use a graphical interface. If these problems occur, you can either increase the number of colors in the host operating system or decrease the number of colors in the guest operating system.

To change color settings on the host operating system, power off all virtual machines and close Player and then follow standard procedures for changing color settings.

How you change color settings in a guest operating system depends on the type of guest operating system. In a Windows guest, the Display Properties control panel offers only those settings that are supported. In a Linux or FreeBSD guest, you must change the color depth before you start the X server, or you must restart the X server after making the changes.

For best performance, use the same number of colors in the host and guest operating systems.

Using Accelerated 3D Graphics

You must perform certain preparation tasks on the host system and on virtual machines to use accelerated 3D graphics.

Support for applications that use DirectX 9 accelerated graphics applies only to Windows XP, Windows Vista, and Windows 7 guests on hosts running Windows XP, Windows Vista, Windows 7, or Linux. OpenGL applications run in software emulation mode.

Prepare the Host System to Use DirectX 9 Accelerated Graphics

You must perform certain preparation tasks on the host system to use DirectX 9 accelerated graphics in a virtual machine.

Prerequisites

- Verify that the host operating system is Windows XP, Windows Vista, Windows 7, or Linux.
- On a Windows host, verify that the host has a video card that supports DirectX 9 and the latest DirectX Runtime.
- On a Linux host, verify that the host has a video card that can run accelerated OpenGL 2.0.

Procedure

1. Upgrade the video drivers on the host system to the latest versions.
   ATI Graphics drivers are available from the AMD Web site. NVIDIA drivers are available from the NVIDIA Web site.
2 If you have a Windows host system, move the Hardware Acceleration slider to the Full position.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows XP</td>
<td>Right-click the desktop and select Properties &gt; Settings &gt; Advanced &gt; Troubleshoot.</td>
</tr>
<tr>
<td>Windows Vista</td>
<td>Right-click the desktop and select Personalize &gt; Display Settings &gt; Advanced Settings &gt; Troubleshoot &gt; Change settings.</td>
</tr>
<tr>
<td>Windows 7</td>
<td>Right-click the desktop and select Personalize &gt; Screen resolution &gt; Advanced Settings &gt; Troubleshoot &gt; Change settings.</td>
</tr>
</tbody>
</table>

3 If you have a Linux host system, run commands to test the host for compatibility.

a Verify that direct rendering is enabled.
   glxinfo | grep direct

b Verify that 3-D applications work.
   glxgears

Prepare a Virtual Machine to Use Accelerated 3D Graphics

You must perform certain preparation tasks to use accelerated 3D graphics on a virtual machine.
The accelerated 3D graphics feature is enabled by default on Player 3.x and later virtual machines.

Prerequisites

- Prepare the host system to use accelerated 3D graphics. See “Prepare the Host System to Use DirectX 9 Accelerated Graphics,” on page 72.
- Verify that the guest operating system is Windows XP, Windows Vista, or Windows 7.
- Verify that the latest version of VMware Tools is installed in the guest operating system.
- Power off the virtual machine. The virtual machine must not be suspended.

Procedure

1 Select the virtual machine and select Player > Manage > Virtual Machine Settings.
2 On the Hardware tab, select Display.
3 Select Accelerate 3D graphics.
4 Configure the virtual machine to use only one monitor.
5 Click OK to save your changes.
6 Power on the virtual machine and install DirectX 9.0c End User Runtime.
   This download is available from the Microsoft Download Center.
7 Install and run your 3D applications.
Configuring Sound


Sound support includes pulse code modulation (PCM) output and input. For example, you can play .wav files, MP3 audio, and Real Media audio. MIDI output from Windows guests is supported through the Windows software synthesizer. MIDI input is not supported, and no MIDI support is available for Linux guests.

Windows 2000, Windows XP, and most recent Linux distributions detect the sound device and install appropriate drivers for it.


Configure Sound Card Settings

The VMware virtual sound device is compatible with a Creative Technology Sound Blaster Audio API. The sound device supports sound in Windows and Linux guest operating systems.

Procedure

1. Select the virtual machine and select Player > Manage > Virtual Machine Settings.
2. On the Hardware tab, select Sound.
3. Configure one or more sound card settings.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Connected</td>
<td>Connects or disconnects the sound device while the virtual machine is running. You can also use the Devices menu and select the drive to connect or disconnect.</td>
</tr>
<tr>
<td>Connect at power on</td>
<td>Automatically connects the sound device to the virtual machine when you power on the virtual machine.</td>
</tr>
<tr>
<td>Specify host sound card</td>
<td>(Windows hosts only) Select which sound card to use if you have more than one physical sound card on the host system.</td>
</tr>
<tr>
<td>Use physical sound card</td>
<td>(Linux hosts only) Select which sound card to use if you have more than one physical sound card on the system.</td>
</tr>
</tbody>
</table>

4. Click OK to save your changes.

Install Sound Drivers in Windows 9x and NT Guests

Windows 95, Windows 98, Windows 98SE, and Windows NT 4.0 do not have drivers for the Sound Blaster AudioPCI adapter.

To use sound in these guest operating systems, download the driver from the Creative Labs Web site and install it in the guest operating system.

Procedure

1. Go to the Creative Labs Web site for your region of the world.
2. Search for the adapter whose name includes PCI 128.
3. Follow the instructions on the Web site to download and install the driver.
Moving Virtual Machines

You can move a virtual machine that was created in Player to a different host system or to a different location on the same host system and connect to a virtual machine by using a VNC client.

- **Move a Virtual Machine to a New Location or New Host** on page 75
  You can move a virtual machine that is created in Player to a different host system or to a different location on the same host system. You can move a virtual machine to a host system that has a different operating system.

- **Configure a Virtual Machine for Compatibility** on page 76
  When you create a virtual machine that you intend to distribute to other users, you should configure the virtual machine for maximum compatibility with all expected host systems. Users might be limited in their ability to make changes in a virtual machine so that it is compatible with their host systems.

- **Using the Virtual Machine UUID** on page 77
  Each virtual machine has a universal unique identifier (UUID). The UUID is generated when you initially power on the virtual machine.

### Move a Virtual Machine to a New Location or New Host

You can move a virtual machine that is created in Player to a different host system or to a different location on the same host system. You can move a virtual machine to a host system that has a different operating system.

Moving a virtual machine typically involves moving the files that make up the virtual machine. The pathnames for all files associated with a Player virtual machine are relative to the virtual machine directory.

When you move a virtual machine, Player generates a new MAC address for the virtual network adapter. Player also generates a new MAC address when you rename a directory in the path to the virtual machine configuration (.vmx) file.

**Prerequisites**

- Familiarize yourself with how Player generates UUIDs for moved virtual machines. See “Using the Virtual Machine UUID,” on page 77.

- If you are moving the virtual machine to a different host system, familiarize yourself with the limitations of moving a virtual machine to a new host. See “Limitations of Moving a Virtual Machine to a Different Host,” on page 76.

- If you configured the working directory to reside in a different location on the host system, move files from the working directory into the virtual machine directory and change the working directory to this location.

- Verify that virtual machine devices and any associated files point to locations that you can access from the new location.

- Verify that all virtual machine files are stored in the virtual machine directory. Some files might reside outside of the virtual machine directory.

**Procedure**

1. Shut down the guest operating system and power off the virtual machine.
2. Copy the virtual machine files to the new location.
3. Verify that you copied all of the virtual machine files to the new location.
4  Open the virtual machine in Player.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>If you moved the virtual machine to a different location on the same host system</td>
<td>Remove the virtual machine from the library, select File &gt; Open a Virtual Machine, and browse to the .vmx file in its new location.</td>
</tr>
<tr>
<td>If you moved the virtual machine to a different host system</td>
<td>Start Player on the new host system, select File &gt; Open a Virtual Machine, and browse to the .vmx file.</td>
</tr>
</tbody>
</table>

5  When you are certain that the virtual machine in the new location works correctly, delete the virtual machine files from the original location.

Limitations of Moving a Virtual Machine to a Different Host

You should be aware of certain limitations before you move a virtual machine to a different host system.

- The guest operating system might not work correctly if you move a virtual machine to a host system that has significantly different hardware, for example, if you move a virtual machine from a 64-bit host to a 32-bit host or from a multiprocessor host to a uniprocessor host.

- Player 3.x and later virtual machines support up to eight-way virtual symmetric multiprocessing (SMP) on multiprocessor host systems. You can assign up to eight virtual processors to virtual machines running on host systems that have at least two logical processors. If you attempt to assign two processors to a virtual machine that is running on a uniprocessor host system, a warning message appears. You can disregard this message and assign two processors to the virtual machine, but you must move it to a host that has at least two logical processors before you can power it on.

- You can move a virtual machine from a 32-bit host to a 64-bit host. You cannot move a virtual machine from a 64-bit host to a 32-bit host unless the 32-bit host has a supported 64-bit processor.

Configure a Virtual Machine for Compatibility

When you create a virtual machine that you intend to distribute to other users, you should configure the virtual machine for maximum compatibility with all expected host systems. Users might be limited in their ability to make changes in a virtual machine so that it is compatible with their host systems.

Procedure

- Install VMware Tools in the virtual machine.
  VMware Tools significantly improves the user’s experience working with the virtual machine.

- Determine which virtual devices are actually required, and do not include any that are not needed or useful for the software you are distributing with the virtual machine.
  Generic SCSI devices are typically not appropriate.

- To connect a physical device to a virtual device, use the Auto detect options when you configure the virtual machine.
  The Auto detect options allow the virtual machine to adapt to the user’s system, and they work whether the host operating system is Windows or Linux. Users who have no physical device receive a warning message.

- To connect a CD-ROM or floppy to an image file that you ship with the virtual machine, make sure the image file is in the same directory as the virtual machine.
  A relative path, rather than an absolute path, is used.

- For both a physical CD-ROM and an image, provide two virtual CD-ROM devices in the virtual machine.
Choose a reasonable amount of memory to allocate to the virtual machine.

For example, if the host system does not have enough physical memory to support the memory allocation, the user cannot power on the virtual machine.

Choose a reasonable screen resolution for the guest.

A user is likely to find it easier to increase the resolution manually than to deal with a display that exceeds the user’s physical screen size.

Using the Virtual Machine UUID

Each virtual machine has a universal unique identifier (UUID). The UUID is generated when you initially power on the virtual machine.

You can use the UUID of a virtual machine for system management in the same way that you use the UUID of a physical computer. The UUID is stored in the SMBIOS system information descriptor, and you can access it by using standard SMBIOS scanning software, including SiSoftware Sandra or IBM smbios2.

If you do not move or copy the virtual machine to another location, the UUID remains constant. When you power on a virtual machine that was moved or copied to a new location, you are prompted to specify whether you moved or copied the virtual machine. If you indicate that you copied the virtual machine, the virtual machine receives a new UUID.

Suspending and resuming a virtual machine does not trigger the process that generates a UUID. The UUID in use at the time the virtual machine was suspended remains in use when the virtual machine is resumed, even if it was copied or moved. You are not prompted to specify whether you moved or copied the virtual machine until the next time you reboot the virtual machine.

Configure a Virtual Machine to Keep the Same UUID

You can configure a virtual machine to always keep the same UUID, even when it is moved or copied.

When a virtual machine is set to always keep the same UUID, you are not prompted when a virtual machine is moved or copied.

Prerequisites

Power off the virtual machine.

Procedure

1. Open the virtual machine configuration (.vmx) file in a text editor.
2. Add the `uuid.action` property and set it to `keep`.

   For example: `uuid.action = "keep"

Delete a Virtual Machine

You can delete a virtual machine and all of its files from the host file system.

IMPORTANT Deleting a virtual machine is irreversible.

Prerequisites

Power off the virtual machine.

Procedure

1. Right-click the virtual machine in the library and select Delete VM from Disk.
2. Click Yes to delete the virtual machine.
The virtual machine and all of its files are removed from the host file system.

**View the Message Log for a Virtual Machine**

You can view the message log to review information about a particular virtual machine. Messages include warning information about the virtual machine.

**Procedure**

1. Power on the virtual machine.
2. Select **Player > Manage > Message Log**.
3. Select a message in the message log to see a detailed description of the message.

**Using the VIX API**

Application developers can use the VMware VIX API to write programs to automate virtual machine operations.

The API is high level, easy to use, and practical for script writers and application programmers. With API functions, you can register, power virtual machines on and off, and run programs in guest operating systems. Additional language bindings are available for Perl, COM, and shell scripts such as `vmrun`.

See the VMware VIX API Release Notes.
You can use Player to add devices to virtual machines, including DVD and CD-ROM drives, floppy drives, USB controllers, virtual and physical hard disks, parallel and serial ports, generic SCSI devices, and processors. You can also modify settings for existing devices.

This chapter includes the following topics:

- "Configuring DVD, CD-ROM, and Floppy Drives," on page 79
- "Configuring a USB Controller," on page 81
- "Configuring and Maintaining Virtual Hard Disks," on page 83
- "Configuring Virtual Ports," on page 89
- "Configuring Generic SCSI Devices," on page 93
- "Configuring Eight-Way Virtual Symmetric Multiprocessing," on page 97
- "Configuring Keyboard Features," on page 98
- "Modify Hardware Settings for a Virtual Machine," on page 105

## Configuring DVD, CD-ROM, and Floppy Drives

You can add up to 4 IDE devices, up to 60 SCSI devices, and up to 120 SATA devices (4 controllers with 30 devices per controller) to a virtual machine. Any of these devices can be a virtual or physical hard disk or DVD or CD-ROM drive. By default, a floppy drive is not connected when a virtual machine powers on.

A virtual machine can read data from a DVD disc. Player does not support playing DVD movies in a virtual machine. You might be able to play a movie if you use a DVD player application that does not require video overlay support in the video card.

### Add a DVD or CD-ROM Drive to a Virtual Machine

You can add one or more DVD or CD-ROM drives to a virtual machine. You can connect the virtual DVD or CD-ROM drive to a physical drive or an ISO image file.

You can configure the virtual DVD or CD-ROM drive as an IDE or a SCSI device, regardless of the type of physical drive that you connect it to. For example, if the host has an IDE CD-ROM drive, you can set up the virtual machine drive as either SCSI or IDE and connect it to the host drive.

Do not configure legacy emulation mode unless you experience problems with normal mode. See "Configure Legacy Emulation Mode for a DVD or CD-ROM Drive," on page 81 for more information.

### Procedure

1. Select the virtual machine and select Player > Manage > Virtual Machine Settings.
On the Hardware tab, click Add.

In the Add Hardware wizard, select DVD/CD Drive.

Select a physical drive or ISO image file to connect to the drive.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use physical drive</td>
<td>The virtual machine uses a physical drive.</td>
</tr>
<tr>
<td>Use ISO image</td>
<td>The drive connects to an ISO image file.</td>
</tr>
</tbody>
</table>

Configure the physical drive or ISO image file.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Physical drive</td>
<td>Select a specific drive, or select Auto detect to allow Player to auto-detect the drive to use.</td>
</tr>
<tr>
<td>ISO image file</td>
<td>Type the path or browse to the location of the ISO image file.</td>
</tr>
</tbody>
</table>

To connect the drive or ISO image file to the virtual machine when the virtual machine powers on, select Connect at power on.

Click Finish to add the drive to the virtual machine.

The drive initially appears as an IDE drive to the guest operating system.

(Optional) To change which SCSI or IDE device identifier to use for the drive, select the drive and click Advanced.

Click OK to save your changes.

Add a Floppy Drive to a Virtual Machine

You can configure a virtual floppy drive to connect to a physical floppy drive or an existing or blank floppy image file. You can add up to two floppy drives to a virtual machine.

Prerequisites

Power off the virtual machine.

Procedure

1. Select the virtual machine and select Player > Manage > Virtual Machine Settings.
2. On the Hardware tab, click Add.
3. In the Add Hardware wizard, select Floppy Drive.
4. Select the floppy media type.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use a physical floppy drive</td>
<td>The virtual machine uses a physical floppy drive.</td>
</tr>
<tr>
<td>Use a floppy image</td>
<td>The drive connects to an floppy image (.*flp) file.</td>
</tr>
<tr>
<td>Create a blank floppy image</td>
<td>The drive connects to a blank floppy image (.*flp) file that you create.</td>
</tr>
</tbody>
</table>

5. If you selected the physical floppy drive media type, select a specific floppy drive or select Auto detect to allow Player to auto-detect the drive to use.

6. If you selected the floppy image or blank floppy image media type, type the name or browse to the location of a floppy image (.*flp) file.

7. To connect the drive or floppy image file to the virtual machine when the virtual machine powers on, select Connect at power on.
Configure Legacy Emulation Mode for a DVD or CD-ROM Drive

Use legacy emulation mode to work around direct communication problems between a guest operating system and a DVD or CD-ROM drive.

In legacy emulation mode, you can read only from data discs in the DVD or CD-ROM drive. Legacy emulation mode does not provide the other capabilities of normal mode. In normal mode, the guest operating system communicates directly with the CD-ROM or DVD drive. This direct communication enables you to read multisession CDs, perform digital audio extraction, view videos, and use CD and DVD writers to burn discs.

If you run more than one virtual machine at a time, and if their CD-ROM drives are in legacy emulation mode, you must start the virtual machines with their CD-ROM drives disconnected. By disconnecting the CD-ROM drives in the virtual machines, you prevent multiple virtual machines from being connected to the CD-ROM drive at the same time.

Procedure

1. Select the virtual machine and select Player > Manage > Virtual Machine Settings.
2. On the Hardware tab, select the drive and click Advanced.
3. Select Legacy emulation and click OK.
   - On Windows hosts, this option is deselected by default. On Linux hosts that have IDE drives, the default setting depends on whether the ide-scsi module is loaded in the kernel. The ide-scsi module must be loaded, or you must use a physical SCSI drive, to connect directly to the DVD or CD-ROM drive.
4. Click OK to save your changes.

Configuring a USB Controller

A virtual machine must have a USB controller to use USB devices and smart card readers. To use a smart card reader, a virtual machine must have a USB controller regardless of whether the smart card reader is actually a USB device.

Player provides a USB controller to support the following types of USB devices.

- USB 1.1 UHCI (Universal Host Controller Interface) is supported for all virtual machine hardware versions.
- USB 2.0 EHCI (Enhanced Host Controller Interface) controllers are supported if the virtual machine hardware is compatible with Workstation 6 and later virtual machines.
- USB 3.0 xHCI (Extensible Host Controller Interface) support is available for Linux guests running kernel version 2.6.35 or later and for Windows 8 guests. The virtual machine hardware must be compatible with Workstation 8 or later virtual machines.

For USB 2.0 or 3.0 support, you must select USB 2.0 or 3.0 compatibility by configuring virtual machine settings for the USB controller. USB 2.0 and 3.0 devices are high-speed devices that include the latest models of USB flash drives, USB hard drives, iPods, and iPhone.

If you select USB 2.0 compatibility, when a USB 2.0 device connects to a USB port on the host system, the device connects to the EHCI controller and operates in USB 2.0 mode. A USB 1.1 device connects to the UHCI controller and operates in USB 1.1 mode. If you enable USB 3.0, the xHCI controller can support all USB devices, including USB 1.1, 2.0, and 3.0 devices.
Although the host operating system must support USB, you do not need to install device-specific drivers for USB devices in the host operating system to use those devices only in the virtual machine. Windows NT and Linux kernels earlier than 2.2.17 do not support USB.

VMware has tested a variety of USB devices. If the guest operating system has the appropriate drivers, you can use many different USB devices, including PDAs, Smart phones, printers, storage devices, scanners, MP3 players, digital cameras, memory card readers, and isochronous transfer devices, such as webcams, speakers, and microphones.

You can connect USB human interface devices (HIDs), such as the keyboard and mouse, to a virtual machine by enabling the Show all USB input devices option. If you do not select this option, these devices do not appear in the Removable Devices menu and are not available to connect to the virtual machine, even though they are plugged in to USB ports on the host system.

See “Connect USB HIDs to a Virtual Machine,” on page 57 for information on connecting HIDs.

Add a USB Controller to a Virtual Machine

A USB controller is required to use a smart card in a virtual machine, regardless of whether the smart card reader is a USB device. You can add one USB controller to a virtual machine.

When you create a virtual machine in Player, a USB controller is added by default. If you remove the USB controller, you can add it back.

Prerequisites

Power off the virtual machine.

Procedure

1. Select the virtual machine and select Player > Manage > Virtual Machine Settings.
2. On the Hardware tab, click Add.
3. In the New Hardware wizard, select USB Controller.
4. Configure the USB connection settings.

You can select multiple settings.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>USB Compatibility</td>
<td>Selecting USB 2.0 or 3.0 enables support for isochronous USB devices, including Web cams, speakers, and microphones.</td>
</tr>
<tr>
<td>Automatically connect new USB</td>
<td>Connect new USB devices to the virtual machine. If this setting is not selected, new USB devices are connected only to the host system.</td>
</tr>
<tr>
<td>devices</td>
<td></td>
</tr>
<tr>
<td>Show all USB input devices</td>
<td>Human interface devices (HIDs), such as USB 1.1 and 2.0 mouse and keyboard devices, appear in the Removable Devices menu. Icons for HIDs appear in the status bar. An HID that is connected to the guest operating system is not available to the host system. The virtual machine must be powered off when you change this setting.</td>
</tr>
<tr>
<td>Share Bluetooth devices with</td>
<td>Enable support for Bluetooth devices.</td>
</tr>
<tr>
<td>the virtual machine</td>
<td></td>
</tr>
</tbody>
</table>

5. Click Finish to add the USB controller.
Enable Support for Isochronous USB Devices

Modems and certain streaming data devices, such as speakers and webcams, do not work properly in a virtual machine unless you enable support for isochronous USB devices.

Prerequisites

- Verify that the guest operating system supports USB 2.0 devices or 3.0 devices.
- On a Windows XP guest operating system, verify that the latest service pack is installed. If you use Windows XP with no service packs, the driver for the EHCI controller cannot be loaded.

Procedure

1. Select the virtual machine and select Player > Manage > Virtual Machine Settings.
2. On the Hardware tab, select USB Controller.
3. From the USB Compatibility list, select USB 2.0 or USB 3.0.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>USB 2.0</td>
<td>Available if the virtual machine hardware is compatible with Workstation 6 and later virtual machines.</td>
</tr>
<tr>
<td>USB 3.0</td>
<td>Available for Linux guests running kernel version 2.6.35 or later and for Windows 8 guests. The virtual machine hardware must be compatible with Workstation 8 and later virtual machines.</td>
</tr>
</tbody>
</table>

4. Click OK to save your changes.

Configuring and Maintaining Virtual Hard Disks

You can use Player to configure virtual hard disk storage for virtual machines.

A virtual disk is a file or set of files that appears as a physical disk drive to a guest operating system. The files can be on the host system or on a remote computer. When you configure a virtual machine to use a virtual disk, you can install a new operating system onto the virtual disk without repartitioning a physical disk or rebooting the host.

The New Virtual Machine wizard creates a virtual machine that has one disk drive. You can modify virtual machine settings to add more disk drives to a virtual machine, remove disk drives from a virtual machine, and change certain settings for the existing disk drives.

- Configuring a Virtual Hard Disk on page 84
  You can configure virtual hard disks as IDE or SATA disks for any guest operating system. You can also set up a virtual hard disk as a SCSI disk for any guest operating system that has a driver for the LSI Logic or BusLogic SCSI adapter. You determine which SCSI adapter to use when you create a virtual machine.

- Compact a Virtual Hard Disk on page 86
  Compacting a virtual hard disk reclaims unused space in the virtual disk. If a disk has empty space, this process reduces the amount of space the virtual disk occupies on the host drive.

- Expand a Virtual Hard Disk on page 86
  You can add storage space to a virtual machine by expanding its virtual hard disk.

- Defragment a Virtual Hard Disk on page 87
  Like physical disk drives, virtual hard disks can become fragmented. Defragmenting disks rearranges files, programs, and unused space on the virtual hard disk so that programs run faster and files open more quickly. Defragmenting does not reclaim unused space on a virtual hard disk.
Configuring a Virtual Hard Disk

You can configure virtual hard disks as IDE or SATA disks for any guest operating system. You can also set up a virtual hard disk as a SCSI disk for any guest operating system that has a driver for the LSI Logic or BusLogic SCSI adapter. You determine which SCSI adapter to use when you create a virtual machine.

The files that make up an IDE, SATA, or SCSI virtual hard disk can be stored on an IDE hard disk, SATA hard disk, or on a SCSI hard disk. They can also be stored on other types of fast-access storage media.

To use SCSI hard disks in a 32-bit Windows XP virtual machine, you must download a special SCSI driver from the VMware Web site. Follow the instructions on the Web site to use the driver with a fresh installation of Windows XP.

Growing and Allocating Virtual Disk Storage Space

IDE and SCSI virtual hard disks can be up to 8TB. Depending on the size of the virtual hard disk and the host operating system, Player creates one or more files to hold each virtual disk.

Virtual hard disk files include information such as the operating system, program files, and data files. Virtual disk files have a .vmdk extension.

By default, the actual files that the virtual hard disk uses start small and grow to their maximum size as needed. The main advantage of this approach is the smaller file size. Smaller files require less storage space and are easier to move to a new location, but it takes longer to write data to a disk configured in this way.

You can also configure virtual hard disks so that all of the disk space is allocated when the virtual disk is created. This approach provides enhanced performance and is useful if you are running performance-sensitive applications in the virtual machine.

Regardless of whether you allocate all disk space in advance, you can configure the virtual hard disk to use a set of files limited to 2GB per file. Use this option if you plan to move the virtual hard disk to a file system that does not support files larger than 2GB.

Add a New Virtual Hard Disk to a Virtual Machine

To increase storage space, you can add a new virtual hard disk to a virtual machine. You can add up to four IDE devices and up to 60 SCSI devices. Any of these devices can be a virtual or physical hard disk or DVD or CD-ROM drive.

Virtual hard disks are stored as files on the host computer or on a network file server. A virtual IDE drive or SCSI drive can be stored on a physical IDE drive or on a physical SCSI drive.

If you have a Windows NT 4.0 virtual machine that has a SCSI virtual hard disk, you cannot add both an additional SCSI disk and an IDE disk to the configuration.

As an alternative to adding a new virtual hard disk, you can expand the existing virtual hard disk. See “Expand a Virtual Hard Disk,” on page 86.
Procedure

1. Select the virtual machine and select **Player > Manage > Virtual Machine Settings**.
2. On the **Hardware** tab, click **Add**.
3. In the New Hardware wizard, select **Hard Disk**.
4. Select **Create a new virtual disk**.
5. Select the disk type.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>IDE</td>
<td>Create an IDE device. You can add up to four IDE devices to a virtual machine.</td>
</tr>
<tr>
<td>SCSI</td>
<td>Create a SCSI device. You can add up to 60 SCSI devices to a virtual machine.</td>
</tr>
<tr>
<td>SATA</td>
<td>Create a SATA device. You can add up to 120 SATA devices: four controllers and 30 devices per controller.</td>
</tr>
</tbody>
</table>
6. (Optional) To exclude the disk from snapshots, select **Independent** for the mode and select a persistence option.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Persistent</td>
<td>Disks in persistent mode behave like conventional disks on a physical computer. All data written to a disk in persistent mode is written permanently to the disk.</td>
</tr>
<tr>
<td>Nonpersistent</td>
<td>Changes to disks in nonpersistent mode are discarded when you power off or reset the virtual machine. With nonpersistent mode, you always restart the virtual machine with a virtual disk in the same state. Changes to the disk are written to and read from a redo log file that is deleted when you power off or reset the virtual machine.</td>
</tr>
</tbody>
</table>
7. Set the capacity for the new virtual hard disk.
   You can set a size between 0.001GB and 8TB for a virtual disk.
8. Specify how to allocate the disk space.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Allocate all disk space now</td>
<td>Allocating all of the disk space when you create the virtual hard disk can enhance performance, but it requires all of the physical disk space to be available now. If you do not select this setting, the virtual disk starts small and grows as you add data to it.</td>
</tr>
<tr>
<td>Store virtual disk as a single file</td>
<td>Select this option if the virtual disk is stored on a file system that does not have a file size limitation.</td>
</tr>
<tr>
<td>Split virtual disk into multiple files</td>
<td>Select this option if the virtual disk is stored on a file system that has a file size limitation. When you split a virtual disk less than 950GB, a series of 2GB virtual disk files are created. When you split a virtual disk greater than 950GB, two virtual disk files are created. The maximum size of the first virtual disk file is 1.9TB and the second virtual disk file stores the rest of the data.</td>
</tr>
</tbody>
</table>
9. Accept the default filename and location, or browse to and select a different location.
10. Click **Finish** to add the new virtual hard disk.
    The wizard creates the new virtual hard disk. The disk appears to the guest operating system as a new, blank hard disk.
11. Click **OK** to save your changes.
12 Use the guest operating system tools to partition and format the new drive.

**Add an Existing Virtual Hard Disk to a Virtual Machine**

You can reconnect an existing virtual hard disk that was removed from a virtual machine.

**Procedure**

1. Select the virtual machine and select Player > Manage > Virtual Machine Settings.
2. On the Hardware tab, click Add.
3. In the Add Hardware wizard, select Hard Disk.
4. Select Use an existing virtual disk.
5. Specify the path name and filename for the existing disk file.
6. Click Finish to add the existing virtual hard disk.
7. Click OK to save your changes.

**Compact a Virtual Hard Disk**

Compacting a virtual hard disk reclaims unused space in the virtual disk. If a disk has empty space, this process reduces the amount of space the virtual disk occupies on the host drive.

**Prerequisites**

- Power off the virtual machine.
- Verify that the virtual disk is not mapped or mounted. You cannot compact a virtual disk while it is mapped or mounted.
- Verify that the disk space is not preallocated for the virtual hard disk. If the disk space was preallocated, you cannot compact the disk.
- If the virtual hard disk is an independent disk, verify that it is in persistent mode.

**Procedure**

1. Select the virtual machine and select Player > Manage > Virtual Machine Settings.
2. On the Hardware tab, select the virtual hard disk to compact.
3. Select Utilities > Compact.
4. Click OK after the disk compacting process is complete.

**Expand a Virtual Hard Disk**

You can add storage space to a virtual machine by expanding its virtual hard disk.

When you expand a virtual hard disk, the added space is not immediately available to the virtual machine. To make the added space available, you must use a disk management tool to increase the size of the existing partition on the virtual hard disk to match the expanded size.

The disk management tool that you use depends on the virtual machine guest operating system. Many operating systems, including Windows Vista, Windows 7, and Windows 8 and some versions of Linux, provide built-in disk management tools that can resize partitions. Third-party disk management tools are also available, such as EASEUS Partition Master, Acronis Disk Director, and the open-source tool GParted.

When you expand the size of a virtual hard disk, the sizes of partitions and file systems are not affected.

As an alternative to expanding a virtual hard disk, you can add a new virtual hard disk to the virtual machine. See “Add a New Virtual Hard Disk to a Virtual Machine,” on page 84.
Prerequisites
- Power off the virtual machine.
- Verify that the virtual disk is not mapped or mounted. You cannot expand a virtual disk while it is mapped or mounted.
- Verify that the virtual machine has no snapshots.
- Verify that the virtual machine is not a linked clone or the parent of a linked clone.

Procedure
1. Select the virtual machine and select **Player > Manage > Virtual Machine Settings**.
2. On the **Hardware** tab, select the virtual hard disk to expand.
3. Select **Utilities > Expand**.
4. Set the new maximum size for the virtual disk.
   - You can set a size between 0.001GB and 2TB for a virtual disk.
5. Select **Expand**.
6. Click **OK** after the disk expansion process is complete.

What to do next
Use a disk management tool to increase the disk partition size to match the expanded virtual disk size.

Defragment a Virtual Hard Disk

Like physical disk drives, virtual hard disks can become fragmented. Defragmenting disks rearranges files, programs, and unused space on the virtual hard disk so that programs run faster and files open more quickly. Defragmenting does not reclaim unused space on a virtual hard disk.

Defragmenting disks can take considerable time.

Prerequisites
- Verify that there is adequate free working space on the host system. For example, if the virtual hard disk is contained in a single file, there must be free space equal to the size of the virtual disk file. Other virtual hard disk configurations require less free space.
- Verify that the virtual disk is not mapped or mounted. You cannot defragment a virtual disk while it is mapped or mounted.

Procedure
1. Run a disk defragmentation utility in the guest operating system.
2. If disk space is not preallocated for the virtual hard disk, use the Player defragmentation tool to defragment it.
   a. Power off the virtual machine.
   b. Select the virtual machine and select **Player > Manage > Virtual Machine Settings**.
   c. On the **Hardware** tab, select **Hard Disk**.
   d. Select **Utilities > Defragment**.
   e. When the defragmentation process is finished, click **OK**.
3. Run a disk defragmentation utility on the host system.
Remove a Virtual Hard Disk from a Virtual Machine

Removing a virtual hard disk disconnects it from a virtual machine. It does not delete files from the host file system.

After you remove a virtual hard disk from a virtual machine, you can map or mount the disk to the host system and copy data from the guest operating system to the host without powering on the virtual machine or starting Player. You can also add the disk to another virtual machine.

Procedure

1. Select the virtual machine and select Player > Manage > Virtual Machine Settings.
2. On the Hardware tab, select the virtual hard disk and click Remove.
3. Click OK to save your changes.

Using Lock Files to Prevent Consistency Problems on Virtual Hard Disks

A running virtual machine creates lock files to prevent consistency problems on virtual hard disks. Without locks, multiple virtual machines might read and write to the disk, causing data corruption.

Lock files have a .lck suffix and are created in subdirectories in the same directory as the virtual disk (.vmdk) files. A locking subdirectory and lock file are created for .vmdk files, .vmx files, and .vmem files.

A unified locking method is used on all host operating systems so that files shared between them are fully protected. For example, if one user on a Linux host tries to power on a virtual machine that is already powered on by another user with a Windows host, the lock files prevent the second user from powering on the virtual machine.

When a virtual machine powers off, it removes the locking subdirectories and the lock files. If the virtual machine cannot remove these locking controls, one or more stale lock files might remain. For example, if the host system fails before the virtual machine removes its locking controls, stale lock files remain.

When the virtual machine restarts, it scans any locking subdirectories for stale lock files and, when possible, removes them. A lock file is considered stale if the lock file was created on the same host system that is now running the virtual machine and the process that created the lock is no longer running. If either of these conditions is not true, a dialog box warns you that the virtual machine cannot be powered on. You can delete the locking directories and their lock files manually.

Locks also protect physical disk partitions. Because the host operating system is not aware of this locking convention, it does not recognize the lock. For this reason, you should install the physical disk for a virtual machine on the same physical disk as the host operating system.

Moving a Virtual Hard Disk to a New Location

A key advantage of virtual hard disks is their portability. Because the virtual hard disks are stored as files on the host system or a remote computer, you can move them easily to a new location on the same computer or to a different computer.

For example, you can use Player on a Windows host system to create virtual hard disks, move the disks to a Linux computer, and use the disks with Player on a Linux host system.
Configuring Virtual Ports

You can add virtual parallel (LPT) ports and virtual serial (COM) ports to a virtual machine. A Player virtual machine can use up to three parallel ports and up to four virtual serial ports.

- **Add a Virtual Parallel Port to a Virtual Machine** on page 89
  You can attach up to three bidirectional parallel (LPT) ports to a virtual machine. Virtual parallel ports can output to parallel ports or to files on the host system.

- **Configure a Virtual Parallel Port on a Linux 2.6.x Kernel Host** on page 90
  Linux 2.6.x kernels that support parallel ports use the `modprobe modulename` and `modprobe parport_pc` modules. Player requires that the parallel port PC-style hardware option (CONFIG_PARPORT_PC) is built and loaded as a kernel module.

- **Configure Permissions for a Parallel Port Device on a Linux Host** on page 91
  Some Linux distributions do not grant a virtual machine access to the `lp` and `parport` devices by default. If this is the case on your Linux host system, you must add the VMware user to the group that has permission to access those devices.

- **Troubleshoot ECR Errors for Parallel Ports** on page 91
  A parallel port on the host system does not have an Extended Control Register (ECR).

- **Add a Virtual Serial Port to a Virtual Machine** on page 92
  You can add up to four serial (COM) ports to a virtual machine. Virtual serial ports can output to physical serial ports, files, or named pipes.

- **Change the Input Speed of a Serial Connection** on page 93
  You can increase the speed of a serial connection over a pipe to a virtual machine.

**Add a Virtual Parallel Port to a Virtual Machine**

You can attach up to three bidirectional parallel (LPT) ports to a virtual machine. Virtual parallel ports can output to parallel ports or to files on the host system.

Parallel ports are used for a variety of devices, including printers, scanners, dongles, and disk drives. Although these devices can connect to the host system, only printers can reliably connect to virtual machines by using parallel ports.

Player provides only partial emulation of PS/2 hardware. Interrupts that a device connected to a physical port requests are not passed to the virtual machine. The guest operating system cannot use direct memory access (DMA) to move data to or from the port. For this reason, not all devices that attach to a parallel port work correctly. Do not use virtual parallel ports to connect parallel port storage devices or other types of parallel port devices to a virtual machine.

**Prerequisites**

- If you are using a Linux host system that has a 2.6.x kernel, verify that the parallel port PC-style hardware option (CONFIG_PARPORT_PC) is built and loaded as a kernel module. See “Configure a Virtual Parallel Port on a Linux 2.6.x Kernel Host,” on page 90.

- If you are using a Linux host system that does not grant virtual machines access to the `lp` and `parport` devices by default, add the VMware user to the group that has permission to access those devices. See “Configure Permissions for a Parallel Port Device on a Linux Host,” on page 91.

- Power off the virtual machine.

**Procedure**

1. Select the virtual machine and select **Player > Manage > Virtual Machine Settings.**
2 On the **Hardware** tab, click **Add**.

3 In the New Hardware wizard, select **Parallel Port**.

4 Select where the virtual parallel port sends output.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use a physical parallel port</td>
<td>Select a parallel port on the host system.</td>
</tr>
<tr>
<td>Use output file</td>
<td>Send output from the virtual parallel port to a file on the host system. Either locate an existing output file or browse to a directory and type a filename to create a new output file.</td>
</tr>
</tbody>
</table>

5 To connect the virtual parallel port to the virtual machine when the virtual machine powers on, select **Connect at power on**.

6 Click **Finish** to add the virtual parallel port to the virtual machine.

When a parallel port is configured for a virtual machine, most guest operating systems detect the port at installation time and install the required drivers. Some operating systems, including Linux, Windows NT, and Windows 2000, detect the ports at boot time.

**What to do next**

If the guest operating system is Windows 95 or Windows 98, run the Add New Hardware wizard to detect and add the parallel port.

### Configure a Virtual Parallel Port on a Linux 2.6.x Kernel Host

Linux 2.6.x kernels that support parallel ports use the `modprobe modulename` and `modprobe parport_pc` modules. Player requires that the parallel port PC-style hardware option (CONFIG_PARPORT_PC) is built and loaded as a kernel module.

Linux kernels in the 2.6.x series use a special arbitrator for access to the parallel port hardware. If the host system is using the parallel port, the virtual machine cannot use it. If a virtual machine is using the parallel port, the host and any users accessing the host are denied access to the device. You must use the **Removable Devices** menu to disconnect the parallel port from the virtual machine to access the device from the host system.

**Procedure**

1 To determine whether the `modprobe modulename` and `modprobe parport_pc` modules are installed and loaded on the host system, run the `lsmod` command as the root user.

   You can also see a list of modules in the `/proc/modules` file.

   **Note** In Linux 2.6.x, loading `parport_pc` does not load all modules.

2 If necessary, load the parallel port modules.

   For example: `modprobe parport_pc` & `modprobe ppdev`

   This command inserts the modules that are required for a parallel port.

3 If the `lp` module is loaded, run the `rmmod` command as root to remove it.

   For example: `rmmod lp`

   The virtual machine cannot use the parallel port correctly if the `lp` module is loaded.
4 Comment out the line that refers to the lp module in the /etc/modules.conf or /etc/conf.modules file. The name of the configuration file depends on the Linux distribution.

When the line is commented out, the configuration file no longer starts the lp module when you reboot the host system.

5 To make sure that the proper modules for the parallel port are loaded at boot time, add the following line to the /etc/modules.conf or /etc/conf.modules file.

```
alias parport_lowlevel parport_pc
```

Configure Permissions for a Parallel Port Device on a Linux Host

Some Linux distributions do not grant a virtual machine access to the lp and parport devices by default. If this is the case on your Linux host system, you must add the VMware user to the group that has permission to access those devices.

Procedure

1 On the Linux host system, use the ls command to determine the owner and group for the device.

   For example: `ls -la /dev/parport0`

   The third and fourth columns of the output show the owner and group, respectively. In most cases, the owner of the device is root and the associated group is lp.

2 To add the user to the device group, become root and open the /etc/group file in a text editor.

3 On the line that defines the lp group, add the Player username.

   For example: `lp::7:daemon,lp,player_username`

   The changes take effect the next time the user logs in to the host system.

Troubleshoot ECR Errors for Parallel Ports

A parallel port on the host system does not have an Extended Control Register (ECR).

Problem

When you power on a virtual machine after adding a parallel port, an error messages states that the parallel port on the host system does not have an ECR.

Cause

This problem can occur when the hardware supports ECR, but ECR has been disabled in the BIOS.

Solution

1 Reboot the host system.

2 Early in the boot process, press and hold down the Delete key to enter the BIOS configuration editor.

3 Find the parallel port field and enable Extended Capability Port (ECP) mode or a combination of modes that includes ECP.

   Most modern computers support ECP mode.
Add a Virtual Serial Port to a Virtual Machine

You can add up to four serial (COM) ports to a virtual machine. Virtual serial ports can output to physical serial ports, files, or named pipes. You might want to add a virtual serial port to a virtual machine to make devices such as modems and printers available to the virtual machine. You can also use virtual ports to send debugging data from a virtual machine to the host system or to another virtual machine.

**Note** The virtual printer feature configures a serial port to make host printers available to the guest. You do not need to install additional drivers in the virtual machine.

**Prerequisites**

Power off the virtual machine.

**Procedure**

1. Select the virtual machine and select **Player > Manage > Virtual Machine Settings**.
2. On the **Hardware** tab, click **Add**.
3. In the Add Hardware wizard, select **Serial Port**.
4. Select where the virtual serial port sends output.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use a physical parallel port</td>
<td>Send output to a physical serial port on the host system.</td>
</tr>
<tr>
<td>Use output file</td>
<td>Send output to a file on the host system. Either locate an existing output file or browse to a directory and type a filename to create a new output file.</td>
</tr>
<tr>
<td>Output to named pipe</td>
<td>Set up a direct connection between two virtual machines, or a connection between a virtual machine and an application on the host system.</td>
</tr>
</tbody>
</table>

5. If you selected **Output to named pipe**, configure the named pipe.
   a. (Windows host) Use the default pipe name, or type another pipe name.
      The pipe name must begin with `\\\pipe\` and must be the same on both the server and the client.
      For example: `\\\pipe\namedpipe`
   b. (Linux host) Type `/tmp/socket` or another UNIX socket name in the first text box.
      The pipe name must be the same on both the server and the client.
   c. To send debugging information to an application on the host system, select **This end is the server** from the first drop-down menu and select **The other end is an application** from the second drop-down menu.
   d. To send debugging information to another virtual machine, select **This end is the server** from the first drop-down menu and **The other end is a virtual machine** from the second drop-down menu.
6. To connect the port to the virtual machine when the virtual machine powers on, select **Connect at power on**.
7. Click **Finish** to add the virtual serial port to the virtual machine.
8  (Optional) On the Hardware tab, select the new serial port, select Yield CPU on poll, and click OK.
   This option is useful if you are using debugging tools that communicate over a serial connection. If the
   serial port in the guest operating system is being used in polled mode rather than interrupt mode, you
   might notice performance issues. This option forces the virtual machine to yield processor time if the
   only task it is trying to do is poll the virtual serial port.

What to do next
If you set up a connection between two virtual machines, the first virtual machine is set up as the server.
Repeat this procedure for the second virtual machine, but set it up as the client by selecting This end is the
client when you configure the named pipe.

Change the Input Speed of a Serial Connection
You can increase the speed of a serial connection over a pipe to a virtual machine.
In principle, the output speed, which is the speed at which the virtual machine sends data through the
virtual serial port, is unlimited. In practice, the output speed depends on how fast the application at the
other end of the pipe reads inbound data.

Prerequisites
- Use the guest operating system to configure the serial port for the highest setting supported by the
  application that you are running in the virtual machine.
- Power off the virtual machine and exit Player.

Procedure
1  In a text editor, add the following line to the virtual machine configuration (.vmx) file.

   serialport_number.pipe.charTimePercent = "time"

   where
   port_number is the number of the serial port, starting from 0. The first serial port is serial0.
   time is a positive integer that specifies the time taken to transmit a character, expressed as a percentage of
   the default speed set for the serial port in the guest operating system. For example, a setting of 200 forces
   the port to take twice as long for each character, or send data at half the default speed. A setting of 50
   forces the port to take only half as long for each character, or send data at twice the default speed.

2  Assuming that the serial port speed is set appropriately in the guest operating system, experiment with
   this setting by starting with a value of 100 and gradually decreasing it until you find the highest speed
   at which the connection works reliably.

Configuring Generic SCSI Devices
The generic SCSI feature gives the guest operating system direct access to SCSI devices that are connected to
the host system, including scanners, tape drives, and other data storage devices. A virtual machine can use
the generic SCSI driver to run any SCSI device that is supported by the guest operating system.
To use SCSI devices in a virtual machine running on a Windows host system, you must run Player as a user
who has administrator access.
On Linux host systems, you must have read and write permissions on a given generic SCSI device to use
that device in a virtual machine, even if the device is a read-only device, such as a CD-ROM drive. These
devices typically default to root-only permissions. A Linux administrator can create a group that has read
and write access to these devices and add the appropriate users to that group.
Although generic SCSI is device independent, it can be sensitive to the guest operating system, device class,
and specific SCSI hardware.
Add a Generic SCSI Device to a Virtual Machine on page 94
You must add a generic SCSI device to the virtual machine to map virtual SCSI devices on a virtual machine to physical generic SCSI devices on the host system. You can add up to 60 generic SCSI devices to a virtual machine.

Install the BusLogic Driver in a Windows NT 4.0 Guest on page 95
Generic SCSI devices use the virtual Mylex (BusLogic) BT/KT-958 compatible host bus adapter provided by the virtual machine. On Windows NT 4.0, you might need to install the driver manually if it is not already installed for a virtual SCSI disk. Install the driver before you add a generic SCSI device.

Avoiding Concurrent Access Problems for SCSI Devices on Linux Hosts on page 95
Player makes sure that multiple programs do not use the same /dev/sg entry at the same time, but it cannot always ensure that multiple programs do not use the /dev/sg entry and the traditional /dev entry at the same time.

Troubleshoot Problems Detecting Generic SCSI Devices on page 95
When you add a generic SCSI device to a virtual machine, the device does not appear in the list of available SCSI devices.

Add a Generic SCSI Device to a Virtual Machine
You must add a generic SCSI device to the virtual machine to map virtual SCSI devices on a virtual machine to physical generic SCSI devices on the host system. You can add up to 60 generic SCSI devices to a virtual machine.

**Prerequisites**
- On a Windows host system, run Player as a user who has administrator access.
- On a Linux host system, log in as a user who has read and write permissions for the SCSI device. Also, verify that version 2.1.36 or later of the SCSI Generic driver (sg.o) is installed. This version of the SCSI Generic driver is included with Linux kernel 2.2.14 and later.
- On a Windows 95, Windows 98, or Windows Me virtual machine, install the latest Mylex (BusLogic) BT/KT-958 compatible host bus adapter. This driver overrides the driver that Windows chooses as the best driver, but it corrects known problems. You can download the driver from the LSI Web site.
- On a 32-bit Windows XP virtual machine, install the special SCSI driver that VMware provides. You can download the driver from the VMware Web site.
- On a Windows NT 4.0 virtual machine, install the BusLogic MultiMaster PCI SCSI Host Adapters driver. See “Install the BusLogic Driver in a Windows NT 4.0 Guest,” on page 95.

**Procedure**
1. Select the virtual machine and select Player > Manage > Virtual Machine Settings.
2. On the Hardware tab, click Add.
3. In the Add Hardware wizard, select Generic SCSI Device.
4. Select the physical SCSI device to map to the virtual SCSI device.
   When you type the path to the SCSI device on a Linux host, do not enter /dev/st0 or /dev/sr0.
5. To connect the device when the virtual machine powers on, select Connect at power on.
6. Click Finish to add the device.
On the **Hardware** tab, select the SCSI device identifier to use for the device from the **Virtual device node** drop-down menu and click **OK**.

For example, if you select **SCSI 0:2**, the guest operating system sees the drive as ID 2 on controller 0.

### Install the BusLogic Driver in a Windows NT 4.0 Guest

Generic SCSI devices use the virtual Mylex (BusLogic) BT/KT-958 compatible host bus adapter provided by the virtual machine. On Windows NT 4.0, you might need to install the driver manually if it is not already installed for a virtual SCSI disk. Install the driver before you add a generic SCSI device.

**Prerequisites**

Verify that the Windows NT installation CD is available.

**Procedure**

1. Select **Start > Settings > Control Panel > SCSI Adapters** to open the SCSI Adapters control panel.
2. On the **Drivers** tab, click **Add**.
3. From the list of vendors, select **BusLogic**.
4. From the list of drivers, select **BusLogic MultiMaster PCI SCSI Host Adapters** and click **OK**.
5. Insert the Windows NT CD and click **OK**.
6. Reboot the virtual machine.

### Avoiding Concurrent Access Problems for SCSI Devices on Linux Hosts

Player makes sure that multiple programs do not use the same `/dev/sg` entry at the same time, but it cannot always ensure that multiple programs do not use the `/dev/sg` entry and the traditional `/dev` entry at the same time.

The SCSI generic driver sets up a mapping in `/dev` for each SCSI device. Each entry starts with `sg`, for the SCSI generic driver, followed by a number. For example, `/dev/sg0` is the first generic SCSI device. Each entry corresponds to a SCSI device in the order specified in `/proc/scsi/scsi`, from the lowest device ID on the lowest adapter to the highest device ID on the lowest adapter, and so on to the highest device ID on the highest adapter.

Some Linux devices, such as tape drives, disk drives, and CD-ROM drives, already have a designated `/dev` entry (`st`, `sd`, and `sr`, respectively). When the SCSI generic driver is installed, Linux identifies these devices with corresponding `sg` entries in `/dev`, in addition to their traditional entries.

To avoid concurrent access problems, do not specify `/dev/st0` or `/dev/sr0` when you specify which SCSI device to use in a virtual machine.

**IMPORTANT** Do not attempt to use the same generic SCSI device in both the host system and guest operating system. Unexpected behavior and data loss or corruption might occur.

### Troubleshoot Problems Detecting Generic SCSI Devices

When you add a generic SCSI device to a virtual machine, the device does not appear in the list of available SCSI devices.

**Problem**

The SCSI device does not appear in the list of available SCSI devices after you add it to a virtual machine.
**Cause**

A driver for that device is not installed on the host system, a driver on the host system prevents the device from being detected, or the virtual machine uses a device for which there are no drivers available to the host operating system.

**Solution**

1. Determine the SCSI bus number that the device uses on the host system.
   
   The SCSI bus is assigned a number by the host operating system after all IDE buses are assigned numbers. For example, if you have two IDE buses, they are numbered 0 and 1. The first SCSI bus is assigned bus number 2. You can use a third-party tool, such as `winobj`, to determine the SCSI bus number.

2. Determine the target ID that the device uses in the virtual machine and on the host system.
   
   This ID is usually set by some jumpers or switches on the device.

3. Determine whether the device driver for the device is installed on the host system.
   
   If the device driver is not installed, install it and see if the device appears. To avoid a device-in-use conflict between the host and guest, you might not want to install the driver on the host system.

4. If an original SCSI device driver is already installed on the host system, disable it.
   
   Some Windows operating systems do not process the send command from the adapter if the device driver owns the device.

5. Power off the virtual machine and open the virtual machine configuration (.vmx) file in a text editor.

6. Add or change the following line in the virtual machine configuration (.vmx) file.

   ```
   scsiZ:Y.fileName = "deviceName"
   ```

   $Z$ is the SCSI bus number the device uses in the virtual machine. For `deviceName`, use `scsiX:Y`, where $X$ is the SCSI bus number that the device uses on the host system and $Y$ is the target ID that the device uses in both the virtual machine and on the host system.

   For example, if the problematic device is a CD-ROM drive, the existing entry is `scsi0:4.fileName = "CdRom0"` and the device on the host system is located on bus 2 with target ID 4, change the line to `scsi0:4.fileName = "scsi2:4"`.

7. If the virtual machine does not contain any SCSI devices, to add a generic SCSI device to a new virtual SCSI adapter, or to use an existing SCSI device as a generic SCSI device, add the following line to the virtual machine configuration (.vmx) file.

   ```
   scsiZ:Y.deviceType = "scsi-passthru"
   ```

8. If the virtual machine does not contain any SCSI devices, or to add a generic SCSI device to a new virtual SCSI adapter, add the following lines to the virtual machine configuration (.vmx) file.

   ```
   scsiZ:Y.present = "true"
   scsiZ.present = "true"
   ```
Configuring Eight-Way Virtual Symmetric Multiprocessing

With virtual symmetric multiprocessing (SMP), you can assign processors and cores per processor to a virtual machine on any host system that has at least two logical processors.

Player considers multiprocessor hosts that have two or more physical CPUs, single-processor hosts that have a multicore CPU, and single-processor hosts that have hyperthreading enabled, to have two logical processors.

**NOTE** On hyperthreaded uniprocessor hosts, performance of virtual machines that have virtual SMP might be below normal. Even on multiprocessor hosts, performance is affected if you overcommit by running multiple workloads that require more total CPU resources than are physically available.

You can power on and run multiple dual-processor virtual machines concurrently. The number of processors for a given virtual machine appears in the summary view of the virtual machine.

**Configure Eight-Way Virtual Symmetric Multiprocessing**

You can configure eight-way virtual symmetric multiprocessing (SMP) for an existing virtual machines.

**Procedure**

1. Select the virtual machine and select Player > Manage > Virtual Machine Settings.
2. On the Hardware tab, select Processors.
3. Change the Number of processors setting to 8.
4. Click OK to save your changes.

**Use a Virtual Machine That Has More Than Eight Virtual Processors**

If Player is running on a multiprocessor host system, you can open a virtual machine that has more than eight virtual processors assigned to it. You must change the number of processors before powering on the virtual machine.

You can see the number of processors in the virtual machine summary view or by viewing the virtual machine hardware settings.

**Prerequisites**

Power off the virtual machine.

**Procedure**

1. Select the virtual machine and select Player > Manage > Virtual Machine Settings.
2. On the Hardware tab, select Processors.
   
   Note that Number of processors is set to Other (x), where x is the number of processors originally assigned to it. Player preserves this original configuration setting for the number of processors, even though eight is the maximum number of processors supported.

3. Change the Number of processors setting to 1, 2, 4, 8, or 16.

   After you commit a change to this setting, the original setting for the number of processors is discarded and no longer appears as an option.

4. Click OK to save your changes.
Configuring Keyboard Features

You can change key combinations for hot-key sequences in Player and the language for the keyboard that VNC clients use. You can also configure platform-specific keyboard features for Windows and Linux host systems.

- Use the Enhanced Virtual Keyboard Feature in a Virtual Machine on page 98
  The enhanced virtual keyboard feature provides better handling of international keyboards and keyboards that have extra keys. This feature is available only on Windows host systems.

- Use Ctrl+Alt in a Key Combination on page 99
  Because Ctrl+Alt tells Player to release mouse and keyboard input, hot-key combinations that include Ctrl+Alt are not passed to the guest operating system. You must use the Space key if the key combination includes Ctrl+Alt.

- Configure Keyboard Mapping for a Remote X Server on page 99
  Although the keyboard works correctly with a local X server, it might not work correctly when you run the same virtual machine with a remote X server.

- Change How a Specific Key Is Mapped on page 100
  If some keys on the keyboard do not work correctly in a virtual machine, you can set a property that makes a modification to the map. To change how a specific key is mapped, you add the appropriate property to the virtual machine configuration (.vmx) file or to ~/.vmware/config.

- Configure How Keysyms Are Mapped on page 101
  When key code mapping cannot be used or is disabled, Player maps keysyms to v-scan codes. If a language-specific keyboard does not appear to be supported by Player, you might need to set a property that tells Player which keysym table to use.

- V-Scan Code Table on page 102
  You specify v-scan codes when you change how keys or keysyms are mapped.

Use the Enhanced Virtual Keyboard Feature in a Virtual Machine

The enhanced virtual keyboard feature provides better handling of international keyboards and keyboards that have extra keys. This feature is available only on Windows host systems.

Because it processes raw keyboard input as soon as possible, the enhanced virtual keyboard feature also offers security improvements by bypassing Windows keystroke processing and any malware that is not already at a lower layer. When you use the enhanced virtual keyboard feature, only the guest operating system acts when you press Ctrl+Alt+Delete.

Prerequisites

- If you recently installed or upgraded Player, but did not restart the host system, restart the host system.
- Power off the virtual machine.

Procedure

1. Select the virtual machine and select Player > Manage > Virtual Machine Settings.
2. On the Options tab, select General.
3 Select an option from the Enhanced virtual keyboard drop-down menu.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Off</td>
<td>The virtual machine does not use the enhanced virtual keyboard feature.</td>
</tr>
<tr>
<td></td>
<td>This is the default value.</td>
</tr>
<tr>
<td>Use if available (recommended)</td>
<td>The virtual machine uses the enhanced virtual keyboard feature, but only</td>
</tr>
<tr>
<td></td>
<td>if the enhanced virtual keyboard driver is installed on the host system.</td>
</tr>
<tr>
<td>Required</td>
<td>The virtual machine must use the enhanced virtual keyboard feature. If</td>
</tr>
<tr>
<td></td>
<td>you select this option and the enhanced keyboard driver is not installed on</td>
</tr>
<tr>
<td></td>
<td>the host system, Player returns an error message.</td>
</tr>
</tbody>
</table>

4 Click OK to save your changes.

**Use Ctrl+Alt in a Key Combination**

Because Ctrl+Alt tells Player to release mouse and keyboard input, hot-key combinations that include Ctrl + Alt are not passed to the guest operating system. You must use the Space key if the key combination includes Ctrl+Alt.

**Procedure**

1. Press Ctrl+Alt+spacebar.
2. Release the spacebar without releasing Ctrl and Alt.
3. Press the third key of the key combination to send to the guest operating system.

**Configure Keyboard Mapping for a Remote X Server**

Although the keyboard works correctly with a local X server, it might not work correctly when you run the same virtual machine with a remote X server.

For local X servers, Player maps X key codes to PC scan codes to correctly identify a key. Because it cannot tell whether a remote X server is running on a PC or on some other kind of computer, Player uses this key code map only for local X servers. You can set a property to tell Player to use key code mapping. See “Understanding X-Key Codes and Keysyms,” on page 100 for more information.

To configure a keyboard mapping for a remote X server, you add the appropriate property to the virtual machine configuration (.vmx) file or to ~/.vmware/config.

**Prerequisites**

- Verify that the remote X server is an XFree86 server running on a PC.
- Power off the virtual machine and exit Player.

**Procedure**

- If you use an XFree86-based server that Player does not recognize as an XFree86 server, add the xkeymap.usekeycodeMap property and set it to TRUE.
  
  This property tells Player to always use key code mapping regardless of server type.

  For example: `xkeymap.usekeycodeMap = "TRUE"`
If Player does not recognize the remote server as an XFree86 server, add the 
\texttt{xkeymap.usekeycodeMapIfXFree86} property and set it to \texttt{TRUE}.

This property tells Player to use key code mapping if you are using an XFree86 server, even if it is remote.

For example: \texttt{usekeycodeMapIfXFree86 = "TRUE"}

\begin{flushleft}
\textbf{Understanding X-Key Codes and Keysyms}
\end{flushleft}

Pressing a key on a PC keyboard generates a PC scan code based roughly on the position of the key. For example, the Z key on a German keyboard generates the same code as the Y key on an English keyboard because they are in the same position on the keyboard. Most keys have one-byte scan codes, but some keys have two-byte scan codes with prefix 0xe0.

Internally, Player uses a simplified version of the PC scan code that is a single nine-bit numeric value, called a v-scan code. A v-scan code is written as a three-digit hexadecimal number. The first digit is 0 or 1. For example, the Ctrl key on the left side of the keyboard has a one-byte scan code (0x1d) and its v-scan code is 0x01d. The Ctrl key scan code on the right side of the keyboard is two bytes (0xe0, 0x1d) and its v-scan code is 0x11d.

An XFree86 server on a PC has a one-to-one mapping from X key codes to PC scan codes, or v-scan codes, which is what Player uses. When Player is hosted on an XFree86 server and runs a local virtual machine, it uses the built-in mapping from X key codes to v-scan codes. This mapping is keyboard independent and should be correct for most languages. In other cases (not an XFree86 server or not a local server), Player must map keysyms to v-scan codes by using a set of keyboard-specific tables.

An X server uses a two-level encoding of keys, which includes the X key code and the keysym. An X key code is a one-byte value. The assignment of key codes to keys depends on the X server implementation and the physical keyboard. As a result, an X application normally cannot use key codes directly. Instead, the key codes are mapped into keysyms that have names like space, escape, x and 2. You can use an X application to control the mapping by using the function \texttt{XChangeKeyboardMapping()} or by the program \texttt{xmodmap}. To explore keyboard mappings, you can use the \texttt{xev} command, which shows the key codes and keysyms for keys typed into its window.

A key code corresponds roughly to a physical key, while a keysym corresponds to the symbol on the key top. For example, with an XFree86 server running on a PC, the Z key on the German keyboard has the same key code as the Y key on an English keyboard. The German Z keysym, however, is the same as the English Z keysym, and different from the English Y keysym.

\begin{flushleft}
\textbf{Change How a Specific Key Is Mapped}
\end{flushleft}

If some keys on the keyboard do not work correctly in a virtual machine, you can set a property that makes a modification to the map. To change how a specific key is mapped, you add the appropriate property to the virtual machine configuration (.vmx) file or to ~/.vmware/config.

\begin{flushleft}
\textbf{Prerequisites}
\end{flushleft}

\begin{itemize}
\item Verify that the X server is an XFree86 server running on a PC. If the X server is remote, configure it to use key code mapping. See “Configure Keyboard Mapping for a Remote X Server,” on page 99.
\item Determine the X key code and the corresponding v-scan code for the key. To find the X key code for a key, run \texttt{xev} or \texttt{xmodmap -pk}. See “V-Scan Code Table,” on page 102 for most v-scan codes.
\item Power off the virtual machine and exit Player.
\end{itemize}

\begin{flushleft}
\textbf{Procedure}
\end{flushleft}

1. Open .vmx or ~/.vmware/config in a text editor.
Add the `xkeymap.keycode.code` property and set it to the v-scan code.

code must be a decimal number and the v-scan code must be a C-syntax hexadecimal number, such as 0x001.

In this example, the properties swap left Ctrl and Caps Lock.

```
xkeymap.keycode.64 = "0x01d # X Caps_Lock -> VM left ctrl"
xkeymap.keycode.37 = "0x03a # X Control_L -> VM caps lock"
```

### Configure How Keysyms Are Mapped

When key code mapping cannot be used or is disabled, Player maps keysyms to v-scan codes. If a language-specific keyboard does not appear to be supported by Player, you might need to set a property that tells Player which keysym table to use.

Player determines which table to use by examining the current X keymap. However, its decision-making process can sometimes fail. In addition, each mapping is fixed and might not be completely correct for any given keyboard and X key code-to-keysym mapping. For example, if a user uses `xmodmap` to swap Ctrl and Caps Lock by, the keys are swapped in the virtual machine when using a remote server (keysym mapping), but are unswapped when using a local server (key code mapping). To correct this situation, you must remap the keys in Player.

To configure how keysyms are mapped, you add one or more properties to the virtual machine configuration (.vmx) file or to `~/.vmware/config`.

### Prerequisites

- To change the mapping of a few keys, determine the keysym name for each key. To find a keysym name, use the `xev` or `xmodmap -pk` command. The X header file `/usr/include/X11/keysymdef.h` also has a complete list of keysyms. The name of a keysym is the same as its C constant, but without the XK_prefix.

- To use a different keysym table, determine which mapping table to use. The tables are located in the `xkeymap` directory in the Player installation directory, which is usually `/usr/lib/vmware`. The table you must use depends on the keyboard layout. The normal distribution includes tables for PC keyboards for the United States and a number of European countries and languages. For most of these, both the 101-key (or 102-key) and the 104-key (or 105-key) variants are available.

  If none of the mapping tables is completely correct, find one that works best, copy it to a new location, and change the individual keysym mappings.

- Familiarize yourself with the v-scan codes. See “V-Scan Code Table,” on page 102.

- Power off the virtual machine and exit Player.

### Procedure

- To disable X key code mapping to map keysyms rather than key codes to v-scan codes, add the `xkeymap.nokeycodeMap` property and set it to TRUE.

  For example: `xkeymap.nokeycodeMap = "TRUE"

- If Player has a table in the `xkeymap` directory for your keyboard but cannot detect it, add the `xkeymap.language` property and set it to one of the tables in the `xkeymap` directory.

  For example: `xkeymap.language = "keyboard_type"

  If the failure to detect the keyboard means that the table is not completely correct for you, you might need to create a modified table and use the `xkeymap.fileName` property instead.
To use a different keysym mapping table that is not in the xkeymap directory, add the xkeymap.fileName property and set it to the path to the table.

For example: `xkeymap.fileName = "file_path"

The table must list a keysym for each key by using the form `sym="v-scan_code"`, where the `sym` value is an X keysym name and `v-scan_code` is a C-syntax hexadecimal number, for example, 0x001. Use a new line for each keysym.

**NOTE** Because compiling a complete keysym mapping is difficult, you should usually edit an existing table and make small changes.

To change the keysym mapping of a few keys, type the xkeymap.keysym property for each key, on separate lines.

For example: `xkeymap.keysym.sym = "v-scan_code"

The value of `sym` must be an X keysym name and `v-scan_code` is a C-syntax hexadecimal number, for example, 0x001.

### V-Scan Code Table

You specify v-scan codes when you change how keys or keyssyms are mapped.

Following are the v-scan codes for the 104-key U.S. keyboard.

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Shifted Symbol</th>
<th>Location</th>
<th>V-Scan Code</th>
</tr>
</thead>
<tbody>
<tr>
<td>Esc</td>
<td></td>
<td></td>
<td>0x001</td>
</tr>
<tr>
<td>1</td>
<td>!</td>
<td></td>
<td>0x002</td>
</tr>
<tr>
<td>2</td>
<td>@</td>
<td></td>
<td>0x003</td>
</tr>
<tr>
<td>3</td>
<td>#</td>
<td></td>
<td>0x004</td>
</tr>
<tr>
<td>4</td>
<td>$</td>
<td></td>
<td>0x005</td>
</tr>
<tr>
<td>5</td>
<td>%</td>
<td></td>
<td>0x006</td>
</tr>
<tr>
<td>6</td>
<td>^</td>
<td></td>
<td>0x007</td>
</tr>
<tr>
<td>7</td>
<td>&amp;</td>
<td></td>
<td>0x008</td>
</tr>
<tr>
<td>8</td>
<td>*</td>
<td></td>
<td>0x009</td>
</tr>
<tr>
<td>9</td>
<td>(</td>
<td></td>
<td>0x00a</td>
</tr>
<tr>
<td>0</td>
<td>)</td>
<td></td>
<td>0x00b</td>
</tr>
<tr>
<td>-</td>
<td>_</td>
<td></td>
<td>0x00c</td>
</tr>
<tr>
<td>=</td>
<td>+</td>
<td></td>
<td>0x00d</td>
</tr>
<tr>
<td>Backspace</td>
<td></td>
<td></td>
<td>0x00e</td>
</tr>
<tr>
<td>Tab</td>
<td></td>
<td></td>
<td>0x00f</td>
</tr>
<tr>
<td>Q</td>
<td></td>
<td></td>
<td>0x010</td>
</tr>
<tr>
<td>W</td>
<td></td>
<td></td>
<td>0x011</td>
</tr>
<tr>
<td>E</td>
<td></td>
<td></td>
<td>0x012</td>
</tr>
<tr>
<td>R</td>
<td></td>
<td></td>
<td>0x013</td>
</tr>
<tr>
<td>T</td>
<td></td>
<td></td>
<td>0x014</td>
</tr>
<tr>
<td>Y</td>
<td></td>
<td></td>
<td>0x015</td>
</tr>
<tr>
<td>U</td>
<td></td>
<td></td>
<td>0x016</td>
</tr>
</tbody>
</table>
### Table 6-1. V-Scan Codes for the 104-Key U.S. Keyboard (Continued)

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Shifted Symbol</th>
<th>Location</th>
<th>V-Scan Code</th>
</tr>
</thead>
<tbody>
<tr>
<td>I</td>
<td></td>
<td></td>
<td>0x017</td>
</tr>
<tr>
<td>O</td>
<td></td>
<td></td>
<td>0x018</td>
</tr>
<tr>
<td>P</td>
<td></td>
<td></td>
<td>0x019</td>
</tr>
<tr>
<td>[</td>
<td></td>
<td></td>
<td>0x01a</td>
</tr>
<tr>
<td>]</td>
<td></td>
<td></td>
<td>0x01b</td>
</tr>
<tr>
<td>Enter</td>
<td></td>
<td></td>
<td>0x01c</td>
</tr>
<tr>
<td>Ctrl left</td>
<td></td>
<td></td>
<td>0x01d</td>
</tr>
<tr>
<td>A</td>
<td></td>
<td></td>
<td>0x01e</td>
</tr>
<tr>
<td>S</td>
<td></td>
<td></td>
<td>0x01f</td>
</tr>
<tr>
<td>D</td>
<td></td>
<td></td>
<td>0x020</td>
</tr>
<tr>
<td>F</td>
<td></td>
<td></td>
<td>0x021</td>
</tr>
<tr>
<td>G</td>
<td></td>
<td></td>
<td>0x022</td>
</tr>
<tr>
<td>H</td>
<td></td>
<td></td>
<td>0x023</td>
</tr>
<tr>
<td>J</td>
<td></td>
<td></td>
<td>0x024</td>
</tr>
<tr>
<td>K</td>
<td></td>
<td></td>
<td>0x025</td>
</tr>
<tr>
<td>L</td>
<td></td>
<td></td>
<td>0x026</td>
</tr>
<tr>
<td>;</td>
<td></td>
<td></td>
<td>0x027</td>
</tr>
<tr>
<td>'</td>
<td></td>
<td></td>
<td>0x028</td>
</tr>
<tr>
<td>`</td>
<td></td>
<td></td>
<td>0x029</td>
</tr>
<tr>
<td>Shift left</td>
<td></td>
<td></td>
<td>0x02a</td>
</tr>
<tr>
<td>\</td>
<td></td>
<td></td>
<td>0x02b</td>
</tr>
<tr>
<td>Z</td>
<td></td>
<td></td>
<td>0x02c</td>
</tr>
<tr>
<td>X</td>
<td></td>
<td></td>
<td>0x02d</td>
</tr>
<tr>
<td>C</td>
<td></td>
<td></td>
<td>0x02e</td>
</tr>
<tr>
<td>V</td>
<td></td>
<td></td>
<td>0x02f</td>
</tr>
<tr>
<td>B</td>
<td></td>
<td></td>
<td>0x030</td>
</tr>
<tr>
<td>N</td>
<td></td>
<td></td>
<td>0x031</td>
</tr>
<tr>
<td>M</td>
<td></td>
<td></td>
<td>0x032</td>
</tr>
<tr>
<td>,</td>
<td></td>
<td></td>
<td>0x033</td>
</tr>
<tr>
<td>.</td>
<td></td>
<td></td>
<td>0x034</td>
</tr>
<tr>
<td>/</td>
<td></td>
<td></td>
<td>0x035</td>
</tr>
<tr>
<td>Shift right</td>
<td></td>
<td></td>
<td>0x036</td>
</tr>
<tr>
<td>*</td>
<td>numeric pad</td>
<td></td>
<td>0x037</td>
</tr>
<tr>
<td>Alt left</td>
<td></td>
<td></td>
<td>0x038</td>
</tr>
<tr>
<td>Space bar</td>
<td></td>
<td></td>
<td>0x039</td>
</tr>
<tr>
<td>Caps Lock</td>
<td></td>
<td></td>
<td>0x03a</td>
</tr>
<tr>
<td>F1</td>
<td></td>
<td></td>
<td>0x03b</td>
</tr>
<tr>
<td>F2</td>
<td></td>
<td></td>
<td>0x03c</td>
</tr>
<tr>
<td>F3</td>
<td></td>
<td></td>
<td>0x03d</td>
</tr>
</tbody>
</table>
### Table 6-1. V-Scan Codes for the 104-Key U.S. Keyboard (Continued)

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Shifted Symbol</th>
<th>Location</th>
<th>V-Scan Code</th>
</tr>
</thead>
<tbody>
<tr>
<td>F4</td>
<td></td>
<td></td>
<td>0x03e</td>
</tr>
<tr>
<td>F5</td>
<td></td>
<td></td>
<td>0x03f</td>
</tr>
<tr>
<td>F6</td>
<td></td>
<td></td>
<td>0x040</td>
</tr>
<tr>
<td>F7</td>
<td></td>
<td></td>
<td>0x041</td>
</tr>
<tr>
<td>F8</td>
<td></td>
<td></td>
<td>0x042</td>
</tr>
<tr>
<td>F9</td>
<td></td>
<td></td>
<td>0x043</td>
</tr>
<tr>
<td>F10</td>
<td></td>
<td></td>
<td>0x044</td>
</tr>
<tr>
<td>Num Lock</td>
<td>numeric pad</td>
<td></td>
<td>0x045</td>
</tr>
<tr>
<td>Scroll Lock</td>
<td></td>
<td></td>
<td>0x046</td>
</tr>
<tr>
<td>Home</td>
<td>7</td>
<td>numeric pad</td>
<td>0x047</td>
</tr>
<tr>
<td>Up arrow</td>
<td>8</td>
<td>numeric pad</td>
<td>0x048</td>
</tr>
<tr>
<td>PgUp</td>
<td>9</td>
<td>numeric pad</td>
<td>0x049</td>
</tr>
<tr>
<td>-</td>
<td>numeric pad</td>
<td></td>
<td>0x04a</td>
</tr>
<tr>
<td>Left arrow</td>
<td>4</td>
<td>numeric pad</td>
<td>0x04b</td>
</tr>
<tr>
<td>5</td>
<td>numeric pad</td>
<td></td>
<td>0x04c</td>
</tr>
<tr>
<td>Right arrow</td>
<td>6</td>
<td>numeric pad</td>
<td>0x04d</td>
</tr>
<tr>
<td>+</td>
<td>numeric pad</td>
<td></td>
<td>0x04e</td>
</tr>
<tr>
<td>End</td>
<td>1</td>
<td>numeric pad</td>
<td>0x04f</td>
</tr>
<tr>
<td>Down arrow</td>
<td>2</td>
<td>numeric pad</td>
<td>0x050</td>
</tr>
<tr>
<td>PgDn</td>
<td>3</td>
<td>numeric pad</td>
<td>0x051</td>
</tr>
<tr>
<td>Ins</td>
<td>0</td>
<td>numeric pad</td>
<td>0x052</td>
</tr>
<tr>
<td>Del</td>
<td>numeric pad</td>
<td></td>
<td>0x053</td>
</tr>
<tr>
<td>F11</td>
<td></td>
<td></td>
<td>0x057</td>
</tr>
<tr>
<td>F12</td>
<td></td>
<td></td>
<td>0x058</td>
</tr>
<tr>
<td>Break</td>
<td>Pause</td>
<td></td>
<td>0x100</td>
</tr>
<tr>
<td>Enter</td>
<td>numeric pad</td>
<td></td>
<td>0x111c</td>
</tr>
<tr>
<td>Ctrl</td>
<td>right</td>
<td></td>
<td>0x11d</td>
</tr>
<tr>
<td>/</td>
<td>numeric pad</td>
<td></td>
<td>0x135</td>
</tr>
<tr>
<td>SysRq</td>
<td>Print Scrn</td>
<td></td>
<td>0x137</td>
</tr>
<tr>
<td>Alt</td>
<td>right</td>
<td></td>
<td>0x138</td>
</tr>
<tr>
<td>Home</td>
<td>function pad</td>
<td></td>
<td>0x147</td>
</tr>
<tr>
<td>Up arrow</td>
<td>function pad</td>
<td></td>
<td>0x148</td>
</tr>
<tr>
<td>Page Up</td>
<td>function pad</td>
<td></td>
<td>0x149</td>
</tr>
<tr>
<td>Left arrow</td>
<td>function pad</td>
<td></td>
<td>0x14b</td>
</tr>
<tr>
<td>Right arrow</td>
<td>function pad</td>
<td></td>
<td>0x14d</td>
</tr>
<tr>
<td>End</td>
<td>function pad</td>
<td></td>
<td>0x14f</td>
</tr>
<tr>
<td>Down arrow</td>
<td>function pad</td>
<td></td>
<td>0x150</td>
</tr>
<tr>
<td>Page Down</td>
<td>function pad</td>
<td></td>
<td>0x151</td>
</tr>
<tr>
<td>Insert</td>
<td>function pad</td>
<td></td>
<td>0x152</td>
</tr>
</tbody>
</table>
Table 6-1. V-Scan Codes for the 104-Key U.S. Keyboard (Continued)

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Shifted Symbol</th>
<th>Location</th>
<th>V-Scan Code</th>
</tr>
</thead>
<tbody>
<tr>
<td>Delete</td>
<td></td>
<td>function pad</td>
<td>0x153</td>
</tr>
<tr>
<td>Windows</td>
<td></td>
<td>left</td>
<td>0x15b</td>
</tr>
<tr>
<td>Windows</td>
<td></td>
<td>right</td>
<td>0x15c</td>
</tr>
<tr>
<td>Menu</td>
<td></td>
<td></td>
<td>0x15d</td>
</tr>
</tbody>
</table>

The 84-key keyboard has a Sys Req key on the numeric pad. Its v-scan code is 0x054.

Keyboards outside the U.S. usually have an extra key (often < > or < > |) next to the left Shift key. The v-scan code for this key is 0x056.

Modify Hardware Settings for a Virtual Machine

You can modify memory, processor, virtual and physical hard disk, CD-ROM and DVD drive, floppy drive, virtual network adapter, USB controller, sound card, serial port, generic SCSI device, printer, and display settings for a virtual machine.

Procedure

1. Select the virtual machine and select Player > Manage > Virtual Machine Settings.
2. Click the Hardware tab.
3. Select the hardware setting to modify.
4. Click Help for information about how to modify the hardware setting.

You must power off a virtual machine before you change certain hardware settings.
Configuring Network Connections

Player provides bridged networking, network address translation (NAT), and host-only networking to configure a virtual machine for virtual networking. The software that you need for all networking configurations is installed on the host system when you install Player.

This chapter includes the following topics:

- “Understanding Virtual Networking Components,” on page 107
- “Understanding Common Networking Configurations,” on page 108
- “Configuring Bridged Networking,” on page 109
- “Configuring Network Address Translation,” on page 110
- “Configuring Host-Only Networking,” on page 111
- “Changing a Networking Configuration,” on page 112

Understanding Virtual Networking Components

The virtual networking components in Player include virtual switches, virtual network adapters, the virtual DHCP server, and the NAT device.

Virtual Switches

Like a physical switch, a virtual switch connects networking components together. Virtual switches, which are also referred to as virtual networks, are named VMnet0, VMnet1, VMnet2, and so on. A few virtual switches are mapped to specific networks by default.

Table 7-1. Default Virtual Network Switches

<table>
<thead>
<tr>
<th>Network Type</th>
<th>Switch Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bridged</td>
<td>VMnet0</td>
</tr>
<tr>
<td>NAT</td>
<td>VMnet8</td>
</tr>
<tr>
<td>Host-only</td>
<td>VMnet1</td>
</tr>
</tbody>
</table>

Player creates virtual switches as needed, up to 20 virtual switches on a Windows host system and up to 255 virtual switches on a Linux host system. You can connect an unlimited number of virtual network devices to a virtual switch on a Windows host system and up to 32 virtual network devices to a virtual switch on a Linux host system.

Note: On Linux host systems, the virtual switch names are in all lowercase letters, for example, vmnet0.
Virtual Network Adapters

When you use the New Virtual Machine wizard to create a new virtual machine, the wizard creates a virtual network adapter for the virtual machine. The virtual network adapter appears in the guest operating system as an AMD PCNET PCI adapter or Intel Pro/1000 MT Server Adapter. In Windows Vista, Windows 7, and Windows 8 guest operating systems, it is an Intel Pro/1000 MT Server Adapter.

Player 3.x and later virtual machines can have up to 10 virtual network adapters.

Virtual DHCP Server

The virtual Dynamic Host Configuration Protocol (DHCP) server provides IP addresses to virtual machines in configurations that are not bridged to an external network. For example, the virtual DHCP server assigns IP addresses to virtual machines in host-only and NAT configurations.

NAT Device

In a NAT configuration, the NAT device passes network data between one or more virtual machines and the external network, identifies incoming data packets intended for each virtual machine, and sends them to the correct destination.

Understanding Common Networking Configurations

You can configure bridged networking, NAT, and host-only networking for virtual machines. You can also use the virtual networking components to create sophisticated custom virtual networks.

Creating custom networks is available only on virtual machines that are created in Workstation. Although you cannot configure custom networking in Player, you can run a virtual machine that has custom networking in Player.

Bridged Networking

Bridged networking connects a virtual machine to a network by using the network adapter on the host system. If the host system is on a network, bridged networking is often the easiest way to give the virtual machine access to that network.

When you install Player on a Windows or Linux host system, a bridged network (VMnet0) is set up for you.

NAT Networking

With NAT, a virtual machine does not have its own IP address on the external network. Instead, a separate private network is set up on the host system. In the default configuration, a virtual machine gets an address on this private network from the virtual DHCP server. The virtual machine and the host system share a single network identity that is not visible on the external network.

When you install Player on a Windows or Linux host system, a NAT network (VMnet8) is set up for you. When you use the New Virtual Machine wizard to create a new virtual machine and select the typical configuration type, the wizard configures the virtual machine to use the default NAT network.

You can have only one NAT network.
Host-Only Networking

Host-only networking creates a network that is completely contained within the host computer. Host-only networking provides a network connection between the virtual machine and the host system by using a virtual network adapter that is visible on the host operating system.

When you install Player on a Windows or Linux host system, a host-only network (VMnet1) is set up for you.

Configuring Bridged Networking

When you install Player on a Windows or Linux host system, a bridged network (VMnet0) is set up for you. Bridged networking connects a virtual machine to a network by using the network adapter on the host system. If the host system is on a network, bridged networking is often the easiest way to give the virtual machine access to that network.

With bridged networking, the virtual network adapter in the virtual machine connects to a physical network adapter in the host system. The host network adapter enables the virtual machine to connect to the LAN that the host system uses. Bridged networking works with both wired and wireless host network adapters.

Bridged networking configures the virtual machine as a unique identity on the network, separate from and unrelated to the host system. The virtual machine is a full participant in the network. It has access to other machines on the network, and other machines on the network can contact it as if it were a physical computer on the network.

Figure 7-1. Bridged Networking Configuration

You can view and change the settings for bridged networking on the host system, determine which network adapters to use for bridged networking, and map specific host network adapters to specific virtual switches.

Assigning IP Addresses in a Bridged Networking Environment

A virtual machine must have its own identity on a bridged network. For example, on a TCP/IP network, the virtual machine needs its own IP address. Your network administrator can tell you whether IP addresses are available for virtual machines and which networking settings to use in the guest operating system.

Typically, the guest operating system can acquire an IP address and other network details from a DHCP server, but you might need to set the IP address and other details manually in the guest operating system.

Users who boot multiple operating systems often assign the same address to all systems because they assume that only one operating system will be running at a time. If the host system is set up to boot multiple operating systems, and you run one or more operating systems in virtual machines, you must configure each operating system to have a unique network address.
Configure Bridged Networking for an Existing Virtual Machine

You can configure bridged networking for an existing virtual machine.

To configure bridged networking for a new virtual machine, select Customize Hardware when you run the New Virtual Machine wizard.

Procedure

1. Select the virtual machine and select Player > Manage > Virtual Machine Settings.
2. On the Hardware tab, select Network Adapter.
3. Select Bridged: Connected directly to the physical network.
4. If you use the virtual machine on a laptop or other mobile device, select Replicate physical network connection state.
   This setting causes the IP address to be renewed when you move from one wired or wireless network to another.
5. Click OK to save your changes.

Configuring Network Address Translation

When you install Player on a Windows or Linux host system, a NAT network (VMnet8) is set up for you. When you use the New Virtual Machine wizard to create a typical virtual machine, the wizard configures the virtual machine to use the default NAT network.

With NAT, a virtual machine does not have its own IP address on the external network. Instead, a separate private network is set up on the host system. In the default configuration, virtual machines get an address on this private network from the virtual DHCP server.

Figure 7-2. NAT Configuration

The virtual machine and the host system share a single network identity that is not visible on the external network. NAT works by translating the IP addresses of virtual machines in the private network to the IP address of the host system. When a virtual machine sends a request to access a network resource, it appears to the network resource as if the request is coming from the host system.

The host system has a virtual network adapter on the NAT network. This adapter enables the host system and virtual machines to communicate with each other. The NAT device passes network data between one or more virtual machines and the external network, identifies incoming data packets intended for each virtual machine, and sends them to the correct destination.
Configuring Host-Only Networking

When you install Player on a Windows or Linux host system, a host-only network (VMnet1) is set up for you. Host-only networking is useful if you need to set up an isolated virtual network. In a host-only network, the virtual machine and the host virtual network adapter are connected to a private Ethernet network. The network is completely contained within the host system.

The network connection between the virtual machine and the host system is provided by a virtual network adapter that is visible on the host operating system. The virtual DHCP server provides IP addresses on the host-only network.

In the default configuration, a virtual machine in a host-only network cannot connect to the Internet. If you install the proper routing or proxy software on the host system, you can establish a connection between the host virtual network adapter and a physical network adapter on the host system to connect the virtual machine to a Token Ring or other non-Ethernet network.

On a Windows XP or Windows Server 2003 host computer, you can use host-only networking in combination with the Internet connection sharing feature in Windows to allow a virtual machine to use the dial-up networking adapter or other connection to the Internet on the host system. See Microsoft documentation for information on configuring Internet connection sharing.

Configure Host-Only Networking for an Existing Virtual Machine

You can configure host-only networking for an existing virtual machine. You can connect a virtual network adapter to the default host-only network (VMnet1) or to a custom host-only network. If a virtual machine has two virtual network adapters, you can connect it to two host-only networks.

To configure host-only networking for a new virtual machine, select Customize Hardware when you run the New Virtual Machine wizard.

Prerequisites

To connect the virtual machine to two host-only networks, add a second virtual network adapter to the virtual machine. See “Add a Virtual Network Adapter to a Virtual Machine,” on page 112.

Procedure

1. Select the virtual machine and select Player > Manage > Virtual Machine Settings.
2. On the Hardware tab select a virtual network adapter.
3 Select the host-only network.

<table>
<thead>
<tr>
<th>Option</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use the default host-only network</td>
<td>Select Host-only: A private network shared with the host.</td>
</tr>
<tr>
<td>(VMnet1)</td>
<td></td>
</tr>
<tr>
<td>Use a custom host-only network</td>
<td>Select Custom and select the custom host-only network from the drop-down menu.</td>
</tr>
</tbody>
</table>

4 To connect the virtual machine to a second host-only network, select another virtual network adapter and select the second host-only network.

5 Click OK to save your changes.

What to do next

Assign IP addresses to the virtual network adapters. To see the IP address that a host-only network is using, use the `ipconfig /all` command on a Windows host or the `ipconfig` command on a Linux host.

Changing a Networking Configuration

You can determine the type of network that a virtual machine is using, add virtual network adapters to a virtual machine, and change the configuration of existing virtual network adapters.

Find the Network Type of a Virtual Machine

Unless you configure a custom network connection, a virtual machine uses a bridged, NAT, or host-only network connection. When you use the New Virtual Machine wizard to create a virtual machine, the new virtual machine defaults to using the NAT network type.

Procedure

1 Select the virtual machine and select Player > Manage > Virtual Machine Settings.
2 On the Hardware tab, select Network Adapter.

Add a Virtual Network Adapter to a Virtual Machine

You can add up to 10 virtual network adapters to a virtual machine.

Prerequisites

Familiarize yourself with the network configuration types. See “Understanding Common Networking Configurations,” on page 108.

Procedure

1 Select the virtual machine and select Player > Manage > Virtual Machine Settings.
2 On the Hardware tab, click Add.
3 Select Network Adapter.
4  Select the virtual network adapter type.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bridged</td>
<td>The virtual machine is connected to the network by using the network adapter on the host system. The virtual machine has a unique identity on the network, separate from and unrelated to the host system.</td>
</tr>
<tr>
<td>NAT</td>
<td>The virtual machine and the host system share a single network identity that is not visible on the external network. When the virtual machine sends a request to access a network resource, it appears to the network resource as if the request is coming from the host system.</td>
</tr>
<tr>
<td>Host-only</td>
<td>The virtual machine and the host virtual network adapter are connected to a private Ethernet network. The network is completely contained within the host system.</td>
</tr>
<tr>
<td>LAN segment</td>
<td>Select a LAN segment from the drop-down menu. A LAN segment is a private network that is shared by other virtual machines.</td>
</tr>
</tbody>
</table>

5  Click Finish to add the virtual network adapter to the virtual machine.

6  Click OK to save your changes.

7  Verify that the guest operating system is configured to use an appropriate IP address on the new network.
   a  If the virtual machine is using DHCP, release and renew the lease.
   b  If the IP address is set statically, verify that the guest operating system has an address on the correct virtual network.

**Modify an Existing Virtual Network Adapter for a Virtual Machine**

You can change the settings of a virtual network adapter that is currently used by a virtual machine.

**Prerequisites**

Familiarize yourself with the network configuration types. See “Understanding Common Networking Configurations,” on page 108.

**Procedure**

1  Select the virtual machine and select Player > Manage > Virtual Machine Settings.

2  On the Hardware tab, select the virtual network adapter.

3  Select the virtual network adapter type.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bridged</td>
<td>The virtual machine is connected to the network by using the network adapter on the host system. The virtual machine has a unique identity on the network, separate from and unrelated to the host system.</td>
</tr>
<tr>
<td>NAT</td>
<td>The virtual machine and the host system share a single network identity that is not visible on the external network. When the virtual machine sends a request to access a network resource, it appears to the network resource as if the request is coming from the host system.</td>
</tr>
<tr>
<td>Host-only</td>
<td>The virtual machine and the host virtual network adapter are connected to a private Ethernet network. The network is completely contained within the host system.</td>
</tr>
<tr>
<td>LAN segment</td>
<td>Select a LAN segment from the drop-down menu. A LAN segment is a private network that is shared by other virtual machines.</td>
</tr>
</tbody>
</table>

4  Click OK to save your changes.
5 Verify that the guest operating system is configured to use an appropriate IP address on the new network.
   a If the virtual machine is using DHCP, release and renew the lease.
   b If the IP address is set statically, verify that the guest operating system has an address on the correct virtual network.
Index

A
accelerated 3D graphics
   preparing a virtual machine 73
   preparing the host system 72
   using 72
acceleration, disabling 62
additional information 5
application shortcuts, creating in Unity mode 66
Autologon, configuring 43

B
battery information 64
bridged networking
   assigning IP addresses 109
   configuring 109, 110
BusLogic driver, installing 95

C
CD-ROM drives
   adding 79
   configuring 79
   configuring legacy emulation mode 81
close behavior, configuring 46
command line options, installing Workstation on Linux 15
compatible virtual machines and system images 11
configuring virtual machines 69
copy and paste feature
   restrictions 48
   using 48
copy virtual machine 75
CPUs, host requirements 7
creating virtual machines 19
Ctrl+Alt, using in a key combination 99
Ctrl+Alt+Delete 45
Ctrl+Alt+Ins 45
drag-and-drop feature
   restrictions 47
   using 47
DVD drives
   adding 79
   configuring 79
   configuring legacy emulation mode 81

E
Easy Install, responding to prompts 20, 24
ECR errors, troubleshooting 91
e-mail collection 16
encrypted virtual machines 42
enhanced virtual keyboard 98

F
files, virtual machine 38
floppy drives
   adding 80
   configuring 79
FreeBSD guest operating system, VMware Tools installation or upgrade (tar installer) 36
full screen mode 63

G
generic SCSI devices
   adding 94
   avoiding concurrent access problems on Linux 95
   configuring 93
troubleshooting detection problems 95
guest operating systems
   changing 70
   installing manually 24
   selecting 20
   supported 10, 20

H
hardware, customizing 22
hardware settings, modifying 105
help system, host requirements 9
host-only networks, configuring 111
human interface devices, connecting 57

I
IDE drives, host requirements 9
importing virtual machines 26
installing 13
installing Player
   Linux host 14
   Windows host 13
installing VMware Tools
   FreeBSD (tar installer) 36
   Linux (tar installer) 32
   Microsoft Windows 31
   NetWare (tar installer) 34
   process overview 28
   Solaris (tar installer) 35
intended audience 5

K
   key code mappings, configuring 101
   key mappings, changing 100
   keyboard features, configuring 98
   keysyms
      defined 100
      mapping 101

L
   license key 16
   Linux guest, VMware Tools installation or upgrade (tar installer) 32
   local area networking, host requirements 9
   lock files 88

M
   managing virtual machines 69
   mapped drives 53
   memory
      host requirements 8
      virtual machine allocation 10
   memory allocation, changing 71
   message log, viewing 78
   Microsoft Windows guest operating system, VMware Tools installation or upgrade 31
   monitors, using multiple 67
   moving a virtual machines 75
   moving virtual machines, considerations 76
   multiple monitors 67
   multiple monitors for one virtual machine 67

N
   NAT, configuring 110
   NetWare guest operating system, VMware Tools installation or upgrade (tar installer) 34
   network type of a virtual machine, finding 112
   networking components, understanding 107
   networking configurations
      changing 112
      common 108
   New Virtual Machine wizard 23

O
   operating systems, host supported 8
   optical drives supported in host 9
   OVA format virtual machines 26
   OVF format virtual machines 26

P
   parallel ports
      configuring 89
      configuring device permissions 91
   configuring on Linux 2.6.x kernels hosts 90
   PDAs, installing drivers 58
   Player window 16
   printers, using host printers in a virtual machine 54
   processors
      host requirements 7
      supported in virtual machines 10
   using a virtual machine that has more than eight 97

R
   RAM, host requirements 8
   removable devices, using in virtual machines 54
   removing virtual machines 68
   repairing VMware Tools installations 37
   resetting a virtual machine 45

S
   SATA drives 9
   screen colors, setting for virtual machines 72
   SCSI drives, host requirements 9
   serial ports
      changing the input speed 93
      configuring 89, 92
   shared folders
      changing 52
      changing properties 52
      configuring 49
      disabling 53
      mounting 51
   supported guest operating systems 49
      using 48
      using permissions to restrict access 51
      viewing in Windows 50
   smart card readers, switching on Linux hosts 61
   smart cards
      disabling sharing 60
      using in virtual machines 59, 60
   software update preferences, configuring 29
   Solaris guest operating system, VMware Tools installation or upgrade (tar installer) 35
   solid-state drives 9
   sound, configuring 71, 74
   sound drivers, installing 74
SSD 9
starting virtual machines, streaming 42
stopping virtual machines 44
streaming virtual machines 42, 43
suspending virtual machines 45
system requirements, host system 7

T
tar installer 32
transferring files and text 46

U
uninstalling, Windows host 15
uninstalling VMware Tools 37
Unity mode, setting preferences 65
Unity mode features 64
upgrading VMware Tools
  FreeBSD (tar installer) 36
  Linux (tar installer) 32
  Microsoft Windows 31
  NetWare (tar installer) 34
  process overview 28
Solaris (tar installer) 35
USB controller
  adding 82
  configuring 81
USB devices
  connecting 56
  disabling autoconnect 56
  enabling high-speed support for USB 2.0 or 3.0 83
  installing drivers 56
  mounting on a Linux host 57
  troubleshooting connection issues 58
  understanding device control sharing 58
UUIDs
  configuring 77
  using 77

V
v-scan codes 102
video, configuring 71
virtual disks
  allocating disk space 22
  disconnecting from the host 54
  mapping and mounting 53
  SSD 9
virtual appliances 67
virtual disk, optimize behavior 9
virtual hard disks
  adding 84, 86
  compacting 86
  configuring 83
defragmenting 87
expanding 86
growing and allocating storage space 84
moving 88
removing 88
setting up as IDE or SCSI 84
virtual machine directory, changing 70
virtual machine files, specifying in the New Virtual Machine wizard 21
virtual machines
  changing names 69
  configuring for compatibility 76
  creating 19
  deleting 77
  installing software 61
  moving 75
  shutting down 44
  specifications 10
  starting 42
  understanding 19
  using 41
virtual machines directory 21
virtual network adapter, changing 113
virtual network adapters, adding 112
virtual networks, configuring 107
virtual symmetric multiprocessing, configuring 97
VIX API 78
VMnet
t  virtual network 107
t  virtual switch 107
VMware Tools
  installing 31
  updating on a specific virtual machine 30
  using 27
VMware Player, start 16
VMware Player email collection 16
VMware Tools installation
  FreeBSD (tar installer) 36
  Linux (tar installer) 32
  Microsoft Windows 31
  NetWare (tar installer) 34
  process 28
  Solaris (tar installer) 35
VMware Tools upgrade
  FreeBSD (tar installer) 36
  Linux (tar installer) 32
  Microsoft Windows 31
  NetWare (tar installer) 34
  process 28
  Solaris (tar installer) 35
vmware-user, starting manually 37
### W
- Windows Virtual PC virtual machines 27
- Windows XP Mode virtual machine, importing 26
- working directory, changing 70
- worksheet, typical virtual machine 22

### X
- X server and keyboard mapping 99
- x-key codes, defined 100
- xFree86 and keyboard mapping 99