Getting Started with VMware Workstation

VMware Workstation 9

This document supports the version of each product listed and supports all subsequent versions until the document is replaced by a new edition. To check for more recent editions of this document, see http://www.vmware.com/support/pubs.
You can find the most up-to-date technical documentation on the VMware Web site at:
http://www.vmware.com/support/
The VMware Web site also provides the latest product updates.
If you have comments about this documentation, submit your feedback to:
docfeedback@vmware.com
Contents

Getting Started with VMware Workstation 5

1 Introduction and System Requirements 7
   Host System Requirements 7
   Virtual Machine Features and Specifications 10

2 Installing and Using Workstation 15
   Obtaining the Workstation Software and License Key 15
   Installing Workstation with Other VMware Products 16
   Reinstalling Workstation When Upgrading a Windows Host Operating System 16
   Installing the Integrated Virtual Debuggers for Eclipse and Visual Studio 16
   Installing Workstation 16
   Upgrading Workstation 21
   Uninstalling Workstation 27
   Start Workstation 28
   Using the Workstation Window 28
   Using the Workstation Online Help 32

3 Creating Virtual Machines 33
   Understanding Virtual Machines 33
   Features of a Typical Virtual Machine 34
   Preparing to Create a Typical Virtual Machine 34
   Create a Typical Virtual Machine 38
   Use Easy Install to Install a Guest Operating System 39
   Install a Guest Operating System Manually 40
   Installing and Upgrading VMware Tools 41
   Install New Software in a Virtual Machine 49

4 Using Virtual Machines 51
   Start a Virtual Machine 51
   Shut Down a Virtual Machine 52
   Pause and Unpause a Virtual Machine 53
   Suspend and Resume a Virtual Machine 54
   Using the Drag-and-Drop Feature 55
   Using the Copy and Paste Feature 55
   Add a Host Printer to a Virtual Machine 56
   Use a Removable Device in a Virtual Machine 56
   Changing the Virtual Machine Display 58
   Using Folders to Manage Virtual Machines 62
   Taking Snapshots of Virtual Machines 64
   Closing Virtual Machines and Exiting Workstation 69
Getting Started with VMware Workstation

*Getting Started with VMware Workstation* describes how to install and upgrade VMware® Workstation, create a typical virtual machine, and perform common virtual machine operations.

**Intended Audience**

This information is intended for anyone who wants to install Workstation and create a typical virtual machine. See *Using VMware Workstation* for complete information about Workstation, including how to use advanced Workstation features.

**Where to Find Additional Information**

See the following documents for additional information about using Workstation. All of the documents are available from the VMware Web site.

- *Using VMware Workstation* contains complete information about Workstation, including how to use advanced Workstation features.
- The *VMware Guest Operating System Installation Guide* contains information about installing specific guest operating systems.
- The online VMware Compatibility Guide lists the supported host and guest operating systems for Workstation.

The Workstation online help contains quick reference information about Workstation settings and common tasks. It is available from the Workstation Help menu and when you click Help on a Workstation dialog box.
Host computers that run Workstation must meet specific hardware and software requirements. Virtual machines that run in Workstation support specific devices and provide certain features.

This chapter includes the following topics:

- “Host System Requirements,” on page 7
- “Virtual Machine Features and Specifications,” on page 10

Host System Requirements

The physical computer on which you install Workstation is called the host system and its operating system is called the host operating system. To run Workstation, the host system and the host operating system must meet specific hardware and software requirements.

Processor Requirements for Host Systems

You must install Workstation on a host system that meets certain processor requirements.

Supported Processors

The host system must have a 64-bit x86 CPU that meets the following requirements.

- LAHF/SAHF support in long mode
- 1.3GHz or faster core speed

Multiprocessor systems are supported.

When you install Workstation, the installer performs checks to make sure the host system has a supported processor. You cannot install Workstation if the host system does not meet the processor requirements.

Processor Requirements for 64-Bit Guest Operating Systems

The operating system that runs inside a virtual machine is called the guest operating system. To run 64-bit guest operating systems, the host system must have one of the following processors.

- An AMD CPU that has segment-limit support in long mode
- An Intel CPU that has VT-x support

If you have an Intel CPU that has VT-x support, you must verify that VT-x support is enabled in the host system BIOS. The BIOS settings that must be enabled for VT-x support vary depending on the system vendor. See the VMware knowledge base article at http://kb.vmware.com/kb/1003944 for information about how to determine if VT-x support is enabled.
When you install a 64-bit operating system, Workstation performs checks to make sure the host system has a supported processor. You cannot install a 64-bit operating system if the host system does not meet the processor requirements.

**Processor Requirements for Windows 7 Aero Graphics**

To support Windows 7 Aero graphics, the host system should have either an Intel Dual Core 2.2GHz or later CPU or an AMD Athlon 4200+ or later CPU.

**Supported Host Operating Systems**

You can install Workstation on Windows and Linux host operating systems.

To see a list of the supported host operating systems, search the online VMware Compatibility Guide on the VMware Web site.

**Memory Requirements for Host Systems**

The host system must have enough memory to run the host operating system, the guest operating systems that run inside the virtual machines on the host system, and the applications that run in the host and guest operating systems.

The minimum memory required on the host system is 1GB. 2GB and above is recommended.

To support Windows 7 Aero graphics in a virtual machine, at least 3GB of host system memory is required. 1GB of memory is allocated to the guest operating system and 256MB is allocated to graphics memory.

See your guest operating system and application documentation for more information on memory requirements.

**Display Requirements for Host Systems**

The host system must have a 16-bit or 32-bit display adapter. Use the latest graphics driver recommended for the host system.

To support Windows 7 Aero graphics, the host system should have either an NVIDIA GeForce 8800GT or later or an ATI Radeon HD 2600 or later graphics processor.

**Important** 3D benchmarks, such as 3DMark '06, might not render correctly or at all when running Windows Vista or Windows 7 virtual machines on some graphics hardware.
Disk Drive Requirements for Host Systems

Host systems must meet certain disk drive requirements. Guest operating systems can reside on physical disk partitions or in virtual disk files.

Table 1-1. Disk Drive Requirements for Host Systems

<table>
<thead>
<tr>
<th>Drive Type</th>
<th>Requirements</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hard disk</td>
<td>▪ IDE and SCSI hard drives are supported.</td>
</tr>
<tr>
<td></td>
<td>▪ At least 1GB free disk space is recommended for each guest operating system</td>
</tr>
<tr>
<td></td>
<td>and the application software used with it. If you use a default setup, the</td>
</tr>
<tr>
<td></td>
<td>actual disk space needs are approximately the same as those for installing</td>
</tr>
<tr>
<td></td>
<td>and running the guest operating system and applications on a physical</td>
</tr>
<tr>
<td></td>
<td>computer.</td>
</tr>
<tr>
<td></td>
<td>▪ For basic installation, 1.5GB free disk space is required on Windows and</td>
</tr>
<tr>
<td></td>
<td>Linux. Delete the installer after the installation is finished to reclaim</td>
</tr>
<tr>
<td></td>
<td>disk space.</td>
</tr>
<tr>
<td>Optical CD-ROM and DVD</td>
<td>▪ IDE and SCSI optical drives are supported.</td>
</tr>
<tr>
<td></td>
<td>▪ CD-ROM and DVD drives are supported.</td>
</tr>
<tr>
<td></td>
<td>▪ ISO disk image files are supported.</td>
</tr>
<tr>
<td>Floppy</td>
<td>Virtual machines can connect to disk drives on the host computer. Floppy</td>
</tr>
<tr>
<td></td>
<td>disk image files are also supported.</td>
</tr>
</tbody>
</table>

Local Area Networking Requirements for Host Systems

You can use any Ethernet controller that the host operating system supports.

Non-Ethernet networks are supported by using built-in network address translation (NAT) or by using a combination of host-only networking and routing software on the host operating system.

ALSA Requirements for Host Systems

To use ALSA in a virtual machine, the host system must meet certain requirements.

- The ALSA library version on the host system must be version 1.0.16 or later.
- The sound card on the host system must support ALSA. The ALSA project Web site maintains a current listing of sound cards and chipsets that support ALSA.
- The sound device on the host system must not be muted.
- The current user must have the appropriate permissions to use the sound device.

Help System Requirements

You must have a supported Web browser installed on the host system to use the Workstation Help system.

The following Web browser versions are supported.

- Internet Explorer 6 or later
- Mozilla Firefox 1.x or later
- Netscape 7.x or later
- Safari 1.x or later
- Opera 7.54u2 or later

Because Chrome does not support JavaScript on local systems, you cannot display the Workstation Help system in Chrome.
Virtual Machine Features and Specifications

Workstation virtual machines support specific devices and provide certain features.

Supported Guest Operating Systems

A guest operating system can be Windows, Linux, and other commonly used operating systems.

To see a list of the supported guest operating systems, search the online VMware Compatibility Guide on the VMware Web site.

See the VMware Guest Operating System Installation Guide for information on installing the most common guest operating systems.

Virtual Machine Processor Support

Virtual machines support certain processor features.

- The same as the processor on the host computer.
- One virtual processor on a host system that has one or more logical processors.
- Up to eight virtual processors (eight-way virtual symmetric multiprocessing, or Virtual SMP) on a host system that has at least two logical processors.

**Note:** Workstation considers multiprocessor hosts that have two or more physical CPUs, single-processor hosts that have a multicore CPU, and single-processor hosts that have hyperthreading enabled, to have two logical processors.

Virtual Machine Chip Set and BIOS Support

Virtual machines support certain virtual machine chip set and BIOS features.

- Intel 440BX-based motherboard
- NS338 SIO chip set
- 82093AA I/O Advanced Programmable Controller (I/O APIC)
- Phoenix BIOS 4.0 Release 6 with VESA BIOS

Virtual Machine Memory Allocation

The total amount of memory that you can assign to all virtual machines running on a single host system is limited only by the amount of RAM on the host.

On 64-bit hosts, the maximum amount of memory for each virtual machine is 64GB. On 32-bit hosts, the maximum amount of memory for each virtual machine is 8GB. Workstation prevents powering on virtual machines that are configured to use more than 8GB of memory on 32-bit hosts. Memory management limitations on 32-bit operating systems cause virtual machine memory to overcommit, which severely affects system performance.

Virtual Machine Graphics and Keyboard Support

Virtual machines support certain graphics features and keyboards.

- VGA and SVGA are supported.
- 104-key Windows 95/98 enhanced keyboards are supported.
To use the GL_EXT_texture_compression_s3tc and GL_S3_s3tc Open Graphics Library (OpenGL) extensions in a Windows XP or Windows 7 guest operating system, you must install Microsoft DirectX End-User Runtime in the guest operating system. OpenGL is an application program interface that is used to define 2D and 3D computer graphics. You can download Microsoft DirectX End-User Runtime from the Microsoft Download Center Web site.

**Virtual Machine IDE Drive Support**

Virtual machines support certain IDE drives and features.

- Up to four devices, including disk, CD-ROM, and DVD drives, are supported.
- DVD drives can be used to read data DVD discs only.
- DVD video is not supported.
- Hard disks can be virtual disks or physical disks.
- IDE virtual disks can be up to 2TB.
- CD-ROM drives can be physical devices or ISO image files.

**Virtual Machine SCSI Device Support**

Virtual machines support certain SCSI devices and features.

- Up to 60 devices are supported.
- SCSI virtual disks can be up to 2TB.
- Hard disks can be virtual disks or physical disks.
- With Generic SCSI support, you can use devices in a virtual machine without installing drivers in the host operating system. Generic SCSI support works with scanners, CD-ROM drives, DVD drives, tape drives, and other SCSI devices.
- The LSI Logic LSI53C10xx Ultra320 SCSI I/O controller is supported.

**Virtual Machine Floppy Drive Support**

Virtual machines can have floppy drives.

- Up to two 2.88MB floppy devices are supported.
- Floppy drives can be physical drives or floppy image files.

**Virtual Machine Serial and Parallel Port Support**

Virtual machines support serial (COM) and parallel (LPT) ports.

- Up to four serial (COM) ports are supported. Output can be sent to serial ports, Windows or Linux files, or named pipes.
- Up to three bidirectional parallel (LPT) ports. Output can be sent to parallel ports or host operating system files.

**Virtual Machine USB Port Support**

Virtual machines can have USB ports and can support certain USB devices.

- USB 1.1 UHCI (Universal Host Controller Interface) is supported for all virtual machine hardware versions.
USB 2.0 EHCI (Enhanced Host Controller Interface) controllers are supported if the virtual machine hardware is compatible with Workstation 6 and later virtual machines.

USB 3.0 xHCI (Extensible Host Controller Interface) support is available for Linux guests running kernel version 2.6.35 or later and for Windows 8 guests. The virtual machine hardware must be compatible with Workstation 8 and later virtual machines.

Support for USB 2.0 and 3.0 requires that you configure virtual machine settings to enable USB 2.0 and 3.0 support and that you have compatible guest operating systems and virtual machine hardware versions.

Most USB devices are supported, including USB printers, scanners, PDAs, hard disk drives, memory card readers, and digital cameras. Streaming devices, such as webcams, speakers, and microphones, are also supported.

Virtual Machine Mouse and Drawing Tablet Support

Virtual machines support certain types of mice and drawing tablets.

- PS/2 and USB mouse types are supported.
- Serial tablets are supported.
- USB tablets are supported.

Virtual Machine Ethernet Card Support

Virtual machines support certain types of Ethernet cards.

- Up to 10 virtual Ethernet cards are supported.
- The AMD PCnet-PCI II Ethernet Adapter is supported. For 64-bit guests, the Intel Pro/1000 MT Server Adapter is also supported.

Virtual Machine Networking Support

Virtual machines support certain Ethernet switches and networking protocols.

- Up to 10 virtual Ethernet switches are supported on Windows host operating systems. Up to 255 virtual Ethernet switches are supported on Linux host operating systems.
- Three switches are configured by default for bridged, host-only, and NAT networking.
- Most Ethernet-based protocols are supported, including TCP/IP, NetBEUI, Microsoft Networking, Samba, Novell NetWare, and Network File System (NFS).
- Built-in NAT networking supports client software that uses TCP/IP, FTP, DNS, HTTP, and Telnet. VPN is supported for PPTP over NAT.

Virtual Machine Sound Support

Workstation provides a sound device that is compatible with the Sound Blaster AudioPCI and Intel High-Definition Audio Specification. The Workstation sound device is enabled by default.


Sound support includes pulse code modulation (PCM) output and input. You can play .wav files, MP3 audio, and Real Media audio. MIDI output from Windows guest operating systems is supported by the Windows software synthesizer. MIDI input is not supported, and no MIDI support is available for Linux guest operating systems.

Windows XP, Windows Vista, Windows 7 and most recent Linux distributions detect the sound device and install appropriate drivers for it.
Windows 95, Windows 98, Windows 98SE, and Windows NT 4.0 do not have drivers for the Sound Blaster AudioPCI adapter. To use sound in these guest operating systems, you must download the driver from the Creative Labs Web site and install it in the guest operating systems. Creative Labs has Web sites that serve different regions of the world. The adapter name varies, depending on the region, but usually includes PCI 128.


For Workstation 8.x and later virtual machines, the High-Definition Audio (HD Audio) device is presented by default for both 64-bit and 32-bit Windows Vista and Windows 7 guest operating systems and their server counterparts. Windows provides a driver for HD Audio that is not part of VMware Tools.

On Linux host systems, Workstation 7.x and later supports Advanced Linux Sound Architecture (ALSA). Earlier versions of Workstation use the Open Sound System (OSS) interface for sound playback and recording in virtual machines running on Linux host systems. Unlike OSS, ALSA does not require exclusive access to the sound device. The host system and multiple virtual machines can play sound at the same time.
You can install Workstation on a Linux or Windows host system. Installing or upgrading Workstation typically involves running a standard GUI wizard.

This chapter includes the following topics:

- “Obtaining the Workstation Software and License Key,” on page 15
- “Installing Workstation with Other VMware Products,” on page 16
- “Reinstalling Workstation When Upgrading a Windows Host Operating System,” on page 16
- “Installing the Integrated Virtual Debuggers for Eclipse and Visual Studio,” on page 16
- “Installing Workstation,” on page 16
- “Upgrading Workstation,” on page 21
- “Uninstalling Workstation,” on page 27
- “Start Workstation,” on page 28
- “Using the Workstation Window,” on page 28
- “Using the Workstation Online Help,” on page 32

**Obtaining the Workstation Software and License Key**

If you have the packaged distribution of Workstation, the installation software is on the installation media in the package and the license key is on the registration card. If you have the electronic distribution, the installation software is in the file that you downloaded and the license key is sent to you in email.

The installation files for both host platforms are included in the packaged distribution. You can use the license key on both the Windows and Linux versions of Workstation. You need one license for each host system.

If you do not enter the Workstation license key during installation, you can specify the license key later, in Workstation, select **Help > Enter License Key** and enter the license key on the Workstation Activation dialog box. You can also purchase a license key and view the status of an evaluation license from the Workstation Activation dialog box.

See the VMware Web site for information on obtaining an evaluation license.

**Note** If you have an invalid license, Workstation prompts you to enter a license key each time you attempt to power on a virtual machine.
Installing Workstation with Other VMware Products

The only VMware products that can share a host system with Workstation are VMware vSphere Client and VMware vCenter Converter Standalone. You cannot install Workstation on a host system that has any other VMware virtualization products installed.

If the host system has another VMware virtualization product installed, you must uninstall that product before you install Workstation.

Reinstalling Workstation When Upgrading a Windows Host Operating System

Before you upgrade the operating system on a Microsoft Windows host, VMware recommends that you uninstall VMware Workstation.

The way Workstation is installed and configured depends partly on the version of Windows used. As a best practice, to ensure that Workstation is properly configured for a new operating system, you must remove the Workstation application before you perform the operating system upgrade. Uninstalling Workstation guarantees that legacy components that apply only to older versions of Windows are not left behind.

For example, if you do not uninstall Workstation before upgrading the Windows operating system, some virtual network adapters might not function properly after the operating system upgrade. Before you uninstall Workstation, open the virtual network editor and note the settings used. You must configure these settings again after you reinstall Workstation.

When you uninstall Workstation, you need only uninstall the VMware Workstation application, not the virtual machines that you have created. When the operating system upgrade is complete, reinstall Workstation or, if you are also upgrading Workstation, install the new version of Workstation.

Installing the Integrated Virtual Debuggers for Eclipse and Visual Studio

If you plan to use the Integrated Virtual Debugger for Visual Studio or Eclipse, you should install it on the host system before you install Workstation.

If you must install the Integrated Virtual Debugger for Visual Studio or Eclipse after you install Workstation, run the Workstation installer again and select Modify/Change to install the associated Workstation plug-ins.


Installing Workstation

You can install Workstation on a Windows host system by running the installation wizard or by using the unattended installation feature of the Microsoft Windows Installer (MSI). The MSI unattended installation feature is useful if you are installing Workstation on several Windows hosts and do not want to respond to wizard prompts. You install Workstation on a Linux host system by running the Workstation bundle installer.

- Install Workstation on a Windows Host on page 17
  You run the Windows setup program and installation wizard to install Workstation on a Windows host system.

- Run an Unattended Workstation Installation on a Windows Host on page 18
  You can use the unattended installation feature of the Microsoft Windows Installer (MSI) to install Workstation on several Windows host systems without having to respond to wizard prompts. This feature is convenient in a large enterprise.
Install Workstation on a Linux Host on page 20

You run the Linux bundle installer to install Workstation on a Linux host system. On most Linux distributions, the Linux bundle installer launches a GUI wizard. On some Linux distributions, including Red Hat Enterprise Linux 5.1, the bundle installer launches a command-line wizard instead of a GUI wizard. You can run the installer with the --console option to install Workstation in a terminal window.

Install Workstation on a Windows Host

You run the Windows setup program and installation wizard to install Workstation on a Windows host system. Remote connections and virtual machine sharing are enabled by default when you install Workstation. With remote connections, you can connect to remote hosts and run remote virtual machines. With virtual machine sharing, you can create virtual machines that other instances of Workstation can access remotely.

Shared virtual machines are stored in the shared virtual machines directory, where VMware Workstation Server (the VMware Workstation Server service) manages them. Remote users connect to VMware Workstation Server through HTTPS port 443 on the host system.

To change the shared virtual machines directory or select a different port during the installation process, you must select the Custom option. You can also change the shared virtual machines directory, select a different port, and disable remote connections and virtual machine sharing after Workstation is installed by modifying the Shared VMs Workstation preference setting. See Using VMware Workstation for more information.

Prerequisites

- Verify that the host system meets the host system requirements. See “Host System Requirements,” on page 7.
- Verify that you have administrative privileges on the host system.
- Verify that no incompatible VMware products are installed on the host system. See “Installing Workstation with Other VMware Products,” on page 16.
- Obtain the Workstation software and license key. See “Obtaining the Workstation Software and License Key,” on page 15.
- If you plan to use the Integrated Virtual Debugger for Eclipse or Visual Studio, install it on the host system. See “Installing the Integrated Virtual Debuggers for Eclipse and Visual Studio,” on page 16.

Procedure

1. Log in to the Windows host system as the Administrator user or as a user who is a member of the local Administrators group.
   - If you log in to a domain, the domain account must also be a local administrator.
2. If you are installing Workstation from a CD, insert the CD in the CD-ROM drive on the host system.
   - If autorun is enabled, the installation program begins.
3. If autorun is not enabled, or if you downloaded the installation software, double-click the setup file.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>If you are installing the software from a CD</td>
<td>The setup file is called setup.exe.</td>
</tr>
<tr>
<td>If you downloaded the software</td>
<td>The setup filename is similar to VMware-workstation-xxxx-xxxx.exe, where xxxx-xxxx is the version and build numbers.</td>
</tr>
</tbody>
</table>
4 Select a setup option.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Typical</td>
<td>Installs typical Workstation features. If the Integrated Virtual Debugger for Visual Studio or Eclipse is present on the host system, the associated Workstation plug-ins are installed.</td>
</tr>
<tr>
<td>Custom</td>
<td>Lets you select which Workstation features to install and specify where to install them. Select this option if you need to change the shared virtual machines directory, modify the VMware Workstation Server port, or install the enhanced virtual keyboard driver. The enhanced virtual keyboard driver provides better handling of international keyboards and keyboards that have extra keys.</td>
</tr>
</tbody>
</table>

5 Follow the prompts to finish the installation.

Depending on your configuration, you might need to restart the host system to finish the installation.

After Workstation is installed, the VMware Workstation Server service starts on the host system. The VMware Workstation Server service starts whenever you restart the host system.

Run an Unattended Workstation Installation on a Windows Host

You can use the unattended installation feature of the Microsoft Windows Installer (MSI) to install Workstation on several Windows host systems without having to respond to wizard prompts. This feature is convenient in a large enterprise.

**Prerequisites**

- Verify that the host system meets the host system requirements. See “Host System Requirements,” on page 7.
- Verify that no incompatible VMware products are installed on the host system. See “Installing Workstation with Other VMware Products,” on page 16.
- Obtain the Workstation software and license key. See “Obtaining the Workstation Software and License Key,” on page 15.
- If you plan to use the Integrated Virtual Debugger for Eclipse or Visual Studio, install it on the host system. See “Installing the Integrated Virtual Debuggers for Eclipse and Visual Studio,” on page 16.
- Verify that the host computer has version 2.0 or higher of the MSI runtime engine. This version of the installer is available in versions of Windows beginning with Windows XP and is available from Microsoft. See the Microsoft Web site for more information.
- Familiarize yourself with the REMOVE property values. See “REMOVE Property Values,” on page 19.
- Familiarize yourself with the installation properties. See “Installation Properties,” on page 19.

**Procedure**

1 Log in to the host system as the Administrator user or as a user who is a member of the local Administrators group.
   - If you log in to the domain, the domain account must also be a local administrator.
2 If you are installing Workstation from a CD, insert the CD in the CD-ROM drive on the host system.
3 Extract the administrative installation image from the setup file.
   - If you are installing Workstation from a CD, the setup file is called setup.exe. If you downloaded the installation software, the setup filename is similar to VMware-workstation-xxxx-xxxx.exe where xxxx-xxxx is the version and build number.
   - For example: setup.exe /s /e install_temp_path
4 Type the installation command on one line.

For example:

```
setup.exe /s /v "[INSTALLDIR=""path_to_program_directory"","
[REMOVE=value,value] /qn"
```

You can use the optional INSTALLDIR property to specify a file path for the installation that is different from the default location. The double quotes around the file path are important. All the MSI arguments are passed with the /v option. The outer quotes group the MSI arguments and the double quotes put a quote in that argument. You can use the optional REMOVE property to skip the installation of certain features.

**REMOVE Property Values**

When you perform an unattended installation of Workstation, you can skip the installation of certain features by specifying the REMOVE property in the installation command.

To specify a REMOVE property value in the installation command, use the format REMOVE=value. To skip multiple features, separate each value with a comma, for example, REMOVE=value,value.

**Table 2-1. REMOVE Property Values**

<table>
<thead>
<tr>
<th>Value</th>
<th>Skipped Feature</th>
</tr>
</thead>
<tbody>
<tr>
<td>Authd</td>
<td>The VMware authorization service, which is used to perform tasks when you are not running Workstation as an Administrator user.</td>
</tr>
<tr>
<td>Network</td>
<td>Networking components, including the virtual bridge and the host adapters for host-only networking and NAT networking. Do not remove this component if you want to use NAT or DHCP.</td>
</tr>
<tr>
<td>DHCP</td>
<td>The virtual DHCP server.</td>
</tr>
<tr>
<td>NAT</td>
<td>The virtual NAT device.</td>
</tr>
</tbody>
</table>

**Installation Properties**

When you perform an unattended installation of Workstation, you can customize the installation by specifying installation properties in the installation command.

To specify an installation property in the installation command, use the format property="value". A value of 1 means true and a value of 0 means false.

**Table 2-2. Installation Properties**

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
<th>Default Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>DESKTOP_SHORTCUT</td>
<td>Adds a shortcut on the desktop when Workstation is installed.</td>
<td>1</td>
</tr>
<tr>
<td>REMOVE_LICENSE</td>
<td>Removes all stored licenses when Workstation is uninstalled.</td>
<td>0</td>
</tr>
<tr>
<td>SERIALNUMBER</td>
<td>Lets you enter the license key when Workstation is installed. Enter the license key with hyphens, for example, xxxxx-xxxxx-xxxxx-xxxxx-xxxxx.</td>
<td></td>
</tr>
<tr>
<td>HOSTD_HTTPS_PORT</td>
<td>Specifies the HTTPS port for VMware Workstation Server.</td>
<td>443</td>
</tr>
<tr>
<td>REMOVE_ACCOUNT_INFO</td>
<td>Removes account information when Workstation is uninstalled.</td>
<td>1</td>
</tr>
<tr>
<td>REMOVE_SETTINGFILES</td>
<td>Removes settings files when Workstation is uninstalled.</td>
<td>1</td>
</tr>
<tr>
<td>STARTMENU_SHORTCUT</td>
<td>Adds a Start menu item when Workstation is installed.</td>
<td>1</td>
</tr>
<tr>
<td>QUICKLAUNCH_SHORTCUT</td>
<td>Adds a quick launch shortcut when Workstation is installed.</td>
<td>1</td>
</tr>
</tbody>
</table>
Install Workstation on a Linux Host

You run the Linux bundle installer to install Workstation on a Linux host system. On most Linux distributions, the Linux bundle installer launches a GUI wizard. On some Linux distributions, including Red Hat Enterprise Linux 5.1, the bundle installer launches a command-line wizard instead of a GUI wizard. You can run the installer with the --console option to install Workstation in a terminal window.

Remote connections and virtual machine sharing are enabled by default when you install Workstation. With remote connections, you can connect to remote hosts and run remote virtual machines. With virtual machine sharing, you can create virtual machines that other instances of Workstation can access remotely.

Shared virtual machines are stored in the shared virtual machines directory, where VMware Workstation Server (vmware-workstation-server) manages them. Remote users connect to VMware Workstation Server through HTTPS port 443 on the host system.

To change the shared virtual machines directory or select a different port during the installation process, you must specify the --custom option. You can also change the shared virtual machines directory, select a different port, and disable remote connections and virtual machine sharing after Workstation is installed by modifying the Shared VMs Workstation preference setting. See Using VMware Workstation for more information.

Prerequisites

- Verify that the host system meets the host system requirements. See “Host System Requirements,” on page 7.
- Verify that no incompatible VMware products are installed on the host system. See “Installing Workstation with Other VMware Products,” on page 16.
- Obtain the Workstation software and license key. See “Obtaining the Workstation Software and License Key,” on page 15.
- If you plan to use the Integrated Virtual Debugger for Eclipse, install it on the host system. See “Installing the Integrated Virtual Debuggers for Eclipse and Visual Studio,” on page 16.
- Compile the real-time clock function into the Linux kernel.
- Verify that the parallel port PC-style hardware option (CONFIG_PARPORT_PC) is built and loaded as a kernel module and that it is set to m when the kernel is compiled.
- Familiarize yourself with the Linux command-line installation options. You must use the --custom option to specify certain configuration settings. See “Linux Command Line Installation Options,” on page 21.
- Verify that you have root access on the host system.

Procedure

1. Log in to the host system with the user name that you plan to use when you run Workstation.
2. Become root.
   
   For example: su root
   
   The command that you use depends on your Linux distribution and configuration.
3. If you are installing Workstation from the installation media, mount the Workstation installation media.
4. Change directories to the directory that contains the Workstation installer file.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>If you are installing the software from a CD</td>
<td>The installer file is in the Linux directory.</td>
</tr>
<tr>
<td>If you downloaded the software</td>
<td>The installer file is in the download directory.</td>
</tr>
</tbody>
</table>
5 Run the appropriate Workstation installer for the host system.
   For example: sh VMware-Workstation-xxxx-xxxx.architecture.bundle [--option]

   xxxx-xxxx is the version and build numbers, architecture is i386 or x86_64, and option is a command line option.

6 Accept the Open Virtualization Format (OVF) Tool license agreement.
   If you are using the --console option or installing Workstation on a host system that does not support the GUI wizard, press Enter to scroll through and read the license agreement or type q to skip to the [yes/no] prompt.

7 Follow the prompts to finish the installation.
   After Workstation is installed, vmware-workstation-server starts on the host system. vmware-workstation-server starts whenever you restart the host system.

Linux Command Line Installation Options

You can use command line installation options to install Workstation on a Linux host system.

To use the installation options, you must be logged in as root. Exit from the root account after the installation is finished.

Table 2-3. Linux Command Line Installation Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>--gtk</td>
<td>Opens the GUI-based VMware installer, which is the default option.</td>
</tr>
<tr>
<td>--console</td>
<td>Enables you to use the terminal for installation.</td>
</tr>
<tr>
<td>--custom</td>
<td>Use this option to customize the following installation settings.</td>
</tr>
<tr>
<td></td>
<td>■ The locations of the installation directories.</td>
</tr>
<tr>
<td></td>
<td>■ The user who will initially connect to VMware Workstation Server. This user can create and manage</td>
</tr>
<tr>
<td></td>
<td>shared virtual machines.</td>
</tr>
<tr>
<td></td>
<td>■ The hard limit for the number of open file descriptors.</td>
</tr>
<tr>
<td></td>
<td>■ The location of the shared virtual machines directory.</td>
</tr>
<tr>
<td></td>
<td>■ The HTTPS port that VMware Workstation Server uses on the host system.</td>
</tr>
<tr>
<td>--regular</td>
<td>Shows installation questions that have not been answered before or are required. This is the default</td>
</tr>
<tr>
<td></td>
<td>option.</td>
</tr>
<tr>
<td>--required</td>
<td>Shows the license agreement only and then proceeds to install Workstation.</td>
</tr>
<tr>
<td>--ignore-errors or -I</td>
<td>Allows the installation to continue even if there is an error in one of the installer scripts. Because the section that has an error does not complete, the component might not be properly configured</td>
</tr>
</tbody>
</table>

Upgrading Workstation

You can upgrade from Workstation 4, 5.x, 6.x, or 7.x to the current version of Workstation by running the Workstation installation program.

When you upgrade Workstation, the installation program removes the previous version of Workstation before it installs the new version.

To use the latest features, virtual machines that were created in the previous versions of Workstation must be upgraded to the current version of Workstation.

Prepare for an Upgrade on page 22
   You must perform certain steps before you upgrade Workstation.
You can upgrade from Workstation version 4, 5.x, 6.x, or 7.x to the current version of Workstation on a Windows host system by running the Workstation setup program and installation wizard for Windows.

You can upgrade Workstation version 4, 5.x, 6.x, or 7.x to the current version of Workstation on a Linux host system by running the Linux bundle installer for Workstation. On most Linux distributions, the Linux bundle installer launches a GUI wizard. On some Linux distributions, including Red Hat Enterprise Linux 5.1, the bundle installer launches a command-line wizard instead of a GUI wizard. You can run the installer with the `--console` option to upgrade Workstation in a terminal window.

You can change the hardware compatibility of a virtual machine. All virtual machines have a hardware version. The hardware version indicates which virtual hardware features that the virtual machine supports, such as BIOS or EFI, number of virtual slots, maximum number of CPUs, maximum memory configuration, and other hardware characteristics.

Prepare for an Upgrade

You must perform certain steps before you upgrade Workstation.

Procedure

- Verify that all virtual machines are Workstation 4, 5.x, 6.x, or 7.x virtual machines.
  Direct upgrades from Workstation 2 and 3 virtual machines are not supported.
- Review the system requirements for the new version of Workstation.
- If a virtual machine was created with a version of Workstation earlier than Workstation 5.5 and it has a snapshot, delete the snapshot.
- If you are upgrading from Workstation 4, 5.x, 6.x, or 7.x, and the previous version of Workstation used bridged settings to map virtual networks to specific physical or virtual adapters, record those settings. You must recreate these mappings after you upgrade Workstation.
- Power off all running virtual machines in Workstation.
- If any virtual machines are suspended, resume them and power them off in Workstation.
- If any virtual machines are running in the background, start them in Workstation and power them off.
- Back up all virtual machines by making backup copies of the files in the virtual machine directories and storing them in different directories.
  The files that you back up should include `.vmdk` or `.dsk` files, `.vmx` or `.cfg` files, and `.nvram` files. Depending on the upgrade path, you might not be able to run virtual machines under both the current version of Workstation and the previous version of Workstation.
- If you are upgrading Workstation 6.x on Windows XP to the current version of Workstation on Windows Vista or Windows 7, verify that Service Pack 2 is installed and then upgrade the host operating system to Windows Vista or Windows 7.
- If you are upgrading Workstation 5.x on Windows Vista to the current version of Workstation on Windows Vista, select `Programs > Programs and Features > Uninstall a program` in the Windows control panel to manually uninstall Workstation 5.x.
- If you are upgrading Workstation 5.x on Windows XP to the current version of Workstation on Windows Vista or Windows 7, select `Add or Remove Programs` in the Windows control panel to manually uninstall Workstation 5.x.
During an upgrade from Windows XP to Windows Vista or Windows 7, the location of virtual machines might change. The Windows Vista and Windows 7 upgrade use the registry to map the virtual machines to a new location. Before the upgrade, the default virtual machine location on Windows XP is

C:\Documents and Settings\username\My Documents\My Virtual Machines. After the upgrade, the default virtual machine location on Windows Vista and Windows 7 is C:\Users\username\Documents\Virtual Machines\guestOSname.

**Upgrade Workstation on a Windows Host**

You can upgrade from Workstation version 4, 5.x, 6.x, or 7.x to the current version of Workstation on a Windows host system by running the Workstation setup program and installation wizard for Windows.

Remote connections and virtual machine sharing are enabled by default when you upgrade Workstation. With remote connections, you can connect to remote hosts and run remote virtual machines. With virtual machine sharing, you can create virtual machines that other instances of Workstation can access remotely.

Shared virtual machines are stored in the shared virtual machines directory, where VMware Workstation Server (the VMware Workstation Server service) manages them. Remote users connect to VMware Workstation Server through HTTPS port 443 on the host system.

To change the shared virtual machines directory or select a different port during the upgrade process, you must select the **Custom** option. You can also change the shared virtual machines directory, select a different port, and disable remote connections and virtual machine sharing after Workstation is upgraded by modifying the Shared VMs Workstation preference setting. See *Using VMware Workstation* for more information.

**Prerequisites**

- Verify that the host system meets the host system requirements. See “Host System Requirements,” on page 7.
- Verify that you have a license key.
- Verify that you have administrative privileges on the host system.
- Prepare for the upgrade. See “Prepare for an Upgrade,” on page 22.

**Procedure**

1. Log in to the Windows host system as the Administrator user or as a user who is a member of the local Administrators group.
   
   If you log in to a domain, the domain account must also be a local administrator.

2. If you are upgrading Workstation from a CD, insert the CD in the CD-ROM drive on the host system.
   
   If autorun is enabled, the installation program begins.

3. If autorun is not enabled, or if you downloaded the installation software, double-click the setup file.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>If you are installing the software from a CD</td>
<td>The setup file is called setup.exe.</td>
</tr>
<tr>
<td>If you downloaded the software</td>
<td>The setup filename is similar to VMware-workstation-xxxx-xxxx.exe, where xxxx-xxxx is the version and build numbers.</td>
</tr>
</tbody>
</table>

4. Click **Uninstall** to uninstall the previous version of Workstation.

5. After the host system restarts, log in as the Administrator user or as a user who is a member of the local Administrators group.
   
   If you log in to a domain, the domain account must also be a local administrator.
6 Select a setup option.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Typical</td>
<td>Installs typical Workstation features. If the Integrated Virtual Debugger for Visual Studio or Eclipse is present on the host system, the associated Workstation plug-ins are installed.</td>
</tr>
<tr>
<td>Custom</td>
<td>Lets you select which Workstation features to install and specify where to install them. Select this option if you need to change the shared virtual machines directory, modify the VMware Workstation Server port, or install the enhanced virtual keyboard driver. The enhanced virtual keyboard driver provides better handling of international keyboards and keyboards that have extra keys.</td>
</tr>
</tbody>
</table>

7 Follow the prompts to finish the upgrade.

Depending on your configuration, you might need to restart the host system to finish the installation.

After Workstation is upgraded and you restart the host system, the VMware Workstation Server service starts. The VMware Workstation Server service starts whenever you restart the host system.

**What to do next**

To use the latest features, upgrade existing virtual machines to the new version of Workstation. See “Change the Hardware Compatibility of a Virtual Machine,” on page 25.

If you used bridged settings to map virtual networks to specific physical or virtual adapters in the previous version of Workstation, recreate the mappings. If you created teams in the previous version of Workstation, convert the teams to use them in the new version of Workstation. See *Using VMware Workstation* for more information.

### Upgrade Workstation on a Linux Host

You can upgrade Workstation version 4, 5.x, 6.x, or 7.x to the current version of Workstation on a Linux host system by running the Linux bundle installer for Workstation. On most Linux distributions, the Linux bundle installer launches a GUI wizard. On some Linux distributions, including Red Hat Enterprise Linux 5.1, the bundle installer launches a command-line wizard instead of a GUI wizard. You can run the installer with the `--console` option to upgrade Workstation in a terminal window.

Remote connections and virtual machine sharing are enabled by default when you upgrade Workstation. With remote connections, you can connect to remote hosts and run remote virtual machines. With virtual machine sharing, you can create virtual machines that other instances of Workstation can access remotely.

Shared virtual machines are stored in the shared virtual machines directory, where VMware Workstation Server (`vmware-workstation-server`) manages them. Remote users connect to VMware Workstation Server through HTTPS port 443 on the host system.

To change the shared virtual machines directory or select a different port during the upgrade process, you must specify the `--custom` option. You can also change the shared virtual machines directory, select a different port, and disable remote connections and virtual machine sharing after Workstation is upgraded by modifying the Shared VMs Workstation preference setting. See *Using VMware Workstation* for more information.

**Prerequisites**

- Verify that the host system meets the host system requirements. See “Host System Requirements,” on page 7.
- Verify that you have a license key.
- Prepare for the upgrade. See “Prepare for an Upgrade,” on page 22.
Familiarize yourself with the Linux command-line installation options. You must use the --custom option to specify certain configuration settings. See “Linux Command Line Installation Options,” on page 21.

Verify that you have root access to the host system.

**Procedure**

1. Log in to the host system with the user name that you plan to use when you run Workstation.
2. Become root.
   
   For example: `su root`
   
   The command that you use depends on your Linux distribution and configuration.
3. If you are upgrading Workstation from the installation media, mount the Workstation installation media.
4. Change directories to the directory that contains the Workstation installer file.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>If you are installing the software from a CD</td>
<td>The installer file is in the Linux directory.</td>
</tr>
<tr>
<td>If you downloaded the software</td>
<td>The installer file is in the download directory.</td>
</tr>
</tbody>
</table>

5. Run the appropriate Workstation installer for the host system.

   For example: `sh VMware-Workstation-xxxx-xxxx.architecture.bundle [--option]`

   `xxxx-xxxx` is the version and build numbers, `architecture` is i386 or x86_64, and `option` is a command line option.

6. Accept the Open Virtualization Format (OVF) Tool license agreement.

   If you are using the --console option or installing Workstation on a host system that does not support the GUI wizard, press Enter to scroll through and read the license agreement or type `q` to skip to the [yes/no] prompt.

7. Follow the prompts to finish the installation.

   After Workstation is upgraded, `vmware-workstation-server` starts on the host system. `vmware-workstation-server` starts whenever you restart the host system.

**What to do next**

To use the latest features, upgrade existing virtual machines to the new version of Workstation. See “Change the Hardware Compatibility of a Virtual Machine,” on page 25.

If you used bridged settings to map virtual networks to specific physical or virtual adapters in the previous version of Workstation, recreate the mappings. If you created teams in the previous version of Workstation, convert the teams to use them in the new version of Workstation. See *Using VMware Workstation* for more information.

**Change the Hardware Compatibility of a Virtual Machine**

You can change the hardware compatibility of a virtual machine. All virtual machines have a hardware version. The hardware version indicates which virtual hardware features that the virtual machine supports, such as BIOS or EFI, number of virtual slots, maximum number of CPUs, maximum memory configuration, and other hardware characteristics.

When you upgrade Workstation, you must change the hardware compatibility of virtual machines that were created in previous versions of Workstation so that they can use the new features in the new version of Workstation. You can run older versions of virtual machines in the new version of Workstation, but you will not have the benefits of the new features.
If you want a virtual machine to remain compatible with other VMware products that you are using, you might not want to change the hardware compatibility to the latest Workstation version.

**NOTE** If you decide not to change the hardware compatibility of a virtual machine, you should consider upgrading to the latest version of VMware Tools to obtain the latest VMware Tools features.

**Prerequisites**

Familiarize yourself with the considerations and limitations of changing the hardware compatibility of a virtual machine. See “Considerations for Changing the Hardware Compatibility of a Virtual Machine,” on page 26.

**Procedure**

1. Make backup copies of the virtual disk (.vmdk) files.

2. If you are upgrading from a Workstation 4 or 5.x virtual machine, or downgrading to a Workstation 4 or 5.x virtual machine, make a note of the NIC settings in the guest operating system.

   If you specified a static IP address for the virtual machine, that setting might be changed to automatic assignment by DHCP after the upgrade.

3. Shut down the guest operating system and power off the virtual machine.

4. Select the virtual machine and select **VM > Manage > Change Hardware Compatibility**.

5. Follow the prompts in the wizard to change the hardware compatibility of the virtual machine.

   When you select a hardware compatibility setting, a list of the VMware products that are compatible with that setting appears. For example, if you select Workstation 4, 5, or 6, a list of Workstation 6.5 and later features that are not supported for that Workstation version also appears.

6. Power on the virtual machine.

   If you upgrade a virtual machine that contains a Windows 98 operating system to a Workstation 6.5 or later virtual machine, you must install a PCI-PCI bridge driver when you power on the virtual machine.

   **NOTE** Because Workstation 6.5 and later versions have 32 more PCI-PCI bridges than Workstation 6, you might need to respond to the prompt 32 or 33 times.

7. If the NIC settings in the guest operating system have changed, use the NIC settings that you recorded to change them back to their original settings.

8. If the virtual machine does not have the latest version of VMware Tools installed, update VMware Tools.

   You should update VMware Tools to the version included with the latest version of Workstation, even if you upgraded the virtual machine to an earlier version of Workstation. Do not remove the older version of VMware Tools before installing the new version.

   **NOTE** If you are upgrading a virtual machine that runs from a physical disk, you can safely ignore this message: Unauthorized upgrade drive_name. One of the supplied parameters is invalid.

**Considerations for Changing the Hardware Compatibility of a Virtual Machine**

Before you change the hardware compatibility of a virtual machine, you should be aware of certain considerations and limitations.

- For Workstation 5.x, 6, 6.5, 7.x, and later virtual machines, you can change the version of the original virtual machine or create a full clone so that the original virtual machine remains unaltered. For Workstation 4 virtual machines, Workstation changes the original virtual machine.
If you upgrade a Workstation 4 or 5.x virtual machine that is compatible with ESX Server to Workstation 6, 6.5, 7.x, or later, you cannot use the Change Hardware Compatibility wizard to later downgrade the virtual machine to an ESX-compatible virtual machine.

When you upgrade a Windows XP, Windows Server 2003, Windows Vista, or Windows 7 virtual machine, the Microsoft product activation feature might require you to reactivate the guest operating system.

You cannot change the hardware compatibility of a shared or remote virtual machine.

**Uninstalling Workstation**

You uninstall Workstation on a Windows host by using the Windows setup program. On a Linux host, you uninstall Workstation by running the bundle installer.

**Important** If you uninstall Workstation and do not save the configuration, then when you reinstall Workstation, shared virtual machines will no longer appear in the **Shared VMs** list in the virtual machine library. To display virtual machines in the list again, you will need to share them again.

**Uninstall Workstation from a Windows Host**

You can run the Windows setup program to uninstall Workstation from a Windows host system.

**Procedure**

1. Log in to the Windows host system as the Administrator user or as a user who is a member of the local Administrators group.
   
   If you log in to the domain, the domain account must also be a local administrator.

2. If you have a Workstation CD, insert the CD in the CD-ROM drive on the host system.
   
   If autorun is enabled, the installation program begins.

3. If autorun is not enabled, or if you downloaded the installation software, double-click the setup file.
   
   If you have a Workstation CD, the setup file is called `setup.exe`. If you downloaded the installation software, the setup filename is similar to `VMware-workstation-x.x-x.exe`, where `x.x-x` is the version and build numbers.

4. Click **Next** on the Welcome screen and then click **Remove**.

5. (Optional) To save product license and Workstation configuration information, select the appropriate check boxes.

6. Click **Next** to begin uninstalling Workstation.

**Uninstall Workstation from a Linux Host**

You must run a command to uninstall Workstation from a Linux host.

**Prerequisites**

Verify that you have root access to the host system.

**Procedure**

1. Log in to the Linux host system with the username that you use when you run Workstation.

2. Become root.
   
   For example: `su root`

   The command that you use depends on your Linux distribution and configuration.
3 In a terminal window, type `vmware-installer -u vmware-workstation`.
4 Click Next to begin uninstalling Workstation.

## Start Workstation

How you start Workstation depends on the host system platform and the options that you selected during Workstation installation.

On Windows host systems, you might have a desktop shortcut, a quick launch shortcut, or a combination of these options in addition to a **Start** menu item.

On Linux host systems, you start Workstation from the command line. On some Linux distributions, including Red Hat Enterprise Linux 5.1, you can also start Workstation from the **System Tools** menu under **Applications**.

### Procedure

- To start Workstation on a Windows host system, select **Start > Programs > VMware > VMware Workstation**.
- To start Workstation on a Linux host system, type the `vmware` command in a terminal window.

<table>
<thead>
<tr>
<th>Option</th>
<th>Command</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>/usr/bin is in your default path</code></td>
<td><code>vmware &amp;</code></td>
</tr>
<tr>
<td><code>/usr/bin is not in your default path</code></td>
<td><code>/usr/bin/vmware &amp;</code></td>
</tr>
</tbody>
</table>

The first time you start Workstation, Workstation prompts you to accept the End User License Agreement. After you start Workstation, the Workstation window opens.

## Using the Workstation Window

A virtual machine is like a separate computer that runs in a window on the host system. Workstation displays more than the screen of another computer. From the Workstation window, you can interact with and run virtual machines. You can also switch easily from one virtual machine to another.

The best way to learn how to use Workstation is to use it. The Workstation window is designed to be intuitive and easy to use.

- **Use Virtual Machines in the Workstation Window** on page 29
  You interact with virtual machines through the Workstation window.

- **Use the Virtual Machine Library** on page 29
  The virtual machine library appears on the left side of the Workstation window. You use the library to view and select virtual machines, folders, and remote hosts in Workstation. The library appears by default.

- **Use the Thumbnail Bar** on page 30
  The thumbnail bar appears along the bottom of the Workstation window.

- **Use the Status Bar** on page 30
  The status bar appears at the bottom of the Workstation window. You can use the icons on the status bar to see Workstation messages and perform actions on devices such as hard disks, CD/DVD drives, floppy drives, and network adapters. The status bar appears by default.

- **Use Workstation Tabs** on page 31
  Workstation creates a tab in the right pane of the Workstation window when you select an item in the library. Tabs appear by default.
Customize the Workstation Window on page 31
You can customize the appearance of the Workstation window by selecting items from the View menu.

Default Hot-Key Combinations on page 32
You can use keyboard shortcuts to interact with Workstation and with virtual machines. Most of the available keyboard shortcuts for Workstation are listed next to their associated commands in Workstation menus.

Use Virtual Machines in the Workstation Window
You interact with virtual machines through the Workstation window.

Procedure
- Use the icons on the Home tab to create a new virtual machine, open an existing virtual machine, connect to a remote server, or view the Workstation help system.
- Select a powered-off virtual machine in the library or click its tab to see the summary view for that virtual machine.
  The summary view shows a summary of configuration information and the virtual machine state. You can power on the virtual machine and edit virtual machine settings from the summary view.
- Select an active virtual machine in the library or click its tab to see the console view.
  The console view is like the monitor display of a physical computer. You can click the console view button on the toolbar to switch between the console and summary views.
- Select a virtual machine in the library and use the VM menu on the menu bar at the top of the Workstation window to perform all virtual machine operations for the selected virtual machine.
  You can use the VM menu when a virtual machine is powered on or off. If an operation is not supported for the virtual machine in its current state, the menu item is not available.
- Select a virtual machine in the library and use the buttons on the toolbar at the top of the Workstation window to perform common virtual machine operations and change the display for the selected virtual machine.
  You can use the buttons on the toolbar to take and manage snapshots, enter full screen and Unity mode, cycle multiple monitors, and switch between the console and summary views.
- When a virtual machine is powered on, use the icons on the status bar at the bottom of the Workstation window to see Workstation messages and perform actions on virtual devices such as hard disks, CD/DVD drives, floppy drives, and network adapters.
  You can click or right-click on a removable device icon to connect or disconnect the device or edit its settings, and you can click the Message log icon to view the message log. Messages include warning information about the virtual machine. If the icon is dimmed, all messages have already been read.
- Select items in the library or use tabs to quickly switch between virtual machines, folders, and remote hosts.

Use the Virtual Machine Library
The virtual machine library appears on the left side of the Workstation window. You use the library to view and select virtual machines, folders, and remote hosts in Workstation. The library appears by default.

Prerequisites
If the library is not visible, select View > Customize > Library.
Procedure
- Right-click a virtual machine, folder, or remote host in the library to view the item’s context menu and perform common operations.
- To find a specific virtual machine in the library, type its name, part of its description, or the name of the guest operating system in the search box.
  For example, to find all of the virtual machines that have a Windows 7 guest operating system, type Windows 7. You can also search for folders and remote hosts.
- To mark a virtual machine or folder as a favorite in the library, right-click it and select Mark as Favorite or click the star icon.
- Use the library drop-down menu to show only powered on virtual machines or favorite items.
  By default, the library shows all items.
- To remove an item from the library, right-click it and select Remove.

Use the Thumbnail Bar
The thumbnail bar appears along the bottom of the Workstation window.
For active virtual machines, Workstation updates the thumbnail in real time to show the actual content of the virtual machine. When a virtual machine is suspended, the thumbnail is a screenshot of the virtual machine at the time that it was suspended.

Prerequisites
If the thumbnail bar is not visible, select View > Customize > Thumbnail Bar.

Procedure
- Click a thumbnail to show the summary or console view for a virtual machine.
- Click thumbnails to quickly switch between virtual machines.
- To change the order of the thumbnails, change the order of the virtual machine tabs.
  Thumbnails appear in the same order as the virtual machine tabs. To move a virtual machine tab, drag and drop it to a new location.
- To change the virtual machines that appear in the thumbnail bar, select Open Virtual Machines or Folder View Virtual Machines from the thumbnail bar drop-down menu.
  The drop-down menu is a down-arrow on the thumbnail bar.

Use the Status Bar
The status bar appears at the bottom of the Workstation window. You can use the icons on the status bar to see Workstation messages and perform actions on devices such as hard disks, CD/DVD drives, floppy drives, and network adapters. The status bar appears by default.

Procedure
- Mouse over an icon on the status bar to see its name.
- Click or right-click on a removable device icon to connect or disconnect the device or edit its settings.
- Click the message log icon to view the message log.
  Messages include warning information about the virtual machine. If the icon is dimmed, all messages have already been read.
Use Workstation Tabs

Workstation creates a tab in the right pane of the Workstation window when you select an item in the library. Tabs appear by default.

Procedure

- Use the links on the Home tab to create a virtual machine, open a virtual machine, connect to a remote server, virtualize a physical machine, use the virtual network editor, customize Workstation preferences, download software updates, and view the help system.
- Use the virtual machine tabs to view virtual machine configuration information, modify virtual machine hardware and option settings, and create or modify the virtual machine description.
- Use the Shared VMs tab to see information about all of the shared virtual machines on the host system.
- Use the tab for a remote host to see information about the remote host, including CPU, memory, and disk usage, and the virtual machines and virtual machine tasks running on the remote host.
- Select File > Close Tab to close a tab.

Customize the Workstation Window

You can customize the appearance of the Workstation window by selecting items from the View menu.

Procedure

1. Select View > Customize and select a Workstation window view.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Library</td>
<td>The virtual machine library appears in the left side of the window. You can use the library to view and select virtual machines, folders, and remote hosts in Workstation. The library appears by default.</td>
</tr>
<tr>
<td>Thumbnail Bar</td>
<td>A thumbnail bar appears at the bottom of the window. Depending on the thumbnail bar option that is selected, the thumbnail bar shows all open virtual machines or the virtual machines in the selected folder.</td>
</tr>
<tr>
<td>Toolbar</td>
<td>A toolbar appears at the top of the window. You can use the icons on the toolbar to start and stop virtual machines, take snapshots, change the display, and perform other common tasks. The toolbar appears by default.</td>
</tr>
<tr>
<td>Status Bar</td>
<td>A status bar appears at the bottom of the window when a virtual machine is selected. You can use the icons on the status bar to see Workstation messages and perform actions on virtual machine devices such as hard disks, CD/DVD drives, floppy drives, and network adapters. The status bar appears by default.</td>
</tr>
<tr>
<td>Tabs</td>
<td>Workstation creates a tab in the right pane when you select an item in the library. Tabs appear by default.</td>
</tr>
</tbody>
</table>

2. To specify which virtual machines appear in the thumbnail bar, select View > Customize > Thumbnail Bar Options.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open Virtual Machines</td>
<td>The thumbnail bar shows thumbnails for all open virtual machines.</td>
</tr>
<tr>
<td>Folder View Virtual Machines</td>
<td>The thumbnail bar shows thumbnails for virtual machines in the selected folder.</td>
</tr>
</tbody>
</table>
Default Hot-Key Combinations

You can use keyboard shortcuts to interact with Workstation and with virtual machines. Most of the available keyboard shortcuts for Workstation are listed next to their associated commands in Workstation menus.

Table 2-4. Default Hot-Key Combinations

<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+G</td>
<td>Grab input from the keyboard and mouse.</td>
</tr>
<tr>
<td>Ctrl+Alt</td>
<td>Release the mouse cursor.</td>
</tr>
<tr>
<td>Ctrl+Alt+Insert</td>
<td>Shut down or, depending on the guest operating system, log out of the guest operating system. This command is received solely by the virtual machine.</td>
</tr>
<tr>
<td>Ctrl+Alt+Delete</td>
<td>Shut down or, depending on the operating system, log out of the guest operating system. On a Windows host, if you do not use the enhanced virtual keyboard feature, both the host operating system and the virtual machine receive this command, even when Workstation has control of input. Cancel the ending of the host operating system session and return to the virtual machine to log out or shut down or perform administrative tasks.</td>
</tr>
<tr>
<td>Ctrl+Alt+Enter</td>
<td>Enter full screen mode.</td>
</tr>
<tr>
<td>Ctrl+Alt+spacebar</td>
<td>Send any command to the virtual machine so that Workstation does not process it. Hold down Ctrl+Alt as you press and release the spacebar, and continue to hold the Ctrl+Alt keys down as you press the next key in the combination.</td>
</tr>
<tr>
<td>Ctrl+Tab</td>
<td>(Windows hosts only) Switch among tabs.</td>
</tr>
<tr>
<td>Ctrl+Shift+Tab</td>
<td>(Windows hosts only) Switch among tabs.</td>
</tr>
<tr>
<td>Ctrl+Alt+right arrow</td>
<td>In full screen mode, switch to the next powered-on virtual machine.</td>
</tr>
<tr>
<td>Ctrl+Alt+left arrow</td>
<td>In full screen mode, switch to the previous powered-on virtual machine.</td>
</tr>
<tr>
<td>Ctrl+Shift+U</td>
<td>In Unity mode, give access to the virtual machine Start or Applications menu. You can change the Unity hot-key combination by modifying Unity preference settings.</td>
</tr>
</tbody>
</table>

You can change the default hot-key combinations by modifying Workstation preference settings. If you change the hot-key settings, substitute your new hot-key combination for Ctrl+Alt. For example, if you change the hot-key combination for common virtual machine operations to Ctrl+Shift, you press Ctrl+Shift instead of Ctrl+Alt to release control from the current virtual machine.

See Using VMware Workstation for information on changing the default hot-key combinations.

Using the Workstation Online Help

The Workstation online help contains information about Workstation settings and common tasks. Use the online help when you need to quickly find information about Workstation preferences, virtual hardware settings, and virtual machine options.

For example, if you are configuring a virtual machine and you need information about a specific hardware setting, click Help on the dialog box that contains the setting. The Help window opens and a context-sensitive help topic appears in the right pane. To see the entire help system, select Help > Help Topics (Windows host) or Help > Contents (Linux host).
Creating Virtual Machines

When you want to create a virtual machine in Workstation, you typically use the New Virtual Machine wizard. You can create a virtual machine in a minimum number of steps by selecting the typical configuration option in the New Virtual Machine wizard.

With Workstation, you can also clone virtual machines from existing virtual machines or virtual machine templates, import Open Virtualization Format (OVF) and third-party virtual machines, create virtual machines that remote Workstation users can use, and create virtual machines on remote hosts. See Using VMware Workstation for information on these advanced features.

This chapter includes the following topics:

- “Understanding Virtual Machines,” on page 33
- “Features of a Typical Virtual Machine,” on page 34
- “Preparing to Create a Typical Virtual Machine,” on page 34
- “Create a Typical Virtual Machine,” on page 38
- “Use Easy Install to Install a Guest Operating System,” on page 39
- “Install a Guest Operating System Manually,” on page 40
- “Installing and Upgrading VMware Tools,” on page 41
- “Install New Software in a Virtual Machine,” on page 49

Understanding Virtual Machines

A virtual machine is a software computer that, like a physical machine, runs an operating system and applications. A virtual machine uses the physical resources of the physical machine on which it runs, which is called the host system. Virtual machines have virtual devices that provide the same functionality as physical hardware, but with the additional benefits of portability, manageability, and security.

A virtual machine has an operating system and virtual resources that you manage in much the same way that you manage a physical computer. For example, you install an operating system in a virtual machine in the same way that you install an operating system on a physical computer. You must have a CD-ROM, DVD, or ISO image that contains the installation files from an operating system vendor.
Features of a Typical Virtual Machine

When you select the typical configuration option in the New Virtual Machine wizard, Workstation creates a virtual machine that has specific hardware and software features. After the virtual machine is created, you can change many of these features by modifying virtual machine settings.

Shared virtual machines and virtual machines that you create on remote hosts do not have the same features as virtual machines that you create on the local host system. See Using VMware Workstation for information on creating shared and remote virtual machines.

Hardware Features

A typical virtual machine has the following hardware features.

- The hardware compatibility of the virtual machine is the same as the default hardware compatibility setting configured in Workstation preferences. By default, the default hardware compatibility setting is the installed Workstation version.
- One processor and one processor per core. Workstation chooses the execution mode for the virtualization engine based on the guest operating system and the host CPU.
- One IDE CD/DVD drive, which is configured to connect at power on and autodetect a physical drive on the host system.
- One floppy drive, which is configured to connect at power on and autodetect a physical drive on the host system.
- One virtual network adapter, which is configured to connect at power on and use network address translation (NAT). With NAT networking, the virtual machine shares the IP address of the host system.
- One USB controller.
- One sound card, which is configured to use the default sound card on the host system.
- One display, which is configured to use the display settings on the host computer.

The options that you select when you create the virtual machine determine the amount of memory that is allocated to the virtual machine, the size of the virtual disk, and whether the virtual disk is split into multiple virtual disk files.

Software Features

A typical virtual machine has the following software features.

- The drag-and-drop and cut and paste features are enabled.
- Shared folders and remote access by VNC clients are disabled.
- The virtual machine is not encrypted.
- VMware Tools must be updated manually.

Preparing to Create a Typical Virtual Machine

When you select the typical configuration option in the New Virtual Machine wizard, you must specify or accept defaults for a few basic virtual machine settings.

- How to install the guest operating system
- A name for the virtual machine and a location for the virtual machine files
- The size of the virtual disk and whether to split the disk into multiple virtual disk files
Whether to customize hardware settings

After you create a typical virtual machine, you can add devices and set up custom network connections.

Selecting a Guest Operating System on page 35

The New Virtual Machine prompts you to select the source media for the operating system that will run inside the virtual machine. You can specify an installer disc inserted in a physical drive, an ISO image file, or you can instruct the New Virtual Machine wizard to create a virtual machine that has a blank hard disk.

Specifying the Virtual Machine Name and File Location on page 36

The New Virtual Machine wizard prompts you for a virtual machine name and a directory for the virtual machine files.

Specifying Disk Capacity for a Virtual Machine on page 37

If you instruct the New Virtual Machine wizard to create a new virtual disk during a custom configuration, the wizard prompts you to set the size of the virtual disk and specify whether to split the disk into multiple virtual disk (.vmdk) files.

Customizing Virtual Machine Hardware on page 37

You can click Customize Hardware on the last page of the New Virtual Machine wizard to customize the virtual machine hardware.

Worksheet for Creating a Typical Virtual Machine on page 37

You can print this worksheet and write the values to specify when you create a typical virtual machine.

Selecting a Guest Operating System

The New Virtual Machine prompts you to select the source media for the operating system that will run inside the virtual machine. You can specify an installer disc inserted in a physical drive, an ISO image file, or you can instruct the New Virtual Machine wizard to create a virtual machine that has a blank hard disk.

If you select an installer disc or an ISO image file and the operating system supports Easy Install, the guest operating system installation is automated and VMware Tools is installed. If the installer disc or ISO image file contains a product key number and is already set up to perform an unattended installation, the only benefit of using Easy Install is the automatic installation of VMware Tools.

NOTE For remote virtual machines, you must specify whether the physical drive or ISO image file is located on the local host or remote host before you select the installer disc or ISO image file.

If you instruct the New Virtual Machine wizard to create a virtual machine that has a blank hard disk, the wizard prompts you to specify an operating system and version and you must install the guest operating system manually after the virtual machine is created. Workstation uses this information to set the appropriate default values, name files associated with the virtual machine, adjust performance settings, and work around special behaviors and bugs in the guest operating system. If the operating system you plan to install is not listed in the wizard, select Other for both the operating system and version.

If you are installing an operating system that supports Easy Install but you do not want to use Easy Install, you can instruct the wizard to create a virtual machine that has a blank disk and install the guest operating system manually.

Providing Easy Install Information

When the New Virtual Wizard detects an operating system that supports Easy Install, the wizard prompts you for information about the guest operating system. After the virtual machine is created, the guest operating system installation is automated and VMware Tools is installed.

For Windows guest operating systems, you must provide the following Easy Install information.
Table 3-1. Easy Install Information for Windows Guests

<table>
<thead>
<tr>
<th>Easy Install Prompt</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows product key</td>
<td>(Optional) Type a product key unless the installation media contains a volume license product key. If you provide a product key here, you are not prompted to provide a product key when you install the guest operating system.</td>
</tr>
<tr>
<td>Version of Windows to install</td>
<td>For Windows Vista, Windows 7, and Windows Server 2008 guest operating systems, select the operating system edition.</td>
</tr>
<tr>
<td>Full name</td>
<td>The name to use to register the guest operating system. Do not use the name Administrator or Guest. If you use one of these names, you must enter a different name when you install the guest operating system.</td>
</tr>
<tr>
<td>Password</td>
<td>(Optional) The password to use for an account with Administrator permissions on Windows operating systems other than Windows 2000. On Windows 2000, this is the password for the Administrator account. On Windows XP Home, an Administrator account without a password is created and you are automatically logged in to the guest operating system.</td>
</tr>
<tr>
<td>Log on automatically (requires a password)</td>
<td>(Optional) Save your login credentials and bypass the login dialog box when you power on the virtual machine. You must enter a name and password to use this feature.</td>
</tr>
</tbody>
</table>

For Linux guest operating systems, you must provide the following Easy Install information.

Table 3-2. Easy Install Information for Linux Guests

<table>
<thead>
<tr>
<th>Prompt</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Full name</td>
<td>The name to use to register the guest operating system, if registration is required. Workstation uses the first name to create the host name for the virtual machine.</td>
</tr>
<tr>
<td>User name</td>
<td>Your user name. You can use lowercase letters, numbers, and dashes, but avoid using user names that begin with a dash. Do not use the name root. Some operating systems set up sudo access for this user and other operating systems require this user to use su to obtain root privileges.</td>
</tr>
<tr>
<td>Password</td>
<td>The password for the User name and the root user.</td>
</tr>
</tbody>
</table>

Specifying the Virtual Machine Name and File Location

The New Virtual Machine wizard prompts you for a virtual machine name and a directory for the virtual machine files.

The name of the default directory for virtual machine files is derived from the name of the guest operating system, for example, Microsoft Windows 7 (32-bit).

For standard virtual machines, the default directory for virtual machine files is located in the virtual machine directory. For best performance, do not place the virtual machines directory on a network drive. If other users need to access the virtual machine, consider placing the virtual machine files in a location that is accessible to those users.

See Using VMware Workstation for descriptions of the virtual machine files.

Virtual Machines Directory

Workstation stores standard virtual machines in the virtual machines directory.

The default location of the virtual machines directory depends on the host operating system.
### Table 3-3. Default Virtual Machines Directory

<table>
<thead>
<tr>
<th>Host Operating System</th>
<th>Default Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows XP</td>
<td>C:\Documents and Settings\username\My Documents\My Virtual Machines</td>
</tr>
<tr>
<td>Windows Server 2003</td>
<td>username is the name of the currently logged in user.</td>
</tr>
<tr>
<td>Windows Vista</td>
<td>C:\Users\username\Documents\Virtual Machines</td>
</tr>
<tr>
<td>Windows 7</td>
<td>username is the name of the currently logged in user.</td>
</tr>
<tr>
<td>Linux</td>
<td>homedir/vmware</td>
</tr>
<tr>
<td></td>
<td>homedir is the home directory of the currently logged in user.</td>
</tr>
</tbody>
</table>

### Specifying Disk Capacity for a Virtual Machine

If you instruct the New Virtual Machine wizard to create a new virtual disk during a custom configuration, the wizard prompts you to set the size of the virtual disk and specify whether to split the disk into multiple virtual disk (.vmdk) files.

A virtual disk is made up of one or more virtual disk files. Virtual disk files store the contents of the virtual machine hard disk drive. Almost all of the file content is virtual machine data. A small portion of the file is allotted to virtual machine overhead. If the virtual machine is connected directly to a physical disk, the virtual disk file stores information about the partitions that the virtual machine is allowed to access.

You can set a size between 0.001GB and 2TB for a virtual disk file. You can also select whether to store a virtual disk as a single file or split it into multiple files.

Select **Split virtual disk into multiple files** if the virtual disk is stored on a file system that has a file size limitation. When you split a virtual disk less than 950GB, a series of 2GB virtual disk files are created. When you split a virtual disk greater than 950GB, two virtual disk files are created. The maximum size of the first virtual disk file is 1.9TB and the second virtual disk file stores the rest of the data.

After you create a virtual machine, you can edit virtual disk settings and add additional virtual disks.

### Customizing Virtual Machine Hardware

You can click **Customize Hardware** on the last page of the New Virtual Machine wizard to customize the virtual machine hardware.

You can change the default hardware settings, including memory allocation, number of virtual CPUs, CD/DVD and floppy drive settings, and the network connection type.

See **Using VMware Workstation** for information on customizing virtual machine hardware.

### Worksheet for Creating a Typical Virtual Machine

You can print this worksheet and write the values to specify when you create a typical virtual machine.

#### Table 3-4. Worksheet: Typical Virtual Machine

<table>
<thead>
<tr>
<th>Option</th>
<th>Write Your Value Here</th>
</tr>
</thead>
<tbody>
<tr>
<td>Guest operating system source</td>
<td></td>
</tr>
<tr>
<td>Guest operating system type for manual installation</td>
<td></td>
</tr>
<tr>
<td>Easy Install information for Windows guests</td>
<td></td>
</tr>
<tr>
<td>- Product key</td>
<td></td>
</tr>
<tr>
<td>- Operating system version</td>
<td></td>
</tr>
<tr>
<td>- Full name</td>
<td></td>
</tr>
<tr>
<td>- Password</td>
<td></td>
</tr>
<tr>
<td>- Credentials for automatic login</td>
<td></td>
</tr>
</tbody>
</table>
Table 3-4. Worksheet: Typical Virtual Machine (Continued)

<table>
<thead>
<tr>
<th>Option</th>
<th>Write Your Value Here</th>
</tr>
</thead>
<tbody>
<tr>
<td>Easy Install information for Linux guests</td>
<td></td>
</tr>
<tr>
<td>- Full name</td>
<td></td>
</tr>
<tr>
<td>- User name</td>
<td></td>
</tr>
<tr>
<td>- Password</td>
<td></td>
</tr>
<tr>
<td>Virtual machine name</td>
<td></td>
</tr>
<tr>
<td>Virtual machine location</td>
<td></td>
</tr>
<tr>
<td>Disk capacity</td>
<td></td>
</tr>
</tbody>
</table>

Create a Typical Virtual Machine

When you select the typical configuration option in the New Virtual Machine wizard, you create a virtual machine in a minimum number of steps.

You must select a custom configuration if you need to create a virtual machine that has a hardware compatibility setting that is different from the default hardware compatibility setting, select the I/O controller type for the SCSI controller, select the virtual disk type, configure a physical disk, or allocate all virtual disk space rather than let disk space gradually increase. See *Using VMware Workstation* for information about creating a custom configuration.

**Prerequisites**

- Verify that you have the information the New Virtual Machine wizard requires to create a typical virtual machine. See “Preparing to Create a Typical Virtual Machine,” on page 34.
- Verify that the guest operating system you plan to install is supported. See the online VMware Compatibility Guide, which is available on the VMware Web site.
- See the *VMware Guest Operating System Installation Guide* for information about the guest operating system that you plan to install.
- If you are installing the guest operating system from an installer disc, insert the installer disc in the CD-ROM drive in the host system.
- If you are installing the guest operating system from an ISO image file, verify that the ISO image file is in a directory that is accessible to the host system.

**Procedure**


<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Windows host</strong></td>
<td>- If the host is not connected to a remote server, select File &gt; New Virtual Machine.</td>
</tr>
<tr>
<td></td>
<td>- If the host is connected to a remote server, select File &gt; New Virtual Machine &gt; On this Computer.</td>
</tr>
<tr>
<td><strong>Linux host</strong></td>
<td>Select File &gt; New Virtual Machine.</td>
</tr>
</tbody>
</table>

2. Select *Typical* to create a typical virtual machine.
Select the source of the guest operating system.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use a physical disc</td>
<td>Select the physical drive where you inserted the installation disc.</td>
</tr>
<tr>
<td>Use an ISO image</td>
<td>Type or browse to the location of the ISO image file.</td>
</tr>
<tr>
<td>Install the guest operating system later</td>
<td>Create a virtual machine that has a blank disk. You must install the guest operating system manually after the virtual machine is created.</td>
</tr>
</tbody>
</table>

Specify information about the guest operating system.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>If you are using Easy Install</td>
<td>Type the Easy Install information for the guest operating system.</td>
</tr>
<tr>
<td>If you are not using Easy Install</td>
<td>Select the guest operating system and version. If the guest operating system is not listed, select Other for both the operating system and version.</td>
</tr>
</tbody>
</table>

Type a virtual machine name and type or browse to the directory for the virtual machine files.

Select the virtual disk size and specify whether to split the disk into multiple files.

(Optional) Click Customize Hardware to customize the hardware configuration. You can also modify virtual hardware settings after you create the virtual machine.

(Optional) Select Power on this virtual machine after creation to power on the virtual machine after it is created.

This option is not available if you are installing the guest operating system manually.

Click Finish to create the virtual machine.

If you are using Easy Install, the guest operating system installation begins when the virtual machine powers on. The guest operating system installation is automated and typically runs without requiring any input from you. After the guest operating system is installed, Easy Install installs VMware Tools.

If you are not using Easy Install, the virtual machine appears in the library.

What to do next

If you used Easy Install and the virtual machine did not power on when the New Virtual Machine wizard finished, power on the virtual machine to start the guest operating system installation. See “Use Easy Install to Install a Guest Operating System,” on page 39.

If you did not use Easy Install, install the guest operating system manually. See “Install a Guest Operating System Manually,” on page 40.

Use Easy Install to Install a Guest Operating System

When you use Easy Install, you usually do not need to provide information during guest operating system installation.

If you did not provide all of the Easy Install information in the New Virtual Machine wizard, you might be prompted for a product key, username, or password.

Also, if the guest operating system installation consists of multiple discs or ISO image files, the installer might prompt you for the next disk.

Procedure

- If the installer prompts you for a product key, username, or password, click in the virtual machine window and type the required information.

Mouse and keyboard input are captured by the virtual machine.
If you are using physical discs and the installer prompts you for the next disk, use the CD-ROM or DVD drive on the host system.

If you are using multiple ISO image files and the installer prompts you for the next disk, select the next ISO image file.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows host</td>
<td>Click Change Disk and browse to the next ISO image file.</td>
</tr>
</tbody>
</table>
| Linux host    | a Select VM > Removable Devices > CD/DVD > Settings and browse to the next ISO image file.  
               | b Select Connected.                                                         |
               | c Click Save.                                                               |

**Install a Guest Operating System Manually**

Installing a guest operating system in a virtual machine is similar to installing an operating system on a physical computer. If you do not use Easy Install when you create a virtual machine in the New Virtual Machine wizard, you must install the guest operating system manually.

You can install a guest operating system from an installer disc or ISO image file. You can also use a PXE server to install the guest operating system over a network connection. If the host configuration does not permit the virtual machine to boot from an installer disc, you can create an ISO image file from the installer disc.

**Prerequisites**

- Verify that the operating system is supported. See the online VMware Compatibility Guide on the VMware Web site.
- See the *VMware Guest Operating System Installation Guide* for information on the guest operating system that you are installing.

**Procedure**

1. If you are installing the guest operating system from an installer disc, configure the virtual machine to use a physical CD-ROM or DVD drive and configure the drive to connect at power on.
   a. Select the virtual machine and select VM > Settings.
   b. On the Hardware tab, select CD/DVD drive.
   c. Select Connect at power on.
   d. (Remote virtual machine only) Select the location of the CD-ROM or DVD drive.
   e. Select Use physical drive and select a the drive.
   f. Click OK to save your changes.

2. If you are installing the guest operating system from an ISO image file, configure the CD/DVD drive in the virtual machine to point to the ISO image file and configure the drive to connect at power on.
   a. Select the virtual machine and select VM > Settings.
   b. On the Hardware tab, select CD/DVD drive.
   c. Select Connect at power on.
   d. (Remote virtual machine only) Select the location of the ISO image file.
   e. Select Use ISO image file and browse to the location of the ISO image file.
   f. Click OK to save your changes.
3 If you are installing the guest operating system from an installer disc, insert the disc in the CD-ROM or DVD drive.

4 Power on the virtual machine.

5 Follow the installation instructions provided by the operating system vendor.

6 If the operating system consists of multiple installer discs and you are prompted to insert the next disc, insert the next disc in the physical drive.

7 If the operating system consists of multiple ISO image files, select the image file for the next CD.
   a Select VM > Removable Devices > CD/DVD > Disconnect and disconnect from the current ISO image file.
   b Select VM > Removable Devices > CD/DVD > Settings and select the next ISO image file.
   c Select Connected and click OK.

8 Use the standard tools in the operating system to configure its settings.

What to do next
Install VMware Tools. You should install VMware Tools before you activate the license for the operating system. See “Installing VMware Tools,” on page 42.

Installing and Upgrading VMware Tools
Installing VMware Tools is part of the process of creating a new virtual machine. Upgrading VMware Tools is part of the process of keeping virtual machines up to current standards.

For the best performance and latest updates, install or upgrade VMware Tools to match the version of Workstation that you are using. Other compatibility options are also available.

See Installing and Configuring VMware Tools for complete information on installing, upgrading, and configuring VMware Tools.

- Installing VMware Tools on page 42
  VMware Tools is a suite of utilities that enhances the performance of the virtual machine’s guest operating system and improves management of the virtual machine.

- Upgrading VMware Tools on page 42
  You can upgrade VMware Tools manually, or you can configure virtual machines to check for and install newer versions of VMware Tools.

- Manually Installing and Upgrading VMware Tools on page 43
  You can manually install or upgrade VMware Tools on Windows, Linux, NetWare, Solaris, and FreeBSD virtual machines.

- Start the VMware User Process Manually If You Do Not Use a Session Manager on page 48
  One of the executables used by VMware Tools in Linux, Solaris, and FreeBSD guest operating systems is the VMware User process. This program implements the fit-guest-to-window feature and Unity mode, among other features.

- Uninstall VMware Tools on page 49
  Occasionally, an upgrade of VMware Tools is incomplete. You can usually solve the problem by uninstalling VMware Tools and then reinstalling.
Installing VMware Tools

VMware Tools is a suite of utilities that enhances the performance of the virtual machine’s guest operating system and improves management of the virtual machine.

Although the guest operating system can run without VMware Tools, many VMware features are not available until you install VMware Tools. For example, if you do not have VMware Tools installed in your virtual machine, you cannot use the shutdown or restart options from the toolbar. You can use only the power options.

You can use the Windows Easy Install or Linux Easy Install feature to install VMware Tools as soon as the operating system is finished installing.

The installers for VMware Tools are ISO image files. An ISO image file looks like a CD-ROM to your guest operating system. There is an ISO image file for each type of guest operating system, including Windows, Linux, Solaris, FreeBSD, and NetWare. When you select the command to install or upgrade VMware Tools, the virtual machine’s first virtual CD-ROM disk drive temporarily connects to the VMware Tools ISO file for your guest operating system.

The most recent versions of the ISO files are stored on a VMware Web site. When you select the command to install or upgrade VMware Tools, the VMware product determines whether it has downloaded the most recent version of the ISO file for the specific operating system. If the latest version has not been downloaded or if no VMware Tools ISO file for that operating system has ever been downloaded, you are prompted to download the file.

The installation procedure varies, depending on the operating system.

Upgrading VMware Tools

You can upgrade VMware Tools manually, or you can configure virtual machines to check for and install newer versions of VMware Tools.

The guest operating system checks the version of VMware Tools when you power on a virtual machine. The status bar of the virtual machine displays a message when a new version is available.

In Windows virtual machines, you can set VMware Tools to notify you when an upgrade is available. If this notification option is enabled, the VMware Tools icon in the Windows taskbar includes a yellow caution icon when a VMware Tools upgrade is available.

To install a VMware Tools upgrade, you can use the same procedure that you used for installing VMware Tools the first time. Upgrading VMware Tools means installing a new version.

For Windows and Linux guest operating systems, you can configure the virtual machine to automatically upgrade VMware Tools. Although the version check is performed when you power on the virtual machine, on Windows guest operating systems, the automatic upgrade occurs when you power off or restart the virtual machine. The status bar displays the message Installing VMware Tools ... when an upgrade is in progress.

**IMPORTANT** When you upgrade VMware Tools on Linux guest operating systems, new network modules are available but are not used until you either reboot the guest operating system or stop networking, unload and re-load the VMware networking kernel modules, and then restart networking. This behavior means that even if VMware Tools is set to automatically upgrade, you must reboot or re-load network modules to make new features available.

This strategy avoids network interruptions and allows you to work with VMware Tools over SSH.

For best performance and the latest updates, install or upgrade VMware Tools to the VMware Tools version that is included with the VMware product you are using. Other compatibility options are also available.
Manually Installing and Upgrading VMware Tools

You can manually install or upgrade VMware Tools on Windows, Linux, NetWare, Solaris, and FreeBSD virtual machines.

If you are installing VMware Tools in a number of Windows virtual machines, you can automate its installation by using the VMware Tools `setup.exe` at a command prompt in the guest operating system. See Installing and Configuring VMware Tools for more information.

- **Manually Install or Upgrade VMware Tools in a Windows Virtual Machine** on page 43
  All supported Windows guest operating systems support VMware Tools.
- **Manually Install or Upgrade VMware Tools in a Linux Virtual Machine** on page 44
  For Linux virtual machines, you manually install or upgrade VMware Tools by using the command line.
- **Manually Install or Upgrade VMware Tools in a NetWare Virtual Machine** on page 46
  For NetWare virtual machines, you manually install or upgrade VMware Tools by using the command line.
- **Manually Install or Upgrade VMware Tools in a Solaris Virtual Machine** on page 46
  For Solaris virtual machines, you manually install or upgrade VMware Tools by using the command line.
- **Manually Install or Upgrade VMware Tools in a FreeBSD Virtual Machine** on page 47
  For FreeBSD virtual machines, you manually install or upgrade VMware Tools by using the command line.

**Manually Install or Upgrade VMware Tools in a Windows Virtual Machine**

All supported Windows guest operating systems support VMware Tools.

Install the latest version of VMware Tools to enhance the performance of the virtual machine's guest operating system and improve virtual machine management. When you power on a virtual machine, if a new version of VMware Tools is available, you see a notification in the status bar of the guest operating system.

For Windows 2000 and later, VMware Tools installs a virtual machine upgrade helper tool. This tool restores the network configuration if you upgrade from virtual hardware version 4 to version 7 or higher.

**Prerequisites**

- Power on the virtual machine.
- Verify that the guest operating system is running.
- If you connected the virtual machine’s virtual CD/DVD drive to an ISO image file when you installed the operating system, change the setting so that the virtual CD/DVD drive is configured to autodetect a physical drive.

  The autodetect setting enables the virtual machine’s first virtual CD/DVD drive to detect and connect to the VMware Tools ISO file for a VMware Tools installation. This ISO file looks like a physical CD to your guest operating system. Use the virtual machine settings editor to set the CD/DVD drive to autodetect a physical drive.

- If the guest operating system is a Windows NT, Windows 2000, Windows XP, Windows Server 2003, Windows Vista, or Windows 7 operating system, log in as an administrator. Any user can install VMware Tools in a Windows 95, Windows 98, or Windows Me guest operating system.

**Procedure**

1. On the host, from the Workstation menu bar, select **VM > Install VMware Tools**.

   If an earlier version of VMware Tools is installed, the menu item is **Update VMware Tools**.
2. If you are installing VMware Tools for the first time, click OK in the Install VMware Tools information screen.

   If autorun is enabled for the CD-ROM drive in the guest operating system, the VMware Tools installation wizard appears.

3. If autorun is not enabled, to manually launch the wizard, click Start > Run and enter D:\setup.exe, where D: is your first virtual CD-ROM drive.

4. Follow the on-screen instructions.

5. If the New Hardware wizard appears, go through the wizard and accept the defaults.

6. If you are installing a beta or RC version of VMware Tools and you see a warning that a package or driver is not signed, click Install Anyway to complete the installation.

7. When prompted, reboot the virtual machine.

**What to do next**

If a new virtual hardware version is available for the virtual machine, upgrade the virtual hardware.

**Manually Install or Upgrade VMware Tools in a Linux Virtual Machine**

For Linux virtual machines, you manually install or upgrade VMware Tools by using the command line.

Install the latest version of VMware Tools to enhance the performance of the virtual machine's guest operating system and improve virtual machine management. When you power on a virtual machine, if a new version of VMware Tools is available, you see a notification in the status bar of the guest operating system.

**Prerequisites**

- Power on the virtual machine.
- Verify that the guest operating system is running.
- Because the VMware Tools installer is written in Perl, verify that Perl is installed in the guest operating system.

**Procedure**

1. On the host, from the Workstation menu bar, select VM > Install VMware Tools.

   If an earlier version of VMware Tools is installed, the menu item is Update VMware Tools.

2. In the virtual machine, log in to the guest operating system as root and open a terminal window.

3. Run the mount command with no arguments to determine whether your Linux distribution automatically mounted the VMware Tools virtual CD-ROM image.

   If the CD-ROM device is mounted, the CD-ROM device and its mount point are listed as something like this:

   /dev/cdrom on /mnt/cdrom type iso9660 (ro,nosuid,nodev)
4 If the VMware Tools virtual CD-ROM image is not mounted, mount the CD-ROM drive.
   a If a mount point directory does not already exist, create it.
      
      ```
      mkdir /mnt/cdrom
      ```
      
      Some Linux distributions use different mount point names. For example, on some distributions the
      mount point is /media/VMware Tools rather than /mnt/cdrom. Modify the command to reflect the
      conventions that your distribution uses.
   
   b Mount the CD-ROM drive.
      
      ```
      mount /dev/cdrom /mnt/cdrom
      ```
      
      Some Linux distributions use different device names or organize the /dev directory differently. If your
      CD-ROM drive is not /dev/cdrom or if the mount point for a CD-ROM is not /mnt/cdrom, modify the
      command to reflect the conventions that your distribution uses.

5 Change to a working directory (for example, /tmp).
   
   ```
   cd /tmp
   ```

6 Delete any previous vmware-tools-distrib directory before you install VMware Tools.
   
   The location of this directory depends on where you placed it during the previous installation. Often this
   directory is placed in /tmp/vmware-tools-distrib.

7 List the contents of the mount point directory and note the filename of the VMware Tools tar installer.
   
   ```
   ls mount-point
   ```

8 Uncompress the installer.
   
   ```
   tar zxf /mnt/cdrom/VMwareTools-x.x.x-yyyy.tar.gz
   ```
   
   The value x.x.x is the product version number, and yyyy is the build number of the product release.
   
   If you attempt to install a tar installation over an RPM installation, or the reverse, the installer detects the
   previous installation and must convert the installer database format before continuing.

9 If necessary, unmount the CD-ROM image.
   
   ```
   umount /dev/cdrom
   ```
   
   If your Linux distribution automatically mounted the CD-ROM, you do not need to unmount the image.

10 Run the installer and configure VMware Tools.
   
   ```
   cd vmware-tools-distrib
   ./vmware-install.pl
   ```
   
   Usually, the vmware-config-tools.pl configuration file runs after the installer file finishes running.

11 Respond to the prompts by pressing Enter to accept the default values, if appropriate for your
    configuration.

12 Follow the instructions at the end of the script.
   
   Depending on the features you use, these instructions can include restarting the X session, restarting
   networking, logging in again, and starting the VMware User process. You can alternatively reboot the
   guest operating system to accomplish all these tasks.

**What to do next**

If a new virtual hardware version is available for the virtual machine, upgrade the virtual hardware.
Manually Install or Upgrade VMware Tools in a NetWare Virtual Machine

For NetWare virtual machines, you manually install or upgrade VMware Tools by using the command line.

Install the latest version of VMware Tools to enhance the performance of the virtual machine's guest operating system and improve virtual machine management. When you power on a virtual machine, if a new version of VMware Tools is available, you see a notification in the status bar of the guest operating system.

**Prerequisites**

- Power on the virtual machine.
- Verify that the guest operating system is running.
- Because the VMware Tools installer is written in Perl, verify that Perl is installed in the guest operating system.

**Procedure**

1. On the host, from the Workstation menu bar, select **VM > Install VMware Tools**.
   
   If an earlier version of VMware Tools is installed, the menu item is **Update VMware Tools**.

2. Load the CD-ROM driver so that the virtual CD-ROM device mounts the ISO image as a volume.

<table>
<thead>
<tr>
<th>Operating System</th>
<th>Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>NetWare 6.5</td>
<td>LOAD CDVD</td>
</tr>
<tr>
<td>NetWare 6.0 or NetWare 5.1</td>
<td>LOAD CD9660.NSS</td>
</tr>
<tr>
<td>NetWare 4.2 (not available in vSphere)</td>
<td>load cdrom</td>
</tr>
</tbody>
</table>

When the installation finishes, the message **VMware Tools for NetWare are now running** appears in the Logger Screen for NetWare 6.5 and NetWare 6.0 guest operating systems and in the Console Screen for NetWare 4.2 and 5.1 operating systems.

3. If the VMware Tools virtual disc (netware.iso) is attached to the virtual machine, right-click the CD-ROM icon in the status bar of the console window and select **Disconnect** to disconnect it.

**What to do next**

If a new virtual hardware version is available for the virtual machine, upgrade the virtual hardware.

Manually Install or Upgrade VMware Tools in a Solaris Virtual Machine

For Solaris virtual machines, you manually install or upgrade VMware Tools by using the command line.

Install the latest version of VMware Tools to enhance the performance of the virtual machine's guest operating system and improve virtual machine management. When you power on a virtual machine, if a new version of VMware Tools is available, you see a notification in the status bar of the guest operating system.

**Prerequisites**

- Power on the virtual machine.
- Verify that the guest operating system is running.
- Because the VMware Tools installer is written in Perl, verify that Perl is installed in the guest operating system.

**Procedure**

1. On the host, from the Workstation menu bar, select **VM > Install VMware Tools**.
   
   If an earlier version of VMware Tools is installed, the menu item is **Update VMware Tools**.
In the virtual machine, log in to the guest operating system as root and open a terminal window.

If the Solaris volume manager does not mount the CD-ROM under 
 `/cdrom/vmwaretools`, restart the volume manager.

/etc/init.d/volmgt stop
/etc/init.d/volmgt start

Change to a working directory (for example, `/tmp`).

cd /tmp

Extract VMware Tools.

gunzip -c /cdrom/vmwaretools/vmware-solaris-tools.tar.gz | tar xf -

Run the installer and configure VMware Tools.

cd vmware-tools-distrib
./vmware-install.pl

Usually, the `vmware-config-tools.pl` configuration file runs after the installer file finishes running.

Respond to the prompts by pressing Enter to accept the default values, if appropriate for your configuration.

Follow the instructions at the end of the script.

Depending on the features you use, these instructions can include restarting the X session, restarting networking, logging in again, and starting the VMware User process. You can alternatively reboot the guest operating system to accomplish all these tasks.

**What to do next**

If a new virtual hardware version is available for the virtual machine, upgrade the virtual hardware.

**Manually Install or Upgrade VMware Tools in a FreeBSD Virtual Machine**

For FreeBSD virtual machines, you manually install or upgrade VMware Tools by using the command line.

Install the latest version of VMware Tools to enhance the performance of the virtual machine's guest operating system and improve virtual machine management. When you power on a virtual machine, if a new version of VMware Tools is available, you see a notification in the status bar of the guest operating system.

**Prerequisites**

- Power on the virtual machine.
- Verify that the guest operating system is running.
- Because the VMware Tools installer is written in Perl, verify that Perl is installed in the guest operating system.

**Procedure**

1. On the host, from the Workstation menu bar, select **VM > Install VMware Tools**.

   If an earlier version of VMware Tools is installed, the menu item is **Update VMware Tools**.

2. In the virtual machine, log in to the guest operating system as root and open a terminal window.

3. If the distribution does not automatically mount CD-ROMs, mount the VMware Tools virtual CD-ROM image.

   For example, type `mount /cdrom`. 

4 Change to a working directory (for example, /tmp).
   cd /tmp

5 Untar the VMware Tools tar file.
   tar zxfp /cdrom/vmware-freebsd-tools.tar.gz

6 If the distribution does not use automounting, unmount the VMware Tools virtual CD-ROM image.
   umount /cdrom

7 Run the installer and configure VMware Tools.
   cd vmware-tools-distrib
   ./vmware-install.pl
   
   Usually, the vmware-config-tools.pl configuration file runs after the installer file finishes running.

8 Respond to the prompts by pressing Enter to accept the default values, if appropriate for your configuration.

9 Follow the instructions at the end of the script.
   
   Depending on the features you use, these instructions can include restarting the X session, restarting networking, logging in again, and starting the VMware User process. You can alternatively reboot the guest operating system to accomplish all these tasks.

What to do next

If a new virtual hardware version is available for the virtual machine, upgrade the virtual hardware.

Start the VMware User Process Manually If You Do Not Use a Session Manager

One of the executables used by VMware Tools in Linux, Solaris, and FreeBSD guest operating systems is the VMware User process. This program implements the fit-guest-to-window feature and Unity mode, among other features.

Normally, this process is started automatically after you configure VMware Tools and then log out of the desktop environment and log back in. You must start the process manually in the following environments:

- If you run an X session without a session manager (for example, by using startx and getting a desktop and not using xdm, kdm, or gdm).
- If you are using certain older versions of GNOME without gdm or xdm.
- If you are using any session manager or environment that does not support the Desktop Application Autostart Specification, available from http://standards.freedesktop.org.
- If you upgrade VMware Tools.

Procedure

- To have the VMware User process start when you start an X session, add vmware-user to the appropriate X startup script, such as the .xsession or .xinitrc file.

  The vmware-user program is located in the directory where you selected to install binary programs, which defaults to /usr/bin. The startup script that needs to be modified depends on your particular system.

- To start the process after a VMware Tools software upgrade or if you notice certain features are not working, open a terminal window and enter the vmware-user command.
Uninstall VMware Tools

Occasionally, an upgrade of VMware Tools is incomplete. You can usually solve the problem by uninstalling VMware Tools and then reinstalling.

Prerequisites

- Power on the virtual machine.
- Log in to the guest operating system.

Procedure

- Use the appropriate operating-system-specific procedure to uninstall VMware Tools.

<table>
<thead>
<tr>
<th>Operating System</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows 7</td>
<td>Use the guest operating system’s Programs &gt; Uninstall a program item.</td>
</tr>
<tr>
<td>Windows Vista and Windows Server 2008</td>
<td>Use the guest operating system’s Programs and Features &gt; Uninstall a program item.</td>
</tr>
<tr>
<td>Windows XP and earlier</td>
<td>Use the guest operating system’s Add/Remove Programs item.</td>
</tr>
<tr>
<td>Linux</td>
<td>On a Linux guest operating system that has VMware Tools installed by using an RPM installer, enter the following command in a terminal window: <code>rpm -e VMwareTools</code>.</td>
</tr>
<tr>
<td>Linux, Solaris, FreeBSD, NetWare</td>
<td>Log in as root and enter the following command in a terminal window: <code>vmware-uninstall-tools.pl</code>.</td>
</tr>
<tr>
<td>Mac OS X Server</td>
<td>Use the Uninstall VMware Tools application, found in /Library/Application Support/VMware Tools.</td>
</tr>
</tbody>
</table>

What to do next

Reinstall VMware Tools.

Install New Software in a Virtual Machine

Installing new software in a virtual machine is similar to installing new software on a physical computer. Only a few additional steps are required.

Prerequisites

- Verify that VMware Tools is installed in the guest operating system. Installing VMware Tools before installing the software minimizes the likelihood that you will have to reactivate the software if the virtual machine configuration changes.
- Verify that the virtual machine has access to the CD-ROM drive, ISO image file, or floppy drive where the installation software is located.

Procedure

1. Select the virtual machine and select VM > Settings.
2. On the Hardware tab, select Memory, set the final memory size for the virtual machine, and click OK.

   Some applications use a product activation feature that creates a key based on the virtual hardware in the virtual machine where it is installed. Changes in the configuration of the virtual machine might require you to reactivate the software. Setting the memory size minimizes the number of significant changes.

3. Install the new software according to the manufacturer’s instructions.
Using Virtual Machines

When you use a virtual machine in Workstation, you can transfer files and text between the host system and the virtual machine, print to host printers, connect removable devices, and change display settings.

You can also use folders to organize and manage virtual machines, and take snapshots to preserve virtual machine states.

With more advanced Workstation features, you can map virtual disks, set up shared folders to share files between virtual machines and between virtual machines and the host system, share virtual machines with remote users, and use virtual machines on remote hosts. See Using VMware Workstation for complete information on these and other advanced features.

This chapter includes the following topics:

- “Start a Virtual Machine,” on page 51
- “Shut Down a Virtual Machine,” on page 52
- “Pause and Unpause a Virtual Machine,” on page 53
- “Suspend and Resume a Virtual Machine,” on page 54
- “Using the Drag-and-Drop Feature,” on page 55
- “Using the Copy and Paste Feature,” on page 55
- “Add a Host Printer to a Virtual Machine,” on page 56
- “Use a Removable Device in a Virtual Machine,” on page 56
- “Changing the Virtual Machine Display,” on page 58
- “Using Folders to Manage Virtual Machines,” on page 62
- “Taking Snapshots of Virtual Machines,” on page 64
- “Closing Virtual Machines and Exiting Workstation,” on page 69

Start a Virtual Machine

You can start a virtual machine from the VM menu or from the toolbar. When you use the VM menu, you can select a soft or hard power option or start the virtual machine in BIOS setup mode.

When virtual machines are in a folder, you can perform batch power operations. See “Using Folders to Manage Virtual Machines,” on page 62.

When you use Workstation to connect to a remote server, you can start virtual machines on a remote host. See Using VMware Workstation for information on using remote virtual machines.
Prerequisites

If the virtual machine does not appear in the library, select File > Open and browse to the virtual machine configuration (.vmx) file.

Procedure

- To select a power option when you start the virtual machine, select the virtual machine and select VM > Power.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Power On</td>
<td>(Hard option) Workstation starts the virtual machine.</td>
</tr>
<tr>
<td>Start Up Guest</td>
<td>(Soft option) Workstation starts the virtual machine and VMware Tools runs a script in the guest operating system. On Windows guests, if the virtual machine is configured to use DHCP, the script renews the IP address of the virtual machine. On a Linux, FreeBSD, or Solaris guest, the script starts networking for the virtual machine.</td>
</tr>
<tr>
<td>Power On to BIOS</td>
<td>Workstation starts the virtual machine in BIOS setup mode.</td>
</tr>
</tbody>
</table>

- To start the virtual machine from the toolbar, select the virtual machine and click the start button.

The start power control setting that is configured for the virtual machine determines whether Workstation performs a hard or soft power on operation. The configured behavior appears in a tooltip when you mouse over the button.

What to do next

Click anywhere inside the virtual machine console to give the virtual machine control of the mouse and keyboard.

Shut Down a Virtual Machine

You can shut down a virtual machine from the VM menu or from the toolbar. When you use the VM menu, you can select a hard or soft power option.

You are not required to power off a virtual machine that is running on the local host system before you exit Workstation. You can exit Workstation and leave the virtual machine running in the background. See “Closing Virtual Machines and Exiting Workstation,” on page 69.

When virtual machines are in a folder, you can perform batch power operations. See “Using Folders to Manage Virtual Machines,” on page 62.

Procedure

- To select a power option when you shut down the virtual machine, select the virtual machine and select VM > Power.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Power Off</td>
<td>(Hard option) Workstation powers off the virtual machine abruptly with no consideration for work in progress.</td>
</tr>
<tr>
<td>Shut Down Guest</td>
<td>(Soft option) Workstation sends a shut down signal to the guest operating system. An operating system that recognizes the signal shuts down gracefully. Not all guest operating systems respond to a shutdown signal from Workstation. If the guest operating system does not respond to the signal, shut down from the guest operating system as you would a physical machine.</td>
</tr>
</tbody>
</table>
To shut down the virtual machine from the toolbar, select the virtual machine and click the stop button. The stop power control setting that is configured for the virtual machine determines whether Workstation performs a hard or soft power off operation. The configured behavior appears in a tooltip when you mouse over the button.

### Pause and Unpause a Virtual Machine

You can pause a virtual machine multiple times for a few seconds, or up to several minutes. The pause feature is useful when a virtual machine is engaged in a lengthy, processor-intensive activity that prevents you from using the host system to do a more immediate task.

**Note** You cannot pause a remote virtual machine.

**Prerequisites**

Familiarize yourself with the restrictions and limitations of the pause feature. See “Pause Feature Restrictions and Limitations,” on page 53.

**Procedure**

- To pause a virtual machine, select the virtual machine and select **VM > Pause**.

  The virtual machine display dims and a play button appears over the display. Paused virtual machines that are configured to display on more than one monitor have a play button on each monitor.

- To pause all of the powered-on virtual machines without interacting with the Workstation user interface, right-click the virtual machine status icon located in the notification area on the task bar of the host computer and select **Pause All Virtual Machines**.

- To unpause a virtual machine, click the play button on the virtual machine display or deselect **VM > Pause**.

**Pause Feature Restrictions and Limitations**

The pause feature has certain restrictions and limitations.

- You cannot switch to Unity mode when a virtual machine is paused.
- When paused, a virtual machine does not send or receive network packets. If a virtual machine is paused for more than a few minutes, some network connections might be interrupted.
- If you take a snapshot when the virtual machine is paused, the virtual machine is not paused when you restore that snapshot. Similarly, if you suspend a virtual machine while it is paused, it is not paused when you resume the virtual machine.
- If you initiate soft power operations when a virtual machine is paused, those operations do not take effect until the virtual machine is unpause.
- While a virtual machine is paused, LEDs and devices remain enabled, but device connection changes do not take effect until the virtual machine is unpause.
- You cannot pause a remote virtual machine.
Suspend and Resume a Virtual Machine

You suspend a virtual machine when you want to save its current state. When you resume the virtual machine, applications that were running before the virtual machine was suspended resume in their running state and their content is unchanged.

How quickly the suspend and resume operations perform depends on the how much data changed after you started the virtual machine. The first suspend operation typically takes longer than subsequent suspend operations. When you suspend a virtual machine, Workstation creates a virtual machine suspended state (.vmss) file in the working directory.

After you resume a virtual machine and do more work, you cannot return to the state that the virtual machine was in when you suspended it. To return to the same state repeatedly, you must take a snapshot.

When virtual machines are in a folder, you can perform batch power operations. See “Using Folders to Manage Virtual Machines,” on page 62.

Procedure

To select a suspend option when you suspend a virtual machine, select the virtual machine and select VM > Power.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Suspend</td>
<td>(Hard option) Workstation suspends the virtual machine and leaves it connected to the network.</td>
</tr>
<tr>
<td>Suspend Guest</td>
<td>(Soft option) Workstation suspends the virtual machine and disconnects it from the network. VMware Tools runs a script in the guest operating system. On Windows guests, if the virtual machine is configured to use DHCP, the script releases the IP address of the virtual machine. On Linux, FreeBSD, and Solaris guests, the script stops networking for the virtual machine.</td>
</tr>
</tbody>
</table>

To suspend a virtual machine from the toolbar, select the virtual machine and click the suspend button.

The suspend power control setting that is configured for the virtual machine determines whether Workstation performs a hard or soft suspend operation. The configured behavior appears in a tooltip when you mouse over the button.

To select a resume option when you resume a suspended virtual machine, select the virtual machine and select VM > Power.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resume</td>
<td>(Hard option) Workstation resumes the virtual machine from the suspended state.</td>
</tr>
<tr>
<td>Resume Guest</td>
<td>(Soft option) Workstation resumes the virtual machine from the suspended state and reconnects it to the network.</td>
</tr>
</tbody>
</table>

To resume a virtual machine from the toolbar, select the virtual machine and click the resume button.

The suspend power control setting that is configured for the virtual machine determines whether Workstation performs a hard or soft resume operation. The configured behavior appears in a tooltip when you mouse over the button.
Using the Drag-and-Drop Feature

You can use the drag-and-drop feature to move files and directories, email attachments, plain text, formatted text, and images between the host system and virtual machines. Dragging email attachments is especially useful in Unity mode.

You can drag files or directories between the following locations:

- File managers, such as Windows Explorer, on the host system and virtual machines.
- A file manager to an application that supports drag-and-drop.
- Applications, such as zip file managers, which support drag-and-drop extraction of individual files.
- Different virtual machines.

When you drag a file or folder between the host and a virtual machine, Workstation copies the file or folder to the location where you drop it. For example, if you drop a file on the desktop icon of a word processor, the word processor opens a copy of the original file. The original file does not include changes that you make to the copy.

Initially, the application opens a copy of the file that is stored in the temp directory. On Windows, the temp directory is specified in the %TEMP% environment variable. On Linux and Solaris, the temp directory is /tmp/VMwareDnD. Save the file in a different directory to protect changes that you make.

Drag-and-Drop Requirements and Restrictions

The drag-and-drop feature has certain requirements and restrictions.

- You must install VMware Tools in a virtual machine to use the drag-and-drop feature.
- The drag-and-drop feature requires Linux hosts and guests to run X Windows and Solaris 10 guests to run an Xorg X server and JDS/Gnome.
- You can drag images between applications on Windows hosts and applications on Windows guests only. Dragging images is not supported for Linux hosts or guests.
- You can drag files and directories, email attachments, plain text, and formatted text between Linux and Windows hosts and Linux, Windows, and Solaris 10 guests only.
- Dragging email attachments is restricted to images or files smaller than 4MB.
- Dragging plain text and formatted text (including the formatting) is restricted to amounts less than 4MB.
- Dragging text is restricted to text in languages that can be represented by Unicode characters.
- Workstation uses the PNG format to encode images that are dragged. Dragging images is restricted to images smaller than 4MB after conversion to PNG format.
- On Windows 95 and Windows 98 guests, the drag-and-drop feature is supported only for files and directories.

Using the Copy and Paste Feature

You can cut, copy, and paste text between virtual machines and between applications running in virtual machines.

You can also cut, copy, and paste images, plain text, formatted text, and email attachments between applications running on the host system and applications running in virtual machines.

Copying and pasting email attachments is especially useful in Unity mode. Use the normal hot keys or menu choices to cut or copy and paste.
Copy and Paste Requirements and Restrictions

The copy and paste feature has certain requirements and restrictions.

- You must install VMware Tools in a virtual machine to use the copy and paste feature.
- The copy and paste feature works with Linux and Windows hosts and Linux, Windows, and Solaris 10 guests only.
- The copy and paste feature requires Linux hosts and guests to run X Windows and Solaris 10 guests to run an Xorg X server and JDS/Gnome.
- Copying and pasting email attachments is restricted to images or files smaller than 4MB.
- Copying and pasting plain text and formatted text (including the formatting) is restricted to amounts less than 4MB.
- Copying and pasting text is restricted to text in languages that can be represented by Unicode characters.
- Workstation uses the PNG format to encode images that are copied and pasted. Copying and pasting images is restricted to images smaller than 4MB after conversion to PNG format.
- You cannot copy and paste files between virtual machines.
- On Windows 95 and Windows 98 guests, copying and pasting is restricted to plain text in amounts less than 64KB.

Add a Host Printer to a Virtual Machine

You can print from a virtual machine to any printer available to the host computer without having to install additional drivers in the virtual machine.

The Workstation printer feature uses ThinPrint technology to replicate the host system printer mapping in the virtual machine. When you enable the virtual machine printer, Workstation configures a virtual serial port to communicate with the host printers.

**NOTE** You cannot add a printer to a shared or remote virtual machine.

**Procedure**

1. Select the virtual machine and select **VM > Settings**.
2. On the **Hardware** tab, select **Add**.
3. In the Add Hardware wizard, select **Printer** and **Finish**.

   The default device setting is to connect the virtual machine printer when the virtual machine is powered on.

**What to do next**

In a Print window, when you attempt to select a printer in Windows 7 virtual machines, you might see only the default printer, even though other printers are available. To see the other printers, right-click the default printer and point to **Printer properties**.

Use a Removable Device in a Virtual Machine

You can connect and disconnect removable devices in a virtual machine. You can also change the settings for a removable device by modifying virtual machine settings.

**Prerequisites**

- Power on the virtual machine.
If you are connecting or disconnecting a USB device, familiarize yourself with the way Workstation handles USB devices. See “Connecting USB Devices to Virtual Machines,” on page 57.

If you are connecting or disconnecting a USB device on a Linux host and the USB device file system is not located in /proc/bus/usb, mount the USB file system to that location. See “Mount the USB File System on a Linux Host,” on page 57.

Procedure

- To connect a removable device, select the virtual machine, select VM > Removable Devices, select the device, and select Connect.

  If the device is connected to the host system through a USB hub, the virtual machine sees only the USB device, not the hub.

  A check mark appears next to the name of the device when the device is connected to the virtual machine and a device icon appears on the virtual machine taskbar.

- To change the settings for a removable device, select VM > Removable Devices, select the device, and select Settings.

- To disconnect a removable device, select the virtual machine, select VM > Removable Devices, select the device, and select Disconnect.

  You can also disconnect the device by clicking or right-clicking the device icon on the virtual machine taskbar. Using the taskbar icon is especially useful if you run the virtual machine in full screen mode.

Connecting USB Devices to Virtual Machines

When a virtual machine is running, its window is the active window. If you plug a USB device into the host system, the device connects to the virtual machine instead of the host by default. If a USB device connected to the host system does not connect to a virtual machine at power on, you must manually connect the device to the virtual machine.

When you connect a USB device to a virtual machine, Workstation retains the connection to the affected port on the host system. You can suspend or power off the virtual machine, or unplug the device. When you plug in the device again or resume the virtual machine, Workstation reconnects the device. Workstation retains the connection by writing an autoconnect entry to the virtual machine configuration (.vmx) file.

If Workstation cannot reconnect to the device, for example, because you disconnected the device, the device is removed and Workstation displays a message to indicate that it cannot connect to the device. You can connect to the device manually if it is still available.

Follow the device manufacturer’s procedures for unplugging the device from the host computer when you physically unplug the device, move the device from host system to a virtual machine, move the device between virtual machines, or move the device from a virtual machine to the host computer. Following these procedures is especially important for data storage devices, such as zip drives. If you move a data storage device too soon after saving a file and the operating system did not actually write the data to the disk, you can lose data.

Mount the USB File System on a Linux Host

On Linux hosts, Workstation uses the USB device file system to connect to USB devices. If the USB device file system is not located in /proc/bus/usb, you must mount the USB file system to that location.

**IMPORTANT** Do not attempt to add a USB drive device node directory, for example, /dev/sda, to the virtual machine as a hard disk.

**Prerequisites**

Verify that you have root access to the host system.
Procedure

1. As root, mount the USB file system.
   
   mount -t usbfs none /proc/bus/usb

2. Connect the USB device to the host system.

Changing the Virtual Machine Display

You can change the way Workstation displays virtual machines and virtual machine applications. You can use full screen mode to make the virtual machine display fill the screen and use multiple monitors, and you can use Unity mode to display applications directly on the host system desktop.

- Use Full Screen Mode on page 58
  In full screen mode, the virtual machine display fills the screen and you cannot see the borders of the Workstation window.

- Use Exclusive Mode on page 59
  Like full screen mode, exclusive mode causes the Workstation virtual machine display to fill the screen. You might want to use exclusive mode to run graphics-intensive applications, such as games, in full screen mode.

- Use Unity Mode on page 60
  You can switch virtual machines that have Linux or Windows 2000 or later guest operating systems to Unity mode to display applications directly on the host system desktop.

- Use Multiple Monitors for One Virtual Machine on page 61
  If the host system has multiple monitors, you can configure a virtual machine to use multiple monitors. You can use the multiple-monitor feature when the virtual machine is in full screen mode.

- Use Multiple Monitors for Multiple Virtual Machines on page 61
  If the host system has multiple monitors, you can run a different virtual machine on each monitor.

Use Full Screen Mode

In full screen mode, the virtual machine display fills the screen and you cannot see the borders of the Workstation window.

You can configure the guest operating system to report battery information. This feature is useful when you run a virtual machine in full screen mode on a laptop. See “Report Battery Information in the Guest,” on page 59.

Prerequisites

- Verify that the latest version of VMware Tools is installed in the guest operating system.
- Verify that the guest operating system display mode is larger than the host system display mode. If the guest operating system display mode is smaller than the host system display mode, you might not be able to enter full screen mode. If you cannot enter full screen mode, add the line mks.maxRefreshRate=1000 to the virtual machine configuration (.vmx) file.

- Power on the virtual machine.

- If you have multiple monitors, move the Workstation window onto the monitor to use for full screen mode.

Procedure

- To enter full screen mode, select the virtual machine and select View > Full Screen.
Press Ctrl+Alt+right arrow to switch to the next powered-on virtual machine and Ctrl+Alt+left arrow to switch to the previous powered-on virtual machine.

Use the left and right arrows on the full screen toolbar to switch among tabs.

To hide the full screen toolbar while you are using full screen mode, click the push pin icon on the full screen toolbar and move the mouse pointer off of the toolbar.

The toolbar is unpinned and slides up to the top of the monitor and disappears.

To show the full screen toolbar after it has been hidden, point to the top of the screen until the toolbar appears and click the push pin icon.

To exit full screen mode, select View > Full Screen on the full screen toolbar and deselect Full Screen.

Report Battery Information in the Guest

If you run a virtual machine on a laptop in full screen mode, configure the option to report battery information in the guest so that you can determine when the battery is running low.

Prerequisites

Power off the virtual machine.

Procedure

1. Select the virtual machine and select VM > Settings.
2. On the Options tab, select Power.
3. Select Report battery information to guest.
4. Click OK to save your changes.

Use Exclusive Mode

Like full screen mode, exclusive mode causes the Workstation virtual machine display to fill the screen. You might want to use exclusive mode to run graphics-intensive applications, such as games, in full screen mode. Exclusive mode has certain advantages and limitations.

- The full screen toolbar is not engaged when you move the mouse to the top of the screen. To configure virtual machine settings, you must exit exclusive mode.
- When input is grabbed by the virtual machine, only the ungrab shortcut is respected. You can change the ungrab shortcut to reduce the chance of unintentionally pressing it.
- On a Windows host, exclusive mode does not use multiple monitors.

Prerequisites

- Verify that the latest version of VMware Tools is installed in the guest operating system.
- Power on the virtual machine.
- If you have multiple monitors, move the Workstation window onto the monitor to use for exclusive mode.
- Enter full screen mode. See “Use Full Screen Mode,” on page 58.

Procedure

- To enter exclusive mode, select View > Exclusive Mode from the full screen toolbar.
- To exit exclusive mode, press Ctrl+Alt.

On a Windows host, pressing Ctrl+Alt also exits full screen mode. On a Linux host, pressing Ctrl+Alt returns to full screen mode.
Use Unity Mode

You can switch virtual machines that have Linux or Windows 2000 or later guest operating systems to Unity mode to display applications directly on the host system desktop.

In Unity mode, virtual machine applications appear on the host system desktop, you can use the virtual machine Start or Applications menu from the host system, and the virtual machine console view is hidden. Items for open virtual machine applications appear on the host system taskbar in the same way as open host applications.

On host system and virtual machine applications that are displayed in Unity mode, you can use keyboard shortcuts to copy, cut, and paste images, plain text, formatted text, and email attachments between applications. You can also drag and drop and copy and paste files between the host system and the guest operating system.

If you save a file or attempt to open a file from an application in Unity mode, the file system you see is the file system inside the virtual machine. You cannot open a file from the host operating system or save a file to the host operating system.

For some guest operating systems, application windows in Unity mode can appear only on the monitor that is set as the primary display when you have multiple monitors. If the host and guest operating systems are Windows XP or later, the application windows can appear on additional monitors.

Unity mode is not available in full screen mode on Windows.

**NOTE** You cannot use Unity mode with a remote virtual machine.

Prerequisites

- Verify that the virtual machine is a Workstation 6.x or later virtual machine.
- Verify that the latest version of VMware Tools is installed in the guest operating system.
- Verify that the guest operating system is Linux or Windows 2000 or later.
- For Linux guests and hosts, verify that a modern version of Metacity or KDE is installed. Performance on Linux depends on a combination of variables such as the system, the applications that are running, and the amount of RAM.
- Power on the virtual machine.
- If you are entering Unity mode, open applications in the virtual machine to use in Unity mode.

Procedure

- To enter Unity mode, select the virtual machine and select View > Unity.
  
  The console view in the Workstation window is hidden, and open applications appear in application windows on the host system desktop. A check mark appears next to Unity in the View menu.

- To display the virtual machine Start menu on a Windows host system, point to the Start menu on a Windows host system.

- To display the virtual machine Applications menu on a Linux host system, point to the upper-left corner of the primary monitor on the Linux host system.

- To navigate between multiple Start or Applications menus when multiple virtual machines are in Unity mode, press the arrow keys, Tab, or Shift+Tab to cycle through the virtual machine menus and press Enter and the spacebar to select a virtual machine.

- To exit Unity mode, select View > Unity and deselect Unity.
Use Multiple Monitors for One Virtual Machine

If the host system has multiple monitors, you can configure a virtual machine to use multiple monitors. You can use the multiple-monitor feature when the virtual machine is in full screen mode.

**NOTE** You do not need to use the Windows display properties settings in a Windows guest operating system to configure multiple monitors.

**Prerequisites**

- Verify that the virtual machine is a Workstation 6.x or later virtual machine.
- Verify that the latest version of VMware Tools is installed in the guest operating system.
- Verify that the guest operating system is Windows XP, Windows Vista, Windows 7, or Linux.
- Power off the virtual machine.

**Procedure**

1. Select **Edit > Preferences**.
2. Select **Display**, select **Autofit guest**, and click **OK**.
   
   This setting causes the virtual machine display settings to match the application window when the application window is resized.
3. If the virtual machine is set to be restored from a snapshot and background snapshots are enabled, select **Edit > Preferences**, select **Priority**, deselect **Take and restore snapshots in the background**, and click **OK**.
   
   Displaying the virtual machine on two monitors might not work correctly if this setting is enabled.
4. Power on the virtual machine and select **View > Full Screen**.
5. On the full screen toolbar, click the **Cycle multiple monitors** button.
   
   On a Windows host, you can mouse over a button on the toolbar to see its name.
   
   The guest operating system desktop extends to the additional monitor or monitors.
6. If the virtual machine display does not resize correctly, select **View > Autosize > Autofit Guest**.
7. If the host system has more than two monitors and you want the virtual machine to use all of the monitors, click the **Cycle multiple monitors** button again.
   
   The order in which the virtual machine uses the monitors depends on the order in which the monitors were added to the host operating system. If you continue to click the button, you return to fewer monitors.

Use Multiple Monitors for Multiple Virtual Machines

If the host system has multiple monitors, you can run a different virtual machine on each monitor.

**Prerequisites**

Verify that the latest version of VMware Tools is installed in the guest operating system.
Procedure

1. Open a second Workstation window.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open a new Workstation window from Workstation</td>
<td>Select File &gt; New Window. On Linux hosts, the windows operate in a single Workstation process.</td>
</tr>
<tr>
<td>(Linux hosts only) Run a separate Workstation process in a different X server</td>
<td>Use the <code>vmware</code> command with the <code>-W</code> flag, for example, <code>vmware -W &amp;</code>.</td>
</tr>
</tbody>
</table>

2. Start one or more virtual machines in each Workstation window.

3. Drag each Workstation window to the monitor on which you want to use it.

   If a virtual machine is running in one Workstation window and you want to run that virtual machine in another Workstation window, you must close the virtual machine in the first window before you attempt to open it in the other window.

4. To switch mouse and keyboard input from the virtual machine on the first monitor to the virtual machine on the second monitor, move the mouse pointer from one screen to the other screen and click inside the second monitor.

Using Folders to Manage Virtual Machines

You can use folders to organize and manage multiple virtual machines in the library. When virtual machines are in a folder, you can manage them on the folder tab and perform batch power operations.

- **Add a Virtual Machine to a Folder** on page 63
  
  When you add a virtual machine to a folder, it remains an independent entity, but you can also perform batch power operations. For example you can power on, suspend, and resume each virtual machine in a folder separately, or you can power on, suspend, and resume all of the virtual machines in a folder at the same time.

- **Remove a Virtual Machine from a Folder** on page 63
  
  You can remove a virtual machine from a folder or move it to a different folder or subfolder.

- **Manage Virtual Machines in a Folder** on page 63
  
  When virtual machines are in a folder, you can manage them as a unit. For example, you can select multiple virtual machines on the folder tab and perform power operations on several virtual machines at the same time.

- **Change the Power On Delay** on page 64
  
  By default, when you power on several virtual machines in a folder, Workstation delays 10 seconds before powering on the next virtual machine. The power on delay avoids overloading the CPU on the host system when you power on multiple virtual machines. You can change the default power on delay setting by modifying a Workstation preference.

- **Convert a Team** on page 64
  
  If you created a team in an earlier version of Workstation, you must convert the team before you can use the virtual machines in the current version of Workstation.
Add a Virtual Machine to a Folder

When you add a virtual machine to a folder, it remains an independent entity, but you can also perform batch power operations. For example, you can power on, suspend, and resume each virtual machine in a folder separately, or you can power on, suspend, and resume all of the virtual machines in a folder at the same time.

Procedure

1. If the folder does not already exist, create it.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create a folder at the top level of the library</td>
<td>Right-click My Computer, select New Folder, and type a name for the folder. The folder appears under My Computer in the library.</td>
</tr>
<tr>
<td>Create a subfolder</td>
<td>Right-click the folder, select New Folder, and type a name for the folder. The new folder appears under the folder in the library.</td>
</tr>
</tbody>
</table>

You can create an unlimited number of folders or subfolders.

2. To add a virtual machine to a folder, select the virtual machine in the library and drag it to the folder.

The virtual machine appears under the folder in the library. You can add an unlimited number of virtual machines to a folder.

Remove a Virtual Machine from a Folder

You can remove a virtual machine from a folder or move it to a different folder or subfolder.

Procedure

- To remove a virtual machine from a folder, select the virtual machine in the library and drag it to My Computer.

  The virtual machine appears under My Computer in the library.

- To move a virtual machine to a different folder or subfolder, select the virtual machine in the library and drag it to the folder or subfolder.

  The virtual machine appears under the folder or subfolder in the library.

Manage Virtual Machines in a Folder

When virtual machines are in a folder, you can manage them as a unit. For example, you can select multiple virtual machines on the folder tab and perform power operations on several virtual machines at the same time.

When you power on several virtual machines at the same time, Workstation delays 10 seconds before powering on the next virtual machine by default. Workstation performs power operations on virtual machines in the order in which they appear on the folder tab.

You can change the default power on delay setting by modifying a Workstation preference. See “Change the Power On Delay,” on page 64.

Procedure

- To perform a power operation on several virtual machines at the same time, use Ctrl-Click to select the virtual machines on the folder tab and select the power operation from the toolbar or from the VM menu.

  All of the virtual machines that you select must be in the same power state.

- To perform a power operation on all of the virtual machines at the same time, select the folder in the library and select the power operation from the toolbar or from the VM menu.

  All of the virtual machines in the folder must be in the same power state.
To display thumbnails for virtual machines on the folder tab, select a thumbnail size from the drop-down menu on the folder tab.

When a virtual machine is powered on, Workstation updates the thumbnail in real time to show the actual content of the virtual machine. When a virtual machine is suspended, the thumbnail shows a screenshot of the virtual machine at the time that it was suspended.

To display virtual machine names on the folder tab, select Details from the drop-down menu on the folder tab.

To open the tab for a virtual machine, double-click the virtual machine on the folder tab.

Change the Power On Delay

By default, when you power on several virtual machines in a folder, Workstation delays 10 seconds before powering on the next virtual machine. The power on delay avoids overloading the CPU on the host system when you power on multiple virtual machines. You can change the default power on delay setting by modifying a Workstation preference.

Procedure

1. Select Edit > Preferences and select Workspace.
2. Select the number of seconds for the delay from the Seconds between powering on multiple VMs drop-down menu.
3. Click OK to save your changes.

Convert a Team

If you created a team in an earlier version of Workstation, you must convert the team before you can use the virtual machines in the current version of Workstation.

Procedure

1. Open the team in Workstation or browse to the location of the virtual machine team configuration (.vmtm) file and drag it to the library.
   
   A dialog box appears that prompts you to convert the team.
2. Click Convert Team to convert the team.

After the team is converted, the .vmtm file is deleted and the virtual machines are added to a new folder in the library.

After you convert a team, the virtual machines keep their packet loss and bandwidth settings. LAN segment information appears in the network adapter settings for each virtual machine, where you can modify it.

Taking Snapshots of Virtual Machines

Taking a snapshot of a virtual machine saves its current state and enables you to return to the same state repeatedly. When you take a snapshot, Workstation captures the entire state of the virtual machine. You can use the snapshot manager to review and act on the snapshots for an active virtual machine.

Using Snapshots to Preserve Virtual Machine States on page 65

A snapshot includes the contents of the virtual machine memory, virtual machine settings, and the state of all the virtual disks. When you revert to a snapshot, you return the memory, settings, and virtual disks of the virtual machine to the state they were in when you took the snapshot.

Using the Snapshot Manager on page 66

You can review all snapshots for a virtual machine and act on them directly in the snapshot manager.
When you take a snapshot, you preserve the state of a virtual machine at a specific moment in time and the virtual machine continues to run. Taking a snapshot enables you to return to the same state repeatedly. You can take a snapshot while a virtual machine is powered on, powered off, or suspended.

You can restore a virtual machine to a previous state by reverting to a snapshot.

You can configure a virtual machine to revert to a snapshot or take a new snapshot when you power off the virtual machine. This feature is useful if you need to discard changes when a virtual machine is powered off.

The AutoProtect feature preserves the state of a virtual machine by taking snapshots at regular intervals that you specify. This process is in addition to manual snapshots, which you can take at any time.

When you delete a snapshot, you delete the state of the virtual machine that you preserved and you can never return to that state again. Deleting a snapshot does not affect the current state of the virtual machine.

Using Snapshots to Preserve Virtual Machine States

A snapshot includes the contents of the virtual machine memory, virtual machine settings, and the state of all the virtual disks. When you revert to a snapshot, you return the memory, settings, and virtual disks of the virtual machine to the state they were in when you took the snapshot.

You might want to take snapshots in a linear process if you plan to make changes in a virtual machine. For example, you can take a snapshot, continue to use the virtual machine from that point, take another snapshot at a later point, and so on. You can revert to the snapshot of a previous known working state of the project if the changes do not work as expected.

For local virtual machines, you can take more than 100 snapshots for each linear process. For shared and remote virtual machines, you can take a maximum of 31 snapshots for each linear process.

If you are testing software, you might want to save multiple snapshots as branches from a single baseline in a process tree. For example, you can take a snapshot before installing different versions of an application to make sure that each installation begins from an identical baseline.
Multiple snapshots have a parent-child relationship. The parent snapshot of a virtual machine is the snapshot on which the current state is based. After you take a snapshot, that stored state is the parent snapshot of the virtual machine. If you revert to an earlier snapshot, the earlier snapshot becomes the parent snapshot of the virtual machine.

In a linear process, each snapshot has one parent and one child, except for the last snapshot, which has no children. In a process tree, each snapshot has one parent, one snapshot can have more than one child, and many snapshots have no children.

**Using the Snapshot Manager**

You can review all snapshots for a virtual machine and act on them directly in the snapshot manager.

You must use the snapshot manager to perform the following tasks.

- Show AutoProtect snapshots in the **Snapshot** menu.
- Prevent an AutoProtect snapshot from being deleted.
- Rename a snapshot or change its description.
- Delete a snapshot.

All other snapshot actions are available as menu items in the **Snapshot** menu under the **VM** menu.

When you open the snapshot manager for a virtual machine, the snapshot tree appears. The snapshot tree shows all of the snapshots for the virtual machine and the relationships between the snapshots.

The **You Are Here** icon in the snapshot tree shows the current state of the virtual machine. The other icons that appear in the snapshot tree represent AutoProtect snapshots, snapshots of powered-on virtual machines, snapshots of powered-off virtual machines, and snapshots that are used to create linked clones.

The snapshot manager is available as a menu item in the **Snapshot** menu under the **VM** menu.
Take a Snapshot of a Virtual Machine

When you take a snapshot, you preserve the state of a virtual machine at a specific moment in time and the virtual machine continues to run. Taking a snapshot enables you to return to the same state repeatedly. You can take a snapshot while a virtual machine is powered on, powered off, or suspended.

Avoid taking snapshots when applications in the virtual machine are communicating with other computers, especially in production environments. For example, if you take a snapshot while the virtual machine is downloading a file from a server on the network, the virtual machine continues downloading the file after you take the snapshot. If you revert to the snapshot, communications between the virtual machine and the server are confused and the file transfer fails.

Note: Workstation 4 virtual machines do not support multiple snapshots. You must upgrade the virtual machine to Workstation 7.x or later to take multiple snapshots.

Prerequisites

- Verify that the virtual is not configured to use a physical disk. You cannot take a snapshot of a virtual machine that uses a physical disk.
- To have the virtual machine revert to suspend, power on, or power off when you start it, be sure it is in that state before you take the snapshot. When you revert to a snapshot, you return the memory, settings, and virtual disks of the virtual machine to the state they were in when you took the snapshot.
- Complete any suspend operations.
- Verify that the virtual machine is not communicating with another computer.
- For better performance, defragment the guest operating system drives.
- If the virtual machine has multiple disks in different disk modes, power off the virtual machine. For example, if a configuration requires you to use an independent disk, you must power off the virtual machine before you take a snapshot.
- If the virtual machine was created with Workstation 4, delete any existing snapshots or upgrade the virtual machine to Workstation 5.x or later.

Procedure

1. Select the virtual machine and select VM > Snapshot > Take Snapshot.
2. Type a unique name for the snapshot.
3. (Optional) Type a description for the snapshot.
   - The description is useful for recording notes about the virtual machine state captured in the snapshot.
4. Click OK to take the snapshot.

Revert to a Snapshot

You can restore a virtual machine to a previous state by reverting to a snapshot.

If you take a snapshot of a virtual machine and add any kind of disk, reverting to the snapshot removes the disk from the virtual machine. If associated disk (.vmdk) files are not used by another snapshot, the disk files are deleted.

Important: If you add an independent disk to a virtual machine and take a snapshot, reverting to the snapshot does not affect the state of the independent disk.
Procedure

- To revert to the parent snapshot, select the virtual machine and select **VM > Snapshot > Revert to Snapshot**.
- To revert to any snapshot, select the virtual machine, select **VM > Snapshot**, select the snapshot, and click **Go To**.

**Take or Revert to a Snapshot at Power Off**

You can configure a virtual machine to revert to a snapshot or take a new snapshot when you power off the virtual machine. This feature is useful if you need to discard changes when a virtual machine is powered off.

**Procedure**

1. Select the virtual machine and select **VM > Settings**.
2. On the **Options** tab, select **Snapshots**.
3. Select a power off option.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Just power off</strong></td>
<td>Powers off the virtual machine without making any changes to snapshots.</td>
</tr>
<tr>
<td><strong>Revert to snapshot</strong></td>
<td>Reverts to the parent snapshot of the current state of the virtual machine.</td>
</tr>
<tr>
<td><strong>Take a new snapshot</strong></td>
<td>Takes a snapshot of the virtual machine state after it is powered off. The snapshot appears in the Snapshot Manager. The name of the snapshot is the date and time that the virtual machine was powered off and the description is Automatic snapshot created when powering off. <strong>Note</strong>: You cannot configure this option for a shared or remote virtual machine.</td>
</tr>
<tr>
<td><strong>Ask me</strong></td>
<td>Prompts you to power off, revert, or take a snapshot when the virtual machine is powered off.</td>
</tr>
</tbody>
</table>

4. Click **OK** to save your changes.

**Enable AutoProtect Snapshots**

The AutoProtect feature preserves the state of a virtual machine by taking snapshots at regular intervals that you specify. This process is in addition to manual snapshots, which you can take at any time.

When AutoProtect snapshots are enabled for a virtual machine, Workstation shows an estimate of the minimum amount of disk space taken by AutoProtect snapshots on the Virtual Machine Settings window. This minimum is affected by the memory settings for the virtual machine. The more virtual machine memory a virtual machine has, the more disk space is available for AutoProtect snapshots.

The AutoProtect feature has certain restrictions.

- Because AutoProtect takes snapshots only while a virtual machine is powered on, AutoProtect snapshots cannot be cloned. You can clone a virtual machine only if it is powered off.
- AutoProtect snapshots are not taken in VMware Player, even if AutoProtect is enabled for the virtual machine in Workstation.
- You cannot configure the AutoProtect feature for a shared or remote virtual machine.

**Procedure**

1. Select the virtual machine and select **VM > Settings**.
2. On the **Options** tab, select **AutoProtect** and select **Enable AutoProtect**.
3 Select the interval between snapshots.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Half-Hourly</td>
<td>Snapshots are taken every half hour.</td>
</tr>
<tr>
<td>Hourly</td>
<td>Snapshots are taken every hour.</td>
</tr>
<tr>
<td>Daily</td>
<td>Snapshots are taken daily.</td>
</tr>
</tbody>
</table>

The interval is measured only when the virtual machine is powered on. For example, if you set AutoProtect to take snapshots hourly and then power off the virtual machine five minutes later, the next AutoProtect snapshot takes place 55 minutes after you power on the virtual machine again, regardless of the length of time the virtual machine was powered off.

Workstation saves only one snapshot per tier, even if a snapshot matches more than one tier.

4 Select the maximum number of AutoProtect snapshots to retain.

After the maximum number of AutoProtect snapshots is reached, Workstation deletes the oldest AutoProtect snapshot each time a new AutoProtect snapshot is taken. This setting does not affect the number of manual snapshots that you can take and keep.

5 Select OK to save your changes.

Delete a Snapshot

When you delete a snapshot, you delete the state of the virtual machine that you preserved and you can never return to that state again. Deleting a snapshot does not affect the current state of the virtual machine.

If a snapshot is used to create a clone, the snapshot becomes locked. If you delete a locked snapshot, the clones created from the snapshot no longer operate.

You cannot delete a snapshot if the associated virtual machine is designated as a template for cloning.

Procedure

1 Select the virtual machine and select VM > Snapshot > Snapshot Manager.

2 If you are deleting an AutoProtect snapshot, select Show AutoProtect snapshots.

3 Select the snapshot.

4 Select an option to delete the snapshot.

<table>
<thead>
<tr>
<th>Option</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Delete a single snapshot</td>
<td>Click Delete.</td>
</tr>
<tr>
<td>Delete the snapshot and all of its children</td>
<td>Right-click and select Delete Snapshot and Children.</td>
</tr>
<tr>
<td>Delete all snapshots</td>
<td>Right-click, select Select All, and click Delete.</td>
</tr>
</tbody>
</table>

5 Click Close to close the snapshot manager.

Closing Virtual Machines and Exiting Workstation

You can close a virtual machine that is running on the local host system without powering it off. By default, Workstation prompts you to select an action when you close a powered-on virtual machine and when you exit Workstation while virtual machines are running on the local host system.

**Note** When you close a remote virtual machine, the virtual machine tab closes. If the virtual machine is powered on, it continues to run on the remote host.
Table 4-1. Close and Exit Actions

<table>
<thead>
<tr>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Run in Background</td>
<td>Continue to run the virtual machine in the background. You can interact with the virtual machine through VNC or some other service. By default, a virtual machine status icon appears in the notification area of the taskbar on the host system. When you mouse over this icon, a tooltip shows the number of virtual machines running in the background that belong to the currently logged in user.</td>
</tr>
<tr>
<td>Suspend</td>
<td>Suspend the virtual machine and save its current state.</td>
</tr>
<tr>
<td>Power Off</td>
<td>Power off the virtual machine. By default, Workstation powers off the virtual machine abruptly. The effect is the same as using the power button on a physical machine.</td>
</tr>
</tbody>
</table>

You can configure Workstation preference settings so that virtual machines always run in the background and you are not prompted to select an action. You can also configure virtual machine option settings to control power off behavior.

**Configure Virtual Machines to Always Run in the Background**

You can configure Workstation preference settings so that virtual machines always run in the background and you are not prompted to select an action when you close powered-on virtual machines.

**Procedure**

1. Select **Edit > Preferences**.
2. Select **Workspace** and select **Keep VMs running after Workstation closes**.
3. Click **OK** to save your changes.

**Start a Virtual Machine That Is Running in the Background**

You can start a virtual machine that is running in the background when Workstation is not started.

**Prerequisites**

Set the virtual machine to run in the background. See “Closing Virtual Machines and Exiting Workstation,” on page 69.

**Procedure**

1. On the host system, click the virtual machine status icon that is located in the notification area of the taskbar.

   A list of the virtual machines that are running in the background appears in a tooltip. The list contains the virtual machines that belong to the currently logged in user.

2. Select a virtual machine from the list in the tooltip.

   Workstation starts and displays the console view of the virtual machine.
Index

A
Advanced Linux Sound Architecture 9
audience information 5
AutoProtect snapshots, enabling 68

B
background settings, configuring 70
batch power operations 63
battery information 59
BIOS, virtual machine support 10

C
chip sets, virtual machine support 10
closing virtual machines 69
command line options, installing Workstation on Linux 21
converting teams 64
copy and paste feature
restrictions 56
using 55
CPUs, host requirements 7
Creative Labs Sound Blaster 12

disk drives
host requirements 9
virtual machine support 11

D
displays
changing 58
host requirements 8
drag-and-drop feature
restrictions 55
using 55
drawing tablets, virtual machine support 12

E
Easy Install, responding to prompts 35, 39
Eclipse, installing 16, 17
Ethernet cards, virtual machine support 12
exclusive mode 59

F
floppy drives, virtual machine support 11
folders
creating 63
managing virtual machines 62
removing virtual machines 63
FreeBSD guest operating system, VMware Tools
installation or upgrade (tar installer) 47
full screen mode 58

G
graphics, virtual machine support 10
guest operating systems
installing manually 40
selecting 35
supported 10

H
hardware, customizing 37
hardware compatibility, changing 26
HD Audio 12
help system, host requirements 9
hot keys, default combinations 32

I
IDE drives
host requirements 9
virtual machine support 11
installation properties 19
installation restrictions 16
installing VMware Tools
FreeBSD (tar installer) 47
Linux (tar installer) 44
Microsoft Windows 43
NetWare (tar installer) 46
process overview 42
Solaris (tar installer) 46
installing Workstation
Linux host 20
unattended installation on Windows host 18
Windows host 17
Intel High-Definition Audio 12

K
keyboards, virtual machine support 10

L
license key, obtaining 15
Linux guest, VMware Tools installation or upgrade (tar installer) 44
local area networking, host requirements 9
memory 8
virtual machine allocation 10
Microsoft Windows guest operating system, VMware Tools installation or upgrade 43
monitors, using multiple 61
mouse types, virtual machine support 12
NetWare guest operating system, VMware Tools installation or upgrade (tar installer) 46
New Virtual Machine wizard 38
online help, using 32
operating systems host supported 8
OS upgrades on Windows hosts 16
optical drives supported in host 9
parallel ports, virtual machine support 11
pause feature restrictions 53
pausing virtual machines 53
power on delay 64
powering off virtual machines 52
printers, using host printers in a virtual machine 56
processors host requirements 7
supported in virtual machines 10
RAM, host requirements 8
removable devices 56
REMOVE property values 19
repairing VMware Tools installations 48
resuming virtual machines 54
SCSI devices, virtual machine support 11
SCSI drives, host requirements 9
serial ports, virtual machine support 11
silent installation, Windows host 18
snapshot manager, using 66
snapshots deleting 69
enabling AutoProtect 68
power-off options 68
reverting 67
taking 64, 67
using 65
Solaris guest operating system, VMware Tools installation or upgrade (tar installer) 46
sound, virtual machine support 12
starting background virtual machines 70
starting virtual machines 51
starting Workstation 28
status bar 30
suspending virtual machines 54
system requirements, host system 7
tar installer 44
team 64
thumbnails managing virtual machines 62
using 63
unattended installation installation properties 19
REMOVE property values 19
uninstalling VMware Tools 49
uninstalling Workstation Linux host 27
process 27
Windows host 27
Unity mode features 60
upgrading VMware Tools FreeBSD (tar installer) 47
Linux (tar installer) 44
Microsoft Windows 43
NetWare (tar installer) 46
process overview 42
Solaris (tar installer) 46
upgrading Workstation Linux host 24
preparation tasks 21, 22
Windows host 16, 23
USB devices connecting 57
mounting on a Linux host 57
USB ports, virtual machine support 11
virtual disks
allocating disk space 37
using in a new virtual machine 34
virtual machine files, specifying in the New Virtual Machine wizard 36
virtual machine library 29
virtual machines changing hardware compatibility 25
creating 33
installing software 49
specifications 10
Index

VMware, Inc. 73

W
Windows operating system upgrades 16
worksheet, typical virtual machine 37
Workstation tabs 31
Workstation window
  customizing the view 31
  performing virtual machine operations 29
  using 28

 VMware, Inc. 73

Index

VMware, Inc. 73

W
Windows operating system upgrades 16
worksheet, typical virtual machine 37
Workstation tabs 31
Workstation window
  customizing the view 31
  performing virtual machine operations 29
  using 28