Getting Started Guide

VMware Player 3.1

This document supports the version of each product listed and supports all subsequent versions until the document is replaced by a new edition. To check for more recent editions of this document, see http://www.vmware.com/support/pubs.
You can find the most up-to-date technical documentation on the VMware Web site at:

http://www.vmware.com/support/

The VMware Web site also provides the latest product updates.

If you have comments about this documentation, submit your feedback to:

docfeedback@vmware.com
Contents

About This Book  5

1 What Is VMware Player?  7
   What You Can Do with VMware Player  8
   Features in VMware Player  8

2 Host System Requirements for VMware Player  11
   Compatible Virtual Machines and System Images  12
   Using Virtual Symmetric Multiprocessing  12

3 Supported Host and Guest Operating Systems for VMware Player  13
   Processor Support for 64-Bit Guest Operating Systems  13

4 Installing and Running VMware Player  15
   Install VMware Player on a Windows Host  15
   Install VMware Player on a Linux Host  16
   Start VMware Player  18
   Close VMware Player  18

5 Uninstalling VMware Player  19
   Uninstall VMware Player on a Windows Host  19
   Uninstall VMware Player on a Windows Vista or Windows 7 Host  19
   Uninstall VMware Player on a Linux Host  20

Index  21
About This Book

This preface provides information about the VMware Player Getting Started Guide and links to VMware® educational resources.

Intended Audience

This book is intended for anyone who wants to install and use VMware Player 3.1. VMware Player 3.1 users include anyone who wants to create and run virtual machines or virtual appliances. You can download and safely run prebuilt application environments provided by software vendors or colleagues.

Document Feedback

VMware welcomes your suggestions for improving our documentation. If you have comments, send your feedback to docfeedback@vmware.com.

Education Resources

The following Education resources are available to you. To access the current version of this book and other books, go to http://www.vmware.com/support/pubs.

VMware Professional Services

VMware Education Services courses offer extensive hands-on labs, case study examples, and course materials designed to be used as on-the-job reference tools. Courses are available onsite, in the classroom, and live online. For onsite pilot programs and implementation best practices, VMware Consulting Services provides offerings to help you assess, plan, build, and manage your virtual environment. To access information about education classes, certification programs, and consulting services, go to: http://www.vmware.com/services/.
What Is VMware Player?

VMware Player is a desktop application that lets you create, configure, and run virtual machines.

With VMware Player you can use the following features:

- Create virtual machines that can run on a Windows or Linux PC.
- Run virtual machines, making it easy to take advantage of the security, flexibility, and portability of virtual machines.
- Access all of the host machine hardware devices, such as USB drives, from the virtual machine.

The terms host and guest describe physical and virtual machines:

**Host**
The physical computer on which you install the VMware Player software is called the host machine, and its operating system is called the host operating system.

**Guest**
The operating system running inside a virtual machine is called a guest operating system. The virtual machine is called the guest.

VMware Player provides an intuitive user interface for creating virtual machines or running preconfigured virtual machines created with VMware Workstation, ESX Server, VMware Server, VMware Fusion, and GSX Server. On Windows host machines, you can use VMware Player to open and run Microsoft Virtual PC and Microsoft Virtual Server virtual machines, and Symantec Backup Exec System Recovery, formerly LiveState Recovery, system images. VMware Player also lets you download virtual appliances and access Open Virtualization Format (OVF) and Open Virtual Appliance (OVA) files. For information about VMware Player see the compatible virtual machines and system images topic.

VMware Player makes VMware virtual machines accessible to colleagues, partners, customers, and clients, regardless of whether they have purchased VMware products. Anyone who downloads VMware Player can open and run compatible virtual machines.

**Note**  Use of VMware Player is subject to the VMware Player end-user license terms. VMware provides no support for VMware Player. You can download VMware Player from the VMware Web site.

You can also download virtual appliances to use with VMware Player from the Virtual Appliance Marketplace from the VMware Web site.

For self-help resources, see the VMware Player FAQ under the VMware Player section of the VMware Web site. You can also participate in the VMware Player Communities forum under the Support & Downloads section of the VMware Web site. The forum enables members to exchange information, questions, and comments regarding VMware products, services, and product support issues.
This chapter includes the following topics:

- “What You Can Do with VMware Player,” on page 8
- “Features in VMware Player,” on page 8

What You Can Do with VMware Player

VMware Player allows you to perform various tasks in a virtual machine. You can create and run virtual machines, use and evaluate prebuilt applications, simplify software distribution, and collaborate with colleagues.

Create and Run Virtual Machines

Create a virtual machine to configure and test desktops and servers as virtual machines before deploying them to production. You can test new multi-tier applications, application updates, and operating system patches on a single PC. You can host legacy applications within virtual machines, facilitating operating system migrations and eliminating the need to port legacy applications.

Use and Evaluate Prebuilt Applications

Download and safely run prebuilt application environments on virtual machines that are available from the Virtual Appliance Marketplace section on the VMware Web site. The Virtual Appliance Marketplace includes virtual machines from leading software vendors, including Oracle, Red Hat, Novell, BEA, SpikeSource, IBM, and MySQL, as well as virtual machines that are preconfigured with popular open source software.

Transform Software Distribution

Simplify software distribution by shipping preconfigured software on virtual machines. Customers can experience the benefits of your products immediately, without setup hassles. VMware Player is ideal for shipping evaluation copies or beta software. You can package complex, sophisticated applications, complete with a full working environment, on a virtual machine that anyone who downloads VMware Player can use.

Collaborate with Colleagues

VMware Player makes it easy for support, development, and QA to share customer scenarios in virtual machines.

Features in VMware Player

VMware Player is a desktop application for creating and running virtual machines.

VMware Player includes the following new features:

- OpenGL 2.1 support for Windows 7 and Windows Vista guests – Improves the ability to run graphics-based applications in virtual machines.
- Improved Graphics Performance – Enhanced performance with better benchmarks, frame rates, and improved rendering on Windows 7 and Vista guests allows you to run various graphics-based applications. In addition, major improvements in video playback enable you to play high-resolution videos in virtual machines.
- Automatic Software Updates – Download and install VMware Tools, new, and maintenance release updates when available.
- Autologon – Save your login credentials and bypass the login dialog box when you power on a Windows guest. Use this feature if you restart the guest frequently and want to avoid entering your login credentials. You can enable Autologon and use direct launch to open guest applications from the host.
Direct Launch – Drag guest applications from the Unity start menu directly onto the host desktop. Double-click the shortcut to open the guest application. The shortcut remains on the desktop after you exit Unity and close VMware Player.

OVF 1.0 Support – Import or export virtual machines and vApps to upload them to VMware vSphere or VMware Cloud. The VMware OVF tool is a command-line utility bundled in the VMware Player installer. Use this tool along with VMware Player to convert VMware .vmx files to .ovf format or vice versa. VMware recommends that you use the OVF command-line utility. For more information, see the OVF Tool User Guide.

Eight-Way SMP Support – Create and run virtual machines with a total of up to eight-processor cores.

2TB Virtual Disk Support – Maximum virtual disks and raw disks size increased from 950GB to 2TB.

Memory Management – User interface enhancements have simplified the handling of increased virtual memory capacity.

User Experience Improvement Program – Help VMware improve future versions of the product by participating in the User Experience Improvement Program. Participation in the program is voluntary and you can opt out at any time. When you participate in the User Experience Improvement Program, your computer sends anonymous information to VMware, which may include product configuration, virtual machine configuration, usage and performance data, and information about your host system specifications and configuration.

The User Experience Improvement Program does not collect any personal data, such as your name, address, telephone number, or email address that can be used to identify or contact you. No user identifiable data such as the product license key or MAC address are sent to VMware. VMware does not store your IP address with the data that is collected.

For more information about the User Experience Improvement Program, click the Learn More link during installation or from the VMware Player Player Preferences menu.

For more instructions about how to use these features, select Help > Help Topics to view the online help provided in VMware Player.
Your computer must have the compatible hardware to install VMware Player.

The minimum host system requirements for installing and using VMware Player are:

- Standard x86-compatible or x86-64 with Intel® Virtualization Technology feature turned on or most AMD64 processors (except the earliest revision C Opteron processors).
- Processor speed – 1.3GHz or faster
- Memory – Minimum 1GB is required, however VMware recommends to have 2GB and above available memory. You must have enough memory to run the host operating system, the guest operating system for every virtual machine, and for applications on the host and guest. For more information about memory requirements, see your guest operating system documentation.

The total amount of memory you can assign to all virtual machines running on a single host is limited only by the amount of RAM on the host. The maximum amount of memory for each virtual machine on 32-bit hosts is 8GB and on 64-bit hosts is 32GB. VMware Player does not allow powering on virtual machines that are configured to use more than 8GB of memory on 32-bit hosts. Memory management limitations on 32-bit operating systems cause virtual machine memory to overcommit, which severely affects system performance.

- Hard disk – At least 1GB free disk space is recommended for each guest operating system.

This chapter includes the following topics:

- “Compatible Virtual Machines and System Images,” on page 12
- “Using Virtual Symmetric Multiprocessing,” on page 12
Compatible Virtual Machines and System Images

VMware Player runs virtual machines and system images created with other VMware and non-VMware products.

The following virtual machines and system images are compatible with VMware Player:

- **VMware Virtual Machines**
  - VMware Player runs virtual machines created with VMware Workstation 4 and later, GSX Server 3.x, VMware Server, and ESX Server 2.5 and later.
  - Workstation 4 virtual machines run in legacy mode. You must use another VMware product to upgrade virtual machines created in versions earlier than Workstation 4 before you can run them in VMware Player.

- **Microsoft Virtual PC and Virtual Server Virtual Machines**
  - On Windows hosts, VMware Player can run Microsoft Virtual PC and Virtual Server virtual machines.
  - When you open a Virtual PC virtual machine in VMware Player, VMware Player creates a VMware-compatible configuration file with a `.vmx` file extension, and preserves the original Virtual PC configuration file, with a `.vmc` file extension. You can save the VMware-compatible virtual machine without changing your original Virtual PC configuration file.

- **Symantec Backup Exec System Recovery System Images**
  - On Windows hosts, VMware Player can run system images created with Symantec Backup Exec System Recovery, formerly Symantec LiveState Recovery.
  - When you open a Backup Exec System Recovery system image in VMware Player, VMware Player creates a VMware-compatible configuration file (with a `.vmx` extension), and preserves the original Backup Exec System Recovery system image file with a `.sv2i` file extension.

Using Virtual Symmetric Multiprocessing

With Virtual Symmetric Multiprocessing (SMP), you can assign up to eight processors to a virtual machine on any host machine that has at least two logical processors.

The following are all considered to have two or more logical processors:

- A multiprocessor host with two or more physical CPUs
- A single-processor host with a multicore CPU
- A single-processor host with hyperthreading enabled

**Note** On hyperthreaded uniprocessor hosts, performance of virtual machines with Virtual SMP might be below normal.

With VMware Player you can power on and run multiple dual-processor virtual machines concurrently.
Supported Host and Guest Operating Systems for VMware Player

You can check the supported host and guest operating systems list for virtual machines running in VMware Player to verify whether your computer operating system allows you to install VMware Player.

For installation, VMware Player requires approximately 250MB (Windows) or 200MB (Linux) free disk space. You can delete the installer after installation is complete to reclaim disk space.

For host and guest operating system support and known issues, go to the VMware Web site, and click the Support & Downloads tab. Under Support Resources, click the Compatibility Guides link.

VMware Player is not listed, but the information for VMware Workstation 7.x is applicable to VMware Player 3.x. Operating systems that are not listed are not supported for use in a virtual machine.

Processor Support for 64-Bit Guest Operating Systems

When you power on a virtual machine with a 64-bit guest operating system, VMware Player performs an internal check. If the host CPU is not a supported 64-bit processor, you cannot power on the virtual machine.

VMware Player supports virtual machines with 64-bit guest operating systems, running on host machines with the following processors:

- Most AMD64 processors (except the earliest revision C Opteron processors)
- Intel Pentium 4 and Core 2, and Core i7 processors with EM64T and Intel Virtualization Technology

VMware also provides a standalone utility that you can use without VMware Player to perform the same check and determine whether your CPU is supported for VMware Player virtual machines with 64-bit guest operating systems. Download the 64-bit processor check utility from the downloads area of the VMware Web site.
Installing and Running VMware Player

The installation instructions for VMware Player require a product CD to install on Windows and Linux hosts. If you do not have a product CD, download VMware Player from the VMware Web site.

If you are installing VMware Player from a CD and autorun is enabled, follow the prompts when you insert the CD in your CD-ROM drive.

If you are installing VMware Player from a CD and autorun is not enabled, double-click the `VMware-Player-<xxxxx>.exe` installer file in the Windows directory of the CD. In the filename, `<xxxxx>` is a series of numbers representing the version and build numbers.

- **Install VMware Player on a Windows Host** on page 15
  To begin creating and configuring virtual machines you must install VMware Player on your Windows host.

- **Install VMware Player on a Linux Host** on page 16
  To begin creating and configuring virtual machines you must install VMware Player on your Linux host.

- **Start VMware Player** on page 18
  To start VMware Player you must open the `.vmx` virtual machine configuration file.

- **Close VMware Player** on page 18
  Close VMware Player before you shut down the host computer.

**Install VMware Player on a Windows Host**

To begin creating and configuring virtual machines you must install VMware Player on your Windows host.

If you downloaded the software, follow the installation procedure, but install from the directory where you saved the installer file, rather than the Windows directory on the CD.

**Prerequisites**

Make sure that your host and guest operating systems are supported. See Chapter 3, “Supported Host and Guest Operating Systems for VMware Player,” on page 13.

**Procedure**

1. On the Welcome page, click **Next**.
2. On the Destination Folder page, select the location for VMware Player files.
   - If you want VMware Player to be installed in the default location, click **Next**.
   - To select an alternative location for VMware Player files, click **Change**. After you set an alternative location, click **OK** and **Next**.
3 (Optional) Select or deselect **Check for product updates at startup** to allow VMware Player to check for product updates when you start VMware Player.

Product updates include new releases of VMware Player.

Click **Learn More** to review details of the information collected to provide software product updates.

4 (Optional) To change product update settings, select **File > Player Preferences** menu.

5 Click **Next**.

6 (Optional) Confirm whether VMware can collect anonymous system data and usage statistics for product improvement.

   The data collection process does not affect the performance of your computer.

   Click **Learn More** to review details of the information collected.

7 (Optional) To change User experience improvement program settings, select **File > Player Preferences** menu.

8 Click **Next**.

9 (Optional) Deselect any shortcuts on the Shortcuts page, and click **Next**.

10 Click **Continue** to begin the installation.

   VMware Player and any shortcuts you selected are installed on your host machine.

---

**Install VMware Player on a Linux Host**

To begin creating and configuring virtual machines you must install VMware Player on your Linux host.

If you downloaded the software, follow the installation procedure, but install from the directory where you saved the installer file, rather than the Linux directory on the CD.

**Note** If you do not enable host-only networking when you install VMware Player, you cannot allow a virtual machine to use bridged and host-only networking.

**Prerequisites**

Make sure that your host and guest operating systems are supported. See Chapter 3, “Supported Host and Guest Operating Systems for VMware Player,” on page 13.

**Procedure**

1 Log on to your Linux host with the user name you plan to use when you run VMware Player.

2 In the terminal window, become root user to perform the initial installation steps.
   
   `su` or `sudo`

   The command you use depends on your Linux distribution and configuration.

3 If you are installing from a downloaded file, mount the VMware Player CD-ROM.
   
   * VMware-Player-e.x.p-<xxxxxxxx>.i386.bundle
   * VMware-Player-e.x.p-<xxxxxxxx>.x86_64.bundle

   `VMware-Player-<version>-<xxxxxx>.<architecture>.bundle` is the installation file. In the filename, `<xxxx-xxxx>` is a series of numbers representing the version and build numbers.

4 Run the bundle specifying the installation file:

   `sh VMware-Player-e.x.p-<xxxxxxxx>.<architecture>.bundle`

5 Accept the EULA to continue.
6 (Optional) Select either Yes or No to allow VMware Player to check for product updates when you start VMware Player.

Product updates include new releases of VMware Player.

Click Learn More to review details of the information collected to provide software product updates.

7 (Optional) To change product update settings, select File > Player Preferences menu.

8 Click Next.

9 (Optional) Confirm whether VMware can collect anonymous system data and usage statistics for product improvement.

The data collection process does not affect the performance of your computer.

Click Learn More to review details of the information collected.

10 (Optional) To change User experience improvement program settings, select File > Player Preferences menu.

11 Click Next.

12 Click Install.

13 (Optional) If the GUI based VMware Player installer fails, run the installation file with the --console command in your terminal.

Command-Line Installation Options

You can use command-line installation options to install VMware Player on a Linux host.

Command-Line Installation Options Reference

To use the options you must be logged in as root. After you finish the installation process, exit from the root account.

Table 4-1. List of Command-Line Installation Options

<table>
<thead>
<tr>
<th>Command-Line Installation Option</th>
<th>Option Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>--gtk</td>
<td>Opens the GUI based VMware installer. This is the default option.</td>
</tr>
<tr>
<td>--console</td>
<td>Allows you to use the terminal for installation.</td>
</tr>
<tr>
<td>--custom</td>
<td>Shows all the installation questions. You can customize the installation directories, set or reset the Eclipse directories and hard limit for the number of open file descriptors.</td>
</tr>
<tr>
<td>--regular</td>
<td>Shows installation questions that have not been answered before or are required. This is the default option.</td>
</tr>
<tr>
<td>--required</td>
<td>Shows only the EULA, then proceeds to install VMware Player.</td>
</tr>
<tr>
<td>--ignore-errors or -I</td>
<td>Allows the installation to continue even if there is an error in one of the installer scripts. However, the section that has an error does not complete, so the component may not be properly configured.</td>
</tr>
</tbody>
</table>
Start VMware Player

To start VMware Player you must open the .vmx virtual machine configuration file.

**Procedure**

1. Select **Start > Programs > VMware Player** in Windows or use the corresponding program menu in a Linux X windows session.
   - On Windows, type `vmplayer` from the **Start > Run** command menu. You can also type `<path>`\vmplayer.exe in the command interpreter, where `<path>` is the appropriate path on your system to the VMware Player executable file.
   - From the Linux command line, type `<path>/vmplayer`, where `<path>` is the appropriate path on your system to the VMware Player executable file. To run VMware Player process in the background, type `<path>/vmplayer &`.

2. On the VMware Player welcome page, select **Open a VM**.

3. Browse for the configuration file of the virtual machine to run.
   - You can also select a recently used virtual machine or download a virtual appliance from the Virtual Appliance Marketplace.
   - You can use the **Files of type** field to filter the files that are displayed when you browse.
   - VMware Player can open .vmx VMware configuration files, OVF, and OVA files. On Windows, VMware Player can open .vmc Microsoft Virtual PC and Virtual Server files and .sv2i Symantec Backup Exec System Recovery system images.

4. Select a .vmx virtual machine configuration file, and click **Open**.

Close VMware Player

Close VMware Player before you shut down the host computer.

On Linux, depending on the exit behavior preference settings, the virtual machine either suspends or shuts down and the VMware Player window closes.

For ACE instances, the options in the drop-down menu depend on which features the system administrator makes available.

**Procedure**

- On Windows, select **File > Exit**.
- On Linux, select an option based on the exit behavior settings.
  - Select **File > Power Off and Quit**.
  - Select **File > Suspend and Quit**.
  - Select **File > Power Off and Return to Library**.
  - Select **File > Suspend and Return to Library**.
Uninstalling VMware Player

You can uninstall VMware Player from Windows and Linux hosts.

- **Uninstall VMware Player on a Windows Host** on page 19
  To install the latest version of VMware Player on a Windows host you must uninstall the previous version of the product.

- **Uninstall VMware Player on a Windows Vista or Windows 7 Host** on page 19
  To install the latest version of VMware Player on a on a Windows Vista or Windows 7 host you must uninstall the previous version of the product.

- **Uninstall VMware Player on a Linux Host** on page 20
  To install the latest version of VMware Player on a Linux host you must uninstall the previous version of the product.

### Uninstall VMware Player on a Windows Host

To install the latest version of VMware Player on a Windows host you must uninstall the previous version of the product.

**Procedure**

1. Select **Start > Control Panel > Add or Remove Programs**.
2. Locate **VMware Player** in the list of currently installed programs and click **Remove**.
3. Follow the prompts to complete the uninstall.

### Uninstall VMware Player on a Windows Vista or Windows 7 Host

To install the latest version of VMware Player on a on a Windows Vista or Windows 7 host you must uninstall the previous version of the product.

**Procedure**

1. Based on your host operating system, use one of the following methods to uninstall VMware Player:
   - On Windows Vista, select **Start > Control Panel > Programs and Features > Uninstall a program**.
   - On Windows 7, select **Start > Control Panel > Programs > Programs and Features > Uninstall a program**.
2. Right-click and select **Uninstall**.
   A confirmation dialog box appears.
3. Select **Yes**.
Uninstall VMware Player on a Linux Host

To install the latest version of VMware Player on a Linux host you must uninstall the previous version of the product.

Procedure

1. Enter the `vmware-installer -u vmware-player` command to remove VMware Player from your system.
2. Select Yes or No to confirm whether you want to preserve or remove your configuration files.
Index

C
compatible virtual machines and system images 12

D
document feedback 5

G
guest operating system, 64-bit 13

H
host operating system 13
host system requirements 11

I
install VMWare Player
  Linux host 16
  Windows host 15
intended audience 5

L
Linux installation options 17

R
resources 5

U
uninstall VMware Player
  Linux 20
  Windows 19
  Windows Vista 19

V
Virtual Symmetric Multiprocessing (SMP) 12
VMware Player
  close 18
  features 8
  install 15
  introduction 7
  start 18
  use 8