VMSA-2018-0019.1

Horizon 6, 7, Horizon Agent, and Horizon Client for Windows updates address an out-of-bounds read vulnerability

VMware Security Advisory
 
VMware Security Advisory Advisory ID:
  VMSA-2018-0019.1
VMware Security Advisory Severity:
  Important
VMware Security Advisory Synopsis:
  Horizon 6, 7, Horizon Agent, and Horizon Client for Windows updates address an out-of-bounds read vulnerability
VMware Security Advisory Issue date:
  2018-08-07
VMware Security Advisory Updated on:
  2018-08-14
VMware Security Advisory CVE numbers:
  CVE-2018-6970
 
1. Summary

Horizon 6, 7, Horizon Agent, and Horizon Client for Windows updates address an out-of-bounds read vulnerability

2. Relevant Products
  • VMware Horizon 6
  • VMware Horizon 7 
  • VMware Horizon Client for Windows
  • VMware Horizon View Agent
  • VMware Horizon Agents Installer (HAI)
3. Problem Description

Out-of-bounds read vulnerability in the Message Framework library

Horizon 6, 7, Horizon Agent, and Horizon Client for Windows contain an out-of-bounds read vulnerability in the Message Framework library. Successfully exploiting this issue may allow a less-privileged user to leak information from a privileged process running on a system where Horizon Connection Server, Horizon Agent or Horizon Client are installed.

 

Note: This issue doesn’t apply to Horizon 6, 7 Agents installed on Linux systems or Horizon Clients installed on non-Windows systems.

 

VMware would like to thank Steven Seeley (mr_me) of Source Incite working with Trend Micro's Zero Day Initiative for reporting this issue to us.

The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the identifier CVE-2018-6970 to this issue.


Column 5 of the following table lists the action required to remediate the vulnerability in each release, if a solution is available.

VMware Product
Product Version
Running on
Severity
Replace with/ Apply Patch
Mitigation/ Workaround
VMware Product Horizon 7
Product Version 7.x.x
Running on Windows
Severity Important
Replace with/ Apply Patch 7.5.1
Mitigation/ Workaround None
VMware Product Horizon 6
Product Version 6.x.x
Running on Windows
Severity Important
Replace with/ Apply Patch 6.2.7
Mitigation/ Workaround None
VMware Product Horizon Client for Windows
Product Version 4.x.x and prior
Running on Windows
Severity Important
Replace with/ Apply Patch 4.8.1
Mitigation/ Workaround None
VMware Product Horizon View Agent
Product Version 7.x.x and prior**
Running on Windows
Severity Important
Replace with/ Apply Patch 7.5.1
Mitigation/ Workaround None
VMware Product VMware Horizon Agents Installer
Product Version 18.x.x and prior
Running on Windows
Severity Important
Replace with/ Apply Patch 18.2.1*
Mitigation/ Workaround None

 

*Customers on HCS will need to upgrade to 18.2 (with HAI 18.2.1) or 18.3 (with HAI 18.2.1).

 

**Horizon View Agent (7.x.x and prior) is listed separately for Horizon Cloud customers using version 7.x.x who need to upgrade their agents but do not use the Horizon Enterprise Server Components (connection server, security server).  Customers on Horizon Enterprise (Horizon 6 or Horizon 7) should ensure they upgrade Agents as part of applying the patches identified above for those products and versions.

 

4. Solution

 

Please review the patch/release notes for your product and version and verify the checksum of your downloaded file.

 

VMware Horizon 7 version 7.5.1
Downloads and Documentation: 

https://my.vmware.com/en/web/vmware/info/slug/desktop_end_user_computing/vmware_horizon/7_5

 

VMware Horizon 6 version 6.2.7  
Downloads and Documentation:  
https://my.vmware.com/group/vmware/info?slug=desktop_end_user_computing/vmware_horizon/6_2

 

VMware Horizon Client for Windows 4.8.1
Downloads and Documentation:

https://my.vmware.com/web/vmware/details?productId=578&downloadGroup=CART19FQ2_WIN_4_8_1

 

VMware Horizon View Agent 7.5.1
Downloads and Documentation: 

https://my.vmware.com/web/vmware/details?productId=757&downloadGroup=VIEW-751-ADV

 

VMware Horizon Agents Installer 18.2.1
Downloads and Documentation:

https://my.vmware.com/web/vmware/details?productId=716&downloadGroup=HCS-CH-1830

  

6. Change log

 

2018-08-07 VMSA-2018-0019

Initial security advisory in conjunction with the release of VMware Horizon 6 version 6.2.7 and Horizon Client 4.8.1 on 2018-08-07.

 

2018-08-14 VMSA-2018-0019.1

Updated security advisory to clarify about affected products.

 

7. Contact

 

E-mail list for product security notifications and announcements:

http://lists.vmware.com/cgi-bin/mailman/listinfo/security-announce

 

This Security Advisory is posted to the following lists:

  security-announce@lists.vmware.com

  bugtraq@securityfocus.com

  fulldisclosure@seclists.org

 

E-mail: security@vmware.com

PGP key at:

https://kb.vmware.com/kb/1055

 

VMware Security Advisories

http://www.vmware.com/security/advisories

 

VMware Security Response Policy

https://www.vmware.com/support/policies/security_response.html

 

VMware Lifecycle Support Phases

https://www.vmware.com/support/policies/lifecycle.html

 

VMware Security & Compliance Blog  

https://blogs.vmware.com/security

 

Twitter

https://twitter.com/VMwareSRC

 

Copyright 2018 VMware Inc. All rights reserved.

 

Sign up for Security Advisories

Enter your email address: