VMware

 

Eclipse Plugin Starter Guide

Contents

The VMware Studio Plugin for Eclipse provides an integrated view for VMware Studio capabilities. This Eclipse Plugin can help you package applications and create management services for a virtual machine or vApp that you are developing with VMware Studio.

Installing the Eclipse Plugin

First you must download Eclipse 3.4, 3.5, or 3.6 and deploy the VMware Studio appliance. If you deployed an earlier version of VMware Studio, you should remove the plugin as described in Uninstalling the Eclipse Plugin, then reinstall.

Follow these steps to install the plugin:

  1. If you are behind a firewall, set the HTTP proxy in Eclipse.
  2. Using Eclipse menus, get the plugin software.
    In Eclipse 3.4, select Help > Software Updates > Available Software > Add Site.
    In Eclipse 3.5, select Help > Install New Software > Add.
  3. For Location do one of the following:
    Type this URL to get the plugin: http://<StudioIPaddr>/eclipse/update/
    Click Archive and find VMwareStudioForEclipse-2.*.zip if downloaded.
  4. Select the VMware Studio Plugin for Eclipse check box.
    In Eclipse 3.4, click Install.
    In Eclipse 3.5, click Next.
  5. Restart Eclipse when prompted.
  6. Select Window > Show View > Other > VMware Studio > VMware Studio Explorer. This adds a view of VMware Studio into an existing perspective.
  7. Other menu
  8. In the VMware Studio Explorer view, double-click the bar to configure VMware Studio.
  9. Double-click to configure
  10. In the VMware Studio Connection dialog box, type the host name or IP address of the VMware Studio appliance, (port 5480), user name root, and the password you set. Click Finish.
  11. Network Connection
  12. Under the VMware Studio Explorer tab, double-click VMware Studio Web Console. The Web Console view appears. You can add profiles and resources using the Explorer view.
  13. VMware Studio in Eclipse

To learn more about the VMware Studio plugin for Eclipse, see the Eclipse chapter of the manual Developer's Guide to Building vApps and Virtual Appliances.

Uninstalling the Eclipse Plugin

  1. Do one of the following:
    In Eclipse 3.4, select Help > Software Updates > Installed Software.
    In Eclipse 3.5, select Help > About Eclipse > Installation Details > Installed Software.
  2. Select VMware Studio Plugin for Eclipse and click Uninstall.
  3. Restart Eclipse when prompted.