VMware

VMware vCenter Orchestrator AMQP Plug-In 1.0.3 Release Notes

VMware vCenter Orchestrator AMQP Plug-In 1.0.3 | 22 April 2014 | Build 1735033

VMware vCenter Orchestrator 5.5.1 | 11 March 2014 | Build 1281930

Check frequently for additions and updates to these release notes.

What's in the Release Notes

The release notes cover the following topics:

Introduction to the VMware vCenter Orchestrator AMQP Plug-In

The VMware vCenter Orchestrator AMQP plug-in allows organizations to automatically trigger workflows based on Advanced Message Queuing Protocol (AMQP) messages. AMQP is a high scalable publish and subscribe message protocol that is increasingly used in cloud architectures. It is the default messaging protocol for vCloud Director 1.5. With the AMQP plug-in, organizations can define policies that automatically trigger specific workflows based on certain AMQP messages. For example, as part of a vApp pre-provisioning activity in vCloud Director, Orchestrator can detect the provisioning request and automatically fetch the IP address from an external system before allowing vCloud Director to proceed with the provisioning activity. When Orchestrator detects that the vApp provisioning is completed, Orchestrator can update configuration management databases and other management systems with information about the new vApp instance.

The AMQP plug-in provides the ability to monitor and publish AMQP messages, as well as to conduct administrative tasks such as configuring AMQP brokers and managing queues. The AMQP plug-in supports VMware RabbitMQ as well as other implementations of AMQP.

The VMware vCenter Orchestrator AMQP Plug-In 1.0.3 release runs on VMware vCenter Orchestrator 5.5.1. For instructions about installing and configuring the plug-in, see the Using the vCenter Orchestrator AMQP Plug-In 1.0.x.

To upgrade the plug-in, you must install version 1.0.3 on your existing installation. You can download version 1.0.3 from the VMware vCenter Orchestrator AMQP Plug-In download page.

For information about vCenter Orchestrator and vCenter Orchestrator plug-ins, see:

Top of Page

What's New in VMware vCenter Orchestrator AMQP Plug-In 1.0.3

Version 1.0.3 of the AMQP plug-in introduces support for vCenter Orchestrator 5.5.1. The latest version of the plug-in uses the new plug-in configuration API and is not compatible with vCenter Orchestrator versions earler than 5.5.1.
Due to the common SSL trusted store support, SSL certificates of the RabbitMQ brokers are now managed by the Import a certificate from URL workflow, which is shipped with the platform as part of the vCenter Orchestrator Configuration plug-in.

Earlier Releases of the vCenter Orchestrator AMQP Plug-In

Features and issues from earlier releases of the vCenter Orchestrator AMQP plug-in are described in the release notes for each release. To review release notes for earlier releases of the vCenter Orchestrator AMQP plug-in, click one of the following links:

Known Issues

The following issue is a known limitation in the VMware vCenter Orchestrator AMQP Plug-In 1.0.3 release:

  • SSL connections are supported only for the RabbitMQ brokers

    Apache QPID brokers are not supported.

Top of Page