VMware

VMware Workstation 4

Features | Documentation | Knowledge Base | Discussion Forums

previous Prev   Contents   Last   Next next

Host System Requirements

Host System Requirements

What do you need to get the most out of VMware Workstation 4? Take the following list of requirements as a starting point. Remember that the virtual machines running under VMware Workstation are like physical computers in many ways - and, like physical computers, they generally perform better if they have faster processors and more memory.

Note: VMware Workstation 4 is supported only on host processors and host operating systems running in 32-bit mode; processors and operating systems running in 64-bit mode are not supported.

PC Hardware

PC Hardware

  • Standard PC
  • 500MHz or faster compatible x86 processor (recommended; 400MHz minimum)

    Compatible processors include

    • Intel®: Celeron®, Pentium® II, Pentium III, Pentium 4, Xeon (including "Prestonia")
    • AMD: Athlon, Athlon MP, Athlon XP, Duron, Opteron

      For additional information, including notes on processors that are not compatible, see the VMware knowledge base at www.vmware.com/support/kb/enduser/std_adp.php?p_faqid=967.

  • Multiprocessor systems supported
Memory

Memory

  • Enough memory to run the host operating system, plus memory required for each guest operating system and for applications on the host and guest; see your guest operating system and application documentation for their memory requirements
  • 256MB recommended, 128MB minimum
Display

Display

  • 16-bit display adapter recommended; greater than 8-bit display adapter required
  • Linux hosts must have an X server that meets the X11R6 specification (such as XFree86) and a video adapter supported by that server to run guest operating systems in full screen mode
Disk Drives

Disk Drives

  • 100MB (for Windows hosts), 20MB (for Linux hosts) free space required for basic installation
  • At least 1GB free disk space recommended for each guest operating system and the application software used with it; if you use a default setup, the actual disk space needs are approximately the same as those for installing and running the guest operating system and applications on a physical computer
  • IDE or SCSI hard drives, CD-ROM and DVD-ROM drives supported
  • Guest operating systems can reside on physical disk partitions or in virtual disk files
Local Area Networking (Optional)

Local Area Networking (Optional)

  • Any Ethernet controller supported by the host operating system
  • Non-Ethernet networks supported using built-in network address translation (NAT) or using a combination of host-only networking plus routing software on the host operating system
Windows Host Operating Systems

Windows Host Operating Systems

  • Windows Server 2003 Web Edition, Windows Server 2003 Standard Edition, Windows Server 2003 Enterprise Edition
  • Windows XP Professional and Windows XP Home Edition with Service Pack 1 (listed versions also supported with no service pack)
  • Windows 2000 Professional Service Pack 1, 2, 3 or 4, Windows 2000 Server Service Pack 1, 2, 3 or 4, Windows 2000 Advanced Server Service Pack 1, 2, 3 or 4 (listed versions also supported with no service pack)
  • Windows NT® Workstation 4.0 Service Pack 6a, Windows NT Server 4.0 Service Pack 6a, Windows NT 4.0 Terminal Server Edition Service Pack 6

    Caution: Do not install VMware Workstation on a Windows NT 4.0 Server system that is configured as a primary or backup domain controller.

Internet Explorer 4.0 or higher required for Help system

Linux Host Operating Systems

Linux Host Operating Systems

Supported distributions and kernels are listed below. VMware Workstation may not run on systems that do not meet these requirements.

Note: As newer Linux kernels and distributions are released, VMware modifies and tests its products for stability and reliability on those host platforms. We make every effort to add support for new kernels and distributions in a timely manner, but until a kernel or distribution is added to the list below, its use with our products is not supported. Look for newer prebuilt modules in the download area of our Web site. Go to www.vmware.com/download/.

  • Mandrake Linux 9.0 - stock 2.4.19
  • Mandrake Linux 8.2 - stock 2.4.18-6mdk
  • Red Hat Linux Advanced Server 2.1 - stock 2.4.9-e3
  • Red Hat Linux 8.0 - stock 2.4.18
  • Red Hat Linux 7.3 - stock 2.4.18
  • Red Hat Linux 7.2 - stock 2.4.7-10, upgrade 2.4.9-7, upgrade 2.4.9-13, upgrade 2.4.9-21, upgrade 2.4.9-31
  • Red Hat Linux 7.1 - stock 2.4.2-2, upgrade 2.4.3-12
  • Red Hat Linux 7.0 - stock 2.2.16-22, upgrade 2.2.17-14
  • SuSE Linux Enterprise Server 8 - stock 2.4.19
  • SuSE Linux 8.2 - stock 2.4.20
  • SuSE Linux 8.1 - stock 2.4.19
  • SuSE Linux 8.0 - stock 2.4.18
  • SuSE Linux Enterprise Server 7 - stock 2.4.7 and patch 2
  • SuSE Linux 7.3 - stock 2.4.10

Platforms not listed above are not supported.

Web browser required for Help system

previous Prev   Contents   Last   Next next